YAMon 3.4 - usage monitoring for your router

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions
Goto page Previous  1, 2, 3 ... 39, 40, 41, 42  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7182
Location: Texas, USA

PostPosted: Mon Mar 02, 2020 2:17    Post subject: Reply with quote
croweater wrote:
It is strange. All four ports stop working after a day or two. Reboot is a temporary fix.

I will try a remote mount, like NFS or Samba. Thanks


Some research in this forum and Google would've told you to set the MTU to 1472.

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
al_c
DD-WRT Guru


Joined: 13 Apr 2013
Posts: 2134
Location: Ottawa Canada

PostPosted: Mon Mar 02, 2020 2:54    Post subject: Reply with quote
kernel-panic69 wrote:
croweater wrote:
It is strange. All four ports stop working after a day or two. Reboot is a temporary fix.

I will try a remote mount, like NFS or Samba. Thanks


Some research in this forum and Google would've told you to set the MTU to 1472.

From what I saw, that might work but not always... but it is something to try (if you haven't done so already). YMMV

Al

_________________
Thanks to everyone for supporting YAMon!

If you use and like YAMon and have not done so recently, please consider making a donation - thanks!
YAMon GitHub Repository
gb13717
DD-WRT Novice


Joined: 02 Mar 2020
Posts: 2

PostPosted: Mon Mar 02, 2020 16:28    Post subject: No Matching MAC Reply with quote
Just installed YAMon 3.4.7 yesterday on linksys e3000 running DD-WRT v24-sp2 (08/12/10) mega (SVN revision 14929). I'm trying to find the data hog on my network.

All my traffic was going to the "no matching MAC" device. I reran the install.sh script to make sure I had a current util3.2.5.sh per the help page and no difference.

I have started to work around the problem by setting up static leases in dd-wrt for each device. After doing that the reports in YAMon are starting to show traffic for each device. Its just a bit of work to hunt down all the MAC addresses for the devices on my network but not terrible.

Anyway, just fyi on that problem I think my work around is fine. But my question: is there a way to reset the data/logs? I tried deleting the data on the dd-wrt bandwidth page but that apparently wasn't it.

thanks again
al_c
DD-WRT Guru


Joined: 13 Apr 2013
Posts: 2134
Location: Ottawa Canada

PostPosted: Wed Mar 04, 2020 0:36    Post subject: Re: No Matching MAC Reply with quote
gb13717 wrote:
Just installed YAMon 3.4.7 yesterday on linksys e3000 running DD-WRT v24-sp2 (08/12/10) mega (SVN revision 14929). I'm trying to find the data hog on my network.

All my traffic was going to the "no matching MAC" device. I reran the install.sh script to make sure I had a current util3.2.5.sh per the help page and no difference.

I have started to work around the problem by setting up static leases in dd-wrt for each device. After doing that the reports in YAMon are starting to show traffic for each device. Its just a bit of work to hunt down all the MAC addresses for the devices on my network but not terrible.

Anyway, just fyi on that problem I think my work around is fine. But my question: is there a way to reset the data/logs? I tried deleting the data on the dd-wrt bandwidth page but that apparently wasn't it.

thanks again

I suspect that your issues might be related to the age of your firmware (which is almost a decade out of date). I suggest that you try updating to something more current. [Actually I more than suspect...]

To clear the data, delete the files in your data directory and perhaps go to the settings tab in the reports and choose clear settings.

Al

_________________
Thanks to everyone for supporting YAMon!

If you use and like YAMon and have not done so recently, please consider making a donation - thanks!
YAMon GitHub Repository
tack_tx
DD-WRT Novice


Joined: 26 Aug 2019
Posts: 3

PostPosted: Wed Mar 04, 2020 1:18    Post subject: YAMon4 users.js not updating Reply with quote
wrong thread!
croweater
DD-WRT User


Joined: 28 Dec 2019
Posts: 59

PostPosted: Wed Mar 04, 2020 19:12    Post subject: Reply with quote
kernel-panic69 wrote:
croweater wrote:
It is strange. All four ports stop working after a day or two. Reboot is a temporary fix.

I will try a remote mount, like NFS or Samba. Thanks


Some research in this forum and Google would've told you to set the MTU to 1472.


Lame response.

I did research and I did reset MTU to 1472. Stop assuming.

This is a known problem so if you aren't willing to help please don't pretend to.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7182
Location: Texas, USA

PostPosted: Wed Mar 04, 2020 19:44    Post subject: Reply with quote
croweater wrote:
kernel-panic69 wrote:
croweater wrote:
It is strange. All four ports stop working after a day or two. Reboot is a temporary fix.

I will try a remote mount, like NFS or Samba. Thanks


Some research in this forum and Google would've told you to set the MTU to 1472.


Lame response.

I did research and I did reset MTU to 1472. Stop assuming.

This is a known problem so if you aren't willing to help please don't pretend to.


I guess I should've linked the thread and/or post where I found the information that discusses this issue. At least I didn't just throw out a callous RTFM response.

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
al_c
DD-WRT Guru


Joined: 13 Apr 2013
Posts: 2134
Location: Ottawa Canada

PostPosted: Wed Mar 04, 2020 20:24    Post subject: Reply with quote
kernel-panic69 wrote:
croweater wrote:
kernel-panic69 wrote:
croweater wrote:
It is strange. All four ports stop working after a day or two. Reboot is a temporary fix.

I will try a remote mount, like NFS or Samba. Thanks


Some research in this forum and Google would've told you to set the MTU to 1472.


Lame response.

I did research and I did reset MTU to 1472. Stop assuming.

This is a known problem so if you aren't willing to help please don't pretend to.


I guess I should've linked the thread and/or post where I found the information that discusses this issue. At least I didn't just throw out a callous RTFM response.
Let's all play nicely!
_________________
Thanks to everyone for supporting YAMon!

If you use and like YAMon and have not done so recently, please consider making a donation - thanks!
YAMon GitHub Repository
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7182
Location: Texas, USA

PostPosted: Wed Mar 04, 2020 20:40    Post subject: Reply with quote
I was being nice in both posts. I neglected to share the linked thread where I found the information about the "known problem".
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
gb13717
DD-WRT Novice


Joined: 02 Mar 2020
Posts: 2

PostPosted: Wed Mar 04, 2020 23:00    Post subject: Re: No Matching MAC Reply with quote
al_c wrote:
gb13717 wrote:
Just installed YAMon 3.4.7 yesterday on linksys e3000 running DD-WRT v24-sp2 (08/12/10) mega (SVN revision 14929). I'm trying to find the data hog on my network.

All my traffic was going to the "no matching MAC" device. I reran the install.sh script to make sure I had a current util3.2.5.sh per the help page and no difference.

I have started to work around the problem by setting up static leases in dd-wrt for each device. After doing that the reports in YAMon are starting to show traffic for each device. Its just a bit of work to hunt down all the MAC addresses for the devices on my network but not terrible.

Anyway, just fyi on that problem I think my work around is fine. But my question: is there a way to reset the data/logs? I tried deleting the data on the dd-wrt bandwidth page but that apparently wasn't it.

thanks again

I suspect that your issues might be related to the age of your firmware (which is almost a decade out of date). I suggest that you try updating to something more current. [Actually I more than suspect...]

To clear the data, delete the files in your data directory and perhaps go to the settings tab in the reports and choose clear settings.

Al


thanks Al. And yes my router is pretty old but according to the hardware-specific thread on this forum I'm running the latest version of dd-wrt that is known to be stable. thanks again cool software
croweater
DD-WRT User


Joined: 28 Dec 2019
Posts: 59

PostPosted: Wed Mar 04, 2020 23:07    Post subject: Reply with quote
kernel-panic69 wrote:
I was being nice in both posts. I neglected to share the linked thread where I found the information about the "known problem".


I apologize for losing my temper. This thing has me pretty upset and I'm on a short fuse, I guess.
al_c
DD-WRT Guru


Joined: 13 Apr 2013
Posts: 2134
Location: Ottawa Canada

PostPosted: Sat Mar 07, 2020 14:47    Post subject: Reply with quote
After years of nudging from a variety of users, I have finally bitten the bullet and created a githup repository for YAMon -- see https://github.com/al-caughey/

Bear with me as I figure out how things work.

(Thanks to everyone who's helped me finally get over this hump)

Al

_________________
Thanks to everyone for supporting YAMon!

If you use and like YAMon and have not done so recently, please consider making a donation - thanks!
YAMon GitHub Repository
ddaniel51
DD-WRT Guru


Joined: 19 Feb 2013
Posts: 1383

PostPosted: Sun Mar 08, 2020 15:17    Post subject: Reply with quote
Here is a link to DD-WRT current supported routers via years.

download1.dd-wrt.com/dd-wrtv2/downloads/betas/

14929 was a solid version on my E4200 until increasing bandwidth made the 4200 obsolete. I wouldn't dare try running Yamon on it. It'd be like trying to run Win 10 software on a 486.

_________________
Segment 1 R9000 10Gb LAN, 1Gb ISP BS
Test Bed R9000 10Gb LAN
Wired AP 1 R9000 10Gb LAN
Wired AP 2 R9000 1Gb LAN
Wired AP 3 R9000 1Gb LAN
Test Bed R7800 1Gb LAN OpenWRT Kong
download1.dd-wrt.com/dd-wrtv2/downloads/betas/ (Brain Slayer)
www.desipro.de/openwrt/ (Kong's)
YAMon usage-
www.monitoring.com/manualInstall.php
al_c
DD-WRT Guru


Joined: 13 Apr 2013
Posts: 2134
Location: Ottawa Canada

PostPosted: Sat Mar 14, 2020 17:15    Post subject: Reply with quote
I'll have a bunch of time to work on YAMon issues in the next couple of weeks...

I'm a high school teacher. We just started our March Break and the province has announced that the schools will remain closed (for at least) two weeks afterwards.

YAMon, collecting sap and making maple syrup should keep me busy for the next little while (unless the honey-do list gets in the way Smile)

Send me your bugs and frustrations.

Al

_________________
Thanks to everyone for supporting YAMon!

If you use and like YAMon and have not done so recently, please consider making a donation - thanks!
YAMon GitHub Repository
ddaniel51
DD-WRT Guru


Joined: 19 Feb 2013
Posts: 1383

PostPosted: Wed Mar 18, 2020 22:39    Post subject: Reply with quote
Al, tell me again why the Donation nag screen appears on a daily basis?

Tnx

_________________
Segment 1 R9000 10Gb LAN, 1Gb ISP BS
Test Bed R9000 10Gb LAN
Wired AP 1 R9000 10Gb LAN
Wired AP 2 R9000 1Gb LAN
Wired AP 3 R9000 1Gb LAN
Test Bed R7800 1Gb LAN OpenWRT Kong
download1.dd-wrt.com/dd-wrtv2/downloads/betas/ (Brain Slayer)
www.desipro.de/openwrt/ (Kong's)
YAMon usage-
www.monitoring.com/manualInstall.php
Goto page Previous  1, 2, 3 ... 39, 40, 41, 42  Next Display posts from previous:    Page 40 of 42
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum