New Build 36006 (BS): 05-23-2018-r36006

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3  Next
Author Message
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2576
Location: Indy

PostPosted: Thu May 24, 2018 12:24    Post subject: New Build 36006 (BS): 05-23-2018-r36006 Reply with quote
Downloads at:
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2018/05-23-2018-r36006/
ftp://ftp.dd-wrt.com/betas/2018/05-23-2018-r36006/
Also: alternate DD-WRT website link.

Changelogs:
SVN Changelog: Since last build: 35927
Summary: (deprecated after 29739)

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.10 and newer
2. krack fixes for Broadcom were completed in 33678, including k26 (33655) & k24 (33656).

Tickets closed as 'fixed' (Broadcom-related and general):

Issues, observations, and/or workarounds reported:
1. (egc) Policy-Based Routing broken if SFE enabled: http://svn.dd-wrt.com/ticket/5900
quarkysg's PBR+SFE fix: http://svn.dd-wrt.com/ticket/5986
2. Trendnet 81*DRU models are missing factory-to-flash, and 811/812v2 are too big to flash: http://svn.dd-wrt.com/ticket/6144
3. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use:
http://svn.dd-wrt.com/ticket/6246
4. Reports of NAS module (used by the bcm driver) crashes:
https://svn.dd-wrt.com/ticket/6310

Important: if any issues are found, please provide log info (GUI syslog, `dmesg`, `cat /var/log/messages`).
Or put in SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template to copy (after "Code:") for posting a reply, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b]Router/Version: [/b]
[b]Firmware: [/b]
[b]Kernel: [/b]
[b]Mode: [/b]
[b]Status: [/b]

WARNING: This build thread is for reporting success and/or problems with loading this experimental test build.
This is important info for developers and users. Always state your hardware model, version, mode (e.g. Repeater) and SPECIFIC build (e.g. 33555_NEWD-2_K3.x_mega-nv64k.bin). Create a new thread to discuss specific problems or questions, and refrain to respond as this thread is for reporting, not support. Posts not meeting this criteria may be deleted or moved to keep this thread manageable and useful. If you don't understand the risks or what to flash and how, with a means of recovery if it bricks, do NOT flash this experimental test build.

_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
x64 OPNsense 20.7.1|FT2020.5: EA6900v1.1@1GHz, F7D8302@532|DD 44294: DIR-810L, WNDR4500v2 & 4000@533,
R6300v1, RT-N66U@663, E1500@353, WRT54G{Lv1.1,Sv6}@250
|OpenWRT 19.7.3: RT-ACRH13, R6220, WNDR3700v4


Last edited by jwh7 on Tue May 29, 2018 17:30; edited 3 times in total
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7200
Location: Texas, USA

PostPosted: Thu May 24, 2018 14:36    Post subject: Cisco Linksys E4200 V1 Reply with quote
Router/Version: Linksys E4200 v1
Firmware: DD-WRT v3.0-r36006 mega ( 05/23/18 )
Kernel: Linux 3.10.108-dd #19302 Wed May 23 22:04:45 CEST 2018 mips
Previous: DD-WRT v3.0-r35927 mega ( 05/13/18 )
Firmware file used: dd-wrt.v24-36006_NEWD-2_K3.x_mega.bin
Reset: Yes, reset to defaults prior to and after flash via webGUI
Status: OK
Mode: Gateway/AP
Issues: I had to use the reset button during re-configuration, not entirely sure why, but going through settings tabs in order and applying changes locked me out of the webGUI. Shocked Rolling Eyes All good now. Will monitor and report. So far, so good
Very Happy Cool

P.S. I added 4 lines in there for clarification, which probably should be used for future build posts (file used, reset, and status), as I have seen some posts using them and some not. Might help in diagnosis... Idea

EDIT: Syslog time stamps still askew.

Jan 1 00:00:08 DD-WRT daemon.debug ntpclient[1418]: Connecting to 2.pool.ntp.org [152.2.133.54] ...
Jan 1 00:00:08 DD-WRT user.info : WAN is up. IP: 192.168.0.4
May 24 14:19:37 DD-WRT daemon.info ntpclient[1418]: Time set from 2.pool.ntp.org [152.2.133.54].
May 24 14:19:37 DD-WRT daemon.info process_monitor[1417]: cyclic NTP Update success (servers 2.pool.ntp.org 212.18.3.19 88.99.174.22)
May 24 14:19:37 DD-WRT daemon.debug process_monitor[1417]: Restarting cron (time sync change)
May 24 14:19:38 DD-WRT user.info : cron : cron daemon successfully stopped
May 24 14:19:38 DD-WRT user.info : process_monitor : Process Monitor successfully stopped
May 24 14:19:38 DD-WRT cron.info cron[1452]: (CRON) STARTUP (fork ok)
May 24 14:19:38 DD-WRT user.info : process_monitor successfully started
May 24 14:19:38 DD-WRT daemon.debug process_monitor[1453]: We need to re-update after 3600 seconds
May 24 14:19:38 DD-WRT daemon.info process_monitor[1453]: set timer: 3600 seconds, callback: ntp_main()
May 24 14:19:44 DD-WRT user.info : NAS : NAS lan (wl0 interface) successfully started
May 24 14:19:44 DD-WRT user.info : NAS : NAS lan (wl1 interface) successfully started
May 24 14:19:44 DD-WRT user.info : klogd : kernel log daemon successfully stopped
May 24 14:19:45 DD-WRT kern.notice kernel: klogd: exiting
May 24 14:19:45 DD-WRT user.info : syslogd : syslog daemon successfully stopped
May 24 16:19:45 DD-WRT syslog.info syslogd exiting
May 24 16:19:45 DD-WRT syslog.info syslogd started: BusyBox v1.28.3
May 24 14:19:45 DD-WRT user.info : klogd : klog daemon successfully started
May 24 14:19:45 DD-WRT kern.notice kernel: klogd started: BusyBox v1.28.3 (2018-05-23 22:04:06 CEST)

May 24 14:19:45 DD-WRT user.info : httpd : http daemon successfully stopped
May 24 14:19:45 DD-WRT daemon.info httpd[1310]: httpd server shutdown
May 24 14:19:45 DD-WRT daemon.info httpd[1474]: httpd server started at port 80
May 24 14:19:45 DD-WRT user.info : resetbutton : resetbutton daemon successfully stopped
May 24 14:19:45 DD-WRT user.info : resetbutton : resetbutton daemon successfully started
May 24 14:20:46 DD-WRT daemon.err httpd[1484]: Request Error Code 408: No request appeared within a reasonable time period.

EDIT#2: These two lines are in the syslog from last reboot yesterday.

May 25 02:19:17 DD-WRT kern.info kernel: nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
May 25 03:12:32 DD-WRT kern.warn kernel: br0: received packet on eth1 with own address as source address

Not sure what the first one is related to (possibly part of my startup script?) but the second one is on the 2.4GHz radio, which is on, but not being used.


Last edited by kernel-panic69 on Fri May 25, 2018 14:33; edited 2 times in total
jrscs
DD-WRT User


Joined: 09 Aug 2010
Posts: 252

PostPosted: Thu May 24, 2018 16:37    Post subject: Reply with quote
Router/Version: RT-AC66U A1
Firmware: DD-WRT v3.0-r36006 (05/23/18 )
Issues/Errors: Boot loop. Rolled back to 33492.

_________________
Asus AC87U A1 - DD-WRT v3.0-r43217 std (05/22/20)
Repeater Bridges(s)
Asus AC68R A1 - DD-WRT v3.0-r43217 std (05/22/20)
Netgear R6400 V2 - DD-WRT v3.0-r43136 std (05/13/20)
Asus AC66U A1 - DD-WRT v3.0-r43136 giga (05/13/20)
jwh7
DD-WRT Guru


Joined: 25 Oct 2013
Posts: 2576
Location: Indy

PostPosted: Thu May 24, 2018 16:52    Post subject: Re: Cisco Linksys E4200 V1 Reply with quote
kernel-panic69 wrote:
Issues: I had to use the reset button during re-configuration, not entirely sure why, but going through settings tabs in order and applying changes locked me out of the webGUI. Shocked Rolling Eyes All good now. Will monitor and report. So far, so good
Very Happy Cool

P.S. I added 3 lines in there for clarification, which probably should be used for future build posts (file used, reset, and status), as I have seen some posts using them and some not. Might help in diagnosis... Idea
I removed those fields because the status would be reported under Issues (though the reverse makes more sense I guess...), and Reset may not indicate if/when they were done, which could be important in describing an issue. Smile

Router/Version: Linksys WRT54GL v1.1
Firmware: DD-WRT v3.0-r36006 std-special ( 05/23/18 )
Kernel: Linux 2.4.37 #49478 Wed May 23 15:10:09 CEST 2018 mips
Mode: CB
Status: Ran fine for 7 days w/ 35927, seemed fine after upgrading.

Router/Version: Linksys WRT54GS v6
Firmware: micro
Status: Had it setup as an AP w/ 35927, and was still working after the upgrade. I switched it to a CB for testing, which was working but I noticed the Security tab Save nor Apply worked (was doing so cuz SPI Firewall still showed Enabled). It worked on the GL, so I tried a couple different modes, no help. So I `nvram set filter=off` but the other fields weren't changing like usual (I presume triggered by 'action_service=filters') so I figured I might as well just clean it up and do a GUI reset.

Now I can't access the GUI nor telnet, which worked fine before; is telnet locked out until a password is set? But I get an IP, and can connect to the (default open 'DD-WRT') wireless (which took a while for some reason). Tried button reset, reboots, 30-30-30, dancing naked on one foot, no love.

Anyone ran into this on a (recent?) micro build before? I haven't reset since the 33555 timeframe. I will try TFTP later; off to enjoy my vacation day. :-/

_________________
# NAT/SFE/CTF: limited speed w/ DD # Repeater issues # DD-WRT info: FAQ, Builds, Types, Modes, Changes, Demo #
x64 OPNsense 20.7.1|FT2020.5: EA6900v1.1@1GHz, F7D8302@532|DD 44294: DIR-810L, WNDR4500v2 & 4000@533,
R6300v1, RT-N66U@663, E1500@353, WRT54G{Lv1.1,Sv6}@250
|OpenWRT 19.7.3: RT-ACRH13, R6220, WNDR3700v4


Last edited by jwh7 on Thu May 24, 2018 18:35; edited 1 time in total
wicket
DD-WRT Novice


Joined: 18 Jul 2017
Posts: 41
Location: Wisconsin, USA

PostPosted: Thu May 24, 2018 16:54    Post subject: Linksys EA6500 v1 Reply with quote
Router/Version: Linksys EA6500 v1
Firmware: DD-WRT v3.0-r36006 giga ( 05/23/18 )
Kernel: Linux 3.10.108-dd #19286 Wed May 23 21:48:55 CEST 2018 mips
Previous: DD-WRT v3.0-r35927 giga ( 05/13/18 )
Mode/Status: Gateway/AP
Setup: Using IPv6 via DNSMasq, DDNS, & Port Range Forward.
Reset: No
Issues/Errors: Some errors appear in syslog and a few warnings but everything appears to be working as needed so far.

Will continue to test.

_________________
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7200
Location: Texas, USA

PostPosted: Thu May 24, 2018 17:08    Post subject: Re: Cisco Linksys E4200 V1 Reply with quote
jwh7 wrote:
kernel-panic69 wrote:
Issues: I had to use the reset button during re-configuration, not entirely sure why, but going through settings tabs in order and applying changes locked me out of the webGUI. Shocked Rolling Eyes All good now. Will monitor and report. So far, so good
Very Happy Cool

P.S. I added 3 lines in there for clarification, which probably should be used for future build posts (file used, reset, and status), as I have seen some posts using them and some not. Might help in diagnosis... Idea

I removed those fields because the status would be reported under Issues (though the reverse makes more sense I guess...), and Reset may not indicate if/when they were done, which could be important in describing an issue. Smile


Changed it to read 4, as I just included previous firmware version Wink To clarify, reset button was used after *gasp* a power cycle when I lost reconnect after the flash. I almost thought I had bricked it Shocked Anyhow, while going through each tab to change settings to what they were in the previous firmware revision and clicking "Apply Settings" after changes on each tab, poof. Either the order in which I did it from left-to-right was partial culprit, or it was just a glitch, not sure which. I was trying to take it slow and be careful, even *shrug*
smitna
DD-WRT Novice


Joined: 04 Jan 2011
Posts: 29
Location: Germany

PostPosted: Thu May 24, 2018 20:32    Post subject: Reply with quote
Router/Version: Asus RT-AC88U
Firmware: DD-WRT v3.0-r36006 std ( 05/23/18 )
Kernel: 4.4.132 #3130 SMP Wed May 23 17:22:36 CEST 2018 armv7l GNU/Linux
Previous: DD-WRT v3.0-r35531 std ( 03/26/18 )
Mode: Gateway/AP
Reset: NO
Status: OK
Issues/Errors:
First successful flash since r35531, but flash time was about 100 sec., very long compared to the others before.
I don't know why this was successful and r35927 not. Changelog not helpful for me.

Uptime only one hour, too short for a full report. All services (PPPD, DHCP, DNSMasq, USB etc.) up and running for now.
dmesg very good, no errors.
But more monitoring required.

One minor issue with httpd. Syslog:
daemon.err httpd[1860]: Request Error Code 408: No request appeared within a reasonable time period.

This is not a new problem:
Sometimes when using the GUI there is no response (endless loading)

Thanks a lot to the devs!


Edit 05/25/18:

Up since 1 day. NTP and all other things working without problems. No further or new errors.

One note: My old issue loosing wl1 (5 GHz) after some days in the GUI solved by choosing AC/N mixed, not "only AC"

Again: Many thanks to the devs for this build! It seems a big step forward.


Last edited by smitna on Fri May 25, 2018 19:28; edited 1 time in total
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 408

PostPosted: Thu May 24, 2018 22:16    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r36006 std ( 05/23/18 )
Kernel: Linux 4.4.132 #3125 SMP Wed May 23 09:04:24 CEST 2018 armv7l
Previous: r35927
Mode/Status: Gateway / working
Reset: no
Issues/Errors: After numerous DSLReports speed tests (at various times of day), and backing out/forward this version, it looks like something is causing worse test results with 36006 vs previous builds (both speeds and buffer bloat results are worse). Update: back to typical results May 30th, must've been the test site.

Uptime: 1h 48m
Temperatures: CPU 66.9 °C / WL0 47.0 °C / WL1 50.9 °C



Last edited by flyzipper on Wed May 30, 2018 20:43; edited 3 times in total
watchsat
DD-WRT User


Joined: 31 Oct 2017
Posts: 54

PostPosted: Fri May 25, 2018 0:32    Post subject: Reply with quote
Router/Version: Linksys EA6500V2
Firmware: DD-WRT v3.0-r36006 std ( 05/23/18 )
Kernel: Linux 4.4.131 #3081 SMP Sun May 13 07:27:31 CEST 2018 armv7l
Mode: Gateway/Router/Port Forwarding
Issues: None so Far for 10 hours


Router/Version: Linksys EA6400
Firmware: DD-WRT v3.0-r36006 std ( 05/23/18 )
Kernel: Linux 4.4.132 #3125 SMP Wed May 23 09:04:24 CEST 2018 armv7l
Mode: Gateway/Router/Port Forwarding
Issues: None so Far for 10 hours
chenshaoju
DD-WRT User


Joined: 10 Apr 2008
Posts: 91
Location: Chinese Mainland

PostPosted: Fri May 25, 2018 8:31    Post subject: Reply with quote
Sorry for my English.

Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r36006 std ( 05/23/18 )
Kernel: Linux 4.4.132 #3125 SMP Wed May 23 09:04:24 CEST 2018 armv7l
Mode: Wireless Router
Status: Virtual AP (VAP) not working

But, If I manually Apply settings in Wireless tab, Everything is fine for this time.

_________________
NetGear R7000
DD-WRT v3.0-r35531 std ( 03/26/18 )
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 692
Location: Hung Hom, Hong Kong

PostPosted: Fri May 25, 2018 9:31    Post subject: Asus RT-N18U and DD-WRT BS Build 36006 Reply with quote
Router/Version: Asus RT-N18U
Firmware: DD-WRT v3.0-r36006 std (05/23/18)
Kernel: Linux 4.4.132 #3129 Wed May 23 17:16:20 CEST 2018 armv7l
Previous: DD-WRT v3.0-r35927 std (05/13/18)
Mode: Access Point (AP)
Status: Working, no major problems, basic router
Reset: NO reset during firmware upgrade

1. Following error logged many times:
Code:
May 25 09:19:39 DD-WRT daemon.err httpd[1047]: Request Error Code 404: File style/elegant/logo.png not found.

Following error logged a few times
Code:
May 25 09:19:41 DD-WRT daemon.err httpd[1047]: Request Error Code 401: Authorization required. please note that the default username is "root" in all newer releases

2. No LAN LEDs... all off though there were physical cables.

3. Ping response improved? (ping www.google.com replied in 1ms not 2ms)

4. NTP client in trouble AGAIN, when running as daemon? process_monitor making wrong call to ntpclient? Bad timing?
Code:
root@DD-WRT:/tmp/var/log# cat messages | grep -i ntp
May 25 09:36:43 DD-WRT daemon.err ntpclient[2747]: Failed resolving address to hostname --help: Name does not resolve
May 25 09:36:43 DD-WRT daemon.err ntpclient[2747]: Failed resolving server --help: Network is down
May 25 09:36:46 DD-WRT daemon.err ntpclient[2749]: Failed resolving address to hostname --version: Name does not resolve
May 25 09:36:46 DD-WRT daemon.err ntpclient[2749]: Failed resolving server --version: Network is down
May 25 09:36:56 DD-WRT daemon.debug ntpclient[2753]: Connecting to time.hko.hk [118.143.17.82] ...
May 25 09:36:59 DD-WRT daemon.debug ntpclient[2753]: Timed out waiting for time.hko.hk [118.143.17.82].



Miscellaneous:
- Router not using IPv6, VPN nor USB
- Router is NOT working 24/7
- WiFi broken in k3.x editions since build 35531? 5GHz problem?

Old problems:
a. DDNS (inadyn) crashed in build 31722
b. Testing port-forwarding via WAN IP from within LAN not working in builds 34411-34760. Needed external proxy server.
c. NTP client not working in builds 34886-34876,35034 (affecting process_monitor?)
d. The ping to www.google.com increased from 2ms to 13ms after setting a defunct
WINS server in Setup->Basic Setup->DHCP->WINS (also something related to blank Source Net?)
e. The "Source Net" field in Port-Forwarding screen displayd blank field as "¸ÖÁv",
from builds 32667 to 32767. Possibly null-pointer assignment?
f. Blank Source Net in Port Forwarding cripped WAN in builds 35831-35874! Needed to be "0.0.0.0/0" or no internet!
g. Running "cat /proc/mtd" in Administration -> Commands for builds before 35916 didn't escape HTML special characters.




speedtest.dd-wrt.36006.asus.rt-n18u.png
 Description:
speedtest.net result for Asus RT-N18U and DD-WRT BS Build 36006
 Filesize:  14.12 KB
 Viewed:  3914 Time(s)

speedtest.dd-wrt.36006.asus.rt-n18u.png



_________________
Router: Asus RT-N18U (rev. A1)

May the Force and farces be with you! Live long and proper!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832


Last edited by mwchang on Sat May 26, 2018 10:34; edited 2 times in total
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 692
Location: Hung Hom, Hong Kong

PostPosted: Fri May 25, 2018 13:24    Post subject: From New Kong's Test Build v3.0-r36000M kongac (24/05/2018) Reply with quote
From: New Kong's Test Build v3.0-r36000M kongac (24/05/2018)
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315246

For developers

By egc

Possible DNS leak see: http://svn.dd-wrt.com/ticket/6020

There is a solution, to the PBR not working with SFE[/b], @Quarkysg has made a patch for the shortcut-fe module (see: http://svn.dd-wrt.com/ticket/5986#comment:17 ).
Please Kong and/or BS have a look.

He also compiled a shortcut-fe.ko module for testing (Arm/Broadcom , Linux 4.4) see: https://www.dd-wrt.com/phpBB2/viewtopic.php?p=1107870#1107870 , I am running that shortcut-fe.ko module right now and it is working.

_________________
Router: Asus RT-N18U (rev. A1)

May the Force and farces be with you! Live long and proper!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832
Valeriy_tc
DD-WRT User


Joined: 03 Sep 2016
Posts: 57
Location: Ukraine

PostPosted: Fri May 25, 2018 17:28    Post subject: Linksys EA6400 Reply with quote
Router/Version: Linksys EA6400
Firmware: DD-WRT v3.0-r36006 std (05/23/18)
Kernel: Linux 4.4.132 #3125 SMP Wed May 23 09:04:24 CEST 2018 armv7l
Previous: DD-WRT v3.0-r34777
Mode/Status: Gateway/Router/Port Forwarding
Reset: No
Issues/Errors: None so far.
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Fri May 25, 2018 18:14    Post subject: Reply with quote
Router Model Netgear R6250
Firmware Version DD-WRT v3.0-r36006 std (05/23/1Cool
Kernel Version Linux 4.4.132 #3125 SMP Wed May 23 09:04:24 CEST 2018 armv7l


Status: Working
Reset:No
Errata: None that I could find Smile

Thx BS and ddwrt devs...!!!
labo
DD-WRT Guru


Joined: 30 Jan 2015
Posts: 675
Location: Texas, USA

PostPosted: Fri May 25, 2018 20:03    Post subject: Reply with quote
Router: Netgear R7000 as Repeater Bridge
Firmware: DD-WRT v3.0-r36006 std ( 05/23/18 )
Kernel: Linux 4.4.132 #3125 SMP Wed May 23 09:04:24 CEST 2018 armv7l
Mode: Repeater Bridge
Error: Not Working. 5Ghz radio keeps scanning channels unable to lock to AP.

_________________
ASUS RT-AX89X: Main gateway.
QNAP QSW-1208-8C 12-Port 10GbE Switch
Nighthawk SX10 10GbE Switch
1 X RAX120 WAP Bridge
1 X RAX75 WAP Bridge
Archer AX11000 WAP Bridge
2 X R7800 DD-WRT Mesh
2 X R9000 DD-WRT Mesh
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum