Support for TP-Link wr840n v 3.0? (Solved!)

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2
Author Message
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2156
Location: Canada

PostPosted: Fri Dec 15, 2017 23:54    Post subject: EU Version. Reply with quote
Attach a TP-Link EU version firmware for your router. I will modify the 841ND firmware to match the header of the TP-Link firmware.
_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
Netgear R7800 - gateway, DHCP, QoS, VPN
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - not used
Sponsor
Ciao121
DD-WRT Novice


Joined: 15 Dec 2017
Posts: 9

PostPosted: Sat Dec 16, 2017 0:52    Post subject: Reply with quote
You are very kind. Here's the file
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2156
Location: Canada

PostPosted: Sat Dec 16, 2017 1:13    Post subject: EU Version. Reply with quote
Here is a patched 841nd v11 file that should flash. I have not tested any of these files.
_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
Netgear R7800 - gateway, DHCP, QoS, VPN
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - not used
Ciao121
DD-WRT Novice


Joined: 15 Dec 2017
Posts: 9

PostPosted: Sat Dec 16, 2017 2:16    Post subject: Reply with quote
mmm. this seems to have bricked the router. No ping, no TFTP.
Tried bot 192.168.0.1 (the original router ip) and (192.168.1.1)

All leds blinking at 1 sec interval. The eth cable connection connects/disconnects at the same time.
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2156
Location: Canada

PostPosted: Sat Dec 16, 2017 2:23    Post subject: TFTP Server Reply with quote
Like I stated before, look into a specially named file served by a TFTP server (running on a computer, using TFTP32/TFTP64). The server must have an IP of 192.168.0.66. The file should be something close to:

Put an OpenWrt factory image named: for v8 mr3420v2_tp_recovery.bin or wr841nv8_tp_recovery.bin (for v8.4); for v9 wr841nv9_tp_recovery.bin; for v10 wr841nv10_tp_recovery.bin; for v11 and v12 wr841nv11_tp_recovery.bin in the root directory of an TFTP server and start it. For v12 you still need a v12 firmware. Just the filename has to be named as a v11 device!

These devices are really hard to actually brick. They just soft brick.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
Netgear R7800 - gateway, DHCP, QoS, VPN
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - not used
Ciao121
DD-WRT Novice


Joined: 15 Dec 2017
Posts: 9

PostPosted: Sat Dec 16, 2017 9:53    Post subject: Reply with quote
This is what i did. I downloaded the file you kindly tried to provide. I renamed it to wr840nv3_en_tp_recovery.bin.
Then, using a TFTP server on the PC with 192.16.0.66 ip, the file was downloaded by the router.
At this point the router stated flashing (I presume). After few seconds all leds started blinking on/off together. And at each blink, if there is a connected ethernet cable, the connection link "reset".
Like if the router is switching on/off each second. Obviously the router can't boot in this short time and I cannot ping it (tried anyway 192.168.0.1 and 192.168.1.1).
Also it do not try to GET the file from the TFTP server.
Tried 30/30/30 but nothing changes. This is why i think it's bricked.

Took a short video:
https://www.youtube.com/watch?v=dMRvfQ680Ko
This goes on infintely
Ciao121
DD-WRT Novice


Joined: 15 Dec 2017
Posts: 9

PostPosted: Sat Dec 16, 2017 10:09    Post subject: Reply with quote
Sorry.. It was not bricked... keeping the reset button down without releasing it during startup made it redownload from TFTP. This was different from how it was before. Anyway I'm back, with the original TP-LINK firmware Smile
MomenMamdouh
DD-WRT User


Joined: 19 Sep 2017
Posts: 64
Location: Egypt

PostPosted: Sat Dec 16, 2017 17:00    Post subject: Reply with quote
Ciao121 wrote:
Until now I can successfully transfer the wr840nv3_en_tp_recovery.bin file using TFTP. But for some reason the router is not flashing it.
I can't find a way to find any log of what happens after the file transfer.
Trying the same file in the router's web interface give a similar issue. The file seems to be accepted but I have back an error (thesame as in my previous post): "Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name"

So maybe this is the same reason the file is not flashed after the TFTP transfer.

Maybe MomenMamdouh can help. I saw he did 2 steps:
1) make the840 -> 841
2) flahs the dd-wrt firmware for the 841
while I'm only doing 1 step using your file

MomenMamdouh did you try the ian5142 solution? Did it worked for you?

thank you both!!!


You have to follow the solution i wrote before.

TFTP via bootloader won't accept any factory-to-dd-wrt image with a modified header, I don't know if there is any sort of protection applied by tp-link that might prevent flashing custom firmware or even a stripped original one directly via TFTP!!

I think the way i did it is safe because both of wr840nv3 and wr841nv11 uses almost the same hardware and the same CPU operating freq
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum