WRT32X

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page Previous  1, 2, 3 ... , 14, 15, 16  Next
Author Message
Skoda Zek
DD-WRT User


Joined: 07 Apr 2018
Posts: 69
Location: Calgary, AB Canada

PostPosted: Sat Jun 16, 2018 17:22    Post subject: Reply with quote
Conclusions on r36104 for the WRT32X

I can confirm with absolute confidence that if you follow the following guide you can get r36104 installed on you WRT32X from stock Venom via SSH.

Quote:
this is exactly the commands I used and in exact order

root@OpenWrt:~# cd
root@OpenWrt:~# fw_printenv silent
silent=1
root@OpenWrt:~# fw_setenv silent
root@OpenWrt:~# fw_printenv silent
## Error: "silent" not defined
root@OpenWrt:~# wget https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2018/06-10-2018-r36104/linksys-wrt32x/FW_WRT32X_1.0.666_DDWRT.img
<Wait for Wget Download to complete 100%>
root@OpenWrt:~# fw_printenv boot_part
boot_part=1
root@OpenWrt:~# fw_setenv boot_part 2
root@OpenWrt:~# sysupgrade -i -n -v FW_WRT32X_1.0.666_DDWRT.img
Keep config files over reflash (y/N): N

A number of verboise terminal output will display such as killall etc, wait for it to say: "sysupgrade successful" and you can flip the power switch on the back of your WRT32x off and back on. (NOTE: I waited several minutes after the sysupgrade successful message came up before I did anything). At first I thought I had bricked it cause it took a long time to boot up and finally assign an ip to my PC. I power cycled the router several times and hit the reset button once before I just decided to let it boot up for several minutes and when I came back I was able to get a dd-wrt gui at 192.168.1.1


A huge thanks goes to spuriousoffspring & eibgrad for without the help from them I would be completely lost and would have likely hard bricked my WRT32X several times over. They are without a doubt vastly more experienced and informed in regards to router firmware, openwrt, openvpn, iptables, dnsmasq, and dd-wrt especially than I. Thanks again for all your help.

I have tested OpenVPN, Policy Based Routing, IPTables, DNSMasq, DNS (DNS Encryption), USB, DLNA, USB Printing, Multiple DHCP, Statics, Dual Router Bridging, and various other functions available in DD-WRT and can confirm without any doubt that everything works except for 2 issues that I have given up on trying to fix.

One is essentially cosmetic in nature and is really not that important. The lights on the front of WRT32X are working except for a lightswap. Instead of the Internet light turning on/solid when WAN connection is established, the ESATA light turns on and goes solid. This is likely just a minor code error in DD-WRT that has these 2 lights mixed up. Really is of no consequence to functionality.

The second is in regards to DNSMasq and the additional opens likely customizing multiple dns based on IP and MAC address etc, no matter what I did I could not get this to function. Had to use iptables firewall script in Administration to achieve this, which has only one noticeable downside. The limitation of only one DNS server rather than multiples when assigning to specific devices.

Besides the aforementioned 2 problems I cannot seem to find any other issues with the current beta release of DD-WRT for the WRT32X. Of course I am sure there are other functions to which I have no use or lack the knowledge to test that may or may not work as intended but I think it is fair to say that for the vast majority of users the current status of DD-WRT firmware for the WRT32X is essentially stable. The biggest concern at this point is to make it flashable from stock Venom without the use of SSH for ease of use and accessibility to a much more general user base.

Again, I appreciate all the help offered over the last couple weeks while trying to get my complex network needs stable and I have achieved it with the current available firmware. Perhaps knowing this will provide an incentive to find a way to make it easily flashable as it really is fully functional in it's current incarnation.

UPDATE:
Slight update to the light issue. I just took notice of something while watching a review for the WRT32X on youtube. The Internet light that does not work with DD-WRT in the current beta build is actually supposed to be active, not solid. IE. Flashes based on WAN activity. The ESATA light that lights up is solid and never flashes which indicates to me that perhaps its not just a case of swapped light indicators in the software. Again this is entirely cosmetic and does not effect the router functionality or performance but I wanted to point it out because fixing it may be a little more involved than what I originally anticipated.
Sponsor
spuriousoffspring
DD-WRT Guru


Joined: 05 Apr 2017
Posts: 983
Location: South of Heaven, USA

PostPosted: Mon Jun 18, 2018 11:51    Post subject: Reply with quote
isg17 wrote:
Just a quick note about DavidC502's OpenWRT/Lede firmware release. I had an opportunity to try this out today for the first time. His contributions to creating and maintaining his release are quite impressive. However, please note that his factory.img file for the WRT32X is a "ubinize'd" file. That means that there is no way to perform a Venom GUI or secure shell sysupgrade process using that file. Consequently, his image will allow you to successfully perform a partition flash from the Venom U-Boot environment (this requires a serial cable to issue the commands).

The benefit of using the Development Snapshot Build of OpenWRT is that there is an upgrade process that doesn't require you to open up your WRT32X unit and use a serial cable to upgrade. The only downside of this build, as @spuriousoffspring indicates below, is that you will have to manually install the LuCI (web GUI) if you don't want to set up OpenWRT from the Linux command line.

spuriousoffspring wrote:
Until DD-WRT is ready for the WRT32X, LEDE/OpenWRT is performing extremely well.
There's a 'learning curve' if you're unfamiliar with it, but it's easy enough to figure out and there are plenty of guides.

For a complete build ready to go out the box:
https://davidc502sis.dynamic-dns.net/releases/#32x

*The lede-mvebu-cortexa9-linksys-wrt32x-squashfs-factory.img is for first time installation from Linksys Venom GUI.

I went with the latest Development Snapshot Build here:
https://downloads.openwrt.org/snapshots/targets/mvebu/cortexa9/

*You will have to install the LEDE/OpenWRT GUI (LuCI) manually via SSH.
The first time you access the new firmware via SSH just enter the following commands:

opkg update
opkg install luci

and then

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable

LuCI Installation Guide:
https://openwrt.org/docs/guide-user/luci/luci.essentials-tomerge

Quick Start Guide:
https://openwrt.org/docs/guide-quick-start/begin_here

User's Guide:
https://openwrt.org/docs/guide-user/start

There's a OpenWRT Package Repository with a Policy Based Routing add-on as well as others here:
https://github.com/stangri/openwrt-repo


UPDATE:
I was able to flash the 6.16.2018 Davidc502 build directly from Venom GUI
https://davidc502sis.dynamic-dns.net/releases/#32x

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

WRT32X DD-WRT Installation Procedure
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

IPVanish OpenVPN Client Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=308565

FIRMWARE: OpenWrt SNAPSHOT r8217-2cc821e / LuCI Master (git-18.276.41146-280dd33)
MODEM: ARRIS SURFBoard SB8200
ROUTER: Linksys WRT32X
USB NAS: Western Digital BLACK 1 TB Hardrive + Startech USB 3.0 External SATA III Enclosure
Skoda Zek
DD-WRT User


Joined: 07 Apr 2018
Posts: 69
Location: Calgary, AB Canada

PostPosted: Fri Jun 22, 2018 16:14    Post subject: Reply with quote
Whats the status of the latest beta build for WRT32x?
Im still using r36104 simply because with the exception of the front activity light for internet and ESATA not working right everything seems to be good and stable.

I don't want to mess with something that is not broken but wanted to know if upgrading to the latest beta firmware is worth it. Are the indicator lights working properly now?
spuriousoffspring
DD-WRT Guru


Joined: 05 Apr 2017
Posts: 983
Location: South of Heaven, USA

PostPosted: Fri Jun 22, 2018 16:26    Post subject: Reply with quote
Negative. LEDs are still wonky.

Power LED = Working
WAN LED = Not Working
WiFi LEDs = Working
ESATA LED = Constant ON
USB1 LED = Unknown
USB2 LED = Not Working
LAN 1-4 LEDs = Working

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

WRT32X DD-WRT Installation Procedure
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

IPVanish OpenVPN Client Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=308565

FIRMWARE: OpenWrt SNAPSHOT r8217-2cc821e / LuCI Master (git-18.276.41146-280dd33)
MODEM: ARRIS SURFBoard SB8200
ROUTER: Linksys WRT32X
USB NAS: Western Digital BLACK 1 TB Hardrive + Startech USB 3.0 External SATA III Enclosure
spuriousoffspring
DD-WRT Guru


Joined: 05 Apr 2017
Posts: 983
Location: South of Heaven, USA

PostPosted: Sat Jun 23, 2018 5:31    Post subject: Reply with quote
LEDs will be working properly in the next build. Thank you, Brainslayer!

https://svn.dd-wrt.com/changeset/36182

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

WRT32X DD-WRT Installation Procedure
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

IPVanish OpenVPN Client Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=308565

FIRMWARE: OpenWrt SNAPSHOT r8217-2cc821e / LuCI Master (git-18.276.41146-280dd33)
MODEM: ARRIS SURFBoard SB8200
ROUTER: Linksys WRT32X
USB NAS: Western Digital BLACK 1 TB Hardrive + Startech USB 3.0 External SATA III Enclosure
Hyperia
DD-WRT Novice


Joined: 24 Jun 2018
Posts: 11
Location: France

PostPosted: Sun Jun 24, 2018 2:00    Post subject: Reply with quote
Hello everyone

WRT32X user, I waited impatiently for several months the arrival of a version
that is compatible with the firmware update tool integrated into the native administration interface of the router.

And yesterday, I finally found my happiness. I hurried to install it
and have spotted the bug announced regarding the eSata light.

Another problem encountered and not least:

Receiving a security alert message a few seconds after being forced to override the default login credentials.

At this point, no way to identify me, the default connection idenfiants and custom ones do not work or more.

Nothing to do ! (reset, reflash, reboot)

So I went back to the Linksys firmware.
Disappointed with this false joy, I will come back in a few months to see if it gets better.

Good luck to the devs!


Last edited by Hyperia on Sun Jun 24, 2018 6:16; edited 1 time in total
spuriousoffspring
DD-WRT Guru


Joined: 05 Apr 2017
Posts: 983
Location: South of Heaven, USA

PostPosted: Sun Jun 24, 2018 3:13    Post subject: Reply with quote
If you're unable to login to DD-WRT GUI use to change credentials via Telnet / SSH:

setuserpasswd username password

For example:
setuserpasswd admin 12345678

User Name = admin
Password = 12345678

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

WRT32X DD-WRT Installation Procedure
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

IPVanish OpenVPN Client Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=308565

FIRMWARE: OpenWrt SNAPSHOT r8217-2cc821e / LuCI Master (git-18.276.41146-280dd33)
MODEM: ARRIS SURFBoard SB8200
ROUTER: Linksys WRT32X
USB NAS: Western Digital BLACK 1 TB Hardrive + Startech USB 3.0 External SATA III Enclosure
Hyperia
DD-WRT Novice


Joined: 24 Jun 2018
Posts: 11
Location: France

PostPosted: Sun Jun 24, 2018 5:59    Post subject: Reply with quote
When I log on to the DDWRT administration interface the first time, I am forced to change login credentials.

I apply it successfully, however, a few moments later, I'm forced to identify myself again as a result of an
inevitable window telling me that my connection isn't secure.

And it is at this moment that it is impossible for me to reconnect since the identifiers are announced
as invalid.

I also tried to identify myself using the default credentials, nothing helps.
Hyperia
DD-WRT Novice


Joined: 24 Jun 2018
Posts: 11
Location: France

PostPosted: Wed Jun 27, 2018 7:24    Post subject: .. Reply with quote
From the first use, obligation to replace the login credentials, a few moments later, need to reconnect since the connection
is announced as unsecured and there, no way to connect.

The default credentials do not work and those chosen manually either. Evil or Very Mad

Same problem with telnet and with last version
3.0-R36233

pffff Mad Evil or Very Mad
htismaqe
DD-WRT User


Joined: 05 Nov 2015
Posts: 464

PostPosted: Wed Jun 27, 2018 12:26    Post subject: Reply with quote
Your browser is likely informing you the connection isn't secure because DD-WRT is using a self-signed certificate. I haven't used Windows, Firefox, or Google Chrome in years but on MacOS with Safari, the first time the "this connection is not secure" warning comes up, instead of bypassing the warning, I bring up the certificate inspection window and tell my browser to trust the certificate. From there, everything works fine.
_________________
Routing:.......Netgear R7800 (DD-WRT v3.0-r40270M kongat)
Switching:....Netgear GS608_V3 & Netgear GS605_V4
Hyperia
DD-WRT Novice


Joined: 24 Jun 2018
Posts: 11
Location: France

PostPosted: Wed Jun 27, 2018 13:39    Post subject: Reply with quote
Is the certificate problem responsible for the invalid login credentials that i insert? Question
htismaqe
DD-WRT User


Joined: 05 Nov 2015
Posts: 464

PostPosted: Wed Jun 27, 2018 14:03    Post subject: Reply with quote
Hyperia wrote:
Is the certificate problem responsible for the invalid login credentials that i insert? Question


I can't say 100% for certain but it is possible...

_________________
Routing:.......Netgear R7800 (DD-WRT v3.0-r40270M kongat)
Switching:....Netgear GS608_V3 & Netgear GS605_V4
spuriousoffspring
DD-WRT Guru


Joined: 05 Apr 2017
Posts: 983
Location: South of Heaven, USA

PostPosted: Wed Jun 27, 2018 17:11    Post subject: Reply with quote
I believe the certificate warning would only come up if you were using https://192.168.1.1. Also, https would have had to been enabled in GUI under: Administration - Management - Web Access

Make sure you are using: http://192.168.1.1

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

WRT32X DD-WRT Installation Procedure
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

IPVanish OpenVPN Client Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=308565

FIRMWARE: OpenWrt SNAPSHOT r8217-2cc821e / LuCI Master (git-18.276.41146-280dd33)
MODEM: ARRIS SURFBoard SB8200
ROUTER: Linksys WRT32X
USB NAS: Western Digital BLACK 1 TB Hardrive + Startech USB 3.0 External SATA III Enclosure
Hyperia
DD-WRT Novice


Joined: 24 Jun 2018
Posts: 11
Location: France

PostPosted: Wed Jun 27, 2018 17:18    Post subject: Reply with quote
I'm absolutely certain to use HTTP and not HTTPS.
Skoda Zek
DD-WRT User


Joined: 07 Apr 2018
Posts: 69
Location: Calgary, AB Canada

PostPosted: Thu Jun 28, 2018 7:27    Post subject: Reply with quote
What your describing sounds a lot like an unsigned certificate which only applies when using https (SSL). I would recommend taking a screenshot of this page that prevents you from logging into your router firmware for us, that would allow us to diagnose and likely give you an immediate solution.
Goto page Previous  1, 2, 3 ... , 14, 15, 16  Next Display posts from previous:    Page 15 of 16
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum