New Build 40932: BS 09-07-2019-r40932

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 1854
Location: Texas, USA

PostPosted: Sat Sep 07, 2019 14:12    Post subject: New Build 40932: BS 09-07-2019-r40932 Reply with quote
Downloads: (if a link does not work, try another)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/09-07-2019-r40932/
ftp://ftp.dd-wrt.com/betas/2019/09-07-2019-r40932/
Alternate link: DD-WRT website
Note: for wget (or curl) with CLI flash (`write {f/w} linux`), change the https to http, use `curl -k {link} -o {file}`, or use ftp

Changelogs:
SVN* changelog since last build: 40900
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.2 and newer
2. 'KRACK' vulnerability fixes were completed in r33678 for Broadcom, including k26 (33655) & k24 (33656); use 33772 or later.
3. Bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead as WDS doesn't work with Broadcom ARM either (see Issues below).
4. PBR/UDP with SFE working again since r40513 (see 6729)
4. CAKE scheduler added since r40547 (see 5796)

Issues, observations, and/or workarounds reported:
1. Trendnet 81*DRU models are missing factory-to-flash
2. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use: 6246
3. WDS does not work on Broadcom ARM devices (only MIPS<->MIPS)
4. K2.6 builds are broken since 38253(?) (GUI issues): 6538
5. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
This appears fixed (only for unbridged VAPs?) with r40564:40566...

Important: if reporting any issues, provide applicable info (GUI syslog, `dmesg`, `cat /var/log/messages`, etc.)
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b]Router/Version: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Mode: [/b]
[b]Status: [/b]

WARNING: This thread is to report on flashing this experimental test build, providing important info for both developers and users. Always state your hardware model, version, mode (e.g. Repeater) and SPECIFIC build (e.g. 33555_NEWD-2_K3.x_mega-nv64k.bin). Please avoid discussions and create a new thread to discuss specific problems or questions, as this thread is for reporting, not support. Posts may be deleted or moved to keep this thread manageable and useful. If you don't understand the risks or what to flash and how, with a means of recovery if it bricks, do NOT flash this experimental test build.
Sponsor
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1441
Location: Belgrade

PostPosted: Sat Sep 07, 2019 14:50    Post subject: Reply with quote
Router/Version: Netgear R6250
Kernel: Linux 4.4.191 #1163 SMP Sat Sep 7 06:35:50 +04 2019 armv7l
Mode: PPPoE (QoS, WG, AP 2,4&5)
Status: Working, very stable

Thx BS!!!
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1546
Location: Zwolle

PostPosted: Sat Sep 07, 2019 17:23    Post subject: Reply with quote
E3000 and E4200 V1 work OK as access points with dd-wrt.v24-40932_NEWD-2_K3.x_mega-e3000.bin .
_________________
2 times RT-AC56U running 33772 with entware-ng, Yamon 3 (SFE disabled).

Asus RT-N16 running Merlin LTS fork RT-N16_3.0.0.4_374.43_2-25E8j9527.trx with entware-ng.

2 times Asus RT-N16 running dd-wrt.v24-33772_NEWD-2_K3.x_big.bin with entware-ng

E4200 V1 running dd-wrt.v24-33772_NEWD-2_K3.x_mega-e3000.bin

3 times Linksys WRT610N V2 converted to E3000 and 1 original E3000 running dd-wrt.v24-33772_NEWD-2_K3.x_mega-e3000.bin (bridged with LAN cable)

Veritech
DD-WRT User


Joined: 02 Jan 2007
Posts: 79

PostPosted: Sat Sep 07, 2019 18:06    Post subject: WNDR4500v2 Reply with quote
Tested on:
Router/Version: WNDR4500v2
File: DD-WRT v3.0-r40932 giga (09/07/19)
Kernel: Linux 3.10.108-d8 #26590 Sat Sep 7 11:11:38 +04 2019 mips
Mode: Access Point/switch WAN assigned to switch
Status: Working with issues
Uptime: 13min
Temps: WL0 44.6 °C / WL1 46.4 °C

This build still cannot flash without breaking boot loop and tftp stock then flash with .chk file while radios are enabled. Disable the radios (both 5G and 2.4G) and the firmware flash works well and is completed rather quickly. The previous build 40900 was stable if radios disabled. Stability for this build will be check and I'll update this post in approximately 24hrs or sooner if stability is still suspect with radios turned on.

.:EDIT:.
Current uptime is 16hrs and 39 min, forgot I had reconfigured a weekly restart. I has been stable up till 4:30am local time. So far over 24hrs the first go around. I changed the SSIDs from my mesh to a test SSID during that time. Not sure if spaces or special characters play a stability role but worth checking. Will post and update in the next day or so.

.:EDIT PART 2:.
System uptime is 4 days, 13:06
It has been acting in WAP mode since boot. Temps are still good. Moving to next beta version to test if still bricks on flash.


Last edited by Veritech on Fri Sep 13, 2019 22:40; edited 2 times in total
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 251

PostPosted: Sat Sep 07, 2019 19:30    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r40932 std (09/07/19)
Kernel: Linux 4.4.191 #1163 SMP Sat Sep 7 06:35:50 +04 2019 armv7l
Previous: r40900
Mode/Status: Gateway / working
Reset: no
Issues/Errors: Working well so far.

Uptime: 3hr 15min
Temperatures: CPU 69.1 °C / WL0 48.3 °C / WL1 54.3 °C
tinkeruntilitworks
DD-WRT User


Joined: 21 May 2019
Posts: 95
Location: northeast us

PostPosted: Sat Sep 07, 2019 23:24    Post subject: Reply with quote
Router: Netgear R7000P
Kernel: Linux 4.4.191 #1168 SMP Sat Sep 7 07:02:15 +04 2019 armv7l
Mode: Gateway / AP / Unbound / QoS CAKE
Status: all seems well


Last edited by tinkeruntilitworks on Mon Sep 09, 2019 21:36; edited 1 time in total
wabe
DD-WRT Guru


Joined: 17 Jun 2006
Posts: 681

PostPosted: Sun Sep 08, 2019 13:18    Post subject: Reply with quote
Router: ASUS RT-AC68U rev A1 & C1
Kernel: Linux 4.4.191 #1168 SMP Sat Sep 7 07:02:15 +04 2019 armv7l
Mode: Gateway
Reset: No, just power cycle after upgrade
Status: Works well. Guest network, Openvpn and Samba share operational in addition to normal functions.

_________________
AC-68U rev. C1 on Build 40932
AC-68U rev. A1 on Build 40270M
AC-68U rev. A1 on Build 40932


Last edited by wabe on Tue Sep 10, 2019 17:15; edited 1 time in total
MysticGold04
DD-WRT Novice


Joined: 20 Apr 2018
Posts: 15
Location: Troubleshooting

PostPosted: Sun Sep 08, 2019 19:26    Post subject: Reply with quote
Router/Version: Asus TM-ac1900 (AC68u)
Firmware: DD-WRT v3.0-r40932 std (09/07/19)
Kernel: Linux 4.4.191 #1163 SMP Sat Sep 7 06:35:50 +04 2019 armv7l
Previous: r40900
Mode/Status: Client Bridge / AP (2 different units)
Reset: no
Issues/Errors: Working as configured

Uptime: 19 hours

_________________
TM-AC1900 x4 (AC68U) John's fork and DD-WRT Kong Build 40270M (bridges)
lpy
DD-WRT Novice


Joined: 17 Oct 2017
Posts: 19

PostPosted: Mon Sep 09, 2019 10:42    Post subject: Reply with quote
Router/Version: Asus RT-AC68U
File: asus_rt-ac68u-firmware.trx
Firmware: DD-WRT v3.0-r40932 std (09/07/19)
Kernel: Linux 4.4.191 #1163 SMP Sat Sep 7 06:35:50 +04 2019 armv7l
Mode: Gateway/AP
Status: HFSC broken. Internet doesn't work when it's enabled. Previous build works.
underdose
DD-WRT Novice


Joined: 12 Jun 2019
Posts: 14

PostPosted: Mon Sep 09, 2019 13:15    Post subject: Reply with quote
lpy wrote:
Router/Version: Asus RT-AC68U
File: asus_rt-ac68u-firmware.trx
Firmware: DD-WRT v3.0-r40932 std (09/07/19)
Kernel: Linux 4.4.191 #1163 SMP Sat Sep 7 06:35:50 +04 2019 armv7l
Mode: Gateway/AP
Status: HFSC broken. Internet doesn't work when it's enabled. Previous build works.


HSFC + FQ_Codel_Fast works perfectly on my N66U. Did you try to reboot one more time after FW upgrade? Most of the time a reboot solves all the quirks.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 3765
Location: Netherlands

PostPosted: Mon Sep 09, 2019 13:21    Post subject: Reply with quote
Router Model: Linksys EA6900 (XVortex CFE)

Firmware Version: DD-WRT v3.0-r40932 std (09/07/19)
Kernel Version: Linux 4.4.191 #1163 SMP Sat Sep 7 06:35:50 +04 2019 armv7l

Upgraded: DD-WRT v3.0-r40270M kongac via telnet (update via GUI or ddup –flash-latest not possible because nvram is placed on linux partition and not linux2 partition due to Xvortex CFE)

Reset: Yes, before and after (Erase NVRAM and WPS reset)

Configuration: AP, DHCP server, 2,4GHz wireless running, 5GHz running, some static leases, SFE on, NVRAM size just 32K (NVRAM size should not be a problem with the Xvortex CFE), OpenVPN client on PIA with PBR script running.

Status: Up and stable for 3 days, excellent wireless speed and range
Errors: none so far

Thanks BrainSlayer!!

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
Simple PBR (Policy Based Routing) script: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318662
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN server setup guide:
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
lpy
DD-WRT Novice


Joined: 17 Oct 2017
Posts: 19

PostPosted: Mon Sep 09, 2019 13:27    Post subject: Reply with quote
underdose wrote:
HSFC + FQ_Codel_Fast works perfectly on my N66U. Did you try to reboot one more time after FW upgrade? Most of the time a reboot solves all the quirks.

Yes. Definitely broken. It might have something to do with my Netmask Priority settings, but either way, setting HFSC broke the internet connection and reconnected every time I disabled it. It doesn't do that in r40900. I even tried a factory reset.
adasch
DD-WRT Novice


Joined: 02 Jan 2015
Posts: 46
Location: Gdansk, Poland

PostPosted: Mon Sep 09, 2019 18:37    Post subject: Reply with quote
egc wrote:
Router Model: Linksys EA6900 (XVortex CFE)

Firmware Version: DD-WRT v3.0-r40932 std (09/07/19)
Kernel Version: Linux 4.4.191 #1163 SMP Sat Sep 7 06:35:50 +04 2019 armv7l

Upgraded: DD-WRT v3.0-r40270M kongac via telnet (update via GUI or ddup –flash-latest not possible because nvram is placed on linux partition and not linux2 partition due to Xvortex CFE)

Reset: Yes, before and after (Erase NVRAM and WPS reset)

Configuration: AP, DHCP server, 2,4GHz wireless running, 5GHz running, some static leases, SFE on, NVRAM size just 32K (NVRAM size should not be a problem with the Xvortex CFE), OpenVPN client on PIA with PBR script running.

Status: Up and stable for 3 days, excellent wireless speed and range
Errors: none so far

Thanks BrainSlayer!!

Hello, How about your score with speed test on 2.4 Ghz?
Could you check it with enable virtual interface on 2,4Ghz?

My speed with only connected 6 clients (two on Virtual interface) reach leve
l 30 Mbps some times mor but newer more than 60Mbps. On 5GHz I reach full speed (about 120Mbps)

_________________
Linksys EA6900
Firmware: DD-WRT v3.0-r35531 std (03/26/1Cool
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 3765
Location: Netherlands

PostPosted: Mon Sep 09, 2019 19:44    Post subject: Reply with quote
Sorry this router is in my summer residence in rural France with really crappy ADSL, only one laptop with me.
Laptop connects at 144 Mb/s (two stream 20 MHz) at 2,4 GHz and 300 Mb/s 40 MHz at 5 GHz (laptop only use N so 2 stream 40 MHz is 300 Mb/s )
But can not test actual throughput.

Some pointers for wireless settings: never use auto channel and use N or N/G mixed

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
Simple PBR (Policy Based Routing) script: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318662
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN server setup guide:
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 1854
Location: Texas, USA

PostPosted: Wed Sep 11, 2019 3:32    Post subject: Cisco Linksys E4200 v1 Reply with quote
Router Model / Version: Cisco Linksys E4200 v1
File: dd-wrt.v24-40932_NEWD-2_K3.x_mega-e4200.bin
Firmware: DD-WRT v3.0-r40932 mega (09/07/19)
Kernel: Linux 3.10.108-d8 #26606 Sat Sep 7 11:23:37 +04 2019 mips
Previous: DD-WRT v3.0-r40854 mega (08/29/19)
Reset: No
Mode: Gateway / AP
Uptime: ~4:30
Status: OK
Issues/Errors: All good so far. Decided to bump to this one for giggles. Speedtest numbers dropped off a little, but it could've been that the neighborhood cable usage was busy, or I didn't wait long enough for things to settle out. Performance wasn't noticeably bothered by the driver reverts prior to 40890 aside from that, it seems.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum