WRT32X Stuck on Boot after Reset to Stock Firmware

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
Usori
DD-WRT Novice


Joined: 04 Apr 2019
Posts: 9

PostPosted: Fri Apr 12, 2019 4:49    Post subject: WRT32X Stuck on Boot after Reset to Stock Firmware Reply with quote
\Edit: Totally restored the router by flashing the "flat" OEM Linksys Venom firmware. I then used the firmware update feature within the flat OEM firmware to install the regular OEM Venom firmware. Then did OEM-DDWRT flash. Then followed spuriousoffspring's instructions for flashing the webflash version of dd-wrt without overwriting the stock Venom firmware. Reverted to the first Jauary 2019 build. Looking to find out latest stable build, because someone recommended not using anything from February... What build are we using guys?
Edit\

Got a bricked WRT32X, could really use some help.

So long story short:

was trying to set up virtual wireless network as an isolated guest network on ath1 2.4GHz. Was messing with bro, br1, and so forth, adding bridges and trying to figure out how to link it all together to make guest separate and unable to access web GUI

think i accidentally set eth0 as an interface on brX something or other. Broke internet upon applying settings, but real trouble didn't begin until restart. Now can't connect to web GUI over WiFi or Ethernet. Couldn't force it to switch to good partition, which had the Venom-to-DDWrt version of the firmware, whereas the broken partition was the build listed in my signature.

so I was able to get in via USB to TTL serial cable using PuTTy and TFTPD64 and I thought I had flashed the Venom firmware to both partitions successfully, but upon issuing reset command, the boot appears to hang. Have retried this several times. I'm assuming neither of the partitions have a good firmware installation on them now.

I was thinking that maybe the fact that I forgot to quit out of my VPN might have had an affect, so I have tried this several times with VPN disabled. Are there Windows 10 firewall settings that may be screwing with this?

Here is the youtube video tutorial I followed: https://www.youtube.com/watch?v=PZYXKAkuJ5w

Here is the Linksys firmware I downloaded: https://www.linksys.com/us/support-article?articleNum=226203

Edit: tried this firmware but got same result: https://forum.dd-wrt.com/phpBB2/download.php?id=41827
Which comes from this thread: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316094

Edit: have also tried this firmware, same reuslt:
blkt wrote:
About venom.img that's floating around here, it is -not- an official Linksys compiled firmware but compiled from GPL source by inteliboy from this thread.

On page 9 it has been shown that this method of compiling a flat image was unnecessary and frankly his actions were a disservice, harming relations as GPL source downloads were taken offline.

Though the inteliboy image is commonly referred to as venom.img, it's identical to the rango.img from that same thread via zippyshare. You will also find this same image named FW_WRT32X_1.0.170919.nonjenkins-inteliboy-1619.img ...

The conversion method provided by adi-brasov has been successfully replicated by others using official Linksys sysupgrade firmware to create a flat image for use with serial flash.

Here is the current version flat image, properly converted.

flat-FW_WRT32X_1.0.180404.58.img (here is adi-brasov's post about it)


Also, I figured out that I have to CTRL+C out of the normal boot in order to get to the Venom>> CLI. So I'm assuming my bootloader is good.

Below is the output of my attempt to flash both partitions with stock Venom firmware, starting with CTRL+C'ing out of boot:

Code:

BootROM - 1.73
Booting from NAND flash

General initialization - Version: 1.0.0
AVS selection from EFUSE disabled (Skip reading EFUSE values)
mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed
Detected Device ID 6820
High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3
Serdes Lane 4 is SGMII
board SerDes lanes topology details:
 | Lane # | Speed|    Type     |
 ------------------------------|
 |   0    |  6   |  SATA0      |
 |   1    |  5   |  PCIe0      |
 |   2    |  6   |  SATA1      |
 |   3    |  5   |  USB3 HOST1 |
 |   4    |  5   |  PCIe1      |
 |   5    |  0   |  SGMII2     |
 -------------------------------
:** Link is Gen1, check the EP capability
PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities
:** Link is Gen1, check the EP capability
PCIe, Idx 1: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.46.0
mvSysEnvGetTopologyUpdateInfo: TWSI Read failed
DDR3 Training Sequence - Switching XBAR Window to FastPath Window
DDR3 Training Sequence - Ended Successfully
Not detected suspend to RAM indication
BootROM: Image checksum verification PASSED
l

U-Boot 2013.01 (May 18 2017 - 16:37:44) Marvell version: 2015_T1.QA.0p16

Boot version : v2.0.9

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0
Venom>> <INTERRUPT>
Venom>> <INTERRUPT>
Venom>> <INTERRUPT>
Venom>> <INTERRUPT>
Venom>> <INTERRUPT>
Venom>> setenv ipaddr 192.168.1.1
Venom>> setenv serverip 192.168.1.2
Venom>> setenv firmwareName venom.img
Venom>> run update_both_images
Using egiga0 device
TFTP from server 192.168.1.2; our IP address is 192.168.1.1
Filename 'venom.img'.
Load address: 0x2000000
Loading: #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################
         3.4 MiB/s
done
Bytes transferred = 10741760 (a3e800 hex)

NAND erase: device 0 offset 0x900000, size 0x7b00000
Erasing at 0x83e0000 -- 100% complete.
OK

NAND erase: device 0 offset 0x8400000, size 0x7b00000
Erasing at 0xfee0000 -- 100% complete.
OK

NAND write: device 0 offset 0x900000, size 0xa3e800
 10741760 bytes written: OK

NAND write: device 0 offset 0x8400000, size 0xa3e800
 10741760 bytes written: OK
Venom>> reset
resetting ...

BootROM - 1.73
Booting from NAND flash

General initialization - Version: 1.0.0
AVS selection from EFUSE disabled (Skip reading EFUSE values)
mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed
Detected Device ID 6820
High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3
Serdes Lane 4 is SGMII
board SerDes lanes topology details:
 | Lane # | Speed|    Type     |
 ------------------------------|
 |   0    |  6   |  SATA0      |
 |   1    |  5   |  PCIe0      |
 |   2    |  6   |  SATA1      |
 |   3    |  5   |  USB3 HOST1 |
 |   4    |  5   |  PCIe1      |
 |   5    |  0   |  SGMII2     |
 -------------------------------
:** Link is Gen1, check the EP capability
PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities
:** Link is Gen1, check the EP capability
PCIe, Idx 1: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.46.0
mvSysEnvGetTopologyUpdateInfo: TWSI Read failed
DDR3 Training Sequence - Switching XBAR Window to FastPath Window
DDR3 Training Sequence - Ended Successfully
Not detected suspend to RAM indication
BootROM: Image checksum verification PASSED


U-Boot 2013.01 (May 18 2017 - 16:37:44) Marvell version: 2015_T1.QA.0p16

Boot version : v2.0.9

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0

_________________
Thanks to spuriousoffspring for getting me where I am: https://forum.dd-wrt.com/phpBB2/profile_sec.php?mode=viewprofile&u=410326
DD-WRT Installation & Setup TUTORIAL: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117
WRT32X DD-WRT Installation Procedure: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569
Check for Mullvad VPN Connectivity, DNS Leaks, Etc: https://am.i.mullvad.net/
Mullvad VPN Setup Guide for DD-WRT Routers: https://mullvad.net/en/guides/dd-wrt-routers-and-mullvad-vpn/
VPN Comparison Chart: https://thatoneprivacysite.net/vpn-comparison-chart/

FIRMWARE: DD-WRT v3.0-r39715 std (05/03/19)
MODEM: Linksys CM3024
ROUTER: Linksys WRT32X


Last edited by Usori on Sat Apr 13, 2019 8:01; edited 1 time in total
Sponsor
Usori
DD-WRT Novice


Joined: 04 Apr 2019
Posts: 9

PostPosted: Fri Apr 12, 2019 6:34    Post subject: Looks Like I'm In Reply with quote
So I was about to follow Linksys' TFTP utility guide, and the 1 minute hold of the reset button seems to have gotten me in.
https://www.linksys.com/us/support-article?articleNum=137928

I believe I am running the "flat" firmware that blkt posted, which is linked above and again here:
flat-FW_WRT32X_1.0.180404.58.img: https://forum.dd-wrt.com/phpBB2/download.php?id=41511

I am now in the Linksys web GUI preparing to flash DD-Wrt again.

_________________
Thanks to spuriousoffspring for getting me where I am: https://forum.dd-wrt.com/phpBB2/profile_sec.php?mode=viewprofile&u=410326
DD-WRT Installation & Setup TUTORIAL: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117
WRT32X DD-WRT Installation Procedure: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569
Check for Mullvad VPN Connectivity, DNS Leaks, Etc: https://am.i.mullvad.net/
Mullvad VPN Setup Guide for DD-WRT Routers: https://mullvad.net/en/guides/dd-wrt-routers-and-mullvad-vpn/
VPN Comparison Chart: https://thatoneprivacysite.net/vpn-comparison-chart/

FIRMWARE: DD-WRT v3.0-r39715 std (05/03/19)
MODEM: Linksys CM3024
ROUTER: Linksys WRT32X
Usori
DD-WRT Novice


Joined: 04 Apr 2019
Posts: 9

PostPosted: Fri Apr 12, 2019 7:44    Post subject: Reply with quote
references for later http://tftpd32.jounin.net/tftpd32_download.html
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316094&postdays=0&postorder=asc&start=0
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315339
https://wiki.dd-wrt.com/wiki/index.php/Serial_Recovery
https://wiki.dd-wrt.com/wiki/index.php/Telnet/SSH_and_the_Command_Line#Security_Tips
https://www.youtube.com/watch?v=PZYXKAkuJ5w
https://community.linksys.com/t5/Wireless-Routers/Linksys-Firmware-Brick-WRT32x-Booting-from-NAND-flashBootROM-Bad/m-p/1353430
https://www.linksys.com/us/support-article?articleNum=137928
https://wiki.dd-wrt.com/wiki/index.php/TFTP_flash
ftp://ftp.dd-wrt.com/betas/2019/01-02-2019-r38159/linksys-wrt32x/
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/01-02-2019-r38159/linksys-wrt32x/

_________________
Thanks to spuriousoffspring for getting me where I am: https://forum.dd-wrt.com/phpBB2/profile_sec.php?mode=viewprofile&u=410326
DD-WRT Installation & Setup TUTORIAL: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117
WRT32X DD-WRT Installation Procedure: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569
Check for Mullvad VPN Connectivity, DNS Leaks, Etc: https://am.i.mullvad.net/
Mullvad VPN Setup Guide for DD-WRT Routers: https://mullvad.net/en/guides/dd-wrt-routers-and-mullvad-vpn/
VPN Comparison Chart: https://thatoneprivacysite.net/vpn-comparison-chart/

FIRMWARE: DD-WRT v3.0-r39715 std (05/03/19)
MODEM: Linksys CM3024
ROUTER: Linksys WRT32X
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum