D-Link DIR-882 A1 AC2600

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Ralink SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5 ... 9, 10, 11  Next
Author Message

Joined: 13 Dec 2015
Posts: 260

PostPosted: Fri Oct 12, 2018 4:26    Post subject: Reply with quote
hanmaan wrote:
How does anyone keep track of which version does what?

If you're technically inclined, you can read through the Timeline

hanmaan wrote:
Are there long term stable builds ...

No. Just beta releases for current routers.
DD-WRT Novice

Joined: 12 Oct 2018
Posts: 2

PostPosted: Fri Oct 12, 2018 4:53    Post subject: Reply with quote
As full of information the timeline is, it won't say what is changing build to build.

Guess people will just end up posting updates like:

Version Notes
35831 Port forwarding doesn't work
35927 Random reboots
36808 Untried, reported good
37139 USB won't mount
37305 Fixes the 37139 bug with USB won't mount, under review

Joined: 13 Dec 2015
Posts: 260

PostPosted: Sun Oct 14, 2018 3:36    Post subject: Reply with quote
For those curious,
No real issues encountered yet with build 10-10-2018-r37305, which has been up and running for the past two days...

UPDATE 3: 5 days and counting...

Last edited by casualtester on Wed Oct 17, 2018 4:54; edited 3 times in total
DD-WRT Novice

Joined: 15 Oct 2018
Posts: 2

PostPosted: Mon Oct 15, 2018 5:47    Post subject: DIR-882 build 10-10-2018-r37307; NAS not visible. Reply with quote
I have installed build r37307 in a D-Link DIR-882. It is working OK. But, I have 3 Buffalo NAS connected; none show up in the windows explorer network, in windows 10. I have also installed DD-WRT on a TP-Link Archer C7. I have both routers configured with the same IP address scheme and identical WiFi. The Buffalo NAS drives show up immediately when I switch to the TP-Link router.

I have researched other (Windows 10) reasons why the NAS may not show up. NETBIOS, SMB 1.0, Function Discovery Provider Host, SSDP Discovery, and UPnP Device Host. None of these are the cause of this issue.

Consequently, I believe the issue is with this DD-WRT firmware (DIR-882 specifically).

I had first tested this with r36698 in the DIR-882; the symptoms are the same.

Thank You in advance for any further insight into this.
DD-WRT Novice

Joined: 15 Oct 2018
Posts: 2

PostPosted: Mon Oct 15, 2018 5:55    Post subject: correction: r37305 in the DIR-882 Reply with quote
correction: 10-10-2018-r37305 is installed in the DIR-882, not r37307.

Joined: 13 Dec 2015
Posts: 260

PostPosted: Tue Oct 16, 2018 2:28    Post subject: Re: DIR-882 build 10-10-2018-r37307; NAS not visible. Reply with quote
ddwrt_pete wrote:
... I have 3 Buffalo NAS connected; none show up in the windows explorer network, in windows 10...

Similar topic: Windows 10 doesn´t see NAS
DD-WRT Novice

Joined: 17 Oct 2018
Posts: 14

PostPosted: Wed Oct 17, 2018 8:16    Post subject: Info needed Reply with quote
I recently bought this router.

And under wireless is see very few option and am planning to install the latest DD-WRT.

Am pretty new to DD-WRT, so bear with me.

Which will be best release in terms of stability ?

All the features are working ? like USB Ports and WiFi no connection drops.

I use a PPPoE connection, so any known issue with this connection type ?

Also under Wireless Settings do we have option of 160Mhz Channel Bonding ? as i dont see it in the Stock Firmware ?

Hope to hear soon from the Gurus.

Thanks in advance
DD-WRT Novice

Joined: 24 Oct 2018
Posts: 6

PostPosted: Thu Oct 25, 2018 14:42    Post subject: Reply with quote
Hi there!

Just found this on D-Link's official forum (thx to them, it's pretty nice to help people loading other firmware than theirs!!) and I thought it might useful for people like me who didn't manage to upload DD-WRT firmware Smile

You cannot load the DD-WRT firmware through the D-Link GUI. You will have to do a crash recovery.

. Hold the reset button down.
. While still holding the reset button down, press the power button (to turn the router off) for 5 seconds and then press the button again to turn the router on while still holding down the button. You can also pull the power plug out and back in instead of using the power button.
. Wait 10 seconds and then release. Allow about 90 seconds for the router to boot. The power LED will blink red.

4. You will need to statically assign your computer an IP address of (

5. Open Internet Explorer (do not use chrome, firefox, or edge). Go to The D-Link recovery page will appear. If it doesn't, you did not do the crash recovery properly. Repeat the process.

6. Browse to factory-to-ddwrt.bin file and click Upload.

7. Upgrade process should take 3-5 minutes.

8. When the success page appears, close your browser.

9. Change your IP settings on your computer to either DHCP or statically assign to 192.168.1.xxx ( The default IP of the router will be

10. Open Internet Explorer and enter DD-WRT will now be installed. You will be prompted to create a username and password.

11. You can now upgrade the DD-WRT firmware (dlink-dir882-webflash.bin). Go to Administration > Firmware Upgrade and browse to the "webflash.bin" file.

To go back to the D-Link firmware, download the latest firmware from support.dlink.com/dir-882-us. The current is 1.10 which contains 2 firmware files - 1.04 and 1.10.

Perform a crash recovery on the router. Load the 1.04 firmware first. Once completed, log in to the router ( username = admin password = leave blank). You will be prompted to update the firmware to 1.1 (1.10). Do that or you can upgrade to 1.10 manually.

Site Admin

Joined: 06 Jun 2006
Posts: 6860
Location: Dresden, Germany

PostPosted: Fri Nov 16, 2018 17:46    Post subject: Re: static g++/gcc/binutils is a success Reply with quote
broly wrote:
here's a GNUBS'D-out System V (or "linux" if you take uname seriously) DD-WRT image with a native BASH shell (with **working** resetbutton, Linux-PAM, DNSCRYPT, BLOGIC's Hardware NAT for MT7621 devices, and ENTWARE; don't think the first four are in BS' build). tools were built/based on a NeXTSTEP derivative with GLIBC.

currently kernel 4.14.81 and DD-WRT v37715
YO TP-LINK. hook up an A10, i'd love to finish/fill out my build with that extra 128MB (assuming the SPI can tolerate >16MB payload)
latest FW SE [special edition dedicated to John Crispin, aka blogic): factory-to-ddwrt.bin, dlink-dir882-a1-webflash.bin
directory tree of latest FW: https://pastebin.com/anfyEqiV LAST UPDATED 13112018 01:42GMT
bootlog of the latest FW: https://pastebin.com/EFgXicqG LAST UPDATED 12092018 21:57GMT
Linux 4.14.x kernel .config file
older FWs:
37398 factory-to-ddwrt, webflash
37441 factory-to-ddwrt, webflash
37488 factory-to-ddwrt, webflash
37618 factory-to-ddwrt, webflash
37634 factory-to-ddwrt, webflash

here are some additional applications that wouldn't fit on the ramdisk (install instructions are in the download msg):

  • glibc/bash/coreutils locales+tor0.3.4.8+PHP7.2.11+GNU Midnight Commander4.8.11+JAVA (via JamVM)+GRoFF1.22.3+minidlna+VIm8.8+tcl8.6.8+bitchx-git in a nice, tidy LOOTBAG (pam samba policy [pam_smbpass.so] included).
  • (Bell Labs-badgeworthy) NATIVE (mipsel-thread-multi) SHARED BSD perl 5.28.0 (prove me wrong when i say this is the best perl available on any embedded platform (c89std,sysvipc,decimal float,quadmath,manpages,etc).
  • NATIVE SHARED Python 2.7.14 [python] (hashlib [openSSL integration], Tk/Tcl, curses, curses_panel, libffi ctypes,nis,etc). here's what it DOESN'T have:_bsddb,_sqlite3,bsddb185,bz2,dbm,gdbm,readline,sunaudiodev
  • **SHARED+STATIC GCC 8.2.0/BINUTILS2.31.1 (with ld.gold+C11 threads support [libc2.28])** (C++/C/OBJC support, should be fully loaded) i think i've met the goals that i set out a few years ago, so i'll share this sucker. enjoy.
    root@DD-WRT:~# gcc -v
    Using built-in specs.
    Target: mipsel-none-linux-gnu
    Configured with: ../gcc-8.2.0/configure --build=i386-apple-darwin14 --host=mipsel-none-linux-gnu --enable-languages=c,c++,objc --with-system-zlib --enable-install-libiberty --enable-frame-pointer --enable-libffi --enable-decimal-float --enable-libquadmath --enable-libgomp --enable-libbacktrace --disable-multilib --with-native-system-header-dir=/include --cache-file=config.cache
    Thread model: posix
    gcc version 8.2.0 (GCC)
    root@DD-WRT:~# ld -V
    GNU ld (GNU Binutils) 2.31.1
    Supported emulations:

  • [13112018 0136GMT] links have been refreshed, toolchain is now using libc-2.28.
  • ** NOTE **: in case it is not obvious, much of the software compiled below is for mipsel-linux (and not a specific router), meaning it should work on ANY glibc-based MIPS32(el) platform.
  • everything else you need is probably available on Padavan's entware. i have only included the perl/python since i am confident they're as good (maybe better) than the entware offerings, but i feel the rest of entware is probably as-good as what was tediously posted over multiple links.


  • [09112018 22:45GMT] (37634++) the toolchain's peculiar linker error has been fixed. users would typically experience

    /tmp/mnt/main/usr/local/bin/../lib/gcc/mipsel-none-linux-gnu/8.2.0/../../../../mipsel-none-linux-gnu/bin/ld: /tmp/mnt/main/usr/local/bin/../lib/gcc/mipsel-none-linux-gnu/8.2.0/../../../crt1.o: in function `__start':
    /Volumes/xtoolshit/glibc-2.28/csu/../sysdeps/mips/start.S:99: undefined reference to `__libc_csu_init'
    /tmp/mnt/main/usr/local/bin/../lib/gcc/mipsel-none-linux-gnu/8.2.0/../../../../mipsel-none-linux-gnu/bin/ld: /Volumes/xtoolshit/glibc-2.28/csu/../sysdeps/mips/start.S:100: undefined reference to `__libc_csu_fini'

    when compiling executables. turns out libc_nonshared.a was corrupt. enjoy the seamless experience.
  • to use ENTWARE, do the following:
    mkdir /mnt/main #make main mount point directory
    mount /dev/sda1 /mnt/main #mount USB drive to main mount directory
    opt-opkg-upd.sh #run the opkg/entware installer script

    you now have opkg, and can install packages willy-nilly (tested myself! ENJOY! THIS IS WAY BETTER THAN I ANTICIPATED)
  • additional information about RT2880 (MT7615x2) configuration/manipulation

    • each radio now uses one configuration file (i.e. CONFIG_MULTI_PROFILE=n produces AC3467 at 5GHz)
    • VAPs can have distinct wireless channels from the main ssid. To set them, use wl{0,1}_channel=ssid1chan;vap1chan;vap2chan;vap3chan;...;vapNchan where the ordering of the N VAPs' channels (not sure if the limit N is 4, 8 or 16 different channels for VAPS on a single radio) should correspond to the order they are listed in the DD-WRT interface (or nvram settings). I think it's possible to have more VAPs than distinct channels for the respective radio. This feature should really let the mt7615 shine (deal with the reboots. don't create VAPs willy nilly and expect it in 10 seconds k, sometimes it takes 25-30seconds more)
    • users can instantiate the "wl{0,1}_dbdc={0,1}" nvram variable to enable DBDC mode for whichever radio. AC3467 is currently only possible without DBDC mode from my cursory assessment. still a work in progress.
    • PRO TIP #1: switching from BS to my build, or vice-versa, CAN (but SHOULD not [from my experience flashing back and forth for debugging purposes]) corrupt your nvram because we use different NVRAM drivers. BACK UP your settings and restore them after first-boot.

  • additional information about SNMPD

    • snmpd now linked to openssl and supports many more encryption types compared to before.
    • snmpd_conf is now leveraged by services. you can include additional arguments you'd like in snmpd.conf using this nvram variable, which is present in the httpd GUI when enabling the service. enabling encryption requires multiple lines, which can be entered as follows (thx ArchWiki) <angle brackets for command line-equivanet>
      <nvram set snmpd_conf=">rouser *desired username for snmp crypto*<hit enter>
      createUser *desired username for snmp crypto* SHA *desired SHA password* AES *desired AES password*"<hit enter>

  • additional information regarding NVRAM usage:

    • unlike BS's build, my build adheres to the manufacturer's NVRAM partitioning specification, thereby enabling usage of the full 88KB NVRAM spread across the (manufacturer's) five partition scheme. this approach yields 24KB more than BS's "generic" nvram driver that does not use the manufacturer's partitions AT ALL, instead opting to allocate+create a distinct 64KB NVRAM partition. choice is up to YOU, the (YO)USER
    • by default
      nvram show

      will display all nvram banks. i have added the option to show only ONE bank, specified either by the bank name or number (first number in square brackets, second number is the size [in bytes]) as follows:
      nvram show {RT2860_NVRAM [0;32768],RTDEV_NVRAM [1;8192], WIFI3_NVRAM [2;8192], CERT_NVRAM [3;4096], CONFIG2_NVRAM [4;32768]}

    • by default, {RTDEV,WIFI3,CERT}_NVRAM are used as a last-resort (i.e. only if {CONFIG,CONFIG2}_NVRAM are nearly full). the "almost full" heuristic used by the NVRAM is "(nvram_size-nvram_used) / nvram_size < .05"--i.e., less than 5% free.

      • RT2860_NVRAM does not use the heuristic criteria above; instead there is a hard cap of 1000 variables to ensure each variable can accommodate a reasonably-large string.
      • use RALINK's nvram_set if you want to manually set variables to a desired bank; services will have no problem reading/using them.

    • CERT_NVRAM holds the sshd_host key (can't hold much more. 4096 capacity. thought i'd make use of it for the certificate)

  • supported languages are (as of 35771): traditional chinese, german, hungarian, italian, latvian, polish, russian, portuguese, and english.
  • setuserpasswd/httpd's passwd change mechanism uses crypt_r, where i generate the (necessary) 2-byte salt via arc4random_buf--i.e., it is not generated by PAM, but is "PAM-esque". if you want a "pam password", use the "passwd" utility via sshd/telnet


truly grateful to be here, and not live in fear of being persecuted for being an independent thinker. don't know if i'd get that opportunity in any other country.

thank you for taking an immeasurable leap of faith in trying to teach us "The Way" over 200 years ago, Lord/Marquess Cornwallis
this is for you, SIR (doctor) MacKay (and of course: clan MacKAY), Sir TIM (you guys should know who this is), Clan(s) Cunningham Ross (ofc) and MANY others. thank you so much for taking a chance on us.), and of course, HRH HM!!

  • What's Different in your version of DD-WRT compared to the rest?

    • first and foremost: gLIBC 2.28. we disclose briefly disclose noteworthy distinctions, so readers can compare and contrast.

      • bash 5.0 beta [bash/bashbug] again, if i find it's unstable i will revert back to 4.4.19.
      • util-linux 2.33 [libmount/libuuid/liblkid/libfdisk{.so.1.x.x}, cfdisk, mount, umount, findmnt, login, pivot_root, losetup, runuser, hwclock, ctrlaltdelete, swapon, swapoff, agetty, rfkill]
      • libBSD ncurses 6.1 [patched up to 27102018] [libncurses++tw,libncursestw/libsmartcolstw/libpanel/libformtw] (tw suffix meanes "threaded+wide").compiled with reentrant,pthread-eintr,color-fgbgb,ext-colors, and the screen driver (among other things).
      • glib20 2.55.0 (using wide+threaded curses,util-linux mount, and libpcre-jit 8.41 for internal PCRE) [gmodule/gthread/gobject/gio/libiconv/gettext/gnuintl]
      • net-tools 1.60n [ifconfig]
      • SysV syslogd/klogd 1.5.0 because the busybox versions weren't working the way i wanted.
      • BSD(Apple) telnetd [telnetd] uses PAM authentication. (busybox's telnetd can't accommodate PAM-based logins)
      • GNU 'which' 2.21 (c'man, who WOULDN'T want GNU which?!)
      • coreutils 8.30 [all programs in single binary](threads+iconv+gnuintl)
      • ex-vi 050325 [ex,vi] (paying homage to the SysV/BSD guys. much better than bbawx's vi, but may need some tweaks)
      • iproute2, iproute2-ss170905 [ip,tc]
      • iptables 1.6.2 [iptables, ip6tables]
      • ebtables 2.0.10-4 [ebtables]
      • libpcap 1.8.1 [libpcap.so]
      • libdnet 1.10/1.11 [libdnet.so.2.43.2 {unofficial}/libdnet.1.0.1{official}] (1.10 used by common linux distros; 1.11 is OG. kept both to cement DD-WRT's OG status)
      • libgudev-232 [libgudev-1.0.so.0.2.0] (gnome and SysV's seemingly-eternal, yet recently-disturbed matrimony needed this*)
      • procps 3.2.8 [libproc-3.2.8.so/proc/ps/sysctl] again, their inclusion is justified by the added functionality
      • kmod-2.5 [kmod+{modprobe,depmod,insmod,rmmod,lsmod,modinfo} symlinks] (added functionality over busybox justifies inclusion)
      • pci-utils 3.5.5 [libpci.so.3.5.5] (built with kmod for an immersive experienced)
      • e2fsprogs 1.44.0 [libe2p.so/libext2fs.so, mke2fs, tune2fs]
      • autoconf 2.69 [autoconf,autoreconf,autoheader,aclocal] (see below)
      • automake 1.15 [aclocal automake] (including these is an easy one: with the new setup, mounting a foreign perl install like the one i gave above is easy. if you have internet, getting the automake package is also easy. so you should be good to go quite fast.)
      • GNUmake 4.2 [make] (iconv+intl+pthreads)
      • GNUfindutils 4.4.2 [xargs,find] (iconv+intl+pthreads)
      • GNUawk 4.2.1 [gawk] (libsigsegv+iconv+pthread+gnuintl'd)
      • GNUbison 3.2.1 [bison] (iconv+intl+pthreads)
      • GNUsed 4.5 [sed] (iconv+intl+pthreads)
      • GNUscreen 4.6.2[/url] [screen] (working on optimising usage of screen. would like it to get called at login time; ~/.screenrc points to /usr/local/home/.screenrc). thank you maarten and jussi
      • cap 2.25 [libcap.so] (capabilities library)
      • grep 3.1 [grep] (pcre+iconv+threads+intl)
      • attr 1.43.4 [libattr.so] (attributes library)
      • acl 2.2.52 [libacl.so] (access control lists library)
      • Linux-PAM 1.3.1 [/lib/security, /etc/pam.d]
      • shadow 4.5 [user{add,mod,del},group{add,mod,del}] (user-friendly utilities [when we get root] to manage users/groups/privs)
      • sysfsutils v2.1.0 [libsysfs.so] (kong inspired this addition. happy i imitated his style [love u kong;)])
      • file 5.32 [libmagic.so,file] (still limited definitions. add some symlinks in /usr/local/share/misc/magic to increase capabilities!)
        and of course...
      • libqm(FUCKING)i 1.20.0 [libqmi-glib.so.5.2.0,qmicli,qmiproxy,qmi-firmware-update] (because it's DD-WRT and LEGIT NETWORKS people get PRIORITY. not noobs)
      • libmbim 1.16.0 [libmbim-glib.so.4.2.0, mbimcli,mbim-proxy,mbim-network]
      • RALINK RT2800_APPS from 2017 SDK (all built on gLIBC; functional unless otherwise stated.):

        • bandsteering plus (bndstng2) (37497++) due to popular demand, has been re-added. i suspect the VAPpers love it. to use bndstng2, you must have two SSIDs with the same name, on different bands, on a given radio (iirc).
        • flash (lets you read flash memory in linux; saving you from having to hit up uboot)
        • rtdot1x (previously known as rt2860apd) is the new 80211x client for ralink radios. should work if you set the radius variables. i have verified that rtdot1x communicates with the MT7615 linux driver correctly.
        • nvram utilities [nvram_daemon/ralink_init] (for those wanting to return to RALINK's factory firmware [and thus, the factory NVRAM]).

    • Why should I use this version of DD-WRT as opposed to others (assuming availability)?

      • simple answer: don't.
      • i'm neither looking to attract casuals, nor infringe upon territories that my contemporaries have managed so well, for so long.

        • it should be clear that my "target audience" deviates significantly from my contemporaries (if posting serial-only fw files [not deliberately, mind you] didn't signify this already).
        • i hope that, in the near future, when i get the hang of the bare minimums required for basic network interface configuration, this will change. but again: not looking to infringe upon my contemporaries' territories, so it's not a priority

    • So you don't care if I use it, but you're posting like you want me to, what the fuck motivated this undertaking?

      • simple answer: a lot of my interest and involvement in dd-wrt is at the operating systems-level, which is the area of expertise of individuals who influenced me ("bill", and sir tim). i felt building the kernel from scratch for an embedded networking device is the "new frontier" since each radio can be looked at as a CPU, as it must shuttle its data separately from our activities.

        • with our data appetite seemingly growing, the CPU "brick wall" (3.2ish GHZ) going unaddressed, i felt the parallelisation/multiprocessing environment in a networks context would bear fruit at the theoretical (Computing Science) level.
        • there are interesting operating systems paradigms that arise, and i felt the current releases for embedded devices didn't share the same perspective (exception of the Beast known as Padavan; i'd have used his ralink_gpio if it worked with the DIR882, but no LEDs -_-)
        • lastly, i've been a DD-WRT "leech" for over 13 years, and looking at my contemporaries' work (eko/slayer/kong), i was both motivated and inspired to not be a moocher. as an example:

          • my source of inspiration for the recent, yet stripped-down, iptables/iproute2 were their 10 year old makefiles. without them, these programs are approximately five-fold larger. as such, i wanted to "step to the plate" and contribute to their great work, as my work is not possible without their decade-plus dedication to this area. they were doing great work while i was picking my ass, content with being mediocre.

        • in other words, my work is more of a "thank you" to the DD-WRT crew for their great work (evidenced by the stripped down makefiles/custom sources-where-necessary to facilitate reduced size) that many of us enjoy for free (for the most part).

* "IT'S THE GLOBAL ECKANAMY" <cue gesture:>

BONUS/HINT(s) (formerly titled "Bulletin Board") <- this "rant", while still mostly true, is retained since it contains a hint on how to fix the webGUI (for whoever is bold enough to build DD-WRT from source... there are only a few, but history has shown it is those who matter the most...)
i was being overtly generous to BS when i removed my original comment blaming the ugly webgui on the lack of repugly (it has nothing to do with my build configuration). the facts are that others have had this *EXACT* issue. i can't fault BS for not being forthcoming about the deliberate omissions for a working WEBGUI, as he has put a lot of effort into this project and has yet to receive adequate compensation proportional to this effort (something i think he was promised).

  • my take on this complicated situation is this: while the webgui was originally from Linksys, BS has put significant effort into the WEBGUI such that it has become synonymous with DD-WRT. as such, until he gets compensated (he has not, trust me) i will not get upset and start calling DD-WRT "buggy crap" because everything i've had to do was within the bounds of a properly-trained computing science undergraduate with expertise in Operating Systems. LONG STORY SHORT: none of us will get a working WEBGUI from the files in the SVN until BS is compensated. end of story.

    • in order to to shoot down the incorrect claims of "everything is in the source tree", and "all you need to do is uglify the *.js" files, i've attached a pretty decent set of compressed js files. if you compare them to kong's (inspect the webgui on one of his builds), you'll see it's extremely close (not identical obviously). however it's much uglier than the default set of files: (secret hint: BS was right that it's "all on SVN", but if you find the other hint in my "rant", you'll figure it out soon enough [sooner than it took me, at least {you're welcome}]).
      this (should) shoot down the idea that all that is missing is an uglifier.(secret knowledge only for those who spend the time reading my "blabber" and want a functional webGUI; two words: revision 7400)

      • further, if we are to assume all that is missing is uglification of the JS, i point readers to the fact that the compressed form of window_effects.js is the same as the uncompressed, further complicating any claim that uglification was the solution since the full set of uncompressed files are necessary
      • as i've hopefully belaboured throughout: i'm not "upset" or mad that they're withholding information to produce a working DD-WRT WEBGUI, but i would appreciate some honesty. unfortunately they're going to stick to their lie (just like ol' BAB and MLSE [don't forget the samuelis of broadCRAP]). at least be straight about it, jeez. your only critics are the losers who think everything in life should be free, and their expectations are bullshit. stop trying to meet them "on paper" but dodge them in reality, it doesn't look good.

    • lastly, do not believe the claims of "success", or you will be disappointed (i only saw those for the first time a few days ago, when i began thoroughly researching this problem lol). you can/will get a northstar/ARMv6+-based webgui working, but that's about it.

      • the alleged successes (save tsynik, hanskloss and like two other people) were all around the time i began my foray into this area, which certain "powers that (used to) be" used as an opportunity to show their recruits were worthy. however, as has been demonstrated time and time again, these recruits' tendencies to deliberately skew perceptions has been counterproductive (for nearly two centuries). in this case, anyone who is truly familiar with the source tree will know many of their alleged "solutions" are simply not true. such mistruths can only be learned when a post such as this respects/appreciates the sophistication of httpd (it really is amazing).

its really hard to follow up that drug or alcohol influence post as it seems, but i want to bring up one issue. the repugly which is nothing more than

for i in $1/*.js ; do uglifyjs --compress --mangle -- $i > $i.copy; cp $i.copy $i; rm $i.copy; done

uglifyjs can be found on github. but its nothing you need to use. its just to make everything small. its not required to get a working webinterface. the asp and js files can be used as is without mangeling

one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

Linux DD-WRT 4.14.8 #42 SMP PREEMPT Thu Dec 21 18:11:16 CET 2017 armv7l DD-WRT
root@DD-WRT:/sys# nvram get DD_BOARD
Netgear R7800
Site Admin

Joined: 06 Jun 2006
Posts: 6860
Location: Dresden, Germany

PostPosted: Fri Nov 16, 2018 17:51    Post subject: Re: Info needed Reply with quote
ashishchandra wrote:
I recently bought this router.

And under wireless is see very few option and am planning to install the latest DD-WRT.

Am pretty new to DD-WRT, so bear with me.

Which will be best release in terms of stability ?

All the features are working ? like USB Ports and WiFi no connection drops.

I use a PPPoE connection, so any known issue with this connection type ?

Also under Wireless Settings do we have option of 160Mhz Channel Bonding ? as i dont see it in the Stock Firmware ?

Hope to hear soon from the Gurus.

Thanks in advance

the wifi hw on the dir882 doesnt support 160 mhz. if you want 160 mhz use a qca9984 based router like the netgear r7800 or the netgear r9000. these routers do support these features and much more due the much better driver and chipset support

one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

Linux DD-WRT 4.14.8 #42 SMP PREEMPT Thu Dec 21 18:11:16 CET 2017 armv7l DD-WRT
root@DD-WRT:/sys# nvram get DD_BOARD
Netgear R7800
DD-WRT Novice

Joined: 01 Dec 2018
Posts: 2

PostPosted: Sat Dec 01, 2018 23:35    Post subject: Reply with quote
Does this firmware work with the dir 867? It's identical hardware.

If not, any chance of getting support for it?

DD-WRT Novice

Joined: 12 Dec 2018
Posts: 1

PostPosted: Wed Dec 12, 2018 12:58    Post subject: Reply with quote
Anyone got dlna to work? I can mount a usb hdd but I cannot successfully add a share - the button doesn't seem to do anything
DD-WRT Novice

Joined: 04 Jan 2013
Posts: 11

PostPosted: Mon Dec 24, 2018 12:36    Post subject: Reply with quote
I'm thinking on buying this router. But I'm seeing some odd information. Here it says that the router only has 16Mb flash:

Here it says 128Mb

And even some reviews says it has 128Mb flash AND 256Mb RAM??? (There is a different revision or something, because this specs are completely awkward?
Broadcom BCM4709C0 @ 1.4 GHz, 256 MB RAM, 128MB ROM

It seems they have messed up with a AC88U or an Archer C5400...

So reading most reviews everything points out at 128Mb Flash and 128Mb RAM

But I can't understand what happened with wikidevi faulty information.

Can any owner confirm?

Joined: 18 Nov 2015
Posts: 1174
Location: Indiana

PostPosted: Mon Dec 24, 2018 14:22    Post subject: Reply with quote
The build size for that router is 14.9MB.
Not all of the 128MB is reserved for NVRAM.
MY wndr3700v4 says 128MB also but only about 20MB can be used.

R7800 x2 kongat & BS WDS AP & Sta- R7500V2 BS std WDS STA- WNDR3700v4 BS std WDS STA- Nanostation M2 AirOS- LocoM2 AirOS
R6200v2 kongac WLAN Repeater Archer C9 v1 OEM WAP

DDWRT Policy Based Routing guide by egc
DD-WRT Novice

Joined: 04 Jun 2013
Posts: 9

PostPosted: Thu Jan 17, 2019 20:48    Post subject: Reply with quote
larkey wrote:
This isn't that easy because v1.10b2 won't downgrade, and the recovery is buggy, as described. However I found a workaround:

1. Enter recovery mode
2. Load the WebUI, browse the file upgrade file, do *not* hit "Upload"
3. Reboot the router, again into recovery mode (s.t. the upload will be the first request sent, thus succeeding).
4. Perhaps wait a little more than the 3:40mins until "Succeeded" is automatically printed, the router should automatically reboot.

Thank you for sharing that Larkey. I had the same problem and same solution! Seems to be a bit of a buggy router overall!

On another note, I couldn't get the factory to dd-wrt to flash using Internet Explorer, but for me it worked using Chrome, of course YMMV.
Goto page Previous  1, 2, 3, 4, 5 ... 9, 10, 11  Next Display posts from previous:    Page 4 of 11
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Ralink SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum