New Build - 04/17/2020 - r42914

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Ralink SoC based Hardware
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 1486

PostPosted: Fri Apr 17, 2020 15:16    Post subject: New Build - 04/17/2020 - r42914 Reply with quote
This thread is for feedback on beta build r42914 for developers and users (configuration, status, errors & logs).
Please list hardware model & revision, operating & wireless modes along with the exact file applied to upgrade.

Flashing any beta build assumes you are responsible, have researched, know the risks and recovery methods.
If you are unsure about your router, which file or recovery methods, do NOT flash this experimental test build.
Avoid discussions, create a new thread for specific problems, questions or use search as this is not for support.


Downloads: (DD-WRT website) HTTPS & FTP

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Changelogs: SVN changelog since last build: r42910

Notes: 1. CVE-2019-14899 VPN fix from December, since then various revisions including recently 7040.
2. In-kernel Samba has been implemented this year and default min/max versions have changed, with WSD support.
3. VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
4. WireGuard! New GUI Tunnel options have appeared since r42872, script no longer required!

Issues: 1. There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important: if reporting issues, provide applicable info (syslog output, 'dmesg', 'cat /var/log/messages', serial output etc.)
or place into an SVN ticket. For firewall issues, also provide iptables info ('iptables -L', 'iptables -t nat -L', & the /tmp/.ipt file).
Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with any relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]Config/Mode: [/b]
[b]Status/Errors: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
Sponsor
mrwulf
DD-WRT Novice


Joined: 27 Jan 2020
Posts: 42

PostPosted: Fri Apr 17, 2020 21:14    Post subject: Reply with quote
Router Model / Version: Dlink DIR-882 A1
File: dlink-dir882-a1-webflash.bin
Firmware: DD-WRT v3.0-r42910 std (04/15/20)
Kernel: Linux 4.14.176 #275 SMP Fri Apr 17 14:53:38 +04 2020 mips
Previous: DD-WRT v3.0-r42910 std
Reset: No
Mode: PPPOE Router / AP
Uptime: ~ 4 hours
Status: Working
Issues / Errors: No issues
phzr
DD-WRT Novice


Joined: 09 Apr 2020
Posts: 5

PostPosted: Sat Apr 18, 2020 23:09    Post subject: Reply with quote
Router Model / Version: Dlink DIR-882 A1
File: dlink-dir882-a1-webflash.bin
Firmware: DD-WRT v3.0-r42910 std (04/15/20)
Kernel: Linux 4.14.176 #275 SMP Fri Apr 17 14:53:38 +04 2020 mips
Previous: DD-WRT v3.0-r42910 std
Reset: No
Mode: PPPOE Gateway / AP / VAP
Uptime: ~ 12 hours
Status: Working
Issues / Errors: No issues

This build is working really well. GUI is fast and stable. 80Mhz channels on ath1 working well with transfer speeds closing in on 600Mbps on my iPhone. PPOE working fine. VAP also working with devices connected.
mrwulf
DD-WRT Novice


Joined: 27 Jan 2020
Posts: 42

PostPosted: Sun Apr 19, 2020 7:26    Post subject: Reply with quote
Had two PPPOE drop outs both at 23:05 every evening. Connection remains up on the DSL side so not a modem issue.

Rolled back to 42747.
AsGF2MX
DD-WRT Novice


Joined: 27 Oct 2006
Posts: 24

PostPosted: Sun Apr 19, 2020 13:52    Post subject: Reply with quote
Router Model / Version: Dlink DIR-882 A1 
File: dlink-dir882-a1-webflash.bin 
Firmware: DD-WRT v3.0-r42910 std (04/15/20) 
Kernel: Linux 4.14.176 #275 SMP Fri Apr 17 14:53:38 +04 2020 mips 
Previous: DD-WRT v3.0-r42910 std 
Reset: No 
Mode: Gateway
Uptime: ~ 3 hours 
Status: Working 
Issues / Errors:

Finally the SGI works properly and I can get at least 500M. (For reference: 2.4 n only auto, 5G is N/AC also auto both WPA2) 2 wired devices (clocking 800M to internet) and 4 wireless devices.

Setting QOS (disable SFE, apply and reboot,enable QoS) still causes the router to stop accepting traffic on all interfaces even if I manually disable SFE first. As I am now on FTTH, I found disconnecting the WAN does not work as it still keeps the last WAN dhcp in memory.

Point of note, if I set static IP and ping the router its arp entry on my pc will show. It's definitely on the network but it won't accept connection. I also have PPTP setup but it doesn't accept the connections. Also it seems only at the point httpd/etc come up will the Lan interface stop responding to ping.

Tried to get logs but after multiple attempts I had to use the recovery mode to flash back and set the unit up over and over. Not entirely sure I will need QOS at this point but I will still help if I can.

Https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1200833#1200833

Edit: I know one of the previous builds had a tester comment that PPTP pass through doesn't work. I tested it today and found that I am able to initiate the connection from LAN get as far as verifying username and then it sits there for a bit and the connection drops.

Is there any chance to confirm resetbutton daemon is monitoring gpio 15 for reset? It doesn't work
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Ralink SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum