New firmware: DD-WRT v3.0-r31160M kongac (01/18/17)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next
Author Message
labo
DD-WRT Guru


Joined: 30 Jan 2015
Posts: 586
Location: Texas, USA

PostPosted: Wed Jan 18, 2017 22:52    Post subject: New firmware: DD-WRT v3.0-r31160M kongac (01/18/17) Reply with quote
Kong released new build: DD-WRT v3.0-r31160M kongac (01/18/17)

http://desipro.de/ddwrt/K3-AC-Arm/

Your reports for Broadcom units are greatly appreciated !
Router:
Firmware:
Kernel:
Status:
Reset:
Errors:

This build thread is for reporting successes and problem with loading this experimental test build. This is important info for developers and users. Always state your hardware and SPECIFIC build (e.g. 29440_NEWD-2_K2.6_mega-nv64k.bin). Do not ask questions about your specific router or how to configure it in this thread; create your own thread to discuss any specific problems you have or need resolved. Please also do not respond to such questions. This thread is to report info, not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you know how to flash properly and the risk before using this build. It is important to adhere to these requirements, to keep this thread from becoming impossibly long and useless. If you don't know what build to flash and how to flash properly and have a means of recovery if things should go wrong, do NOT flash this experimental test build.
_________________
Sponsor
CloneVince
DD-WRT User


Joined: 31 May 2014
Posts: 216

PostPosted: Wed Jan 18, 2017 23:01    Post subject: Reply with quote
R7000 updated with

Quote:
ddup --flash-latest


No problem so far, thx Kong Smile

_________________
Unofficial Kong's release repository : http://ddwrt-kong.clonevince.fr/
labo
DD-WRT Guru


Joined: 30 Jan 2015
Posts: 586
Location: Texas, USA

PostPosted: Wed Jan 18, 2017 23:03    Post subject: Reply with quote
Router: RT-AC5300
Firmware: Upgraded from 31100M via ddup
Kernel: Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l
Status: Using JFFS2, Up and working so far.
Reset: No
Errors: None so far.

Thanks Kong! for a quick turnaround build after the broken R31135M release.
freebird317
DD-WRT User


Joined: 21 Dec 2009
Posts: 50

PostPosted: Wed Jan 18, 2017 23:20    Post subject: Reply with quote
R8000

ddup --flash-latest

No nvram reset

running good. THX Very Happy
Bembel
DD-WRT Novice


Joined: 18 Jan 2017
Posts: 5

PostPosted: Wed Jan 18, 2017 23:25    Post subject: Reply with quote
Router: Linksys EA6700
Firmware: DD-WRT v3.0-r31160M kongac (01/18/17)
Kernel: Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l
Status: Working
Reset: No
Previous: 31115 - updated using mtd on telnet/ssh [ddup wouldn't work for me - but I never used ddup before]
Errors: wl0 not working (b/g mixed), configured to channel 9, status shows channel 1 - not visible / wl1 works (n/ac mixed) - will wipe configuration and try again tomorrow

Services:
Wireless (wl0,wl1)
usb (JFFS2 -> MiniDLNA DB)
dnla server
samba server

Bricked the device with 31115 multiple times the other day, left it running without MiniDLNA nor startup script until I updated a few hours ago.

EDIT: Downgraded without reset to 30965 (no luck), upgraded to 31160 again (still wl0 not working), wiped the config through power on&reset, basic config got both WiFis working, after JFFS2, Samba and startup script config wl0 was "dead" again. Now running 31160 on basic config until I have more time to test.


Last edited by Bembel on Thu Jan 19, 2017 8:26; edited 1 time in total
decompiled
DD-WRT User


Joined: 02 Jan 2008
Posts: 72

PostPosted: Thu Jan 19, 2017 0:27    Post subject: Reply with quote
Router: R7000
Status: Working
Reset: No
Errors: None
Upgraded from previous release. Using features static wan, dhcp lan, qos, port forwarding, sshd, dnscrypt and both radios.

So far so good!
Corsair1274
DD-WRT User


Joined: 08 Jul 2012
Posts: 51

PostPosted: Thu Jan 19, 2017 1:26    Post subject: Reply with quote
Routers: Buffalo WZR 1750 DHP (Primary)
Buffalo WZR 1750 DHP (Secondary)
Buffalo WZR 1750 DHP (Secondary)
Firmware: DD-WRT v3.0-r31160M kongac (01/18/17)
Kernel: Linux 4.4.43 #223 SMP armv7l
Status: All Good
Reset: No
Errors: None observed
e3000usr
DD-WRT User


Joined: 09 Jul 2014
Posts: 183

PostPosted: Thu Jan 19, 2017 3:50    Post subject: Reply with quote
Router: Asus RT-AC56U
Firmware: DD-WRT v3.0-r31160M kongac (01/18/17)
Kernel: Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l
Status: OK
Reset: NO
Errors: NONE

Thank you Kong and Brainslayer!
pcheng
DD-WRT Novice


Joined: 19 Jan 2017
Posts: 1

PostPosted: Thu Jan 19, 2017 5:13    Post subject: Reply with quote
Flashed on a new R8000, and did reset before and after.
After setting client bridge on the 2.4 Ghz network, router rebooted and has been unable to boot since.

It doesn't respond to ping or telnet, and seems stuck in a repeated sequence of leds flashing. 30/30/30 reset did not do anything either. Currently looking into the serial cables I've seen mentioned around here.

Any thoughts on whether client bridge is expected to work? And other thoughts on recovery options?

Thanks
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 155

PostPosted: Thu Jan 19, 2017 5:52    Post subject: Reply with quote
Router: Netgear R7000
Firmware: DD-WRT v3.0-r31160M kongac (01/18/17)
Kernel: Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l
Status: Working
Reset: No
Previous: 31100
Errors: No

CPU Temperature : CPU 51.9 °C / WL0 45.0 °C / WL1 49.0 °C
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 2057
Location: Netherlands

PostPosted: Thu Jan 19, 2017 9:08    Post subject: Reply with quote
Bembel wrote:
Router: Linksys EA6700
Firmware: DD-WRT v3.0-r31160M kongac (01/18/17)
Kernel: Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l
Status: Working
Reset: No
Previous: 31115 - updated using mtd on telnet/ssh [ddup wouldn't work for me - but I never used ddup before]
Errors: wl0 not working (b/g mixed), configured to channel 9, status shows channel 1 - not visible / wl1 works (n/ac mixed) - will wipe configuration and try again tomorrow

Services:
Wireless (wl0,wl1)
usb (JFFS2 -> MiniDLNA DB)
dnla server
samba server

Bricked the device with 31115 multiple times the other day, left it running without MiniDLNA nor startup script until I updated a few hours ago.

EDIT: Downgraded without reset to 30965 (no luck), upgraded to 31160 again (still wl0 not working), wiped the config through power on&reset, basic config got both WiFis working, after JFFS2, Samba and startup script config wl0 was "dead" again. Now running 31160 on basic config until I have more time to test.


If you are using an external USB device do not enable JFFS2 on the Administration tab, that is to enable internal storage!
If you want I can send you a guide to use USB and NAS.

Question: are you on an alternative CFE? If so be very careful with the JFFS2 internal storage. At least erase nvram before updating and also after.
If you do not use an alternative CFE you could have hit the 32 Kb NVRAM bug.

For more details see the install guide for the EA6900 in my signature.
P.S. Using an alternative CFE is also the reason why ddup does not work Sad

_________________
Router Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
mgm
DD-WRT User


Joined: 27 Dec 2013
Posts: 69

PostPosted: Thu Jan 19, 2017 10:53    Post subject: Reply with quote
Router: Netgear R7000
Firmware: DD-WRT v3.0-r31160M kongac (01/18/17)
Kernel Version: Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l
Status: Working
Reset: No
Previous: 31135
Errors: No

CPU Temperature : CPU 54.5 °C

OpenVPN via Script in Command Tab
DNSMasq/Encrypt DNS
no wireless
Static IP

all works well since 12 hours

thx@kong/brainslayer
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 2057
Location: Netherlands

PostPosted: Thu Jan 19, 2017 11:56    Post subject: Reply with quote
Router Model: Netgear R6400

Firmware Version: DD-WRT v3.0-r31160M kongac (01/18/17)
Kernel Version: Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l

Upgraded: from 31135M via ddup --flash-latest
Reset: No

Status: Up and running for 2 hours, basic setup as AP, static leases, OpenVPN (PIA) up and running, 2,4GHz and 5Ghz working, USB storage and DLNA working

There is a bug in OpenVPN client (also in earlier versions) where DNSMasq is not always using the pushed DNS servers due to a timing problem when resolv.dnsmasq is made. @eibgrad knows the details and will report.
If you are using OpenVPN client be sure to check for DNS leak!

Thanks Kong and BrainSlayer!!

_________________
Router Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
kallsop
DD-WRT User


Joined: 10 Apr 2008
Posts: 135

PostPosted: Thu Jan 19, 2017 12:54    Post subject: Reply with quote
R7000 updated from 31135M via GUI, no reset.

Code:

DD-WRT v3.0-r31160M kongac (01/18/17)
Linux 4.4.43 #223 SMP Wed Jan 18 20:22:16 CET 2017 armv7l

WAN
LAN
2.4GHz WiFi main + guest / WPA2
5GHz WiFi / WPA2
VPN client with policy based routing
dnscrypt + DNSSEC
Port forwarding
Static IP's
QoS


All looks good so far. Not using USB or jffs.
decryption
DD-WRT Novice


Joined: 19 Jan 2017
Posts: 1

PostPosted: Thu Jan 19, 2017 13:13    Post subject: Reply with quote
Router: Netgear EX6200
Firmware: DD-WRT v3.0-r31160M mini (01/18/17)
Kernel: Linux 4.4.43 #222 SMP Wed Jan 18 20:15:47 CET 2017 armv7l
Status: Working
Reset: No
Previous: no previous - first flash of DD-WRT
Services: OpenVPN client
Errors: when enabling "Encrypt DNS" in the DNSMasq options, the drop down box for DNS Crypt Resolver is empty. No options can be selected. Is this normal? How do I get DNS Crypt to work? Here's a screenshot:

Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next Display posts from previous:    Page 1 of 8
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum