FON 2201 - LaFonera+ Latest recommend running release

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
KillerDAN
DD-WRT Novice


Joined: 26 Jun 2013
Posts: 3
Location: PORTUGAL

PostPosted: Thu Aug 20, 2015 18:25    Post subject: FON 2201 - LaFonera+ Latest recommend running release Reply with quote
Anyone still running this hardware these days ?

After a failed upgrade attempt some downgrading and tackling got it running again in:

v24 SP1

For those issuing recommendations whiteout this hardware, and for reference, it is:

Chipset Atheros AR531X
RAM 16 MB
FLASH 8 MB

Prior to the (failed) upgrade was running:

v24 pre SP2 r14896

In between was able to boot several releases up to r27600 but at the time interfaces where messed up and was unable to connect to the box other than serial cable console. Cannot tell if it was a release issue or effects of the failed upgrade.

Curious also to notice latest releases are ~800K smaller that v24 SP1/ pre SP2.

_________________
_____________________
FON2201
FON2202
FON2301
Sponsor
harre
DD-WRT Novice


Joined: 15 Mar 2016
Posts: 3

PostPosted: Tue Mar 15, 2016 17:55    Post subject: Reply with quote
For future googlers.

I have a fon2201 and it seem to be quite unstable on any firmware I throw at it.

I have by trial and error came up to that releases after revision 17967 have some problem with ethernet not being loaded. ifconfig shows no entry for eth0 for releases after that, wireless works though.

I have run wireshark and the fon is completely silent on any of the ethernet ports.

I have also a fon2100a/b/c and it runs without any issues build from yesterday.
arssant
DD-WRT Novice


Joined: 14 Aug 2013
Posts: 13

PostPosted: Tue Nov 12, 2019 12:23    Post subject: Reply with quote
Hi.

I know old post, but same issue here.
I tested a lot o release since revision 17967, and all of them fail to run network correctly.
No ping, no dhcp, no packets over lan port or wireless ( SSID is up and discoverable ).
Telnet to fon2201 port 9000 still connecting to redboot, and I was able to install any release via TFTP.

Code:
root@DD-WRT:~# ifconfig
ath0      Link encap:Ethernet  HWaddr 00:18:84:A2:47:1D
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

br0       Link encap:Ethernet  HWaddr BA:FD:46:1D:83:44
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:252 (252.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING MULTICAST  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:696 (696.0 B)  TX bytes:696 (696.0 B)

wifi0     Link encap:UNSPEC  HWaddr 00-18-84-A2-47-1D-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:408 errors:0 dropped:0 overruns:0 frame:50
          TX packets:95 errors:25 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:295
          RX bytes:113758 (111.0 KiB)  TX bytes:6991 (6.8 KiB)
          Interrupt:3 Memory:b0000000-b000ffff


with revision 17967, all interfaces are working and fon2201 is up and running stable.

Code:

ath0      Link encap:Ethernet  HWaddr 00:18:84:A1:7E:E1 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:176 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
br0       Link encap:Ethernet  HWaddr 00:18:84:A1:7E:E0 
          inet addr:192.168.4.1  Bcast:192.168.4.255  Mask:255.255.255.0
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:1451 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1841 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:105443 (102.9 KiB)  TX bytes:1669637 (1.5 MiB)
eth0      Link encap:Ethernet  HWaddr 00:18:84:A1:7E:E0 
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:1500 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1886 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:81268 (79.3 KiB)  TX bytes:1678117 (1.5 MiB)
          Interrupt:255 Base address:0x1000
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING MULTICAST  MTU:16436  Metric:1
          RX packets:13 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1106 (1.0 KiB)  TX bytes:1106 (1.0 KiB)
vlan0     Link encap:Ethernet  HWaddr 00:18:84:A1:7E:E0 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1500 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1841 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:109544 (106.9 KiB)  TX bytes:1669637 (1.5 MiB)
vlan1     Link encap:Ethernet  HWaddr 00:18:84:A1:7E:E1 
          inet addr:192.168.1.252  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:1890 (1.8 KiB)
wifi0     Link encap:UNSPEC  HWaddr 00-18-84-A1-7E-E1-00-00-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:412 errors:0 dropped:0 overruns:0 frame:106
          TX packets:72 errors:40 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:295
          RX bytes:105508 (103.0 KiB)  TX bytes:8588 (8.3 KiB)
          Interrupt:3 Memory:b0000000-b00ffffc



Question: anyone had succeed to install newer release ?
harre
DD-WRT Novice


Joined: 15 Mar 2016
Posts: 3

PostPosted: Tue Nov 12, 2019 13:04    Post subject: Reply with quote
It's like mission complete when an old post you have made gave users in the future some help Smile

I think I put the foneras back into my tinker-box and put it up on the attic after last post. They became redundant as the new wifi-AP had greater coverage.

I might move to a bigger place next year so perhaps I have use for them again and will check if I can bring them back to life Smile
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum