New build: DD-WRT 30631 - 2016/09/14

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3, 4  Next
Author Message
KrypteX
DD-WRT Guru


Joined: 18 Jan 2014
Posts: 2411

PostPosted: Wed Sep 14, 2016 16:48    Post subject: New build: DD-WRT 30631 - 2016/09/14 Reply with quote
DD-WRT build 30631 - 2016/09/14 has been released: ftp://ftp.dd-wrt.com/betas/2016/09-14-2016-r30631

Changelog: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=279466

Your reports for Qualcomm/Atheros units are greatly appreciated !
Router:
Firmware:
Kernel:
Status:
Reset:
Errors:

This build thread is for reporting successes and problem with loading this experimental test build. This is important info for developers and users. Always state your hardware and SPECIFIC build. Do not ask questions about your specific router or how to configure it in this thread; create your own thread to discuss any specific problems you have or need resolved. Please also do not respond to such questions. This thread is to report info, not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you know how to flash properly and the risk before using this build. It is important to adhere to these requirements, to keep this thread from becoming impossibly long and useless. If you don't know what build to flash and how to flash properly and have a means of recovery if things should go wrong, do NOT flash this experimental test build.

_________________
THERE ARE NO STRANGERS HERE; ONLY FRIENDS YOU HAVEN'T YET MET.
________________________________________________________________________________________________________
DD-WRT CHANGELOG | DEVICES | DD-WRT BUILDS | KONG BUILDS | UNOFFICIAL BUILDS | DD-WRT in VIRTUALBOX

Testing BrainSlayer's DD-WRT build 31924 on various units:
NETGEAR : WNDR3800 WNDR3800CH WNDRMACv2 WNDRMACv1 WNR2200 WNR2000v3
TP-LINK : ArcherC7v3 WR1043NDv3 WR740Nv4 WR740Nv6 WR710Nv1 WR810Nv1 WA850REv1 WA901NDv3 WA901NDv4
D-LINK : DIR-862L DIR-615D2
ASUS : RT-N10 C1
VirtualBox : x86_64
Sponsor
Hackintosh
DD-WRT Novice


Joined: 06 Dec 2015
Posts: 35

PostPosted: Wed Sep 14, 2016 18:04    Post subject: Reply with quote
THANK YOU - For all that you do. Cool

Router: TP-Link N600 (WRD3600 v1.5)
Firmware:

Originally -- : DD-WRT v3.0-r30534 std (09/01/16)

NEW -- DD-WRT v3.0-r30631 std (09/14/16)

Kernel:

Originally -- Linux 3.10.103 #168 Thu Sep 1 11:05:01 CEST 2016 mips

NEW -- Linux 3.10.103 #1174 Wed Sep 14 02:44:27 CEST 2016 mips

Status: GOOD (as far as I can tell - lol)

Reset: NO (kept settings and router rebooted normally as expected in any update)

Errors: None at this time.




Side note: Really wish the interface supported 4 dns (not just 3). ipv6 seems to only support 2 (while ipv4 3). But that's just me. lol I'm sure there is a reason that its 'as is'.
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4711
Location: Texas

PostPosted: Wed Sep 14, 2016 18:22    Post subject: Reply with quote
Netgear WNDR3700 V4
DD-WRT v3.0-r30631 std (09/14/16)
Linux 3.18.41 #826 Wed Sep 14 04:23:33 CEST 2016 mips
GUI install over 30605 - No Reset

All I use seems ok -
8 wireless devices did connect back after update. Some on ath0 - ath0.1 - ath1
No problems so far.
Just one ugly w/ath: phy0 I thought was a long-time-ago bug ¿
But only the 1 time thus far.
root@-----:~# dmesg | tail -5
<4>[ 60.470000] IMQ: autocreate imq1 NS 803b6410
<6>[ 60.470000] IMQ driver loaded successfully. (numdevs = 2, numqueues = 1)
<6>[ 60.480000] Hooking IMQ before NAT on PREROUTING.
<6>[ 60.480000] Hooking IMQ after NAT on POSTROUTING.
<3>[ 365.660000] ath: phy0: Could not kill baseband RX
root@-----:~# uptime
13:19:35 up 49 min, load average: 0.10, 0.05, 0.00

Also don't see DNSMasq size. I don't usually change it so it's always 1500.
Usually found >>> :~# /bin/ps | grep dnsmasq
but it don't say.

EDIT:


Last edited by mrjcd on Wed Sep 14, 2016 20:14; edited 1 time in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4711
Location: Texas

PostPosted: Wed Sep 14, 2016 19:29    Post subject: Reply with quote
EA8500
DD-WRT v3.0-r30631 (09/14/16)
Linux 3.18.41 #104 SMP PREEMPT Wed Sep 7 13:12:34 CEST 2016 armv7l

erase nvram reboot
'Save' and 'Apply Settings' buttons both broken in Setup/Basic Setup

Samba share ok
2.4 & 5 both ok using motorola droid turbo
that's all imma doing with this -
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1450
Location: Belgrade

PostPosted: Wed Sep 14, 2016 19:33    Post subject: Reply with quote
Router Model GL.iNet-AR150
Firmware Version DD-WRT v3.0-r30631 std (09/14/16)
Kernel Version Linux 3.18.41 #842 Wed Sep 14 04:59:36 CEST 2016 mips

Status: working much better than OpenWRT :p
Reset: initial flash
Errors: None
@BS thx for supporting this little guy it is just awesome!!!


Router Model TP-Link TL-WR740N v4
Firmware Version DD-WRT v3.0-r30631 std (09/14/16)
Kernel Version Linux 3.10.103 #1216 Wed Sep 14 03:29:46 CEST 2016 mips

Status: ok
Reset: ok
Errors: None but CPU spikes to 2.5 after boot...
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7052
Location: YWG, Canada

PostPosted: Wed Sep 14, 2016 19:50    Post subject: Reply with quote
Router Model: r7800, dir-862L, dir-862L

Status: somewhat dissapointing
Reset: no
Errors: see tickets below

http://svn.dd-wrt.com/ticket/3616
http://svn.dd-wrt.com/ticket/3726
http://svn.dd-wrt.com/ticket/4839
http://svn.dd-wrt.com/ticket/5169 *
http://svn.dd-wrt.com/ticket/5225 *
http://svn.dd-wrt.com/ticket/5279 *
http://svn.dd-wrt.com/ticket/5334
http://svn.dd-wrt.com/ticket/5348 *
http://svn.dd-wrt.com/ticket/5407 *
http://svn.dd-wrt.com/ticket/5445
http://svn.dd-wrt.com/ticket/5475 *
http://svn.dd-wrt.com/ticket/5512 *
http://svn.dd-wrt.com/ticket/5513
http://svn.dd-wrt.com/ticket/5517
http://svn.dd-wrt.com/ticket/5528
http://svn.dd-wrt.com/ticket/5540
http://svn.dd-wrt.com/ticket/5544
http://svn.dd-wrt.com/ticket/5557
http://svn.dd-wrt.com/ticket/5565 *

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

[X86-64] Haswell i3-4150/4GB ------> Pending
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r40270M kongat
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41074 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41074 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41074 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r40634 std

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..


Last edited by tatsuya46 on Mon Sep 19, 2016 2:41; edited 2 times in total
B@R
DD-WRT Guru


Joined: 16 Apr 2011
Posts: 596
Location: Israel

PostPosted: Wed Sep 14, 2016 21:08    Post subject: Reply with quote
TP-Link Archer C7 V2.0 IL
Update over web UI: OK
Reset: No
Errors: Just flashed
PeteSL
DD-WRT Novice


Joined: 01 May 2007
Posts: 48

PostPosted: Wed Sep 14, 2016 21:36    Post subject: Reply with quote
Buffalo WZR-600DHP
Upgraded from 30385 to 30631

Appeared ok but connectivity on 2.4 was spotty. 2.4 is configured with Dynamic 20/40, NG-only, fixed channel 2 main, 6 secondary, 0 ack timing. This covers an 80' radius with zero interference from other access points. After some testing, ath0 (2.4 GHz) dropped completely. I noticed, as well, are reduced amount of activity on 2.4 than the prior build.

Back on r30385 until this radio issue can be resolved.

Thanks for continuing development!
cyncicle
DD-WRT Novice


Joined: 28 Oct 2011
Posts: 22

PostPosted: Wed Sep 14, 2016 22:17    Post subject: Reply with quote
Updating from 30432

Router: DIR862L
Firmware: v3.0-r30631 std (09/14/16)
Kernel: 3.18.41 #820
Reset: No
Errors: None. Install went smooth. All good so far.
samurai01
DD-WRT User


Joined: 26 Feb 2010
Posts: 66
Location: Japan

PostPosted: Wed Sep 14, 2016 23:04    Post subject: Reply with quote
Buffalo WZR-HP-AG300H

ALL OK!
arrowdau
DD-WRT Novice


Joined: 08 May 2016
Posts: 27

PostPosted: Thu Sep 15, 2016 0:43    Post subject: Reply with quote
Router: TP-link wdr4300 v1.7
Firmware: DD-WRT v3.0-r30631 std (09/14/16)
Kernel: Linux 3.10.103 #1174 Wed Sep 14 02:44:27 CEST 2016 mips
Reset: factory to ddwrt and 30/30/30 reset


Bugs: susceptible reboots when I finish making configurations were about 4 or more reboots and use of heavy cpu after the restart only after 5 min back to normal, otherwise all ok
ShanX
DD-WRT Novice


Joined: 18 Jul 2014
Posts: 16

PostPosted: Thu Sep 15, 2016 6:32    Post subject: Reply with quote
Router: TP-LINK TL-WR841ND v8
Firmware: v3.0-r30631 std (09/14/16)
Kernel: Linux 3.18.41 #800 Wed Sep 14 03:49:42 CEST 2016 mips
Status: OK
Reset: NO Reset, after setup reboot only
Errors: None so far, updated from Factory firmware, using in switch mode at work with Wifi and with Lan too.

It works very smooth. Smile Great work.

Greetings from Hungary!
sontt
DD-WRT Novice


Joined: 13 Mar 2013
Posts: 22

PostPosted: Thu Sep 15, 2016 14:47    Post subject: Reply with quote
Router: wzr-300hp
Firmware: Upgraded from 29739 to 30631
Kernel: Linux 3.10.103 #1154 Wed Sep 14 01:33:58 CEST 2016 mips
Status: OK
Reset: Yes both before and after update
Errors: wifi 2.4Gh drop after running about 40'
Edit: Wifi config same as the PeteSL do.


Last edited by sontt on Fri Sep 16, 2016 5:59; edited 1 time in total
Knomax
DD-WRT Novice


Joined: 19 Mar 2016
Posts: 35
Location: Greece

PostPosted: Thu Sep 15, 2016 17:09    Post subject: Reply with quote
Router: TPLINK WR1043ND V3
Firmware: DD-WRT v3.0-r30631 std (09/14/16)
Kernel: Linux 3.18.41 #810 Wed Sep 14 03:58:23 CEST 2016 mips
Status: Ok
Reset: NO
Errors: No

Is up for about 12 minutes and i think someone has done some good job here.
What i mean...first of all i have the last settings from the previous beta...so i will investigate farther to put the right settings...

First test in dsl reports...



I have 1Mbps for upload...with previous version i was suffering from upload lag spikes in QOS.

Very Happy


UPDATE
...............

I was just lucky in first dsl test...nothing change..it has the same terrible Qos in upload below 1Mbps connections.
I set upload etc at 800kbps and in test it starts at 1,14Mbps!!!!!!!!And then drops...lag spikes from 1ms to 700ms

Sad

_________________
Tp-Link WR-1043ND v3
Firmware:DD-WRT v3.0-r30709 std (09/29/16)


Last edited by Knomax on Fri Sep 16, 2016 13:26; edited 2 times in total
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 2820
Location: UK, London, just across the river..

PostPosted: Thu Sep 15, 2016 18:09    Post subject: Reply with quote
PeteSL wrote:
Buffalo WZR-600DHP
Upgraded from 30385 to 30631

Appeared ok but connectivity on 2.4 was spotty. 2.4 is configured with Dynamic 20/40, NG-only, fixed channel 2 main, 6 secondary, 0 ack timing. This covers an 80' radius with zero interference from other access points. After some testing, ath0 (2.4 GHz) dropped completely. I noticed, as well, are reduced amount of activity on 2.4 than the prior build.

Back on r30385 until this radio issue can be resolved.

Thanks for continuing development!


i guess your radio problems may originate from bad
radio settings.. better try full 40 or 20 only, Dynamic 20/40 has never been working well if you are concern, devices with 20HT will be able to connect even with 40HT selected only, as well ACK timing is broken too especially with 0 , also WPA2 AES wi-fi encryption is a must for a stable radio, i will recommend you short GI and Short preamble too, and try channel 11 + lower Wink NG mixed is ok

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 33772 BS WAP/Switch (wired)
TP-Link WR1043NDv2 -----DD-WRT 41074 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Local DNS,Forced DNS,DoT)
TP-Link WR1043NDv2 -----DD-WRT 41075 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF,Local DNS,Forced DNS,DoT)
TP-Link WR1043NDv2 -----Gargoyle OS 1.11.0 (AP,NAT,QoS,Quotas)
Qualcomm/IPQ8065
Netgear R7800 ---------DD-WRT 40270M 4.9 Kong (AP,NAT,AD-Blocking,AP&Net Isolation,Firewall,Local DNS,Forced DNS,DNSCrypt v2 x2)
Broadcom
Netgear R7000 ---------DD-WRT 40270M Kong (AP,NAT,VLAN,AD-Blocking,Firewall,Local DNS,Forced DNS,DoT)
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum