New Kong's build: DD-WRT 30430M - 2016/08/16

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3, 4, 5, 6  Next
Author Message
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 5140
Location: Netherlands

PostPosted: Tue Aug 16, 2016 16:22    Post subject: New Kong's build: DD-WRT 30430M - 2016/08/16 Reply with quote
Kong's DD-WRT build 30430M - 2016/08/16 has been released: http://desipro.de/ddwrt/K3-AC-Arm/

Your reports for Broadcom units are greatly appreciated !
Router:
Firmware:
Kernel:
Status:
Reset:
Errors:

This build thread is for reporting successes and problem with loading this experimental test build. This is important info for developers and users. Always state your hardware and SPECIFIC build (e.g. 29440_NEWD-2_K2.6_mega-nv64k.bin). Do not ask questions about your specific router or how to configure it in this thread; create your own thread to discuss any specific problems you have or need resolved. Please also do not respond to such questions. This thread is to report info, not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you know how to flash properly and the risk before using this build. It is important to adhere to these requirements, to keep this thread from becoming impossibly long and useless. If you don't know what build to flash and how to flash properly and have a means of recovery if things should go wrong, do NOT flash this experimental test build.

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 5140
Location: Netherlands

PostPosted: Tue Aug 16, 2016 16:35    Post subject: Reply with quote
Router Name: EA6900

Router Model: Linksys EA6900 (XVortex CFE)

Firmware Version: DD-WRT v3.0-r30430M (08/16/16)

Kernel Version: Linux 4.4.17 #15 SMP Tue Aug 16 12:37:42 CEST 2016 armv7l

Upgraded: from 30370M via telnet (upgrade via WebGui or DDUP not possible)

Reset: Yes, before and after (Erase NVRAM and WPS reset)

Configuration: AP, DHCP server, 2,4GHz wireless running, 5GHz disabled, some static leases and some port range forwarding, NVRAM size just below 32K (NVRAM size should not be a problem with the Xvortex CFE)

Status: Up and stable for 15 min, excellent wireless speed and range, WAN throughput 40/4 (is my ISP's maximum)
Errors: none so far, I will keep you informed

Thanks Kong and BrainSlayer!!

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
stephensuley
DD-WRT Guru


Joined: 09 Feb 2008
Posts: 615
Location: Canada

PostPosted: Tue Aug 16, 2016 17:15    Post subject: Reply with quote
Router: Asus RT-AC68U ( Broadcom BCM4708 2Core@800MHz)
Firmware: DD-WRT v3.0-r30430M kongac (08/16/16)
Kernel: Linux 4.4.17 #15 SMP Tue Aug 16 12:37:42 CEST 2016 armv7l
Status: working with no issues
Reset: no
Errors: None
Observations: seems like a fast and stable build for the 68u. The GUI is fast and very responsive. The wifi\wired client performance/speed is as fast and responsive as its ever been. I'm seeing several wl0 clients with 100% conenction quality and other with 96%. no wifi client is below 78% ~1500sq ft range. This is a first time for this.



Temperatures:
CPU 82.5 °C / WL0 53.0 °C / WL1 53.5 °C

Memory:
Total Available: 97% 255288 kB / 262144 kB
Free: 82% 208540 kB / 255288 kB

Wireless Setup:
N-only-AP/wpa2-aes (wl0),AC/N-mixed-AP/wpa2-aes (wl1)

Wireless Packet Stats:

wl0:(~15min with 3 clients)
Received (RX) 100% 44954 OK, no error
Transmitted (TX) 100% 176436 OK, no error

wl1:(~15min with 2clients)
Received (RX) 100% 7405 OK, no error
Transmitted (TX) 100% 11449 OK, 4 errors

WAN: Disabled ( Back-2-back with Cisco ASA5505)

Services:
privoxy,ssh,syslog,snmp,ddns


NVRAM USAGE:
NVRAM 34 KB / 64 KB

_________________
Location 1-rural) -WRT1900AC v1 (AP)- (NG)2.4Ghz/40Mhz) --250ft l.o.s.-->RT-AC87u (N-Only/client bridge) <back2back> RT-AC68u (wl0 & wl1 in AP mode / WAN disabled) - 150MBit/s end to end

Location 2-urban) - 1x Linksys EA8500 (AP)

Location 3-rural) - 1x Asus RT-AC87u (AP)

Latest and greatest builds Wink
pokazene_maslo
DD-WRT User


Joined: 29 Dec 2009
Posts: 83
Location: Slovakia

PostPosted: Tue Aug 16, 2016 17:27    Post subject: Reply with quote
Router: Buffalo WZR1750
Firmware:dd-wrt.v24-K3_AC_ARM_STD
Kernel: ??
Status: router bricked!
Reset: at first no, then yes
Errors: yes - router bricked!

flashed via ddup, digital signature was OK!
Brakiss
DD-WRT Novice


Joined: 16 Aug 2016
Posts: 3

PostPosted: Tue Aug 16, 2016 17:52    Post subject: Reply with quote
Router: Netgear R7000
Firmware: DD-WRT v3.0-r30430M kongac (08/16/16)
Kernel: Linux 4.4.17 #15 SMP Tue Aug 16 12:37:42 CEST 2016 armv7l
Status: UP 15 mins, great speed so far
Reset: No
Errors: None yet
markg23
DD-WRT Novice


Joined: 14 Aug 2009
Posts: 11

PostPosted: Tue Aug 16, 2016 19:25    Post subject: New Kong's build: 30430M - 2016/08/16 working on RT-N18U Reply with quote
Router: Asus RT-N18U
Firmware: DD-WRT v3.0-r30430M kongac (08/16/16)
Kernel: Linux 4.4.17 #15 SMP Tue Aug 16 12:37:42 CEST 2016 armv7l
Status: UP 16 mins, UI Super Responsive. Repeater Mode Working.
Reset: No
Errors: None yet

Upgraded from 28600M, then to 29300M and then to 30430M.
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1478
Location: Canada

PostPosted: Wed Aug 17, 2016 2:19    Post subject: Reply with quote
Router: R7000 x2
Firmware: DD-WRT v3.0-r30430M kongac (08/16/16)
Kernel: Linux 4.4.17 #15 SMP Tue Aug 16 12:37:42 CEST 2016 armv7l
Status: Both Working
Reset: After Upgrade, Erased NVRAM & Manualy Configure
Errors: None

Previous Build was KongAC Build 30370M. Total up time was limited do to tweaking settings and scripts but didn't run into any problems.

Services in use (reference from default)...

R7000 WAN Router:
-DDNS
-1 extra VLAN & BR1
-Disabled Both Radios
-Static Leases
-DNSMasq Options
-SSH with custom port
-Syslogd
-Disabled ttraff
-OpenVPN Client
-USB Storage with Auto Mount
-QoS HTB FQ_CODEL
-UDP Timeout 600
-Scripts for Startup ShutDown Firewall
-YAMon3

R7000 WiFi Router:
-Disabled WAN
-4 extra VLANs & BRs
-Radios - wl0 20Mhz + 3 vwlans & wl1 VHT80 (ch:161 upper upper) + 1 vwlan
-Extra Enabled Wireless - Implicit & AP Isolation(Guest Wifi wl0.2)
-6 SSIDs
-DNSMasq Options
-Syslogd
-Disabled ttraff
-OpenVPN Client
-Disabled SPI
-UPD Timeout 600
-Firewall Script

UPDATE...

After 2 days all is good, I have noticed the WAN Router with enabled USB Storage that the free memory is reduced to 151.8MB. The Wifi Router has been over 200MB the last 2 days.

After 54 hours of uptime, I lost WAN communications. I tried rebooting the modem and didn't fix it. I tried renewing WAN IP but stuck with 0.0.0.0. I enabled MSTP on BR0 (to eliminate any possible loops in BR0) and Internet connections started. I did reboot the WAN Router to reset the uptime. Free memory is at 205.5MB with 58min uptime. Since I have a fairly complex Network setup I'm not faulting the build 30430 yet, even though this same configuration that worked without any issue with build 29875 (Kernal 3.x). By far build 30340 (Kernal 4.x) has been the best compared to previous K4.x builds.

Checking my 8 SSIDs with a SSID scanner I noticed their was problem, with the vwlans, wl0.3 SSID was on the 5Ghz Radio and wl1.3 SSID was missing. I now have 6 SSIDs working. The 2.4Ghz Raido has 4 SSIDs and the 5GHz Radio has 2 SSIDs. Made some other changes to channels that neighbouring WiFi's where conflicting.

_________________
Home Network on Telus PureFibre - 10GbE Copper Backbone
3x R7800 - Gateway WiFi 6xWireGuard - DDWRT r42803 Std
WHR-HP-G54 - Internal Routing - DDWRT r35531 std-special
2x E3000 - Gateway Wired IPTV - DDWRT r35531 Mega
E3000 - TRAVEL Wireless Client WireGuard(30Mbit/s) - DDWRT r42803 Mega

Off Site 1

R7000 - Gateway, WiFi & OpenVPN - KONGAC 39855M
WRT610Nv1 - Client Bridge - DDWRT r33679 Mega K2.4

Off Site 2

R7000 - Gateway & WiFi - KONGAC 39855M
E2000 - Wired PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2


Last edited by mac913 on Sat Aug 20, 2016 18:10; edited 9 times in total
lyuan
DD-WRT User


Joined: 05 Apr 2011
Posts: 85

PostPosted: Wed Aug 17, 2016 5:30    Post subject: Reply with quote
Router: R7000
Firmware: DD-WRT v3.0-r30430M kongac (08/16/16)
Kernel: 4.4.17 #15 SMP Tue Aug 16 12:37:42 CEST 2016 armv7l
Status: Up since 4PM this afternoon
Reset: Nope
Errors: None so far...

This build looks extremely promising. WAN to LAN routing performance is up, and WIFI performance looks good too!

QoS is still a bit down from Kernel 3 builds, but only by a bit.

Thanks Kong!
mchaney
DD-WRT User


Joined: 26 Apr 2013
Posts: 389

PostPosted: Wed Aug 17, 2016 11:52    Post subject: Reply with quote
Kong,

Thanks for another great release! Running fine on my R8500 so far. Question though. This is not specific to this release (30370 did this as well). You cannot turn off dnsmasq in 30370 or 30430. If you disable it, apply settings, and then reboot the router, you find it enabled again. I'm assuming that's not normal behavior.

Edit: reboot is not necessary. If you just disable dnsmasq and then close the browser and reopen to the same tab, it's enabled again.

Edit2: Sorry. Was unchecking it on the "Services" tab. I discovered that if you uncheck "Use dnsmasq" on the basic setup tab, it takes. Shouldn't unchecking it on "Services" also automatically uncheck it on the basic "Setup" tab to avoid confusion?

Regards,
Mike


Last edited by mchaney on Wed Aug 17, 2016 12:01; edited 2 times in total
mchaney
DD-WRT User


Joined: 26 Apr 2013
Posts: 389

PostPosted: Wed Aug 17, 2016 11:54    Post subject: Reply with quote
Duplicate post
SinCalChewy
DD-WRT User


Joined: 09 Nov 2014
Posts: 306
Location: Bakersfield, CA

PostPosted: Wed Aug 17, 2016 12:40    Post subject: Reply with quote
Running 15 hours now on my r7000. Super low CPU usage, and fast WiFi speeds along with a better signal. I used to get ~50% in my room, now it's ~70%.

Thanks for your work, Kong. Smile

_________________

Deployed Routers:
Netgear R7000 - 3x build 42803M (Gateway: DoT/DoH, CAKE QoS, USB /w Entware)
Linksys E3000 - 2x build 42803M (Client Bridges)

Spares/Backups/Collection:
Too many to list. I have old routers, bricked routers, weird routers. You name it.
Xeon2k8
DD-WRT Guru


Joined: 11 Feb 2016
Posts: 1324

PostPosted: Wed Aug 17, 2016 12:49    Post subject: Reply with quote
SinCalChewy wrote:
Running 15 hours now on my r7000. Super low CPU usage, and fast WiFi speeds along with a better signal. I used to get ~50% in my room, now it's ~70%.

Thanks for your work, Kong. Smile


Formula calculation of signal strength was changed. That's what you are seeing. Compare by SNR.
Paint
DD-WRT User


Joined: 22 Jun 2015
Posts: 131

PostPosted: Wed Aug 17, 2016 13:41    Post subject: Reply with quote
Router: R8000
Firmware: R30430M
Kernel: 4.4.17
Status: BAD
Reset: Yes
Errors: In order to get clients to successfully connect wirelessly, I need to change the regulatory domain away from United States and then back to United States after every reboot.


Serial Console Log below:
Code:
Key is a ssh-rsa key
Wrote key to '/tmp/root/.ssh/ssh_host_rsa_key'
ifconfig: ioctl 0x8913 failed: No such device
cannot open /proc/sys/net/ipv4/netfilter/ip_conntrack_udp_timeouts
br0: No such process
cannot open /proc/sys/net/ipv4/netfilter/ip_conntrack_udp_timeouts
route: ioctl 0x890c failed: No such process

--- /dev/sda
Block device, size 57.84 GiB (62109253632 bytes)
DOS/MBR partition map
Partition 1: 8 GiB (8589934592 bytes, 16777216 sectors from 32768)
  Type 0x83 (Linux)
  Ext4 file system
E (DCE, v14)ame "oprandom: nonblocking pool is initialized
    Last mounted at "/jffs"
    Volume size 48.83 GiB (52428800000 bytes, 12800000 blocks of 4 KiB)

Radio: 0 currently turned off
Radio: 1 currently turned off
eth1: Not supported
eth2: Not supported
eth3: Not supported
br0: port 5(eth3) entered forwarding state
br0: port 4(eth2) entered forwarding state
br0: port 3(eth1) entered forwarding state
br0: port 2(vlan2) entered forwarding state
br0: port 1(vlan1) entered forwarding state
br0: port 3(eth1) entered disabled state
br0: port 4(eth2) entered disabled state
br0: port 5(eth3) entered disabled state
radio_off(1) interface: eth2
Radio: 2 currently turned off
Duplicate configuration request

Duplicate configuration request

Duplicate configuration request

/opt/etc/init.d/rcS: No such file or directory
/jffs/etc/init.d/rcS: No such file or directory
/mmc/etc/init.d/rcS: No such file or directory
/etc/config/conntrack.startup: line 8: can't create /proc/sys/net/ipv4/ip_conntrack_max: nonexistent directory
sh: missing ]
The Milkfish Router Services
ERROR: Necessary service setting not found: milkfish_username - aborting.
killall: proxywatchdog.sh: no process killed
/mnt/smbshare
umount: can't unmount /mnt/smbshare: No such file or directory
rmmod: cifs: No such file or directory
rmmod: fscache: No such file or directory
The Milkfish Router Services
Restoring SIP ddsubscriber database from NVRAM...
Empty.
The Milkfish Router Services
Restoring SIP ddaliases database from NVRAM...
Empty.
killall: schedulerb.sh: no process killed
killall: shatd: no process killed
killall: wdswatchdog.sh: no process killed
eth2: Not supported
base addr E8:FC:FF:FF:FF:FF
local bit addr E8:FC:FF:FF:FF:FF
eth2: Not supported
eth2: Operation not permitted
eth2: Not supported
nbw = 40
channel 1, val 40
0, 1800, 0, 3
spec 1803
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
eth2: Not supported
enable bss eth2 0 (1)
eth2: Not supported
eth3: Not supported
eth1: Not supported
radio_on(1) interface: eth2
wl: wl driver adapter not found
eth1: Not supported
eth3: Not supported



R8000 Issue.PNG
 Description:
Tx and Rx show N/A with the last 3 builds
 Filesize:  35.42 KB
 Viewed:  15022 Time(s)

R8000 Issue.PNG



_________________
pfSense i7-4510U + 2x Intel 82574 + 2x Intel i350 Mini-ITX Build
940/880 mbit Fiber Internet from FiOS
Dell PowerConnect 2716 Gigabit Switch
Netgear R8000 AP, running DD-WRT
Asus RT-66U AP, running DD-WRT
stalonge
DD-WRT Guru


Joined: 21 Jul 2006
Posts: 1920
Location: Fortaleza Ce Brazil

PostPosted: Wed Aug 17, 2016 15:58    Post subject: Reply with quote
@Kong

R8500 has same problem with wifi2.4 .. some time it disconect and cant conect again .. need to set wifi off and on .. Dont need to reboot


R7000 is still working flawless for 24 hours ... Lets wait more






Very Happy Very Happy

_________________
DDwrt ...it rocks ....
1 R8500 41556 AP OpenVPN webserver RETIRED (bricked)
1 R7800 42813 AP Wireguard webserver JFFS SAMBA FTP usb HD Mesh
1 R7800 42813 Cli Mesh
1 WZR1750 42741 AP Webserver OpenVPN
1 DDx86 Vmware 40260
1 E3000 41027 K3 @500 WAP wifi client
ironmanlok
DD-WRT User


Joined: 16 Jul 2012
Posts: 59

PostPosted: Wed Aug 17, 2016 19:18    Post subject: Reply with quote
Couple of questions.

You mentioned a security fix for linux kernel in another thread, is this the one where u can workaround by setting 99999999 for tcp_challenge_ack_limit? Described here https://ucrtoday.ucr.edu/39030
I think 4.4.18 (released today) has a permanent fix for this.

Also, a request, can you update iptables version, at least on 4.4 kernels? You ship 1.3.7 which doesn't recognize IPSET rules (-m set) even if you load a proper ipset kernel module (for example, 4.4.7 from OPKG repository). the iptables in OPKG repository is newer (1.4.21) and accepts -m set, however I think it's not working properly, I'm having some strange errors when using it, maybe it's not compatible with the iptables kernel module built into DD-WRT kernel. It would be good if ipset module was built into kernel too.
Goto page 1, 2, 3, 4, 5, 6  Next Display posts from previous:    Page 1 of 6
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum