VAP with no internet... Linksys AC1200

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
DeltaNu1142
DD-WRT Novice


Joined: 12 May 2014
Posts: 10

PostPosted: Tue Jul 26, 2016 2:02    Post subject: VAP with no internet... Linksys AC1200 Reply with quote
I've been setting up a Linksys AC1200 to replace an old WRT54G, and I'm unable to get internet access on the VAP. I've followed the instructions located here to get it set up. I'm posting via the primary wireless SSID now, so no problems there. I can connect to the VAP but there's no internet connection.

I've posted screen shots... any ideas?

TIA
Sponsor
DeltaNu1142
DD-WRT Novice


Joined: 12 May 2014
Posts: 10

PostPosted: Tue Jul 26, 2016 11:45    Post subject: Reply with quote
EDIT: I'm using DD-WRT v3.0-r28788 std (01/13/16)

My WAN IP is 10.0.0.1, so I've set the IP range for this SSID to 10.0.1.x.

Any insight at all? Has anyone gotten this working?
zakaron
DD-WRT User


Joined: 03 Jun 2016
Posts: 90

PostPosted: Tue Jul 26, 2016 18:41    Post subject: Reply with quote
If I had to guess, it may be the firewall that is blocking access. Are any hosts on the VAP able to even get an IP address? As a test, you could try temporarily disabling the firewall under Security tab, firewall sub tab, then disable SPI Firewall. Again, just do this for quick testing as it will open everything up! I have a guest SSID working on a separate network, but did use a more extensive IP Tables ruleset to lock down everything between the guest network, private network, and the LAN. This is all on a WRT1200. If it turns out to be firewall related, I can try to assist with some rules that will allow traffic flow.
DeltaNu1142
DD-WRT Novice


Joined: 12 May 2014
Posts: 10

PostPosted: Thu Jul 28, 2016 22:51    Post subject: Reply with quote
Thanks for your response. I was able to get it working with the help of charmander by adding this script to Administration - Commands - Save Firewall:

Code:
iptables -t nat -I POSTROUTING -o `get_wanface` -j SNAT --to `nvram get wan_ipaddr`


It's now working fine as a guest VAP, but I'd like to isolate the VAP IP addresses 10.0.1.x from the primary IP addresses 10.0.0.x, and from each other, I suppose.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum