Need to move off BS builds for my WRT1900AC - please advise

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
Brewder
DD-WRT User


Joined: 26 Dec 2015
Posts: 178

PostPosted: Mon Apr 25, 2016 19:09    Post subject: Need to move off BS builds for my WRT1900AC - please advise Reply with quote
Like many of you, the BS builds since roughly January have been torturous on my WRT1900ACv1. I have CONSTANT problems and my family wants to hang me! LOL. Most of my issues APPEAR to be with DHCP renewals between the WRT and my cable modem. DD-WRT seems to hold on a WAN Address but my cable modem has been assigned something new. Getting DD-WRT to release and renew is a crap shoot every time. (NEVER EVER had this issue before roughly January).

I also have issues with...

...HTTPD constantly crashes and I need multiple reboots to get the web GUI working.

...wifi issues where devices are connected but nothing happens (verified by using my hard wired machines with no problems).

...Nightly reboots enabled recently which doesn't do anything.

...sudden and mysterious DNS timeouts causing web browsing delays.

...people reporting that my guest network works sometimes, but not others.

I have applied every single BS build the day it's released. I now officially GIVE UP. I want to switch to a more stable Kong build.

I have a very simple setup with a Guest network. Which Kong build should I settle on knowing I have the WRT1900ACv1?

//Brew
Sponsor
lim
DD-WRT User


Joined: 01 Feb 2016
Posts: 94
Location: Devon

PostPosted: Mon Apr 25, 2016 21:58    Post subject: Re: Need to move off BS builds for my WRT1900AC - please adv Reply with quote
Brewder wrote:
I have a very simple setup with a Guest network. Which Kong build should I settle on knowing I have the WRT1900ACv1?

//Brew


The latest build is probably your best bet; that is the one dated 25 March.
That said, I have had no problems with any of Kong's builds since February when I started using them.
Good luck!

Regards, lim

_________________
WRT1900ACS v1
WRT3200ACM
Regulatory Domain: UK
juggler111
DD-WRT User


Joined: 16 Jan 2016
Posts: 91

PostPosted: Mon Apr 25, 2016 22:13    Post subject: Reply with quote
I concur. I also have the WRT1900ACv1 with kong's r29300 running on it since the 03/25 release came out with no real issues. The only issues I have are the long ping times which we all know why and my laptop would occasionally loose connection to the 5GHz channel which I strongly suspect is a channel probably also tied to the aforementioned Marvel driver issues.
Brewder
DD-WRT User


Joined: 26 Dec 2015
Posts: 178

PostPosted: Tue Apr 26, 2016 0:18    Post subject: Reply with quote
ok that's exactly the version I installed. I setup everything from scratch.

So far so good... then again, it's only been 3 hours. Smile

//Brew
vnvjeep
DD-WRT User


Joined: 06 Feb 2014
Posts: 125

PostPosted: Tue Apr 26, 2016 0:27    Post subject: Reply with quote
I will have to say... even running Kong's 3/25 build, every couple of days, maybe 1x a week, I will have to reboot the V1 router, because for some reason the 5GHz range stops responding. The 2.4GHz range works without a hitch... so unfortunately rebooting is still going to be necessary. Not sure what to blame it on. I have not been able to figure out what causes yet, so I'll blame it on shitty drivers for now. Smile
_________________
Device: Linksys WRT1900AC V1
Firmware: Kong Build 31100 1/8/2017
Kong Links: http://www.desipro.de/ddwrt/K3-AC-MVEBU/
BS Links: ftp://ftp.dd-wrt.com/betas/
juggler111
DD-WRT User


Joined: 16 Jan 2016
Posts: 91

PostPosted: Tue Apr 26, 2016 4:10    Post subject: Reply with quote
vnvjeep wrote:
I will have to say... even running Kong's 3/25 build, every couple of days, maybe 1x a week, I will have to reboot the V1 router, because for some reason the 5GHz range stops responding. The 2.4GHz range works without a hitch... so unfortunately rebooting is still going to be necessary. Not sure what to blame it on. I have not been able to figure out what causes yet, so I'll blame it on shitty drivers for now. Smile
You should try the various channels until you find the one that works best for your environment. I've had to do that and now my router has been up 21 days, no reboots.
Yemble
DD-WRT Guru


Joined: 17 Feb 2010
Posts: 607
Location: Yorkshire (GOC)

PostPosted: Tue Apr 26, 2016 7:16    Post subject: Reply with quote
vnvjeep wrote:
I will have to say... even running Kong's 3/25 build, every couple of days, maybe 1x a week, I will have to reboot the V1 router, because for some reason the 5GHz range stops responding. The 2.4GHz range works without a hitch... so unfortunately rebooting is still going to be necessary. Not sure what to blame it on. I have not been able to figure out what causes yet, so I'll blame it on shitty drivers for now. Smile


I've never once had to boot my WRT1900AC v1 running Kong 25th Mar, nor any previous BS versions to be quite honest. What temperature thresholds have you set for the fan? I run mine with the default 60/65 degrees C.

Note that this Kong build does have a tendency to skip around the 5GHz channels, which must be a bug. Mine seems to have settled on channel 149, even though I initially set it to channel 100. I have also seen it using channel 36 and 48 !
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5767
Location: Romerike, Norway

PostPosted: Tue Apr 26, 2016 7:42    Post subject: Reply with quote
The channel skips can be DFS. If a radar is detected,the channel is changed.
Yemble
DD-WRT Guru


Joined: 17 Feb 2010
Posts: 607
Location: Yorkshire (GOC)

PostPosted: Tue Apr 26, 2016 8:58    Post subject: Reply with quote
Per Yngve Berg wrote:
The channel skips can be DFS. If a radar is detected,the channel is changed.


Sorry, I don't understand. Would you please explain in rather more detail.

Note that I have absolutely no contention with any other 5GHz signal.


According to the DD-WRT Wiki, radar detection is disabled by default and would not apply to me anyway...


Radar Detection

Available Settings: Enable, Disable

Default Setting: Disable

Recommended Setting: Disabled for most users. Enabled to comply with regulations where applicable.

Radar detection (AKA DFS: Dynamic Frequency Selection), if enabled, will change the frequency only when it identifies a military or doppler weather radar nearby on the same frequency. Most users shouldn't have any interference issues even those living near such locations. This applies to 5 GHz a/n/ac only.
ATHF
DD-WRT Guru


Joined: 14 Dec 2015
Posts: 725
Location: 127.0.0.1

PostPosted: Tue Apr 26, 2016 10:08    Post subject: Reply with quote
See here:
https://github.com/kaloz/mwlwifi/issues/75

I've had this issue since I got the 1900 and 1200.

_________________
Tutorial for flashing WRT series
WRT Installation,Upgrade & Basic Setup–Cliff Notes
DD-WRT Firmware: r42054: WRT3200ACM, WRT1200ACv1 (Smart crap subnet), WRT1900ACv1
Velop:3 WHW0101, RE6500, RE9000(AP)
TWC/Spectrum - 300/25
SysLog Watcher 5, Security Onion on Virtual Box, Fingboxes, PiHoles
Yemble
DD-WRT Guru


Joined: 17 Feb 2010
Posts: 607
Location: Yorkshire (GOC)

PostPosted: Tue Apr 26, 2016 11:00    Post subject: Reply with quote
ATHF wrote:
See here:
https://github.com/kaloz/mwlwifi/issues/75

I've had this issue since I got the 1900 and 1200.


Is that the same issue?

I've only seen the 5GHz channel skipping around on this one Kong build (25th Mar). This never happened, to the best of my knowledge, on any of the BS builds.
vnvjeep
DD-WRT User


Joined: 06 Feb 2014
Posts: 125

PostPosted: Tue Apr 26, 2016 15:00    Post subject: Reply with quote
juggler111 wrote:
vnvjeep wrote:
I will have to say... even running Kong's 3/25 build, every couple of days, maybe 1x a week, I will have to reboot the V1 router, because for some reason the 5GHz range stops responding. The 2.4GHz range works without a hitch... so unfortunately rebooting is still going to be necessary. Not sure what to blame it on. I have not been able to figure out what causes yet, so I'll blame it on shitty drivers for now. Smile
You should try the various channels until you find the one that works best for your environment. I've had to do that and now my router has been up 21 days, no reboots.


I've tried a variety of channels. I did initially have it set to a high range, and it shifted on its own. But still, after a while, the 5GHz range looks like its up, it just stops responding and prevents devices from connecting to it. Right now, I've set my 5GHz to Channel 36, which will work for up to a week, and will have to manually reboot the router when I start seeing problems. I've seen others with similar issues in these forums.

I saw the post about DFS/Radar above... mine is disabled.

_________________
Device: Linksys WRT1900AC V1
Firmware: Kong Build 31100 1/8/2017
Kong Links: http://www.desipro.de/ddwrt/K3-AC-MVEBU/
BS Links: ftp://ftp.dd-wrt.com/betas/
vnvjeep
DD-WRT User


Joined: 06 Feb 2014
Posts: 125

PostPosted: Tue Apr 26, 2016 15:03    Post subject: Reply with quote
Yemble wrote:
vnvjeep wrote:
I will have to say... even running Kong's 3/25 build, every couple of days, maybe 1x a week, I will have to reboot the V1 router, because for some reason the 5GHz range stops responding. The 2.4GHz range works without a hitch... so unfortunately rebooting is still going to be necessary. Not sure what to blame it on. I have not been able to figure out what causes yet, so I'll blame it on shitty drivers for now. Smile


I've never once had to boot my WRT1900AC v1 running Kong 25th Mar, nor any previous BS versions to be quite honest. What temperature thresholds have you set for the fan? I run mine with the default 60/65 degrees C.

Note that this Kong build does have a tendency to skip around the 5GHz channels, which must be a bug. Mine seems to have settled on channel 149, even though I initially set it to channel 100. I have also seen it using channel 36 and 48 !


My temps are running around 50-51degC... Yeah, because of all the weird channel skipping, I ended up forcing it on channel 36 for now. If you set it to Auto, I don't think the 5GHz range even lights up on this particular build.

_________________
Device: Linksys WRT1900AC V1
Firmware: Kong Build 31100 1/8/2017
Kong Links: http://www.desipro.de/ddwrt/K3-AC-MVEBU/
BS Links: ftp://ftp.dd-wrt.com/betas/
Brewder
DD-WRT User


Joined: 26 Dec 2015
Posts: 178

PostPosted: Tue Apr 26, 2016 15:53    Post subject: Reply with quote
For whatever it's worth.. I have mine configured for a width of VHT80 on channel 149.

When I view the SysInfo page, it reports as channels 153+155 and has been rock solid for almost 24 hours (when I first installed the Kong build)

This is the same way I ran on the BS builds and it never "moved around".

//Brew
Yemble
DD-WRT Guru


Joined: 17 Feb 2010
Posts: 607
Location: Yorkshire (GOC)

PostPosted: Tue Apr 26, 2016 17:52    Post subject: Reply with quote
Checked my advanced WiFi settings and Radar Detection is definitely disabled.

Therefore, this channel skipping MUST be a bug.

As an experiment I have enabled radar, applied, disabled it and applied again. Confirmed that my chosen channel 100 is the one actually being used. So far, it has not switched to a different channel.

Maybe this is just a case of an unitialised boolean?

Unfortunately, after ten minutes it jumped to channel 149. So, it is a bug.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum