New build: DD-WRT v3.0 --- 29193 --- 2016/03/02

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3  Next
Author Message
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1302

PostPosted: Wed Mar 02, 2016 22:34    Post subject: New build: DD-WRT v3.0 --- 29193 --- 2016/03/02 Reply with quote
ftp://ftp.dd-wrt.com/betas/2016/03-02-2016-r29193/

This build thread is for reporting successes and problem with loading this experimental test build.
This is important info for developers and users. Always state your hardware and SPECIFIC build
(e.g. 29193_NEWD-2_K2.6_mega-nv64k.bin). Do not ask questions about your specific router or how
to configure it in this thread; create your own thread to discuss any specific problems you have
or need resolved. Please also do not respond to such questions. This thread is to report info,
not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you
know how to flash properly and the risk before using this build. It is important to adhere to
these requirements, to keep this thread from becoming impossibly long and useless.

If you don't know what build to flash and how to flash properly and have a means of recovery if
things should go wrong, do NOT flash this experimental test build.
Sponsor
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1302

PostPosted: Wed Mar 02, 2016 22:35    Post subject: Reply with quote
Router: TrendNet TEW-811DRU
Firmware: DD-WRT v3.0-r29193 mini (03/02/16)
Kernel: Linux 4.4.3 #384 Wed Mar 2 07:14:25 CET 2016 armv7l
Status: Working
Reset: flash via telnet, erase nvram, reboot
Errors: IPv6 doesn't work with QoS enabled


Last edited by jerrytouille on Thu Mar 03, 2016 14:12; edited 1 time in total
b0f
DD-WRT Novice


Joined: 03 Apr 2014
Posts: 26

PostPosted: Thu Mar 03, 2016 10:59    Post subject: Reply with quote
Router: Archer C9
Firmware: 03-02-2016-r29193 std
Previous: 02-17-2016-r29114 std
Status: Working as Router (PPoE)
Reset: No
Errors: None
Kernel: Linux 4.4.3 #383 SMP Wed Mar 2 07:11:42 CET 2016 armv7l

Router: Linksys e4200
Firmware: 03-02-2016-r29193 mega
Previous: 02-17-2016-r29114 mega
Status: Working as AP
Reset: No
Errors: None
Kernel: Linux 3.10.98 #11713 Wed Mar 2 12:58:53 CET 2016 mips

Router: Linksys es6900
Firmware: 03-02-2016-r29193 std
Previous: 02-17-2016-r29114 std
Status: Working as AP
Reset: No
Errors: None
Kernel: Linux 4.4.3 #381 SMP Wed Mar 2 07:03:33 CET 2016 armv7l
ghoffman
DD-WRT User


Joined: 03 Jan 2010
Posts: 453

PostPosted: Thu Mar 03, 2016 12:22    Post subject: Reply with quote
Router: Linksys EA6400
Firmware Version: DD-WRT v3.0-r29193 std (03/02/16)
Kernel Version: Linux 4.4.3 #381 SMP Wed Mar 2 07:03:33 CET 2016 armv7l
previous: kong 29165m
reset: no
Status: working as AP
Errors: none yet.

fast 2.4 and 5g wireless speeds. will report back with any significant information
commodore
DD-WRT User


Joined: 20 Jun 2010
Posts: 143

PostPosted: Thu Mar 03, 2016 12:26    Post subject: Reply with quote
Router: Asus WL500gP v1
CPU: Broadcom BCM4704 chip rev 9
Firmware: v3.0-r29193 mega (03/02/16) (dd-wrt.v24_mega_generic.bin from ftp://ftp.dd-wrt.com/betas/2016/03-02-2016-r29193/broadcom/)
Previous: r29134
Status: Router/firewall (DHCP); Wireless mode AP
Reset: No
Kernel: Linux 2.4.37 #43391 Wed Mar 2 05:20:33 CET 2016 mips

Errors: The button for turning wifi on/off doesn't work, despite "SES/AOSS/EZ-SETUP/WPS Button" is set correctly. It's been like this for a couple of versions (didn't keep track, but I did perform one or two factory-defaults resets in the meantime).
mchaney
DD-WRT User


Joined: 26 Apr 2013
Posts: 389

PostPosted: Thu Mar 03, 2016 14:16    Post subject: Reply with quote
Upgraded my R7000 from Kong 29165 to 29193 and this is the first time I've been able to achieve full WAN speed on a 4.4 kernel build! I ran the speed test a half dozen times and I'm getting full speed every time. On all previous K4.4 builds, I'd get about 1/3 of my full speed after running the speed test a few times. Average load now looks "normal" as well. Thanks BS!

Mike



29193.jpg
 Description:
 Filesize:  32.05 KB
 Viewed:  13335 Time(s)

29193.jpg


flyzipper
DD-WRT Guru


Joined: 21 Feb 2016
Posts: 504

PostPosted: Thu Mar 03, 2016 16:24    Post subject: Reply with quote
Router: Linksys e4200 
CPU:  BCM4716 chip rev 1
Firmware: 03-02-2016-r29193 mega 
Previous: 02-23-2016-r29147 mega 
Status: Working as Gateway
Reset: No 
Errors: None 
Kernel: Linux 3.10.98 #11713 Wed Mar 2 12:58:53 CET 2016 mips

As others have stated, the increased performance of this build is noticeable with my setup. Seems like a winner!
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1552
Location: Zwolle

PostPosted: Thu Mar 03, 2016 18:41    Post subject: Reply with quote
Router: E4200 V1
Firmware: dd-wrt.v24-29193_NEWD-2_K3.x_mega-e4200.bin
Kernel: 3.10.98
Reset: no.
Errors: no.
Note: no USB device attached, I don't use it as DHCP or DNS server.

Router: Linksys E3000 (formerly WRT610N V2)
Firmware: dd-wrt.v24-29193_NEWD-2_K3.x_mega-e3000.bin
Kernel: 3.10.98
Reset: no
Errors: no.
Note: I don't use it as DHCP or DNS server.

_________________
2 times APU2 Opnsense 21.1 with Sensei

2 times RT-AC56U running DD-WRT 45493 (one as Gateway, the other as AP, both bridged with LAN cable)

3 times Asus RT-N16 shelved

E4200 V1 running freshtomato 2020.8 (bridged with LAN cable)

3 times Linksys WRT610N V2 converted to E3000 and 1 original E3000 running freshtomato 2020.8 (bridged with LAN cable)

Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 217

PostPosted: Thu Mar 03, 2016 19:05    Post subject: Reply with quote
Router: Netgear R7000
Firmware: DD-WRT v3.0-r29193 std (03/02/16)
Kernel: Linux 4.4.3 #381 SMP Wed Mar 2 07:03:33 CET 2016 armv7l
Status: Working
Reset: No
Previous: 29147
Errors: No

OpenVPN 2.3.10 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Mar 2 2016
Library versions: OpenSSL 1.0.2g 1 Mar 2016, LZO 2.09


Last edited by Bernadoe on Thu Mar 03, 2016 19:24; edited 1 time in total
mchaney
DD-WRT User


Joined: 26 Apr 2013
Posts: 389

PostPosted: Thu Mar 03, 2016 19:11    Post subject: Reply with quote
Everything is still fast on my R7000 but I'm getting a line in syslog exactly every 2 minutes, like this:

Mar 3 18:42:00 DD-WRT user.info : process_monitor successfully started
Mar 3 18:44:00 DD-WRT user.info : process_monitor successfully started
Mar 3 18:46:00 DD-WRT user.info : process_monitor successfully started
Mar 3 18:48:00 DD-WRT user.info : process_monitor successfully started
Mar 3 18:50:00 DD-WRT user.info : process_monitor successfully started
Mar 3 18:52:00 DD-WRT user.info : process_monitor successfully started
Mar 3 18:54:01 DD-WRT user.info : process_monitor successfully started
Mar 3 18:56:00 DD-WRT user.info : process_monitor successfully started
Mar 3 18:58:00 DD-WRT user.info : process_monitor successfully started
Mar 3 19:00:00 DD-WRT user.info : process_monitor successfully started
Mar 3 19:02:00 DD-WRT user.info : process_monitor successfully started

Anyone know what causes this?

Thanks,
Mike
dbarron
DD-WRT Novice


Joined: 29 Jun 2006
Posts: 12

PostPosted: Thu Mar 03, 2016 20:54    Post subject: Reply with quote
Router: Buffalo WZR-1750DHP
Firmware: DD-WRT v3.0-r29193 std (03/02/16)
Kernel: Linux 4.4.3 #381 SMP Wed Mar 2 07:03:33 CET 2016 armv7l
Status: Working
Reset: No
Errors: None observed

Also seeing the messages of process_monitor started every 2 minutes, till it was reset for 3600 secs from ntp_main...
usharifu
DD-WRT Novice


Joined: 19 Feb 2013
Posts: 7

PostPosted: Thu Mar 03, 2016 20:59    Post subject: Reply with quote
Router: D-Link DIR-890L
Kernel: Linux 4.4.3 #383 SMP Wed Mar 2 07:11:42 CET 2016 armv7l
Firmware: 03-02-2016-r29193 std
Previous: v4_sp2-r26653
Status: Working as Router or AP
Reset: No
Errors: Client Bridge mode is still not working and causes the router to reboot after a period.

Not sure if this will ever be resolved... May return/sell the router as this is the primary purpose I need it for and the stock firmware does not support bridge as well. C'est la vie.
mchaney
DD-WRT User


Joined: 26 Apr 2013
Posts: 389

PostPosted: Thu Mar 03, 2016 21:13    Post subject: Reply with quote
dbarron wrote:
Also seeing the messages of process_monitor started every 2 minutes, till it was reset for 3600 secs from ntp_main...


What does that mean? Did you change it to 3600 sec somehow? If so, how? And what are the implications?

Mike
dbarron
DD-WRT Novice


Joined: 29 Jun 2006
Posts: 12

PostPosted: Thu Mar 03, 2016 21:31    Post subject: Reply with quote
Sorry, well if you read the log well, you'll see a line indicating that ntp.main is the parent of those messages...and apparently after some period, it put either squelched the messages or put the process making them to sleep for 3600 seconds (so noted in the log). As I'm a LONG time out of the kernel, I don't know which it is.
Sorry to post "discussion" in the build test thread..but I was asked.

Mar 3 17:22:00 router daemon.debug process_monitor[1947]: We need to re-update after 3600 seconds
Mar 3 17:22:00 router daemon.info process_monitor[1947]: set timer: 3600 seconds, callback: ntp_main()
mamock116
DD-WRT Novice


Joined: 17 Dec 2008
Posts: 20

PostPosted: Thu Mar 03, 2016 22:51    Post subject: Reply with quote
Asus RT-AC56R, upgrade was successful and so far no issues.
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum