[Solved] Help with problem using OpenWRT packages

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
foobarfoo
DD-WRT Novice


Joined: 12 Sep 2008
Posts: 25

PostPosted: Sat Feb 27, 2016 19:54    Post subject: [Solved] Help with problem using OpenWRT packages Reply with quote
I am trying to install a few different OpenWRT packages on my WNDR3700v1/r28139 but I appear to be running into a linker issue that I've yet to find a solution to.

# opkg -f /jffs/etc/opkg.conf install iconv
Installing iconv (1.11.1-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/iconv_1.11.1-1_ar71xx.ipk.
Installing libiconv-full (1.11.1-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/libiconv-full_1.11.1-1_ar71xx.ipk.
Installing libcharset (1.11.1-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/libcharset_1.11.1-1_ar71xx.ipk.
Configuring libiconv-full.
Configuring libcharset.
Configuring iconv.

# which iconv
/opt/usr/bin/iconv
# /opt/usr/bin/iconv
-sh: /opt/usr/bin/iconv: not found
# ldd /opt/usr/bin/iconv
/lib/ld-uClibc.so.0 (0x77b76000)
libiconv.so.2 => /opt/usr/lib/libiconv.so.2 (0x77b60000)
libgcc_s.so.1 => /opt/lib/libgcc_s.so.1 (0x77b3c000)
libc.so.0 => /lib/ld-uClibc.so.0 (0x77b76000)
Error relocating /opt/usr/lib/libiconv.so.2: __fgetc_unlocked: symbol not found
Error relocating /opt/usr/bin/iconv: __fputc_unlocked: symbol not found
Error relocating /opt/usr/bin/iconv: canonicalize_file_name: symbol not found
Error relocating /opt/usr/bin/iconv: error: symbol not found
Error relocating /opt/usr/bin/iconv: __uClibc_main: symbol not found

I'm using packages from this URL:
http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base

I can find all of the missing functions in the installed OpenWRT pre-req. libraries:
# strings /opt/lib/libc.so.0 | grep __fgetc_unlocked
__fgetc_unlocked
etc.

I've tried reordering the LD_LIBRARY_PATH so that the OpenWRT libs are located first:
# export LD_LIBRARY_PATH=/jffs/lib:/jffs/usr/lib:/jffs/usr/local/lib:/mmc/lib:/mmc/usr/lib:/opt/lib:/opt/usr/lib:/lib:/usr/lib
# echo $LD_LIBRARY_PATH
/jffs/lib:/jffs/usr/lib:/jffs/usr/local/lib:/mmc/lib:/mmc/usr/lib:/opt/lib:/opt/usr/lib:/lib:/usr/lib

...all to no avail.

Anybody see what I'm doing wrong? I've run out of ideas Smile


Last edited by foobarfoo on Thu Mar 03, 2016 17:40; edited 1 time in total
Sponsor
danymarc
DD-WRT Guru


Joined: 04 Nov 2012
Posts: 523
Location: Acapulco, Mexico

PostPosted: Thu Mar 03, 2016 8:24    Post subject: Reply with quote
https://forum.openwrt.org/index.php
_________________
TP-Link: TL-WR741ND V4
TP-Link: TL-WR842ND V2
wenzhuo
DD-WRT User


Joined: 22 Apr 2011
Posts: 174

PostPosted: Thu Mar 03, 2016 12:23    Post subject: Re: Help with problem I'm encountering using OpenWRT package Reply with quote
foobarfoo wrote:
I am trying to install a few different OpenWRT packages on my WNDR3700v1/r28139 but I appear to be running into a linker issue that I've yet to find a solution to.

Use packages from openwrt trunk. 15.05 and previous versions link against uClibc.
foobarfoo
DD-WRT Novice


Joined: 12 Sep 2008
Posts: 25

PostPosted: Thu Mar 03, 2016 15:12    Post subject: Re: Help with problem I'm encountering using OpenWRT package Reply with quote
wenzhuo wrote:
foobarfoo wrote:
I am trying to install a few different OpenWRT packages on my WNDR3700v1/r28139 but I appear to be running into a linker issue that I've yet to find a solution to.

Use packages from openwrt trunk. 15.05 and previous versions link against uClibc.


That unfortunately no longer seems to be possible.

https://forum.openwrt.org/viewtopic.php?id=52219

There are no longer any files listed in the trunk directory:

https://downloads.openwrt.org/snapshots/trunk/ar71xx/
wenzhuo
DD-WRT User


Joined: 22 Apr 2011
Posts: 174

PostPosted: Thu Mar 03, 2016 15:19    Post subject: Reply with quote
apparently there's a server problem. wait for some time.
cmsigler
DD-WRT User


Joined: 01 Sep 2015
Posts: 108

PostPosted: Thu Mar 03, 2016 15:41    Post subject: Reply with quote
Hi,
wenzhuo wrote:
apparently there's a server problem. wait for some time.

FYI, additional info: Please see Server Status announcement on https://openwrt.org/

UPDATED: Yeah, I'm wrong. The directory structure for trunk is posted but the filesystem contents are not yet available:

https://downloads.openwrt.org/snapshots/trunk/

Instead try:

http://ftp.stw-bonn.de/pub/openwrt/snapshots/trunk/

Current stable release Chaos Calmer has been available since new data storage drives were installed a few days ago:

https://downloads.openwrt.org/chaos_calmer/15.05/

Older releases are not available from the project website ATM. They will show up on old-releases.openwrt.org once sysadmins have time to restore data from backups, etc. For those needing old release packages/files there are mirrors you can try, though they may not contain all old/historic data. Please see:

https://wiki.openwrt.org/about/mirrors

HTH.

Clemmitt
foobarfoo
DD-WRT Novice


Joined: 12 Sep 2008
Posts: 25

PostPosted: Thu Mar 03, 2016 17:38    Post subject: Reply with quote
That worked, thank you for the tip!

src/gz base http://ftp.stw-bonn.de/pub/openwrt/snapshots/trunk/ar71xx/generic/packages/base
dest root /opt
dest ram /opt/tmp
lists_dir ext /opt/tmp/var/opkg-lists
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum