New build: DD-WRT v3.0 --- 27950M --- 2015/10/16 --- by Kong

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3  Next
Author Message
KrypteX
DD-WRT Guru


Joined: 18 Jan 2014
Posts: 2411

PostPosted: Sat Oct 17, 2015 5:49    Post subject: New build: DD-WRT v3.0 --- 27950M --- 2015/10/16 --- by Kong Reply with quote
New Kong build 27950M - 2015/10/16 has been released: http://www.desipro.de/ddwrt/

Supported devices:
ARM/Broadcom: NETGEAR AC1450, EX6200, R6250, R6300v2, R6700, R7000, R8000; ASUS RT-AC68U, etc.
Marvell: Linksys WRT1900AC, WRT1200AC

Partial DD-WRT changelog: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=279467

Your reports are highly appreciated !
Router:
Firmware:
Kernel:
Status:
Reset:
Errors:

This build thread is for reporting successes and problem with loading this experimental test build. This is important info for developers and users. Always state your hardware and SPECIFIC build (e.g. 27950M_NEWD-2_K2.6_mega-nv64k.bin). Do not ask questions about your specific router or how to configure it in this thread; create your own thread to discuss any specific problems you have or need resolved. Please also do not respond to such questions. This thread is to report info, not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you know how to flash properly and the risk before using this build. It is important to adhere to these requirements, to keep this thread from becoming impossibly long and useless. If you don't know what build to flash and how to flash properly and have a means of recovery if things should go wrong, do NOT flash this experimental test build.

_________________
THERE ARE NO STRANGERS HERE; ONLY FRIENDS YOU HAVEN'T YET MET.
________________________________________________________________________________________________________
DD-WRT CHANGELOG | DEVICES | DD-WRT BUILDS | KONG BUILDS | UNOFFICIAL BUILDS | DD-WRT in VIRTUALBOX

Testing BrainSlayer's DD-WRT build 31924 on various units:
NETGEAR : WNDR3800 WNDR3800CH WNDRMACv2 WNDRMACv1 WNR2200 WNR2000v3
TP-LINK : ArcherC7v3 WR1043NDv3 WR740Nv4 WR740Nv6 WR710Nv1 WR810Nv1 WA850REv1 WA901NDv3 WA901NDv4
D-LINK : DIR-862L DIR-615D2
ASUS : RT-N10 C1
VirtualBox : x86_64


Last edited by KrypteX on Sat Oct 17, 2015 9:02; edited 1 time in total
Sponsor
mr_hyde
DD-WRT Novice


Joined: 29 Dec 2012
Posts: 36
Location: Germany

PostPosted: Sat Oct 17, 2015 8:33    Post subject: Reply with quote
First: it's 27950 and not 27957

Router:R7000
Firmware: DD-WRT v3.0-r27950M kongac (10/16/15)
Kernel: Linux 3.10.90 #441 SMP Fri Oct 16 12:13:37 CEST 2015 armv7l
Status: after upgrade from last kong build (9/7) now 14 hrs up in wireless bridge mode on 5 ghz and no issues so far
Reset: No
Errors: No
stalonge
DD-WRT Guru


Joined: 21 Jul 2006
Posts: 1865
Location: Fortaleza Ce Brazil

PostPosted: Sat Oct 17, 2015 9:01    Post subject: Reply with quote
yes , i dont lose my sanity .. i flashed and its working ..


r7000

Very Happy Very Happy

_________________
DDwrt ...it rocks ....
1 R8500 41556 AP OpenVPN webserver RETIRED (bricked)
1 R7800 42912 AP Wireguard webserver JFFS SAMBA FTP usb HD Mesh
1 R7800 42912 Cli Mesh
1 WZR1750 42908 AP Webserver OpenVPN
1 DDx86 Vmware 40260
1 E3000 41027 K3 @500 WAP wifi client
alkanbw
DD-WRT Novice


Joined: 15 Dec 2011
Posts: 11

PostPosted: Sat Oct 17, 2015 9:03    Post subject: Build 27950 works slower than 27775 Reply with quote
On my Netgear R6300V2 with build 27950 I can't have same high download speed as on builtd 27775. On build 27775 I have download speed all time about 220-225 Mb/s, as on 27950 download speed start from 180 and in the end test I have only 140 Mb/s.
tmo1138
DD-WRT User


Joined: 24 Mar 2015
Posts: 175
Location: Tacoma, Wa

PostPosted: Sat Oct 17, 2015 9:14    Post subject: Reply with quote
Router: R8000
Firmware: DD-WRT v3.0-r27950M kongac (10/16/15)
Kernel: Linux 3.10.90 #441 SMP Fri Oct 16 12:13:37 CEST 2015 armv7l
Status: Wireless AC behavior change
Reset: Yes
Errors: None

I noticed the my prior wireless configurations stopped working on my AC/N WL-2 radio:



Changing it to the following I'm able to connect again, but I don't know why this stopped working prior to reset.



Any suggestions would be appreciated.

Other than that everything so far is working great!

_________________
Routers:
Netgear R8000 - DD-WRT v3.0-r43420 std (06/15/20)
Netgear R9000 - DD-WRT v3.0-r43420 std (06/15/20)


Useful links:

Builds:
ftp://ftp.dd-wrt.com/betas/2020/


dd-wrt supported devices:
http://www.dd-wrt.com/wiki/index.php/Supported_Devices

So long <kong> and thanks for all the fish!
MUNGO
DD-WRT Novice


Joined: 01 Nov 2014
Posts: 11

PostPosted: Sat Oct 17, 2015 9:44    Post subject: Reply with quote
Router: R7000
Firmware: DD-WRT v3.0-r27950M kongac (10/16/15)
Kernel: Linux 3.10.90 #441 SMP Fri Oct 16 12:13:37 CEST 2015 armv7
Reset: No
Errors: SSH tunneling is still not working. Get "Server unexpectedly closed network connection" message once you try to tunnel anything. Reverting back to working DD-WRT v3.0-r27560M kongac (08/08/15).
Giraffe
DD-WRT User


Joined: 07 Sep 2014
Posts: 80

PostPosted: Sat Oct 17, 2015 13:15    Post subject: 27950M on WRT1900ACv2 Reply with quote
Router Linksys WRT1900ACv2

Router: Linksys WRT1900ACv2
Firmware: DD-WRT v3.0-r27950M std (10/16/15)
Kernel: Linux 3.18.22 #13 SMP Sat Oct 10 22:37:21 CEST
2015 armv7l
Status: Well, up and running i guess
Reset: Clean install
Errors:

Wifi latency on both 2.4Ghz and 5Ghz band are expectionally high (35ms on speedtest.net whereas 17ms is the norm).

Wifi troughput is exceptionally low only about 35mbit on the 5Ghz band.

Crying or Very sad
NiTrus
DD-WRT User


Joined: 25 Dec 2010
Posts: 295
Location: Twin Cities, MN

PostPosted: Sat Oct 17, 2015 13:21    Post subject: Reply with quote
MUNGO wrote:
Router: R7000
Firmware: DD-WRT v3.0-r27950M kongac (10/16/15)
Kernel: Linux 3.10.90 #441 SMP Fri Oct 16 12:13:37 CEST 2015 armv7
Reset: No
Errors: SSH tunneling is still not working. Get "Server unexpectedly closed network connection" message once you try to tunnel anything. Reverting back to working DD-WRT v3.0-r27560M kongac (08/08/15).


SSH is working fine on my R7000/R6250.

_________________
NETGEAR R9000 | RT | 40134
NETGEAR R7800 | AP | 40134



Last edited by NiTrus on Sat Oct 17, 2015 15:19; edited 1 time in total
gil80
DD-WRT User


Joined: 16 Jul 2014
Posts: 177

PostPosted: Sat Oct 17, 2015 13:33    Post subject: Reply with quote
Router: R7000
Firmware: flashed latest kong over 28705
Kernel:
Status: bricked
Reset: no
Errors: router doesn't respond. Can't access it.

Appreciate any help.
razel
DD-WRT Novice


Joined: 11 Aug 2015
Posts: 15

PostPosted: Sat Oct 17, 2015 13:36    Post subject: Linksys EA6200 Reply with quote
Router: Linksys EA6200
Firmware: DD-WRT v3.0-r27950M kongac (10/16/15)
Kernel: Linux 3.10.90 #441 SMP Fri Oct 16 12:13:37 CEST 2015 armv7l
Status: No issues
Reset: No
Errors: None
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Sat Oct 17, 2015 14:58    Post subject: Re: 27950M on WRT1900ACv2 Reply with quote
Giraffe wrote:
Router Linksys WRT1900ACv2

Router: Linksys WRT1900ACv2
Firmware: DD-WRT v3.0-r27950M std (10/16/15)
Kernel: Linux 3.18.22 #13 SMP Sat Oct 10 22:37:21 CEST
2015 armv7l
Status: Well, up and running i guess
Reset: Clean install
Errors:

Wifi latency on both 2.4Ghz and 5Ghz band are expectionally high (35ms on speedtest.net whereas 17ms is the norm).

Wifi troughput is exceptionally low only about 35mbit on the 5Ghz band.

Crying or Very sad


I just did a quick test and can't reproduce this on the 1200AC, I get 150MBit using a crappy dual stream N adapter on the 5G and 120MBit on 2G. I'll try an ac adapter later on.

Also don't see any error regarding sirq (the previous created exceptional high sirq), when running iperf test sirq is around 20% and on idle it is down to 0%, just as expected.

Ping in client mode is not perfect I see 10ms. Ping from client to router is <3ms which is okay.


Last edited by <Kong> on Sat Oct 17, 2015 15:34; edited 1 time in total
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Sat Oct 17, 2015 15:00    Post subject: Re: Build 27950 works slower than 27775 Reply with quote
alkanbw wrote:
On my Netgear R6300V2 with build 27950 I can't have same high download speed as on builtd 27775. On build 27775 I have download speed all time about 220-225 Mb/s, as on 27950 download speed start from 180 and in the end test I have only 140 Mb/s.


Disconnect the router from power, wait 60s then connect it again.
gil80
DD-WRT User


Joined: 16 Jul 2014
Posts: 177

PostPosted: Sat Oct 17, 2015 15:04    Post subject: Reply with quote
dear kong,

after flashing dd-wrt.k3_r7000.chk 16/10/2015 the router got bricked.
I was able to use tftp and flash stock firmware
Giraffe
DD-WRT User


Joined: 07 Sep 2014
Posts: 80

PostPosted: Sat Oct 17, 2015 16:11    Post subject: Re: 27950M on WRT1900ACv2 Reply with quote
<Kong> wrote:
Giraffe wrote:
Router Linksys WRT1900ACv2

Router: Linksys WRT1900ACv2
Firmware: DD-WRT v3.0-r27950M std (10/16/15)
Kernel: Linux 3.18.22 #13 SMP Sat Oct 10 22:37:21 CEST
2015 armv7l
Status: Well, up and running i guess
Reset: Clean install
Errors:

Wifi latency on both 2.4Ghz and 5Ghz band are expectionally high (35ms on speedtest.net whereas 17ms is the norm).

Wifi troughput is exceptionally low only about 35mbit on the 5Ghz band.

Crying or Very sad


I just did a quick test and can't reproduce this on the 1200AC, I get 150MBit using a crappy dual stream N adapter on the 5G and 120MBit on 2G. I'll try an ac adapter later on.

Also don't see any error regarding sirq (the previous created exceptional high sirq), when running iperf test sirq is around 20% and on idle it is down to 0%, just as expected.

Ping in client mode is not perfect I see 10ms. Ping from client to router is <3ms which is okay.


Do you need any more info regarding the low troughput on 5Ghz?

Or could you advise me on what settings you are using on you're WRT1200AC? (Settings like channel nr. lower/upper,)
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Sat Oct 17, 2015 17:06    Post subject: Re: 27950M on WRT1900ACv2 Reply with quote
Giraffe wrote:
<Kong> wrote:
Giraffe wrote:
Router Linksys WRT1900ACv2

Router: Linksys WRT1900ACv2
Firmware: DD-WRT v3.0-r27950M std (10/16/15)
Kernel: Linux 3.18.22 #13 SMP Sat Oct 10 22:37:21 CEST
2015 armv7l
Status: Well, up and running i guess
Reset: Clean install
Errors:

Wifi latency on both 2.4Ghz and 5Ghz band are expectionally high (35ms on speedtest.net whereas 17ms is the norm).

Wifi troughput is exceptionally low only about 35mbit on the 5Ghz band.

Crying or Very sad


I just did a quick test and can't reproduce this on the 1200AC, I get 150MBit using a crappy dual stream N adapter on the 5G and 120MBit on 2G. I'll try an ac adapter later on.

Also don't see any error regarding sirq (the previous created exceptional high sirq), when running iperf test sirq is around 20% and on idle it is down to 0%, just as expected.

Ping in client mode is not perfect I see 10ms. Ping from client to router is <3ms which is okay.


Do you need any more info regarding the low troughput on 5Ghz?

Or could you advise me on what settings you are using on you're WRT1200AC? (Settings like channel nr. lower/upper,)


Most likely it is client depended, broadcom had lots of issues with ampdu/amsdu handling in the past, which alo caused trouble with android and/apple devices.

I used an Intel 7260 and Netgear A6200 for my tests.
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum