HOW TO: Guest WiFi + abuse control for beginners

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Author Message
htismaqe
DD-WRT User


Joined: 05 Nov 2015
Posts: 471

PostPosted: Thu Nov 05, 2015 20:47    Post subject: Reply with quote
Thanks for that link.

Should I try to use iptables just to block GUI access or are you suggesting I should re-work my config from scratch using that tutorial?

That's really what I'm looking for is a best practice/tutorial. Would there be a better forum to post this rather than in this thread?
Sponsor
kt0516
DD-WRT Novice


Joined: 12 Aug 2015
Posts: 7

PostPosted: Sat Nov 28, 2015 8:35    Post subject: Reply with quote
Hi,

I have createt a guest network according to the guide in the first topic. Everything works, but I have no internet access on guest. Multiple dhcp created for wl0.1.

Can you help me what to do to get internet?

My router is a WRT54GL with build 28320

Thanks in advance
Tom
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sat Nov 28, 2015 9:50    Post subject: Reply with quote
Have you enabled NAT/Masquerade on Network configuraion wl0.1 (Basic/Networking tab)? Start with icmp echo (ping) and tracert google.com from guest client to see where the problem is...
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sat Nov 28, 2015 9:52    Post subject: Reply with quote
also, this guide will only work if you have WAN port enabled...
kt0516
DD-WRT Novice


Joined: 12 Aug 2015
Posts: 7

PostPosted: Sat Nov 28, 2015 17:06    Post subject: Reply with quote
Thanks for the fast reply.

I have attached two pictures about my setup.
WAN port is enabled. I have a wireless repeater with an ethernet port. This is connected to WAN of my WRT54gl.
I am not an expert in ddwrt. Could you help?

thanks in advance
Tom
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sat Nov 28, 2015 19:52    Post subject: Reply with quote
Is your Repeater in Gateway or Router mode (Setup/Advanced routing tab - Operating Mode)?
kt0516
DD-WRT Novice


Joined: 12 Aug 2015
Posts: 7

PostPosted: Sat Nov 28, 2015 21:38    Post subject: Reply with quote
My router is in gateway mode. If I change to router mode, I have no internet both on guest, and on normal wireless network.
kt0516
DD-WRT Novice


Joined: 12 Aug 2015
Posts: 7

PostPosted: Sun Nov 29, 2015 15:08    Post subject: Reply with quote
Should I change to static ip?
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sun Nov 29, 2015 16:59    Post subject: Reply with quote
I really don't know... It should work no matter if Static or Dynamic WAN IP...
kt0516
DD-WRT Novice


Joined: 12 Aug 2015
Posts: 7

PostPosted: Sun Nov 29, 2015 17:38    Post subject: Reply with quote
ok, thanks anyway. Maybe is it work only for atheros?
bmanilow13
DD-WRT Novice


Joined: 01 Dec 2015
Posts: 2

PostPosted: Tue Dec 01, 2015 14:51    Post subject: No luck with guest network - help needed :( Reply with quote
Hello all - DD-WRT noob here. I have tried the steps in both of these threads but am unable to connect to the guest network. the network is available but it always gets stuck trying to assign an IP.

http://tips.desipro.de/2013/12/06/guest-wifi-setup-dd-wrt/
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=277811

I am using beta build r28374 and have tried making the virtual interfaces on both the 2.4 and 5ghz.

Any help would be greatly appreciated, thanks!
josfr4ncisco
DD-WRT Novice


Joined: 12 Sep 2015
Posts: 11

PostPosted: Sat Dec 05, 2015 18:00    Post subject: Reply with quote
Did anyone save the images on the op? They are no longer appearing, and I'm kind of lost here.
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sat Dec 05, 2015 19:27    Post subject: Reply with quote
you have it on wiki see my sig...
server where I posted screenshot went down for good:(
Akkerfeld
DD-WRT Novice


Joined: 08 Oct 2010
Posts: 1

PostPosted: Wed Sep 14, 2016 15:30    Post subject: Reply with quote
Hi,
I followed this tutorial, but if I connect to the guest network there is no Internet access, IP is assigned OK, and I can't connect to clients on the main network.

If I create a bridge between ath0 and ath0.1 without changing any setting, I get Internet access, but I can also connect to clients on the main network.

The router is working as an access point, the WAN connection type is disabled, assign WAN port to switch checked. DHCP forwarding is enabled, but I also tried with DHCP off.

Any ideas what might be wrong?
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Thu Sep 15, 2016 6:01    Post subject: Reply with quote
problem is that you router work in so called "router mode" and this tutorial is designed for routers that work in "gateway mode" (enabled NAT)...
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next Display posts from previous:    Page 6 of 7
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum