[GELÖST] 802.1x / TP-Link WR842ND --> NEUES PROBLEM!

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC basierende Hardware
Author Message
Edon
DD-WRT Novice


Joined: 14 Oct 2014
Posts: 8

PostPosted: Mon Oct 20, 2014 15:52    Post subject: [GELÖST] 802.1x / TP-Link WR842ND --> NEUES PROBLEM! Reply with quote
Hallo zusammen! Smile

ich versuche ein WLAN-Netz aufzubauen, welches ich vom Uni-Netz "eduroam" aus mit Internet versorgen will. "eduroam" erhalte ich auch per WLAN.
Habe mir zu diesem Zweck einen TP-Link WR842ND v2.1 gekauft, und nach dieser Anleitung ( http://www.pc-magazin.de/ratgeber/router-firmware-dd-wrt-freischalten-hack-unlock-modding-tuning-2305820.html -> bis Punkt 6 verwendet ) auch erfolgreich geflasht.
Danach habe ich folgende Einstellungen vom User "JarodRussell" übernommen:

Basic-Settings:
Mode: Client
Network Mode: Mixed
Channel Width: 20MHz (Full)
SSID: eduroam

Wireless-Security:

Security-Mode: 802.1x
XSuplicant-Type: Students use Peap here, employees such as assistants use TTLS
User: your account@youruniversity.de
Anonymous Identity: anonymous
Password: your password
Phase2: auth=MSChapV2 (students) / auth=PAP (employees)
Public Server Certificate: -------BEGIN CERTIFICATE------- till --------------END CERTIFICATE---------------
In the Setup->Basic Setup Tab of the router you need to configure WAN Connection Type to "Automatic DHCP"

(Quelle: http://www.dd-wrt.com/phpBB2/viewtopic.php?p=911224)

Hat - auf Anhieb - nicht funktioniert, ich habe glaube ich MSChapV2 statt auth=MSCapV2 eingegeben :-/
Kann ich allerdings nicht überprüfen, da ich nach einem Neustart des Computers inkl. Ein- und Ausstecken des Router am LAN-Port und an der Steckdose zuerst kein WLAN Netz mehr gefunden habe (direkt nach dem Flashen + Bestätigen der Einstellungen ging es noch, bin ins WLAN-Netz "dd-wrt" reingekommen, habe nur keine Internetverbindung gehabt) und nach einem zweiten Neustart nicht mal mehr den Router per 192.168.1.1 ansteuern kann? Powerlampe und LAN1 (am Notebook angeschlossen) blinken am Router, WLAN-Leuchte geht hin und wieder kurz blinkend an, um dann wieder zu erlöschen.
ipconfig /all sieht wie folgt aus:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\Edon>ipconfig /all

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : Edon-PC
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : eduroam.uni-siegen.de

Drahtlos-LAN-Adapter Drahtlosnetzwerkverbindung:

Verbindungsspezifisches DNS-Suffix: eduroam.uni-siegen.de
Beschreibung. . . . . . . . . . . : Broadcom 802.11n-Netzwerkadapter
Physikalische Adresse . . . . . . : 5C-AC-4C-49-C9-43
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::bc1c:a5f6:1da6:1d0%12(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 10.192.255.21(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.0.0
Lease erhalten. . . . . . . . . . : Montag, 20. Oktober 2014 15:17:50
Lease läuft ab. . . . . . . . . . : Dienstag, 21. Oktober 2014 04:27:44
Standardgateway . . . . . . . . . : 10.192.0.1
DHCP-Server . . . . . . . . . . . : 141.99.2.2
DHCPv6-IAID . . . . . . . . . . . : 425503820
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-18-E2-4D-BB-70-5A-B6-F0-CB-

DNS-Server . . . . . . . . . . . : 141.99.2.2
141.99.1.12
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Ethernet-Adapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
Physikalische Adresse . . . . . . : 70-5A-B6-F0-CB-A8
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::9b6:2a53:d449:a940%10(Bevorzugt)
IPv4-Adresse (Auto. Konfiguration): 169.254.169.64(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.0.0
Standardgateway . . . . . . . . . :
DHCPv6-IAID . . . . . . . . . . . : 242244278
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-18-E2-4D-BB-70-5A-B6-F0-CB-

DNS-Server . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Tunneladapter isatap.{CB792E01-2EC1-43E1-BA1B-5FD6CA9F7CF7}:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #2
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja

Tunneladapter Teredo Tunneling Pseudo-Interface:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
IPv6-Adresse. . . . . . . . . . . : 2001:0:5ef5:79fd:10fd:a9f:f53f:ea(Bevor
gt)
Verbindungslokale IPv6-Adresse . : fe80::10fd:a9f:f53f:ea%18(Bevorzugt)
Standardgateway . . . . . . . . . : ::
NetBIOS über TCP/IP . . . . . . . : Deaktiviert

Tunneladapter isatap.eduroam.uni-siegen.de:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix: eduroam.uni-siegen.de
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter #3
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja

C:\Users\Edon>

Bin leider absoluter Anfänger auf dem Gebiet und somit heillos überfordert! Kann mir jemand weiterhelfen? Hoffe dass das Gerät jetzt nicht "gebricked" ist?

Und Entschuldigung, falls diese Frage schon beantwortet wurde oder ich im falschen Unterforum unterwegs bin! Embarassed Konnte über die Suche nichts finden..

Vielen Dank im Voraus!

Gruß,

Edon

EDIT: Benutze wenn ich das richtig sehe build 3320 für die Version 2.x meines Routers vom 2014-01-11, diese um genau zu sein: http://dd-wrt.com/site/support/other-downloads?path=others%2Feko%2FBrainSlayer-V24-preSP2%2F2014%2F01-10-2014-r23320-fix%2Ftplink_tl-wr842ndv2%2F

EDIT 2: Habe das Problem gelöst indem ich in den Netzwerkadaptereigenschaften folgende Parameter eingesetzt habe, falls noch jemand das Problem haben sollte:

IP-Adresse: 192.168.1.23
Subnetzmaske: 255.255.255.0
Standardgateway: 192.168.1.1
Bevorzugter DNS-Server: 192.168.1.1

Falls jemand das gleiche Problem bekommen sollte Smile

Allerdings weiß ich immer noch nicht, warum der Router kein WLAN-Signal aussendet? :-/

Danke im Voraus Very Happy

EDIT 3:
Aus dem Webinterface:

Router-Modell
TP-Link TL-WR842ND v2

Firmware-Version
DD-WRT v24-sp2 (01/10/14) std - build 23320

Kernel Version
Linux 3.10.26 #3400 Fri Jan 10 08:16:25 CET 2014 mips


Last edited by Edon on Mon Nov 10, 2014 17:25; edited 1 time in total
Sponsor
Edon
DD-WRT Novice


Joined: 14 Oct 2014
Posts: 8

PostPosted: Tue Oct 21, 2014 10:43    Post subject: Reply with quote
Niemand?

Hab jetzt nochmal über das Webinterface alles auf Werkseinstellungen zurückgesetzt, das WLAN ist nun wieder aufgetaucht. Durch Probieren ist mir aufgefallen, dass das WLAN-Signal verschwindet, sobald ich über Wireless -> Baisc Settings den Wireless Mode von AP auf Client setze. Ist mein Vorhaben - eduroam per WLAN empfangen und die Internetverbindung per WLAN weiterzuverteilen - somit überhaupt umsetzbar? Denn ich muss ja Client sein um per WLAN das eduroam aufzunehmen, richtig?
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6981
Location: Dresden, Germany

PostPosted: Wed Oct 22, 2014 16:28    Post subject: Reply with quote
natürlich verschwindet es. im client modus ist er ein client und kein accesspoint mehr. clients sieht man nicht. die wollen sich ja selber mit anderen netzen verbinden. wenn du es als repeater einrichtest, also einen zweiten vap einrichtest so wird dieser erst nach erfolgreicher verbindung sichtbar
_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
Edon
DD-WRT Novice


Joined: 14 Oct 2014
Posts: 8

PostPosted: Sat Oct 25, 2014 14:41    Post subject: Reply with quote
Danke für die Antwort! Smile

Das war mir nicht bewusst.
Welchen Wireless Mode stell ich denn da ein? Habe AP, Client, Client Bride (Routed), Adhoc, WDS Station und WDS AP zur Auswahl.

Da mein Signal im Client - Mode nicht stärker wurde als ohne Router, obwohl ich im selben Raum wie der Router sitze, kann ich davon ausgehen, dass ich noch eine Einstellung unter "Wireless Security" zusätzlich falsch eingegeben habe, oder?
Edon
DD-WRT Novice


Joined: 14 Oct 2014
Posts: 8

PostPosted: Mon Nov 10, 2014 16:51    Post subject: Reply with quote
also...

ich habe nun einen virtuellen Access Point erstellt und lasse den Router im Client-Mode laufen, Sicherheitsinfos habe ich eingegeben, allerdings finde ich weder ein neues Netzwerk das so heißt wie ich es angegeben habe noch ist das eduroam-Signal stärker (wie man es ja sicher ohne den VAP vermuten könnte)als zuvor. Das Netzwerk "dd-wrt" taucht immer noch auf, jedoch auch dieses ohne Internetverbindung.
WAN Connection Type steht auf "Automatic Configuration - DHCP" und unter Status - Wireless - Site Survey find ich das eduroam-Netzwerk auch.
Weiß jemand Rat? :-/
Edon
DD-WRT Novice


Joined: 14 Oct 2014
Posts: 8

PostPosted: Mon Nov 10, 2014 17:23    Post subject: Reply with quote
Problem gelöst!

Unter "Anonymous Identity" musste ich die gleichen Informationen wie unter "User" rein, also meine eMail-Adresse. Dies habe ich durch die Anleitung zum Zugang in das eduroam-Netzwerk für Android Handies auf der Homepage der Universität rausgefunden, da die Zugangsdaten für Android und dd-wrt für eduroam meist ähnlich oder wie in diesem Fall sogar identisch sind (vielen Dank an den User HabeIchVergessen an dieser Stelle!)

Für alle Laien, die ähnliche Probleme haben oder dies über Google finden:

Bei mir hat es so wie hier beschrieben funktioniert!

Einen VAP erstellt man wie folgt:

Habe unter Wireless --> Basic Settings --> Virtual Interface auf "add" gedrückt und dort obenstehendes angegeben --> VAP (Virtual Access Point) erstellt. Über "Wireless Security" habe ich dann einfach wie obenstehend dem neuen Netzwerk, dass ich über den VAP erzeugt hab, eine Verschlüsselung verpasst und ein Kennwort für den Zugang zum Netzwerk gesetzt.

Ich hoffe ich konnte damit jemandem helfen! Smile
Danke an BrainSlayer!
fly5x
DD-WRT Novice


Joined: 22 Oct 2015
Posts: 1

PostPosted: Thu Oct 22, 2015 23:06    Post subject: Reply with quote
Hallo,

läuft oder lief das bei dir? Ich brauche sowas übergangsweise für für ein anderes WLAN bei dem man sich mit User und PW registrieren muss. Mir würde es auch reichen, wenn das Internet per LAN weitergegeben wird, daran kommt dann eine FritzBox.

Alternativ würde ich einfach ein billiges WIndows-Tablet oder ein altes Netbook nehmen. Das dürfte einfacher sein? Wie lange hast du für die Konfiguration mit DD-WRT gebraucht?
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC basierende Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum