Huge speed drop after enabling QoS

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Fri May 16, 2014 13:32    Post subject: Huge speed drop after enabling QoS Reply with quote
Hello

I setup Guest network 172.16.0.x on my E3000 running 23919 K3.x dd-wrt firmware. I try to limit the speed for Guest network, so I enable the Qos, see below setting:

The speed test before Qos enable is as following:

And after Qos enabled, the speed is only 40% for 192.168.10.x network.

What is the problem. I tested 3-4 times on both.



enable QoS.PNG
 Description:
 Filesize:  48.33 KB
 Viewed:  13366 Time(s)

enable QoS.PNG



Disable QoS.PNG
 Description:
 Filesize:  50.34 KB
 Viewed:  13366 Time(s)

Disable QoS.PNG



Qos Setting.PNG
 Description:
 Filesize:  30.43 KB
 Viewed:  13366 Time(s)

Qos Setting.PNG


Sponsor
MongooseProXC
DD-WRT User


Joined: 24 May 2012
Posts: 235

PostPosted: Fri May 16, 2014 14:18    Post subject: Reply with quote
The bulk class was really slowed down at some point during development. I bet the web browsing is noticeably hindered on the guest network as well.

If it bothers you, try an older build in the 19000s. Personally, I'm running 18946 with my guest network in bulk. It works extremely well.
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Sat May 17, 2014 5:31    Post subject: Reply with quote
QoS does not work at all. Whatever I set "Manual, standard", the max download speed I can get is about 23. By now I disabled QoS.

MongooseProXC wrote:
The bulk class was really slowed down at some point during development. I bet the web browsing is noticeably hindered on the guest network as well.

If it bothers you, try an older build in the 19000s. Personally, I'm running 18946 with my guest network in bulk. It works extremely well.
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Sat May 17, 2014 6:14    Post subject: Reply with quote
newnews wrote:
QoS does not work at all. Whatever I set "Manual, standard", the max download speed I can get is about 23. By now I disabled QoS.

MongooseProXC wrote:
The bulk class was really slowed down at some point during development. I bet the web browsing is noticeably hindered on the guest network as well.

If it bothers you, try an older build in the 19000s. Personally, I'm running 18946 with my guest network in bulk. It works extremely well.


I doubt it is the QOS implementation.

How did you setup guest network, this way:

http://tips.desipro.de/2013/12/06/guest-wifi-setup-dd-wrt/

or did you try to do this by hand?
What type of wan connection do you have?
Did you enable access restrictions?
Did you watch the cpu load while doing the speed test. To do this logon to the router and run top, look at the idle value.

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Tue May 20, 2014 21:53    Post subject: Reply with quote
I follow the video "DD-WRT Tutorial Create a secure and separate public guest network" here to create a guest wifi.

http://1drv.ms/1joXDkO

The guest network works fine. I am using Comcast cable. There are some access restriction rules applied for my private network 192.168.10.x only, but no restrict on the computer I did the test. The CPU load is not high: 0.48, 0.27, 0.28.

Looks like there is a speed bottleneck(23Mbps)after enable Qos for 192.168.10.x network.

<Kong> wrote:
I doubt it is the QOS implementation.

How did you setup guest network, this way:

http://tips.desipro.de/2013/12/06/guest-wifi-setup-dd-wrt/

or did you try to do this by hand?
What type of wan connection do you have?
Did you enable access restrictions?
Did you watch the cpu load while doing the speed test. To do this logon to the router and run top, look at the idle value.
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Wed May 21, 2014 5:57    Post subject: Reply with quote
newnews wrote:
I follow the video "DD-WRT Tutorial Create a secure and separate public guest network" here to create a guest wifi.

http://1drv.ms/1joXDkO

The guest network works fine. I am using Comcast cable. There are some access restriction rules applied for my private network 192.168.10.x only, but no restrict on the computer I did the test. The CPU load is not high: 0.48, 0.27, 0.28.

Looks like there is a speed bottleneck(23Mbps)after enable Qos for 192.168.10.x network.

<Kong> wrote:
I doubt it is the QOS implementation.

How did you setup guest network, this way:

http://tips.desipro.de/2013/12/06/guest-wifi-setup-dd-wrt/

or did you try to do this by hand?
What type of wan connection do you have?
Did you enable access restrictions?
Did you watch the cpu load while doing the speed test. To do this logon to the router and run top, look at the idle value.


This tutorial is outdated, not secure, does not tell you how to have internet access on the guest wireless.

Regarding load, you have to check the idle value while doing the speedtest everything else is bullshit, load value is accumulated value over time thus if you had 5 min no load and then 5 min speedtest at 100% cpu it would show 0.5

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Wed May 21, 2014 17:10    Post subject: Reply with quote
Hi, Kong

The CPU idle is 0.0 during speed test on both Qos enabled and disabled condition.

The 23919 K3.x dd-wrt firmware I am using has only 3 options under virtual WLAN setup. see the snapshot "virtualWlan.png". Not the same as the link you posted. I did not mention in my previous post that I have added firewall rules for guest internet:

iptables -t nat -I POSTROUTING -o `get_wanface` -j SNAT --to `nvram get wan_ipaddr`
#Removes guest access to physical network
iptables -I FORWARD -i br1 -o br0 -m state --state NEW -j DROP
iptables -I FORWARD -i br0 -o br1 -m state --state NEW -j DROP
#Removes guest access to the router's config GUI/ports
iptables -I INPUT -i br1 -p tcp --dport telnet -j REJECT --reject-with tcp-reset
iptables -I INPUT -i br1 -p tcp --dport ssh -j REJECT --reject-with tcp-reset
iptables -I INPUT -i br1 -p tcp --dport www -j REJECT --reject-with tcp-reset
iptables -I INPUT -i br1 -p tcp --dport https -j REJECT --reject-with tcp-reset

I can manually set the speed for private and guest lan, however, the max speed I can have is about 23M.

<Kong> wrote:
newnews wrote:
I follow the video "DD-WRT Tutorial Create a secure and separate public guest network" here to create a guest wifi.

http://1drv.ms/1joXDkO

The guest network works fine. I am using Comcast cable. There are some access restriction rules applied for my private network 192.168.10.x only, but no restrict on the computer I did the test. The CPU load is not high: 0.48, 0.27, 0.28.

Looks like there is a speed bottleneck(23Mbps)after enable Qos for 192.168.10.x network.

<Kong> wrote:
I doubt it is the QOS implementation.

How did you setup guest network, this way:

http://tips.desipro.de/2013/12/06/guest-wifi-setup-dd-wrt/

or did you try to do this by hand?
What type of wan connection do you have?
Did you enable access restrictions?
Did you watch the cpu load while doing the speed test. To do this logon to the router and run top, look at the idle value.


This tutorial is outdated, not secure, does not tell you how to have internet access on the guest wireless.

Regarding load, you have to check the idle value while doing the speedtest everything else is bullshit, load value is accumulated value over time thus if you had 5 min no load and then 5 min speedtest at 100% cpu it would show 0.5



VirtualWLAN.PNG
 Description:
 Filesize:  9.76 KB
 Viewed:  13104 Time(s)

VirtualWLAN.PNG


<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Wed May 21, 2014 18:24    Post subject: Reply with quote
newnews wrote:
Hi, Kong

The CPU idle is 0.0 during speed test on both Qos enabled and disabled condition.



That is exactly the problem, this means, 100% CPU Load -> the CPU is too weak.

QOS is quite cpu intensive and access restrictions too.
If you turn on access restrictions, then we cannot optimize iptables rules anymore, each packet has to be processed.

Solution: faster router e.g. dual arm

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Wed May 21, 2014 21:37    Post subject: Reply with quote
<Kong> wrote:
newnews wrote:
Hi, Kong

The CPU idle is 0.0 during speed test on both Qos enabled and disabled condition.



That is exactly the problem, this means, 100% CPU Load -> the CPU is too weak.

QOS is quite cpu intensive and access restrictions too.
If you turn on access restrictions, then we cannot optimize iptables rules anymore, each packet has to be processed.

Solution: faster router e.g. dual arm

Thanks for your help. Is the Virtual interface configuration GUI you introduced only available on your build? or it will be implemented to all dd-wrt build?
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Thu May 22, 2014 12:23    Post subject: Reply with quote
newnews wrote:
<Kong> wrote:
newnews wrote:
Hi, Kong

The CPU idle is 0.0 during speed test on both Qos enabled and disabled condition.



That is exactly the problem, this means, 100% CPU Load -> the CPU is too weak.

QOS is quite cpu intensive and access restrictions too.
If you turn on access restrictions, then we cannot optimize iptables rules anymore, each packet has to be processed.

Solution: faster router e.g. dual arm

Thanks for your help. Is the Virtual interface configuration GUI you introduced only available on your build? or it will be implemented to all dd-wrt build?


They are included in all broadcom dd-wrt builds, since I commit directly to dd-wrt, someone just needs to add the option in the wireless webif section for atheros, since I don't have an atheros I can't test it, so I leave that to BS.

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Thu May 22, 2014 16:42    Post subject: Reply with quote
<Kong> wrote:
They are included in all broadcom dd-wrt builds, since I commit directly to dd-wrt, someone just needs to add the option in the wireless webif section for atheros, since I don't have an atheros I can't test it, so I leave that to BS.


well, I am using Broadcom version 23919 (E3000) but I did not see the GUI option for guest network. You can see what I have on the screenshot attached to my previous post.
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Thu May 22, 2014 19:08    Post subject: Reply with quote
newnews wrote:
<Kong> wrote:
They are included in all broadcom dd-wrt builds, since I commit directly to dd-wrt, someone just needs to add the option in the wireless webif section for atheros, since I don't have an atheros I can't test it, so I leave that to BS.


well, I am using Broadcom version 23919 (E3000) but I did not see the GUI option for guest network. You can see what I have on the screenshot attached to my previous post.


Because your Network Configuration is Bridged, if you set it to Unbridged you will see the Net Isolation.

If you bridge a network you connect a few interfaces e.g. wireless wired etc. you don't want to connect your guest wireless to the rest of your network, thus in bridged mode you don't see options, that make no sense.

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Fri May 23, 2014 4:15    Post subject: Reply with quote
<Kong> wrote:
Because your Network Configuration is Bridged, if you set it to Unbridged you will see the Net Isolation.

If you bridge a network you connect a few interfaces e.g. wireless wired etc. you don't want to connect your guest wireless to the rest of your network, thus in bridged mode you don't see options, that make no sense.


The new method makes much easier to setup guest network! I removed old configuration and firewall rules, re-created guest network by GUI, works perfect. Thanks for your great job.
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7373
Location: YWG, Canada

PostPosted: Fri May 23, 2014 8:29    Post subject: Re: Huge speed drop after enabling QoS Reply with quote
newnews wrote:
Hello

I setup Guest network 172.16.0.x on my E3000 running 23919 K3.x dd-wrt firmware. I try to limit the speed for Guest network, so I enable the Qos, see below setting:

The speed test before Qos enable is as following:

And after Qos enabled, the speed is only 40% for 192.168.10.x network.

What is the problem. I tested 3-4 times on both.


as said the e3000 cpu is too slow to take qos at those speeds, short of getting a new router some things you can do are:

-"overclock" the cpu to 533mhz, according to broadcom the rated speed for it's cpu is 533mhz & was downclocked to 480mhz for whatever reason, most say heat as the e3000 runs hot, though mine didnt it ran cool as my other units do & did fine at 533mhz(it was a converted wrt610n v2)

-remove the qos downlink global limit on the top of the page, dont enter 0(if you enter 0 then the netmask rate limits WONT work for downlink!) just literally leave the field blank for downlink. as most lines have minimal latency increase when downlink is saturated it should be fine, but if you do this you MUST keep using htb, hfsc panics with a blank global downlink & prevents ALL internet from working. while having it set like so it will/should still work for netmask limitations. dont know if its a bug or not that netmask rate limits still work with blank global downlink w/e it is i hope it dont get changed cause i use it just like that, to somewhat work around a different qos bug with a certain modem. remove the priorities & use the kbps limits instead, 0/0 for your subnet & whatever slower values for the guest, as you said you want to "limit" the guest network, giving it only priority is hardly "limiting" it.

nice to see e3000 finally has kbps control..for the longest time before it only had priority qos along with most other units

newnews wrote:
QoS does not work at all. Whatever I set "Manual, standard", the max download speed I can get is about 23. By now I disabled QoS.


you cant enter a kbps rate limit WITH priority, currently its one or the other, hopefully someday that can be changed to set a priority while X subnet/device within said priority, will have "up to" the rate limit you specify instead of the entire line.

MongooseProXC wrote:
The bulk class was really slowed down at some point during development. I bet the web browsing is noticeably hindered on the guest network as well.

If it bothers you, try an older build in the 19000s. Personally, I'm running 18946 with my guest network in bulk. It works extremely well.


bulk is 1% - 100%, only goes down to 1% if multiple other users/classes are demanding bandwidth, even a single maximum priority user wont push bulk down to 1% as maximum guarantees a minimum of 60%. there was a lot of work on qos around the r21000 mark especially to htb, you'd be better off using a modern build..

these were the latest rate changes

http://svn.dd-wrt.com/changeset/20795
http://svn.dd-wrt.com/changeset/20796

for htb anyway i was told hfsc is pending to have the same changes done but since then markus has been quiet

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ----> DD-WRT v3.0-r44586 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44586 std
[QUALCOMM] WNDR4300 v1 ------------------------> DD-WRT v3.0-r44586 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44586 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------------------------> DD-WRT v3.0-r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
newnews
DD-WRT User


Joined: 14 Feb 2010
Posts: 79

PostPosted: Tue Jun 03, 2014 17:54    Post subject: Re: Huge speed drop after enabling QoS Reply with quote
tatsuya46 wrote:
as said the e3000 cpu is too slow to take qos at those speeds, short of getting a new router some things you can do are:


I tried all the method above, seems I am able to get speed up to 30M+ only. It is better but still not fully utilize my cable bandwidth. I consider to get more powerful router in the future. Thanks
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum