RT-AC87U DD-WRT support

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3 ... 25, 26, 27
Author Message
valberti
DD-WRT Novice


Joined: 18 Feb 2020
Posts: 7

PostPosted: Tue Mar 10, 2020 22:26    Post subject: Reply with quote
Tried 2 FW versions at my ASYS RT-AC87R at repeater mode:
1. DD-WRT v3.0-r42557 std (02/28/20)
2. DD-WRT v3.0-r42617 std (03/05/20)
2.4 GHz ap used at uplink directios at REPEATER mode. 2.4 GHz vap and 5GHz ap are used at downlink direction.
Both of FW present the same bug: after power restart, somehow 2.4 GHz vap settings get corrupted.
That makes impossible for old clients (without 5 GHz band) to connect (SSID is visible, connections are refused, tried several phones and PCs).
To restore, always need to delete and recreate 2.4 GHz vap. The 5GHz ap is not affected so far.
What could be a solution to avoid such corruption during power restart?
I faced absolutely the same problem than using AC-RT68P with one of the latest DD-WRT FW as the repeater



AC_RT87R_repeater.PNG
 Description:
 Filesize:  39.54 KB
 Viewed:  3047 Time(s)

AC_RT87R_repeater.PNG


Sponsor
stephensuley
DD-WRT Guru


Joined: 09 Feb 2008
Posts: 623
Location: Canada

PostPosted: Wed Mar 11, 2020 3:20    Post subject: Reply with quote
I just updated my 87u to the last build and it broke my client bridge network mode. Everything else still seems to work. However when I switch to client bridge , nothing, wl0 shows no TX or RX. I've reset and hard reset, and I downgraded and reset again....no change.....

It was working fine before the last build.

_________________
Location 1-rural) Cottage WRT1900AC v1 (AP)- (NG)2.4Ghz/40Mhz) --250ft l.o.s.-->Pool House RT-AC87u (N-Only/client bridge) <back2back> RT-AC68u (wl0 & wl1 in AP mode / WAN disabled) - 150MBit/s end to end

Location 2-urban) - 1x Linksys EA8500 (AP)

Location 3-rural) - 1x Asus RT-AC87u (AP)

Latest and greatest builds Wink
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7213
Location: Texas, USA

PostPosted: Wed Mar 11, 2020 3:56    Post subject: Reply with quote
stephensuley wrote:
I just updated my 87u to the last build and it broke my client bridge network mode. Everything else still seems to work. However when I switch to client bridge , nothing, wl0 shows no TX or RX. I've reset and hard reset, and I downgraded and reset again....no change.....

It was working fine before the last build.


Not sure what build you had before, but this verbiage has been in build release thread posts for at least two years (and I need to fix the order in which it is in the posts):

Quote:
Issues, observations, and/or workarounds reported:
2. WDS does not work on Broadcom ARM devices (only MIPS<->MIPS)

Notes:
3. Bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead as WDS doesn't work with Broadcom ARM either (see Issues below).

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
stephensuley
DD-WRT Guru


Joined: 09 Feb 2008
Posts: 623
Location: Canada

PostPosted: Wed Mar 11, 2020 4:09    Post subject: Reply with quote
kernel-panic69 wrote:
stephensuley wrote:
I just updated my 87u to the last build and it broke my client bridge network mode. Everything else still seems to work. However when I switch to client bridge , nothing, wl0 shows no TX or RX. I've reset and hard reset, and I downgraded and reset again....no change.....

It was working fine before the last build.


Not sure what build you had before, but this verbiage has been in build release thread posts for at least two years (and I need to fix the order in which it is in the posts):

Quote:
Issues, observations, and/or workarounds reported:
2. WDS does not work on Broadcom ARM devices (only MIPS<->MIPS)

Notes:
3. Bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead as WDS doesn't work with Broadcom ARM either (see Issues below).



I've been using Client bridge with every build without issue on my 87u until this build.

Now, no matter what build I load nothing but AP mode seems to work. All client modes show no TX, will not connect. However if I do a site survey it shows the network I'm trying to connect to as a client.

Something strange going on here.


Any other ideas?

_________________
Location 1-rural) Cottage WRT1900AC v1 (AP)- (NG)2.4Ghz/40Mhz) --250ft l.o.s.-->Pool House RT-AC87u (N-Only/client bridge) <back2back> RT-AC68u (wl0 & wl1 in AP mode / WAN disabled) - 150MBit/s end to end

Location 2-urban) - 1x Linksys EA8500 (AP)

Location 3-rural) - 1x Asus RT-AC87u (AP)

Latest and greatest builds Wink
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7213
Location: Texas, USA

PostPosted: Wed Mar 11, 2020 4:24    Post subject: Reply with quote
I answered in the build thread. Most likely something that is still under development related to autochannel, perhaps. The lack of your reporting regularly in past build threads kind of hurts other people, but that is just my $0.02
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
mindtrip
DD-WRT Novice


Joined: 16 Oct 2017
Posts: 1

PostPosted: Thu Mar 19, 2020 9:18    Post subject: Reply with quote
stephensuley wrote:

I've been using Client bridge with every build without issue on my 87u until this build.

Now, no matter what build I load nothing but AP mode seems to work. All client modes show no TX, will not connect. However if I do a site survey it shows the network I'm trying to connect to as a client.


Could you be so kind as to tell us the last build you used where client bridging worked? I would like to flash DD-WRT to my 87u and only need it to serve as a client bridge; knowing which was the last build you ran that worked for this would be very helpful.

Many thanks in advance!
Mr.R™
DD-WRT Novice


Joined: 01 Jun 2010
Posts: 28

PostPosted: Tue Apr 21, 2020 13:38    Post subject: Reply with quote
Has anyone had an issue where the 5Ghz band is open and no matter what wireless security you set it stays open?

I've tried a full reset and it still happens, it started around the December 2019 builds and occurs in every one since even with a full reset, i'm not sure what build it was where 5Ghz worked properly but before updating to the Dec builds i was likely on an early 2019 build but no idea which one.

I'm currently on r42872 std (04/10/20) and use ipv4/6, dhcp with some static leases, usb, optware (or whatever its called these days), netdata, port forwarding and qos (htb/fq codel) if any of that may be causing issues.

If this is a reoccurring issue and I've just missed the fix can someone point me to said fix?

Thanks in advance guys.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7213
Location: Texas, USA

PostPosted: Tue Apr 21, 2020 18:03    Post subject: Reply with quote
This thread was started to add the device to the firmware. It was never meant as a one-stop-shop helpdesk thread. Please open a new topic or use the search function in the forum or report post-flash issues in the appropriate build thread. Thank you.
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
Goto page Previous  1, 2, 3 ... 25, 26, 27 Display posts from previous:    Page 27 of 27
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum