OpenVPN Problem

Post new topic   Reply to topic    DD-WRT Forum Index -> Allgemeine Fragen
Author Message
NeckCheck
DD-WRT Novice


Joined: 16 Mar 2014
Posts: 4

PostPosted: Tue Mar 18, 2014 15:53    Post subject: OpenVPN Problem Reply with quote
Hallo zusammen,

ich habe ein kleines Problem in Verbindung mit DD WRT und OpenVPN an meinem TP Link 1043nd.

Womöglich ist es ein reines OpenVPN Problem und ich habe das Problem auch auf einem englischen OpenVPN Board gepostet.

Ich fange am besten mal mit der OpenVPN Server config an:

Server config:

Code:
port 1194
proto udp
dev tun0
keepalive 10 120
verb 3
persist-key
persist-tun
comp-lzo
push "route 192.168.1.2 255.255.255.0"
push "dhcp-option DNS 192.168.1.1"
server 192.168.66.0 255.255.255.0
push "redirect-gateway def1"
dh /tmp/openvpn/dh.pem
ca /tmp/openvpn/ca.crt
cert /tmp/openvpn/cert.pem
key /tmp/openvpn/key.pem


Mein DD WRT Router Netzwerk ist ja das 192.168.1.0

und mein OpenVPN Netzwerk soll dann das 192.168.66.0 sein.

In der Firewall speichere ich dann folgendes:

Code:
iptables -I INPUT 1 -p udp --dport 1194 -j ACCEPT

iptables -I INPUT 3 -i tun0 -j ACCEPT


iptables -I FORWARD 3 -i tun0 -o tun0 -j ACCEPT

iptables -I FORWARD -i br0 -o tun0 -j ACCEPT
iptables -I FORWARD -i tun0 -o br0 -j ACCEPT



Gehe ich nun in den Status OpenVPN erhalte ich folgenden LOG:

Code:
Serverlog 20140318 16:28:52 I OpenVPN 2.3.0 mips-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Mar 25 2013
20140318 16:28:52 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:14
20140318 16:28:52 W NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
20140318 16:28:52 Diffie-Hellman initialized with 2048 bit key
20140318 16:28:52 Socket Buffers: R=[163840->131072] S=[163840->131072]
20140318 16:28:52 I TUN/TAP device tun0 opened
20140318 16:28:52 TUN/TAP TX queue length set to 100
20140318 16:28:52 I do_ifconfig tt->ipv6=1 tt->did_ifconfig_ipv6_setup=0
20140318 16:28:52 I /sbin/ifconfig tun0 192.168.66.1 netmask 255.255.255.0 mtu 1500 broadcast 192.168.66.255
20140318 16:28:53 I UDPv4 link local (bound): [undef]
20140318 16:28:53 I UDPv4 link remote: [undef]
20140318 16:28:53 MULTI: multi_init called r=256 v=256
20140318 16:28:53 IFCONFIG POOL: base=192.168.66.2 size=252 ipv6=0
20140318 16:28:53 IFCONFIG POOL LIST
20140318 16:28:53 I Initialization Sequence Completed
20140318 16:28:53 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:14
20140318 16:28:53 D MANAGEMENT: CMD 'state'
20140318 16:28:53 MANAGEMENT: Client disconnected
20140318 16:28:53 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:14
20140318 16:28:53 D MANAGEMENT: CMD 'state'
20140318 16:28:53 MANAGEMENT: Client disconnected


Hier noch mein Client config:

Code:
client
dev tun
proto udp
remote domain.no-ip.biz 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca c:\\client1\\ca.crt
key c:\\client1\\client1.key
cert c:\\client1\\client1.crt
comp-lzo
verb 3



Wo könnte ich ein Denkfehler drin haben?

Zertifikate habe ich alle eingetragen.

Vielleicht weiß ja jemand hier wo ich noch ansetzen könnten.
Sponsor
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Allgemeine Fragen All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum