HowTo: unbrick a WL500g Deluxe and a WL500g Premium

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Author Message

Joined: 18 Jan 2007
Posts: 56
Location: Fall River, MA

PostPosted: Tue Nov 18, 2008 21:21    Post subject: Reply with quote
Took a while but finally got my Asus premium back to life. I honestly don't know which one fixed it but I grounded out pin 9, 10,16, tftp asus' firmware, dd-wrt, back to asus, restore and nvram clear numerous ttimes. After putting dd-wrt the gui wouldn't work (for some strange reason). So again tried the clear nvram firmware and back and forth and finally got it working.
Buffalo WHR-HP-G54 - v24 SP1
Motorola WR850g - Bricked, tossed it wouldn't come back to life even with jtag cable.
Asus WL-500gP - v24 SP1
DD-WRT Novice

Joined: 20 Nov 2008
Posts: 6

PostPosted: Fri Nov 21, 2008 1:03    Post subject: I need help here (Solved) Reply with quote
Ok, here you have another newbie...
1. Opened the box, checked Asus firmware for 2 minutes, downloaded dd-wrt 2.4 standard generic and flashed it.
2. Went to dd-wrt interface and started changing things such as admin password and SSID. Everything good so far.
3. *Changed the subnet to*. This was stupid. I think i read somewhere that by using that subnet people would be able to talk only the gateway not each other. I wanted that as a security feature.
4. dd-wrt was not refreshing. Waited a couple of minutes and restarted the router. Outcome?
I am leasing a with subnet and gateway as I asked. (An elaborate f.u. response from the router).
I tried Wireshark and try to ping and browse the IPs I saw there but that did not help.

Even after I try the reset and reflash (dd-wrt or asus firmwares) I don't get anywhere. After I flashed again dd-wrt I am not getting a DHCP offer anymore. Air, power and coresponding ethernet light is on. The recovery.exe file seems to upload something and I can see the light on the router flashing during that (when I select manually for the computer) but my settings still persist (such as SSID).
Does that mean that I have to try the famous pin hack?
Since I have a Premium V2 is it Pin 9 or Pin 10?

Thank you people for any suggestion.

Nothing has changed so far, the DHCP is toast but I noticed that when I go to recovery mode the router gets an IP of I noticed it by looking at the packets with Wireshark.

I also tried to manually add an arp entry to map it to and try to ping it but no dice.

Looks like the pin is my only option but before I totally brick it, which pin?

I had the same problem as Cheech here:
and I had tried to press all buttons but apparently not long enough.
Now all is good, until my bricking skills strike again.

Joined: 30 Nov 2008
Posts: 206
Location: Wherever the wind blows.

PostPosted: Mon Dec 08, 2008 23:21    Post subject: Reply with quote
I would urge major caution here unless you KNOW what you are doing. As for the pin 9 to ground from the first post. The image shows a 29GL064M
Pin 9 is a21 on the 064 48 pin chip, WHY on earth would this work ?, there is no logical reason at all.
All I think you guys are doing is crashing the thing and hoping it a, doesnt permenantly damage the flash, which it sounds like some of you have done, or b, it resets. Reset pin is pin 12 on this chip.
Now I see guys saying they tried 9, 10 12 16,17 etc etc. Each chip is different. What works on one type will not work on another (unless htey are exactly the same pinout.
This is a dangerous thread to keep alive.
I am NOT saying reset by hardware CANT work, it can, but it is not something you just poke around at.

I think the sticky nature of this thread is dangerous, It should be deleted as it has gone too far into fantasy island.
DD-WRT Novice

Joined: 11 Dec 2008
Posts: 1

PostPosted: Thu Dec 11, 2008 22:17    Post subject: Thanx Reply with quote
Do not delete this thread!!!
It just saved me a new router.
The pin9 trick still works!!! What's the harm when your router is dead anyway.

PS. I ended up brick when changing the memory to 32mb.
DD-WRT Novice

Joined: 16 Oct 2007
Posts: 8

PostPosted: Tue Dec 16, 2008 19:32    Post subject: Re: Thanx Reply with quote
mostard wrote:
Do not delete this thread!!!
It just saved me a new router.
The pin9 trick still works!!! What's the harm when your router is dead anyway.

PS. I ended up brick when changing the memory to 32mb.

you mean you bricked your router because use the enable full 32mb command on the 1st post? btw, your wl500gP is V1 or V2 ?
DD-WRT Novice

Joined: 15 Jan 2009
Posts: 1

PostPosted: Thu Jan 15, 2009 16:45    Post subject: Reply with quote
For anyone doubting whether this works on a ASUS WL-500W I can confirm it works.
I was running V24 SP1 when I tried to update to EKO

I reset to defaults and used the web interface to upgrade but it all went wrong.

My router simple kept booting up and the power light kepts flashing slowly (slower than when its ready for a flash). Tried 30:30:30 and the Asus Restore but it never found the device.

I then did the pin 9 trick and id did not work the first time ( I rebooted the device after)

The next time I switched it on with pin9 shorted and removed the connection after 15 secs... I DID NOT REBOOT the device. I plugged in the network cable into port 1 and ran the ASUS Utility from my PC and it started flashing the firmware.

Tears of joy flowed!!!

I found reading this thread that I was not sure if it applied to the ASUS WL-500W as well, so I confirm it does.

Good luck
DD-WRT Novice

Joined: 18 Jan 2009
Posts: 7

PostPosted: Sun Jan 18, 2009 11:35    Post subject: Reply with quote

After flashing the WL-500gP with one of the latest TNG builds (11218), I'm having the same problem as Citaro. (I know that it has been my fault, because I haven't waited long enough)

Citaro wrote:
What is the chance of repairing a WL500gp with a 9-pin method when:
The power led is OFF all the time,
The air led is dim, barely seen
Lan leds turn on when connecting a cable.

After trying several methods mentioned here (30-30-30 etc.) I opened the Wl-500gP and did the pin 9 trick - didn't work either. There has been no way to access the boot loader.
So here is my question - is there any chance to get the router run by using the onboard serial (uart) connector, or do I realy have a bricked device?

Has anybody with the same problem (no power Led and dim air led) found a solution?

DD-WRT Novice

Joined: 02 Dec 2008
Posts: 3

PostPosted: Tue Jan 20, 2009 8:14    Post subject: Reply with quote
Hey Markus,

you're not alone.

Yesterday i flashed mine to EKO 11482-newd-mega... After a movie i checked if the reboot had taken place.

Nothing, plugged out/in ... dimmed air-led that's all.

No restore function anymore. Did the pin9... nothing either.

This is my 2nd already. (actually 3rd after 128 MB upgrade failed).

My 2nd was successfully flashed but after setting my normal settings (no jffs or something) i rebooted ... brick, same situation as above.

Hope there's an afterlife..
DD-WRT Novice

Joined: 04 Feb 2009
Posts: 1

PostPosted: Wed Feb 04, 2009 22:50    Post subject: Reply with quote
Cheech wrote:
I thought I had brick my WL-500gP. After putting DD-WRT v2.4 on it, I tried to install modules for USB Support. When I've put my startup script and restarted my router, it become useless... nothing was working. However, I was in doubt that I bricked my router because my power led was on, and my WAN and LANs light were blinking. However, Wireless and DHCP was no longer working, when I assigned a static IP on my computer and tried telnet, tftp or web console, none were working.

I tried to reset my router has told in the wiki and none of the way worked. My router was useless...

Just before trying the pin 9 trick, I removed all the cables from the router (including the power cable), pressed the EZ Setup button and keeping it pressed while powering on my router. My power blink one time. Oh! so I connected the cables and everything was working. Great!!! I had to clear nvram and reflash dd-wrt so reboot could work in a normal way... Else, I had to press the EZ Button with no cable on the router... weird.

So now it's working fine and but I don't think i'll try again to install USB Support for DD-WRT. Anyway, I'm happy of not having to do the pin 9 trick...

Thank you! You solution worked perfectly. My problem occured when I updated firmware to 11536 (I probably did not apply 30/30/30 correctly...).

Anyway, symptoms:
- no ping
- no telnet
- no tftp
- power led on / power led slowly blinking

1. unplug all the cables
2. hold 'ez button'
3. plug power cable
4. wait a few secs
5. release 'ez button'

After that, router responded to ping and gui was available. I applied 30/30/30 and reflashed it with newest dd-wrt (11540).

Joined: 03 May 2007
Posts: 182

PostPosted: Wed Feb 11, 2009 17:08    Post subject: Re: please help Reply with quote
stormwolf wrote:
i have bricked Asus WL-500g (just g, doesnt say either deluxe or premium). it got bricked when i was messing around routing just froze up..i pulled the power and then turned it back on...and that was it. dead as a brick.
it doesnt answer ping requests on either nor 1.35 (that was last manual setting), and i cant force it into restore mode...the thing where you pull the power then hold reset and plug it back in. it just turns it on flashing. it doesnt start wireless either.
anyway, i ran out of ideas so i tried this pin shorting thing. in short, no luck.
my memory chip has a slightly different marking than stated here, i got a 29LV320ATTC-90 (not ABTC). so i tried messing with pins 12 and 10 million 12 just makes it reboot (??), pin 10 doesnt do anything. i tried that later mention technique to power off, and turn on with short on pin difference.

if anyone has ANY ideas i'd LOVE to hear from you. if someone can post me a link with a diagram or photos on JTAG cable for Asus i'd appreciate. any help really. thanx.

It is the similar process to retrieve the life of WL-500g (not deluxe or premium).
First; shortcut MX29LV320ATTC pin 12 to ground 10 sec (you will see 4 LAN lights are on, when pin12 connects ground).
Second; shortcut MX29LV320ATTC pin 10, you will see power light slow flash (it is in restore mode). then , you will see, you can PING, it means the life already comes back.
Third; using Asus firmware restore utility to load clear-ram.trx, after reboot (hold reset button while on power on), the router would in restore mode (power light slow flash) , using Asus firmware restore utility to install recover.trx file; when finish, reboot to restore mode again to install dd-wrt.trx to make it for dd-wrt router.


Joined: 28 Apr 2008
Posts: 53

PostPosted: Tue Feb 17, 2009 13:34    Post subject: Reply with quote
I successfully unbrick my WL-500W with this method. Thanks.

Joined: 08 Feb 2009
Posts: 88

PostPosted: Tue Feb 24, 2009 14:02    Post subject: Reply with quote
Does anyone know why this work?
You short pin 9 (address) of the flash chip, and what is this supposed to do? cause certain flash areas to be overwrite or what?
DD-WRT Novice

Joined: 23 Feb 2009
Posts: 9

PostPosted: Tue Feb 24, 2009 20:09    Post subject: Reply with quote
I have WL-500W

Method pin9 not work for me, LAN and WAN leds are ON an POWER and AIR are OFF....

The pc not recognize the port LAN.... no ping....

JTAG solution??
DD-WRT Novice

Joined: 25 Feb 2009
Posts: 3

PostPosted: Wed Feb 25, 2009 11:27    Post subject: same as markus.fuger Reply with quote
Hi there,

we have the same problem as markus.fuger... some ideas?

we have tryed out all the pins 9, 10, 16, 17 16/17 and nothing.


DD-WRT Novice

Joined: 28 Feb 2009
Posts: 1

PostPosted: Sat Feb 28, 2009 17:40    Post subject: Reply with quote
For WL-500g Deluxe, there's an easier and more reliable way to clear nvram suggested by Oleg: shorten GPIO7 pin on J1 connector to ground and power on.
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next Display posts from previous:    Page 6 of 10
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum