HowTo: unbrick a WL500g Deluxe and a WL500g Premium

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Author Message
DD-WRT Novice

Joined: 10 Jun 2008
Posts: 12

PostPosted: Thu Jul 03, 2008 2:20    Post subject: Reply with quote
The problem I've been having with both the Firmware Restoration Utility and the TFTP methods are after I put the router in the reset mode with the power light slowly blinking, the router cannot be pinged or seen via "ARP -a" in MS-DOS.

Any clue what's up with that problem?

Joined: 08 Mar 2008
Posts: 239
Location: Wayne, PA

PostPosted: Sat Jul 05, 2008 16:27    Post subject: Reply with quote
BravestIntent wrote:
The problem I've been having with both the Firmware Restoration Utility and the TFTP methods are after I put the router in the reset mode with the power light slowly blinking, the router cannot be pinged or seen via "ARP -a" in MS-DOS.

Any clue what's up with that problem?

Are you sure you've got your computer's IP set to (or something like that) and that your cable is plugged into the unit's LAN (not WAN) port?

If you've got the slow blink, that's good news.


~Netgear WNR834Bv2~ DD-WRT v24-sp2 (12/07/09) vpn-small (SVN revision 13401M NEWD Eko)

~Linksys WRT54Gv6~ DD-WRT v24-sp2 (10/10/09) micro (SVN revision 13064)

~ASUS WL-500G Premium~ DD-WRT v24-sp2 (12/07/09) big (SVN revision 13401M NEWD Eko)
DD-WRT Novice

Joined: 16 Jul 2008
Posts: 3

PostPosted: Wed Jul 16, 2008 14:04    Post subject: Reply with quote
I thought I had brick my WL-500gP. After putting DD-WRT v2.4 on it, I tried to install modules for USB Support. When I've put my startup script and restarted my router, it become useless... nothing was working. However, I was in doubt that I bricked my router because my power led was on, and my WAN and LANs light were blinking. However, Wireless and DHCP was no longer working, when I assigned a static IP on my computer and tried telnet, tftp or web console, none were working.

I tried to reset my router has told in the wiki and none of the way worked. My router was useless...

Just before trying the pin 9 trick, I removed all the cables from the router (including the power cable), pressed the EZ Setup button and keeping it pressed while powering on my router. My power blink one time. Oh! so I connected the cables and everything was working. Great!!! I had to clear nvram and reflash dd-wrt so reboot could work in a normal way... Else, I had to press the EZ Button with no cable on the router... weird.

So now it's working fine and but I don't think i'll try again to install USB Support for DD-WRT. Anyway, I'm happy of not having to do the pin 9 trick...
DD-WRT Novice

Joined: 29 Aug 2008
Posts: 1
Location: HI, USA

PostPosted: Fri Aug 29, 2008 10:06    Post subject: Responds to pings but nothing else Reply with quote
Been reading this forum after I bricked my WL-500W while performing the SP1 update.

I can ping the router at the 10.x.x.x addy I had set before, but I cannot restore via the Asus Firmware tool, nor can I ssh or telnet into the router (it times out; I had disabled telnet and opted for ssh in my config settings).

It appears to be in recovery mode, as the power light has a slow flash and the Asus tool detects it, but when it tries to restore a .bin, the % uploaded doesn't move beyond 0 and it says it fails (probably times out). At this point, the router become totally unresponsive, even to pings, unless I reset the reboot the router.

I have also tried to hold the EZ button, hoping it would force the default settings and perhaps permit telnet, but I've not been able to get it to work.

I tried to short the pin 9 and 16/17 with a paper clip, which admittedly might not be the best tool, but the only one I could find at the time, but it doesn't seem to have any effect. I'm not sure how to tell if it's been shorted, but I would guess the settings would all be gone and it wouldn't be using the 10.x.x.x addy anymore, right? Regarding wires, should I buy a small-gauge wire from a hardware store, or what is most effective?

Thank you for your assistance.
DD-WRT Novice

Joined: 06 Sep 2008
Posts: 1

PostPosted: Sat Sep 06, 2008 1:55    Post subject: Bricked Router Reply with quote
I've tried to use DDWRT 24SP1 on a ASUSWL500Gp mounting jffs and bricked router.

I've tried the pin 9 and got ping running but after a new firmware update i don't even have the power light on.

What can I do to recover from this?
Is there any solution besides putting it into garbage?

DD-WRT Novice

Joined: 25 Sep 2008
Posts: 48

PostPosted: Thu Sep 25, 2008 19:49    Post subject: Reply with quote
I unbricked my WL500W with the pin 9 trick. Prior to doing it i tried every other way to unbrick it. it wouldn't respond to pings, wouldn't let me get into it in any ways. And the weird thing was just applying a setting (enabling SSH) and clicking reboot from the GUI bricked it. Prior to that, it worked fine with DD-WRT.

I also looked up the datasheet for the flash chip. And not sure why shorting pin 9 actually works, since it is just a address line... but in anyway, it worked for me. Afterwards i was able to reflash the firmware w/ asus tool.

btw, you don't need much else then a paperclip to the RF Shield enclosure. It ohms out perfectly to ground.
DD-WRT Novice

Joined: 06 Oct 2008
Posts: 4

PostPosted: Mon Oct 06, 2008 2:45    Post subject: Reply with quote
Subtil wrote:

My wl500gP is froze up. The pb appear when switch ON / OFF 3 or 4 times and after reset button.
My router is bricked

I tried the method with the short circuit bridge successively on pin 9 / 10 / 12 to ground but without success.

My router stay with light ON :
The LEDs : LAN "1-2-3-4" & WAN are LIGHT ON ( Not flashing )
The LED power is OFF.

The previous action they nothing changed.

The router is really bricked (dead) or the JTAG method is possible ?

Thanks a lot.

Did you ever get this solved. Mine just died the same way.

DD-WRT Novice

Joined: 09 Oct 2008
Posts: 1

PostPosted: Thu Oct 09, 2008 12:02    Post subject: Reply with quote
I have also successfully unbricked my WL500W with pin-9 method Smile
Though there is a weird change - the jffs partition is now 1MB of size. I suppose previously it was ~6MB. Has anyone experienced such thing? Knows anybody what to do to get back all built-in flash amount?
DD-WRT Novice

Joined: 16 Oct 2008
Posts: 2

PostPosted: Thu Oct 16, 2008 13:59    Post subject: Bricked WL-500W Reply with quote
I have an Asus WL-500W that I was trying to install DD-WRT on, but ran into an issue. I've read the forum and search for answers and tried all the methods (expect the pin 9 short) with no results.

Issue: I followed the install instructions on the DD-WRT website for my router. Everything went fine and I flashed the mini DD-WRT to my router. I used that to flash v24 mega to it. After reboot, I can no longer connect to the router. It only responds to pings for a few seconds if I hold the restore button while powering on. However, I can't stay connected long enough to flash the firmware again.

Any suggestions? I would prefer not to open the router.

Thank you. -Joe
DD-WRT Novice

Joined: 16 Feb 2008
Posts: 16

PostPosted: Mon Oct 20, 2008 13:54    Post subject: Reply with quote
I tried the pin-9 method to unbrick my WL-500W. The good news is that it now responds to a ping while in recovery mode and will accept tftp. However, tftp is very slow and pauses for a second every so often during the transfer. Sometimes I cannot even upload the whole file, the router replies to one of the tftp packets with "transfer canceled" and instantly reboot. Even when it does take the whole file it doesn't boot properly.

One time it actually booted the asus mini trx, I could see a dd-wrt wireless ap, pings were responding with 64ttl, but couldn't get the web interface to come up. You can connect on port 80 but as soon as you send a byte, the connection would reset.

I'm thinking I've fried part of the flash or something and bits of it are bad or unstable now.
DD-WRT Novice

Joined: 01 Nov 2008
Posts: 1

PostPosted: Sat Nov 01, 2008 20:20    Post subject: Asus WL500G Premium V2 Reply with quote
I recently bought this wonderful router. Unfortunately after following the procedure "Use the full 32MB ram on the WL500gP use the following commands via telnet".
WL500GP V2 has Broadcom chip BCM5354KFBG.

Of course I must have missed something or made some mistake. The router seemed to be dead after it. I left it there, then unplugged the power and plugged it again. Now all LAN and WAN leds are on, all the others are off.

I was wondering whether the unbrick procedure described in this post may be working or not... or if there are any other methods that I can try. I am posting an image of the router.

 Filesize:  195.26 KB
 Viewed:  37919 Time(s)


DD-WRT Novice

Joined: 14 Dec 2007
Posts: 12

PostPosted: Fri Nov 07, 2008 1:15    Post subject: Reply with quote
Today i bricked mine router and this topic saved me trouble of buying another one Wink
Lets start with what happened maybe this will allow you to find a bug or tell me how stupid thing i've done Razz
1. I did set ssh to run on 443
2. I did connect remotely from work to check if it is working with proxy/firewall we have there
It did work so i added tunnel to my home pc(putty settings).
3. Next day I added firewall rule to allow only proxy host to connect to that port
iptables -I FORWARD 1 -p tcp -d --dport 443 -j ACCEPT
iptables -I FORWARD 2 -p tcp --dport 443 -j DROP
4. then I listed iptables with
iptables -L INPUT(-n -nv as well)
and i noticed two hosts from germany
i knew also that my pc is switched off
5. I deleted rule for those german hosts Razz
iptables -L INPUT --line-numbers
iptables -D INPUT x
iptables -D INPUT y
6. I did some netstat before deletion of those rules and the same after pt.5
7. netsat and other network connected commands started to work alot slower with a big choke at start

Around 5/7 i deleted the rule for 443 as well

when I arrived home i wasnt able to connect with router nor internet Razz
router was unavailable in any mode/ip (router had and pcs started over 200 before my actions)
this not so safe and easy method unbricked my router
avalanche post from 2nd page of this topic helped alot though

some pictures below
DD-WRT Novice

Joined: 25 Sep 2008
Posts: 48

PostPosted: Fri Nov 07, 2008 16:12    Post subject: Reply with quote
Yesterday I got my 2nd WL-500W, and had no issues with it bricking. And I flashed it about 3 times w/o issue.

Things I made sure to do:

1. before flashing, restore factory defaults (for both asus firmware, and dd-wrt).

2. Then I used asus firware recovery tool (making sure to disable all other network connections on the pc I am using to flash).

3. after flash, if router is alert (can get into, then I did restore factory defaults again. It it wasn't alert, power cycle it, and then restore factory defaults.

I flashed my new WL500w at least 3 times, trying the current release build, and the latest beta. I also flashed my first WL500w to the lasted beta, and had no issues with that router either, as long as I used restore factory defaults before and after flashing.

Dunno if this is the step people are not doing, which causes bricks, but if your not doing it, i'd suggest you do.
DD-WRT Novice

Joined: 14 Dec 2007
Posts: 12

PostPosted: Fri Nov 07, 2008 16:48    Post subject: Reply with quote
restore didn't work for me
did around 3h attempts with different settings and so on before i used this method
none of them helped
DD-WRT Novice

Joined: 12 Nov 2008
Posts: 1

PostPosted: Wed Nov 12, 2008 23:18    Post subject: Confirming Unbricking WL-500W via pin9 Reply with quote
I have also successfully unbricked my WL-500W with shorting pin9 to earth.

PCB-Version is WL-500WR1d11

Thanks guys!
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next Display posts from previous:    Page 5 of 10
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum