HowTo: unbrick a WL500g Deluxe and a WL500g Premium

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Author Message
DD-WRT Novice

Joined: 16 Aug 2006
Posts: 17

PostPosted: Wed Mar 07, 2007 10:02    Post subject: Reply with quote
no my man, JTAG and this "shorting" cable are not the same thing.
yes, you need a piece of wire that you connect to the DC ground of the router on one end, and with other end you poke at pin 9 at the flash chip. (i recommend puting a sowing needle at the end of the wire thats supposed to touch the pin, for accuracy)
DD-WRT Novice

Joined: 07 Mar 2007
Posts: 2

PostPosted: Wed Mar 07, 2007 19:46    Post subject: Reply with quote
I can use the blue or green feature, but not both
but which is simplest?

foot-note: to use is the blue or green way
thank you !
DD-WRT Novice

Joined: 26 Oct 2006
Posts: 3

PostPosted: Tue Apr 03, 2007 18:40    Post subject: Reply with quote

I have just managed to unbrick my WL-500g Premium using this guide! Great thanks!!

How I did it was: unscrew, open shielding, use a wire and a needle, short circuit pin 9 with cover of the power plug, then plug in the power. Wait till the power led goes off (boot finished), remove power plug.

Voilá Smile
DD-WRT Novice

Joined: 11 Apr 2007
Posts: 1

PostPosted: Wed Apr 11, 2007 17:51    Post subject: WORK FOR ME TO!!!!!!!!!!!!!!!!!!! Reply with quote
Situation :
WL-500gP with dd-wrt V23 SP2 and JFFS enable. When I save a modification, some time the ASUS Break, and in restore mode : no ping, no boot....

I stop the Asus, unplug the connector, open the box, use a wire and a needle, short circuit pin 9 with cover of the power plug, plug in the power, wait till the power led goes off "AND" air led goes on. Then I remove power plug, use Asus Restore Util. Ping OK restore OK.

dd-wrt is unstable on Asus Wl-500gP with JFFS enable, now i use Oleg, it's powerfull a lot off programs, ssh, apache, ftp, torrent, samba, usb, printer, webcam.... AND very stable

Thanks to this forum... The Pin trics is FUNNNNNNNNY

Joined: 16 Jun 2006
Posts: 133
Location: Kolding, Denmark

PostPosted: Mon Jul 02, 2007 16:51    Post subject: Reply with quote
I've two pieces of Wl500gP - A couple of times before I've had success debricking grounding pin9. This time I upgraded the firmware, restored factory defaults and tried to restore backup'ed settings.
Both routers went dead and the one I got back in business using pin9 trick.
The other one is still troubleing me, descriped below.

The router is able to enter recoverymode holding down restore button. Then the router is pingable, but uploading firmware with the restoraion tool or TFTP is really slow and always times out.

Then I've tried grounding pin 10 or 16/17. The last two makes the router enter recovery modus and then speeds are great and the router accepts a new firmware. Tried several different builds, both dd-wrt and olegs firmware. When TFTPing the router never gets back in business, but using restoration tool the router always boot, but only until poweroff or reboot. So until changing settings etc. the router is accessible trough http/telnet and wireless is working.

Is my bootloader broken? - Is there a way on cleaning everything? - I've tried olegs files
wl500g-clear-nvram.trx and wl500g-recover.trx and from telnet "mtd erase nvram" - But the router only is accessible right after flashing from restoration tool and only until it's rebooted.

Really weird. Anyone knows how to solve this. I'll trt attaching a serial cable for further diagnosing, but I have to build the cable first.

Joined: 16 Jun 2006
Posts: 133
Location: Kolding, Denmark

PostPosted: Thu Jul 05, 2007 19:14    Post subject: Reply with quote
After getting no help here or at other forums, I'll post my solution as I managed to get my router back... And still I got no serial console. But I'll definetly have to get myself a working one.

I've seen lots of places mentioning not to short any pins, but I think it work in many cases and actually it's quite easy with a wire and a needle. Shortening pins is also a part of my solution to get my Wl500gP back in business.

To resume: - did not help
wl500g-clear-nvram.trx - did not help
wl500g-recover.trx - did not help

Flashing from recovery mode always timed out, and never made the router work.
Flashing from recovery mode after shorting pin 16/17 with gnd always was a success with every firmware, but only until reboot. Tried to clean nvram with "mtd erase nvram" or "" before rebooting without success. Ended up doing like this


1 ) power off
2 ) short pin 16 with GND and power on until power-LED started flashing
3 ) removed the shorting of pin 16
4 ) flashed with dd-wrt
5 ) after router alive, telnet and logged in
6 ) ran "mtd erase nvram"
7 ) ran "mtd erase linux"
8 ) reboot
9 ) router started up in recovery mode
10 ) flashed with olegs firmware (or other firmware), and uploading speed wasn't slow anymore - after reboot the router was alive and kicking, also after poweroff.

Dunno if the above mentioned method will help someone out there, but maybe someday.
DD-WRT Novice

Joined: 31 Aug 2006
Posts: 22
Location: Poland

PostPosted: Mon Jul 16, 2007 12:34    Post subject: Reply with quote
On Friday I bought second wl500gP. Something went wrong (I have been flashing dozen times my first 500gP) and now I my new second Asus is like a brick. I have tried every trick (recovery mode, pin short, I have not try jtag but I don't have time). Router is dead (Wan and LAN blinks when I plug RJ45 cable, no answer from router). I have managed disassemble It without breaking warranty seal.

Now question: Can I make some kind of short circuit to damage router that warranty service wont be able find out that i have been messing with on board flash and third part firmware (to look like manufacture defect). I have been talking with man from shop and he said that if Asus warranty service will figure out my bad i have to pay for service check and optionally for repairing.

Thx in advance
DD-WRT Novice

Joined: 15 Aug 2007
Posts: 1

PostPosted: Thu Aug 16, 2007 3:34    Post subject: Reply with quote

I just upgrade my WL-500g Premium with dd-wrt v23 sp2 firmware.
The Wireless Router function can work normally.

But the "Power" LED is off meanwhile "Air" , "WAN" and "LAN" LEDs is on normally.
Does anyone have face this problem before ?

Any advise or solution to solve it ?
Thank you .
DD-WRT Novice

Joined: 19 Aug 2007
Posts: 2

PostPosted: Sun Aug 19, 2007 2:44    Post subject: Reply with quote

My Asus WL-500G Premium upgraded to dd-wrt v23 sp2 behaves just the same as yours.

The power light is actually on for several seconds during the power up sequence. I think from what I have read on these forums that this is the period when the bootloader is in operation.

I assume this is normal operation, but it would be good to have the power light operate normally.


Joined: 16 Jun 2006
Posts: 133
Location: Kolding, Denmark

PostPosted: Mon Aug 20, 2007 11:19    Post subject: Reply with quote

use latest V24 or V23SP3 and your lights will behave as expected.
DD-WRT Novice

Joined: 04 Sep 2007
Posts: 28

PostPosted: Thu Sep 06, 2007 1:16    Post subject: Reply with quote
When changing some setting on my router - Wl-500G original, it got bricked..

I tried to force into recovery mode, no now I only have short circuit way-out.

Couple of questions:

1. User stormwolfe posted a reply stating that the pinout for the wl-500g is, indeed, different from 500gP or deluxe. Which pins should I short circuit on my device then (ATBC vs ATTC).

2. I only have PWR light on, the rest is off. Ping not working, reset to factory defaults neither..only static IP works. Is it really bricked?

Thanks for your time Smile
DD-WRT Novice

Joined: 04 Sep 2007
Posts: 28

PostPosted: Thu Sep 06, 2007 1:21    Post subject: Reply with quote
I just found ATTC datasheet, and it says there that pin 12 is active at low (GND), which is the RESET pin. Could this be it?
DD-WRT Novice

Joined: 04 Sep 2007
Posts: 28

PostPosted: Fri Sep 07, 2007 0:45    Post subject: Reply with quote
I just fixed my 500g by short circuiting pin 12 (Reset) and then pin 10 (Recovery mode)... Smile
DD-WRT Novice

Joined: 13 Sep 2007
Posts: 3

PostPosted: Thu Sep 13, 2007 4:07    Post subject: Router is dead Reply with quote
I tried to upload firmware by TFTP
but I reset the Router (WL500gP) too early.

The Router Power LED is now OFF only the LAN ports seem to be active.

How to recover ? In this case, is it possible to recover by using 'Short pin 9 method' ? Please suggest.

Thank you.

Joined: 11 Jun 2006
Posts: 162
Location: DE

PostPosted: Fri Sep 21, 2007 22:59    Post subject: Reply with quote
yeah.. i unbricked my Asus WL500w with pin 9 method...
btw. the wl500w has the same PCB layout as the wl500gP nice.. thanx guys


no support via PN
my equipment
  • WRT54G
  • Cisco Catalyst WS-2950C-24
  • Cisco 1841 ISR@384MB RAM/128MB Flash
  • HP Procurve 2524 & 2512
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next Display posts from previous:    Page 2 of 10
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum