HowTo: unbrick a WL500g Deluxe and a WL500g Premium

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Author Message

Joined: 20 Jul 2006
Posts: 88
Location: Dresden

PostPosted: Wed Aug 02, 2006 13:36    Post subject: HowTo: unbrick a WL500g Deluxe and a WL500g Premium Reply with quote
If you can't ping you unit or you can't access the unit via telnet or the unit is simply confused then you can unbrick the devices by following the instruction below:

WL500g Deluxe:
* open the case (screws are under the rubbers) (guarantee lost)
* turn on the router
* on the flash memory (29LV320ABTC-90) short circuit PIN 12 often (several seconds) to ground
* on the flash memory (29LV320ABTC-90) short circuit PIN 10 often (very short) to ground
* turn off your unit
* wait 10 seconds
* turn the WL500gP on by holding the reset button
* now, you can flash again via the ASUS-Recovery-Tool

WL500g Premium:
* open the case (screws are under the rubbers) (guarantee lost)
* remove the cover inside with a little screwdriver
* short PIN 9 or the marked solder point to ground (e.g. to the outside of the power connector) with a cable and a needle.
* turn the WL500gP on for approx 15 seconds.
* turn the WL500gP off
* remove the short circuit bridge
* turn the WL500gP on by holding the reset button
* now, you can flash again via the ASUS-Recovery-Tool

To use the full 32MB ram on the WL500gP use the following commands via telnet:
nvram set sdram_init=0x0009
nvram set sdram_ncdl=0
nvram commit

Good luck!

Hardware-Recover WL500gP.jpg
WL500g Premium
 Filesize:  253.75 KB
 Viewed:  239387 Time(s)

Hardware-Recover WL500gP.jpg

Hardware-Recover WL500gx.JPG
WL500g Deluxe
 Filesize:  270.38 KB
 Viewed:  239384 Time(s)

Hardware-Recover WL500gx.JPG

Last edited by rj.2001 on Fri Nov 16, 2007 10:56; edited 1 time in total

Joined: 01 Jan 1970

PostPosted: Fri Aug 11, 2006 9:18    Post subject: Reply with quote
Bah, stop this pin shorting crap. If you short the wrong pins you fully destroyed your router.

rj.2001 wrote:
Good luck!


Joined: 20 Jul 2006
Posts: 88
Location: Dresden

PostPosted: Fri Sep 01, 2006 4:01    Post subject: Reply with quote
here is a extra large pic.
To ground Pin 9, you can use the green or blue way....

 Filesize:  442.03 KB
 Viewed:  238268 Time(s)


DD-WRT Novice

Joined: 09 Sep 2006
Posts: 4
Location: Fairbanks, AK

PostPosted: Tue Sep 26, 2006 2:19    Post subject: Reply with quote
Using a WL-500G Premium

Just to report, this worked for me, with one modification. Read on...

The steps that bricked my router were these:

Enable the JFFS2 via the web interface
Disable JFFS2 via web interface (since nothing showed up in the console)
Try to login via ssh (it appears I might have hit it during reboot)

Couldn't reboot, couldn't successfully enter recovery mode (even though the power light was flashing slowly), nothing.

So, I tried it. The first couple times, it didn't help. Then, I held it on the pin for about 15 seconds, and then the power light went off (showing that the dd-wrt firmware had booted). Instead of unplugging it, I plugged in my ethernet cable, and was able to get an IP and view the web console. All has been fine since.

DD-WRT Novice

Joined: 26 Sep 2006
Posts: 1

PostPosted: Tue Sep 26, 2006 10:56    Post subject: Asus WL-500g Deluxe unbricked? Reply with quote
Hi All,

I accidentally applied the use all 32MB nvram settings to my WL-500g Deluxe (instead of Premium) - in my defense I was not feeling well and not paying attention to what I was doing Confused

Now my unit is a brick... I've tried all the standard rest button combinations and nothing seems to get it back - wireless is not responding and can't get to the default IP ( - the only thing that will work is if I manually assign IPs to a couple of pcs and get them to talk to each other (no routing just standard switch).

My next option is to use the unbrick pin method, but I just want to make sure this works - the instructions are a little vague for the deluxe - what does "often" mean i.e. do I have to short pin 12 multiple times first and then pin 10 multiple times ?

Has anyone actually done this and got it to work ?

Any assistance would be appreciated...

DD-WRT Novice

Joined: 09 Jun 2006
Posts: 4

PostPosted: Wed Nov 01, 2006 19:26    Post subject: Reply with quote
Doing something like that without even knowing what's wrong with the device is
Yes, I know there are some cases, where this can be useful. But that's only in very few cases.

Last edited by nbd on Wed Nov 01, 2006 22:08; edited 1 time in total
Site Admin

Joined: 06 Jun 2006
Posts: 7516
Location: Dresden, Germany

PostPosted: Wed Nov 01, 2006 19:32    Post subject: Reply with quote
the ping trick works on the asus as well but the pin is different
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann

Joined: 16 Jun 2006
Posts: 133
Location: Kolding, Denmark

PostPosted: Sat Nov 18, 2006 18:49    Post subject: Reply with quote
shortening pin 9 with ground on a wl500gP also worked for me. I was shortening the pins, turned the router on, removed the shortening after the power LED went out.

But I wasn't able to get an IP from any of the ethernetports, or access the router with a client with af static IP, only the wireless seemed to let me access my router. Was able to reset the router from the webinterface and that seemed to work.

Playing around with JFFS in the web interface was also what made my wl500gP brick.
DD-WRT Novice

Joined: 17 Jun 2006
Posts: 13

PostPosted: Sun Nov 19, 2006 16:55    Post subject: HowTo: unbrick a WL500g Deluxe and a WL500g Premium Reply with quote
Hi all,

Trying around with USB, I managed that the wl500gx was only usable as transparent Hub.
The only flashing Leds where the Links-Leds, if connected. No WAN-Led, No Power-Led.

After a very long weekend trying to debrick wl500gx aka 500g deluxe, there was only ONE way to rescue the Unit:

Long shortening Pin 12 and impulses on pin 10 did not work. (Done x-times)
Shortening Pin 9 on Power did work halfways.

Short Pin 10! during Power-on until Power-Led goes off. (Switching Power with Toe on Powerbar;-) , then the Router is in rescue mode, with blinking power-led.
Then You have to wait, until Your PC has his "Zeroconfig-Address"

Running wireshark the whole time will help to understand how the Rescue-Tool works at Layer2.

Use the ASUS-Tool wit oleg's wl500g-clear-nvram.trx and then restore.trx
At last the wanted firmware.
Back in Business..
DD-WRT Novice

Joined: 19 Nov 2006
Posts: 1

PostPosted: Sun Nov 19, 2006 21:46    Post subject: Reply with quote
Heeeeeey guys, shorting pins to GND or to each other is VERY inefficient. It lowers the voltage of the flash chip. If you want to do it right, you have to grab voltage directly from where the power supply is connected to the board and connect it to the pins.
This doesn't even have to be as precise as the other method. You can just connect any pin most of the time. If that doesn't work, simply go through *ALL* pins and connect them...
Works all the time. If not, try getting a Linksys power supply instead of the Asus one, because it has higher power!
DD-WRT Novice

Joined: 11 Oct 2006
Posts: 29
Location: Cambridge, UK

PostPosted: Thu Nov 23, 2006 4:58    Post subject: Reply with quote
Worked for me. Smile

My WRT54Gv2 @ 300MHz, DD-WRT v24 RC3 .
DD-WRT Novice

Joined: 16 Aug 2006
Posts: 17

PostPosted: Tue Nov 28, 2006 17:42    Post subject: please help Reply with quote
i have bricked Asus WL-500g (just g, doesnt say either deluxe or premium). it got bricked when i was messing around routing just froze up..i pulled the power and then turned it back on...and that was it. dead as a brick.
it doesnt answer ping requests on either nor 1.35 (that was last manual setting), and i cant force it into restore mode...the thing where you pull the power then hold reset and plug it back in. it just turns it on flashing. it doesnt start wireless either.
anyway, i ran out of ideas so i tried this pin shorting thing. in short, no luck.
my memory chip has a slightly different marking than stated here, i got a 29LV320ATTC-90 (not ABTC). so i tried messing with pins 12 and 10 million 12 just makes it reboot (??), pin 10 doesnt do anything. i tried that later mention technique to power off, and turn on with short on pin difference.

if anyone has ANY ideas i'd LOVE to hear from you. if someone can post me a link with a diagram or photos on JTAG cable for Asus i'd appreciate. any help really. thanx.
DD-WRT Novice

Joined: 16 Aug 2006
Posts: 17

PostPosted: Wed Nov 29, 2006 0:29    Post subject: small addition Reply with quote
seems like everything i have here is non-standard $%#@%#
what do i got is: a 20 pin jumper-type connector (that has to be what i'm looking for, just need the correct pin layout, and the processor is BCM4702KPB.
does anyone know what pin is what on that jumper connector? i cant find anything that matches this exactly. all i get is stuff for Linksys routers that have less pins. thanx.
DD-WRT Novice

Joined: 27 Oct 2006
Posts: 10

PostPosted: Thu Jan 04, 2007 15:02    Post subject: Reply with quote
The pin 9 tricked worked for me but I think there is a problem.
The reason I had to do this was a very unresponsive router. It just quite responding one day. After shorting pin 9, I uploaded wl500g-clear-nvram.trx and then restore.trx with the asus windows utility. Then installed the latest asus firmware, version The wired part worked fine. With the wireless, I could see the AP but could not connect with multiple wireless laptops. I flashed with open-wrt, same problem, Flashed with DD-wrt standard and got wireless functionality back. I was afraid I fried the wireless card. Even before this happened, the wireless would stop working very intermittently. The only way to get wireless working again was to restore factory defaults. This was with the VPN version 23 SP2. Seems to happen more often if I change the SSID from the default DD-WRT
One last point, When ever I flash DD-wrt, standard or VPN, it flips out my DSL modem. The modem says it has sync, but no IP address ( I have to leave everything unplugged for several hours before I can get a IP address. Even with my old but stable netgear router. I'll be unplugging the modem before flashing in the future.

My questions are:
Does anyone else have the wireless just quit working even though the wifi light is on?

Does anyone else have problems with getting a IP from DSL after flashing with DD-wrt?

Does anyone think this is a flakey and unstable router?

Sorry for the long post.

1 bottle of beer....
We all have to start with 1 some time
DD-WRT Novice

Joined: 07 Mar 2007
Posts: 2

PostPosted: Wed Mar 07, 2007 8:57    Post subject: Reply with quote
scuse me, i'm french and i don't understand for wl500gp with a pin 9 (or jtag pin) to DC conector. i have need a cable between pin 9 and DC conector ?

but pin 9 = pin jtag ?

thank you, and scuse me for my english !
Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next Display posts from previous:    Page 1 of 10
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum