TP-LINK TL-WDR3600 HDD sharing, OPTWARE, DLNA, Torrent

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... 26, 27, 28, 29, 30  Next
Author Message
petoniano
DD-WRT Novice


Joined: 09 Aug 2011
Posts: 31

PostPosted: Sun Jun 19, 2016 20:48    Post subject: Reply with quote
marcowbecker wrote:
After I run the command:

Quote:
cat > /etc/opkg.conf << EOF
src/gz packages http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages
src/gz base http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/base
dest root /opt
dest ram /opt/tmp
lists_dir ext /opt/tmp/var/opkg-lists
EOF


my putty lines start with ">" and I don't receive the "downloadings" reports mentioned in the tutorial.

I tried to paste the code below to see if the download starts, but no!

Quote:
umount /jffs
mount -o bind /tmp/mnt/sda2/opt /opt
mount -o bind /tmp/mnt/sda2/root /tmp/root
export LD_LIBRARY_PATH='/opt/lib:/opt/usr/lib:/lib:/usr/lib'
opkg update


Am I doing something wrong? I'm just following line by line here and freezed after the "cat >"

I tried with different repositories, but seems like is something I"m messing up in putty.


Have you tryed to copy each line 1 by 1, and don´t copy the last space
specially after EOF (don´t write EOF_ where _ is a space)
after EOF you should see the full path again not only the >

(I´m not an expert just trying to help)
Sponsor
msantos2007
DD-WRT User


Joined: 13 Oct 2009
Posts: 245

PostPosted: Mon Jun 20, 2016 11:14    Post subject: Reply with quote
Hi dupotter and petoniano,

dupotter,

On Step 1.1, the command "mount -o bind /tmp/mnt/sda2/etc /etc" should be issued to ensure /etc being writable. Please just make sure your partitions were mapped as /sda1 and /sda2, using DF command or checking from your browser http://your_router_ip/USB.asp. If not, you'll have to modify the script accordingly, because you have a different router and DD-WRT may have assigned the partitions in a different way too.

I think "chmod 755 /etc" won't work on NTFS.

If it were the case, it would be nice starting a topic, based on this tutorial, specific for TP-Link Archer C7, placing your modified script.



petoniano,

I have just tested the script, as is, and it worked fine. Please start over, entering line by line.
petoniano
DD-WRT Novice


Joined: 09 Aug 2011
Posts: 31

PostPosted: Tue Jun 21, 2016 11:13    Post subject: Reply with quote
thank you very much msantos2007

worked perfect for me, excelent tutorial.

When installing transmission, there is no transmission-daemon in the repository, it should be opkg install transmission-daemon-openssl

Thank you again!!
msantos2007
DD-WRT User


Joined: 13 Oct 2009
Posts: 245

PostPosted: Tue Jun 21, 2016 22:51    Post subject: Reply with quote
Petoniano,

That's the problem with Snapshot repo: it's ephemeral.

Correction made.

Thank YOU for your feedback.
Rubenos
DD-WRT Novice


Joined: 06 May 2015
Posts: 18

PostPosted: Tue Jun 28, 2016 11:27    Post subject: Reply with quote
msantos, I found a tutorial for a Western Digital NAS, which uses PHP as an RSS reading tool (script), but I can't seem to get PHP installed/working on my config. If I Google 'install php on dd-wrt', I only get pages with the .php extension (ofcourse). You are such a legend with this whole tutorial, maybe you could shine a light on it?

https://community.wd.com/t/rss-auto-downloading-with-transmission-without-flexget-tested-on-v4/95000
msantos2007
DD-WRT User


Joined: 13 Oct 2009
Posts: 245

PostPosted: Tue Jun 28, 2016 16:48    Post subject: Reply with quote
LOL.

As I mentioned before, I didn't create this tutorial but I've polished it.

I also didn't find a PHP Optware package yet, but I also found it interesting and I'll keep searching.

I think we should try to install Lighttpd because it supports PHP: https://www.dd-wrt.com/wiki/index.php/WEB_server

What about starting a new thread asking about it? Then, we can start an additional tutorial just for it.

Best Wishes,
Marcelo.
Rubenos
DD-WRT Novice


Joined: 06 May 2015
Posts: 18

PostPosted: Wed Jun 29, 2016 11:40    Post subject: Reply with quote
Sorry about that! I'll give it a go!
creited
DD-WRT Novice


Joined: 26 Jun 2016
Posts: 15

PostPosted: Wed Jul 20, 2016 19:01    Post subject: Reply with quote
Hi Marcelo.

Have you tried to use MiniDLNA over the internet with pptp VPN between two DD-WRT boxes?

I'm not sure, but DLNA uses Multicast, which will not be routed through PPTP VPN.

Do you have any advice? Maybe EoIP or something similar...
msantos2007
DD-WRT User


Joined: 13 Oct 2009
Posts: 245

PostPosted: Thu Jul 21, 2016 0:14    Post subject: Reply with quote
That's a great question!

You're right it won't work, I've tried many things...

Here it is my workaround:

- Get NAS set up with user and password, on server router;
- Get [Administration/Management/CIFS Automount] enabled, on client router;
- Run a "not elegant" command to assign (or map) "/mnt/sda1/dlna/Videos" directory, every boot, on client router; Shocked
- Change MiniDLNA configuration file to read the shared directory [/mnt/smbshare], on client router.


That can be accomplished fine, but...

- MiniDLNA won't detect new media. You have to issue a -R command (rebuild MiniDLNA database) for new media, because Inotify won't work under CIFS; Crying or Very sad
- 2GB movies may not run properly due to VPN bandwidth (tested: 20Mbps upload on server and 10Mbps download on client).


Here they are both Startup Command and MiniDLNA configuration mods:

- mount.cifs //<server_IP>/<NAS_DIRECTORY>/dlna/Videos /tmp/mnt/smbshare -o username=<NAS>,password=<NAS> Wink
- media_dir=V,/mnt/smbshare/


I hope someone has a better idea.

Thx,
Marcelo.
rahupanchal11
DD-WRT Novice


Joined: 17 Jan 2016
Posts: 19

PostPosted: Wed Aug 03, 2016 15:33    Post subject: Reply with quote
will this work for Cisco wrt160NL ? Please i need help, want to install transmission on it, I am a noob Razz
msantos2007
DD-WRT User


Joined: 13 Oct 2009
Posts: 245

PostPosted: Wed Aug 03, 2016 16:27    Post subject: Reply with quote
Please try it. It won't hurt, you'll just have to format your flashdrive if it didn't work. It won't mess with your NVRAM at all, except the Startup commands you'll have to save. Wink
rahupanchal11
DD-WRT Novice


Joined: 17 Jan 2016
Posts: 19

PostPosted: Thu Aug 04, 2016 6:08    Post subject: Reply with quote
i am stuck here,
cp -a /lib/* /tmp/mnt/sda1/lib/
doesn't execute, it just stuck there for hours
couldn't transfer functions.sh also
please help
what am i doing wrong ?
i am on build 28976
tried to upgrade to 29739 but bricked my router


Last edited by rahupanchal11 on Thu Aug 04, 2016 15:51; edited 1 time in total
msantos2007
DD-WRT User


Joined: 13 Oct 2009
Posts: 245

PostPosted: Thu Aug 04, 2016 15:25    Post subject: Reply with quote
Please don't change your firmware yet.

/lib has to be mounted before copying "functions.sh". You didn't get that yet.

You need to figure it out whether /lib exists or your router has the same directories structure as WDR3600.

You've stopped copying /lib at some point. You could check if some files were actually copied to your drive.

With a flashdrive, /lib should be copied in 10-15 minutes, while With a HDD it takes only 3-5 minutes, if I can remember.

Please remove those screenshots when you're done. They are too big.

Thx.
rahupanchal11
DD-WRT Novice


Joined: 17 Jan 2016
Posts: 19

PostPosted: Fri Aug 05, 2016 12:07    Post subject: installed Optware sucessfully but problem in installing Tran Reply with quote
So finally a breakthrough Very Happy
successfully installed optware, but can't install transmission,
instep 1.3 you said to restart the router, but when i restart the router, i don't get a colorful prompt.
also can't update opkg, says -sh : opkg not found ?
so i decided not to restart it and install directly, which one should i install: snapshot repository or the other repository ?
i tried other repository but router kinda bricked (power led kept blinking, no other led were on, and pd led also stopped working)
will try to install snapshot one now from the start

i'll remove the attachment after your reply Wink
rahupanchal11
DD-WRT Novice


Joined: 17 Jan 2016
Posts: 19

PostPosted: Fri Aug 05, 2016 12:36    Post subject: tried opkg install transmission-daemon-openssl too Reply with quote
nope, no luck Sad its just stuck there, its been 35 mins.... please help
gonna buy a better router in few months, fuck this cheap ass router Evil or Very Mad
Goto page Previous  1, 2, 3 ... 26, 27, 28, 29, 30  Next Display posts from previous:    Page 27 of 30
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum