WR1043 und OpenVPN CLIENT Mode

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC basierende Hardware
Author Message
xbox180
DD-WRT Novice


Joined: 09 Apr 2012
Posts: 44

PostPosted: Sat Oct 05, 2013 16:03    Post subject: WR1043 und OpenVPN CLIENT Mode Reply with quote
Hallo zusammen,
ich versuche (bisher über telnet) eine openvpn Verbindung vom Router zu CyberghostVPN einzurichten. die Zertifikate liegen auf einem USB-Stick. Von der Konsole aus führe ich folgenden Befehl aus:

Code:

openvpn --config /mnt/sda_part1/cg/client.ovpn


Dann gebe ich meine Zugangsdaten ein und der Router versucht sich zu verbinden...

Code:

root@DD-WRT:/tmp/mnt/sda_part1# openvpn --config /mnt/sda_part1/cg/client.ovpn
Sat Oct  5 17:47:35 2013 OpenVPN 2.3.0 mips-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Mar 25 2013
Enter Auth Username:xxx
Enter Auth Password:
Sat Oct  5 17:47:49 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Sat Oct  5 17:47:49 2013 WARNING: file '/mnt/sda_part1/cg/xxx.key' is group or others accessible
Sat Oct  5 17:47:49 2013 UDPv4 link local: [undef]
Sat Oct  5 17:47:49 2013 UDPv4 link remote: [AF_INET]79.141.167.28:9081
Sat Oct  5 17:47:49 2013 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Sat Oct  5 17:47:57 2013 [Server] Peer Connection Initiated with [AF_INET]79.141.167.28:9081
Sat Oct  5 17:47:59 2013 TUN/TAP device tun0 opened
Sat Oct  5 17:47:59 2013 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Sat Oct  5 17:47:59 2013 /sbin/ifconfig tun0 10.129.34.70 pointopoint 10.129.34.69 mtu 1500
Sat Oct  5 17:48:04 2013 Initialization Sequence Completed
Sat Oct  5 17:49:46 2013 event_wait : Interrupted system call (code=4)
Sat Oct  5 17:49:46 2013 /sbin/ifconfig tun0 0.0.0.0
Sat Oct  5 17:49:46 2013 SIGINT[hard,] received, process exiting



...und bricht an dieser Stelle ab. Meine Zugangsdaten werden angenommen aber ich weiß einfach nicht was der Fehlercode

Code:
event_wait : Interrupted system call (code=4)


bedeuten soll.

Kann mir jemand weiterhelfen?

Danke!
Sponsor
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17638
Location: Hesse/Germany

PostPosted: Wed Oct 16, 2013 9:41    Post subject: Reply with quote
hier anfangen

Code:
Sat Oct  5 17:47:49 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC basierende Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum