r21286 - wr1043nd & QoS causing reboot

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2
Author Message
lboucher
DD-WRT Novice


Joined: 29 Apr 2013
Posts: 15

PostPosted: Sun May 19, 2013 9:07    Post subject: Reply with quote
You can let the Qos active but remove all the rules and see if it happens...
_________________
Buffalo WHR-G300Nv2 - BrainSlayer-V24-preSP2 - R21286
Sponsor
abelau
DD-WRT Novice


Joined: 19 May 2013
Posts: 4

PostPosted: Sun May 19, 2013 9:36    Post subject: Reply with quote
lboucher wrote:
You can let the Qos active but remove all the rules and see if it happens...


Thanks lboucher. I have just tried what you suggested:
QoS enabled (HFSC), with only
"TCP-Packet Priority": SYN, FIN, RST
"Services Priority": EMPTY

Reloading many webpages at the same time will NOT cause router to reboot!
"cat /proc/net/ip_conntrack | wc -l" went as high as 4114

I wonder what next I could try Wink
lboucher
DD-WRT Novice


Joined: 29 Apr 2013
Posts: 15

PostPosted: Sun May 19, 2013 12:35    Post subject: Reply with quote
Maybe the problem is that using l7filter is consumming too much CPU or something like that.
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=171349

With a few rules like you, when I was opening many tab, or a big media website, my son was complaining about microlags on his video game.

Maybe you can add rules one by one...

But you should considering using personnal services based on port instead of l7 filter rules.

I kept
- two rules based on the video game port ("exemption" to ensure a good ping)
- only one rule based on the port I have fixed for utorrent (bulk)
- two rules based on "steam" game plateform port (express for the match)
- one rule based on the steam port for download (bulk)

And that's all... (the top rules on top for http 80 is something I'm trying to see if it speed up the process of parsing the rules. I'm not very sure.

_________________
Buffalo WHR-G300Nv2 - BrainSlayer-V24-preSP2 - R21286
abelau
DD-WRT Novice


Joined: 19 May 2013
Posts: 4

PostPosted: Sun May 19, 2013 15:44    Post subject: Reply with quote
lboucher wrote:
Maybe the problem is that using l7filter is consumming too much CPU or something like that.
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=171349
...


Thanks lbouocher for your advice. I will try avoiding l7filter on my DLINK DIR-632 and see how it goes.

Just curious, I wonder if it is an expected behavior, as if a few l7filter will significantly increase the load and crash the router.
Does it mean that majority of dd-wrt routers are also affected?
lboucher
DD-WRT Novice


Joined: 29 Apr 2013
Posts: 15

PostPosted: Sun May 19, 2013 16:36    Post subject: Reply with quote
I'm not a big specialist, but I think it's related with the CPU of the routers.

As far as I understand, with l7 rules, the router needs to open headers to see if they matchs with a pattern with a regular expression.

Here: http://l7-filter.sourceforge.net/protocols on the speed paragraph, they give some hints about the performance of the l7 filters. And it seems that the bitorent filter is slow.

_________________
Buffalo WHR-G300Nv2 - BrainSlayer-V24-preSP2 - R21286
aghurab
DD-WRT Novice


Joined: 26 Mar 2013
Posts: 4

PostPosted: Sun May 19, 2013 17:52    Post subject: Same Problem Here Reply with quote
i have also the same problem on Buffalo WZR-HP-AG300H so i disabled QOS anyway and now am waiting for the next build.. hope it will be fixed.
dkratter14
DD-WRT Novice


Joined: 17 Apr 2010
Posts: 10

PostPosted: Thu May 23, 2013 13:13    Post subject: Re: Same Problem Here Reply with quote
aghurab wrote:
i have also the same problem on Buffalo WZR-HP-AG300H so i disabled QOS anyway and now am waiting for the next build.. hope it will be fixed.


I have the same reboot/crash problem on the WZR-HP-G300NH. I only have a single rule though (bittorrent = Bulk). I've had to disable QoS until the problem is fixed.
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1470
Location: Belgrade

PostPosted: Thu May 23, 2013 13:39    Post subject: Reply with quote
Try to limit tcp/udp connections per user
Code:

#Limit TCP connections per user
iptables -t nat -I PREROUTING -p tcp --syn -s 192.168.1.1/24 -m limit --limit-burst 150 -j DROP

#Limit all *other* connections per user including UDP
iptables -t nat -I PREROUTING -p ! tcp -s 192.168.1.1/24 -m limit --limit-burst 100-j DROP
SpeedyRoute
DD-WRT Novice


Joined: 20 May 2013
Posts: 43

PostPosted: Fri May 24, 2013 14:09    Post subject: Reply with quote
At first I thought this was just misconfigured settings, but I had this exact problem QOS is causing the router to reboot! It has to be a bug,

I switched the Packet scheduler to-->HFSC and Queuing to -->FQ-Codel the router was rebooting itself every 2 hours.

I changed back to the default QOS settings:

Packet Scheduler -->HTB

Queneing Disciplie -->SFQ

So far, (knock on wood) it has been solid. So I think there is a bug there.
out of rules
DD-WRT Novice


Joined: 26 Nov 2010
Posts: 30

PostPosted: Sat May 25, 2013 17:15    Post subject: Reply with quote
SpeedyRoute wrote:
So I think there is a bug there.

http://svn.dd-wrt.com/changeset/21324
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum