I need help with uTorrent badly overloading my DD-WRT router

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
duckdown
DD-WRT Novice


Joined: 04 Sep 2012
Posts: 6

PostPosted: Wed Apr 17, 2013 2:12    Post subject: I need help with uTorrent badly overloading my DD-WRT router Reply with quote
Hey folks..

I am having an incredibly annoying problem when trying to seed torrents with uTorrent, and it is killing my entire network.

DD-WRT seems to get instantly overloaded, hitting 100% capacity for ACTIVE IP CONNECTIONS set to 4096 within a matter of a couple short minutes of uTorrent running. It steadily increases to 100% at which point every other device on my network craps out, until I kill uTorrent and let the active connections drop back to a few hundred.

I know, I'm about to be referred to the wiki page for "Router Slowdown" but none of the suggestions on that page have helped; believe me I have googled the living shit out of this problem before even posting here..

Here is the specs of my router:




Here is what my TCP/UDP settings are:




Here are my uTorrent settings:











And here is the lovely result after a few short minutes:



At this point, pages will only partially render or instantly fail as soon as you try to type in a URL on any device on the network. You can press the reload button a few times and it will load once, and the process continues.. Until of course I close uTorrent and things go back to normal.


I am truly out of ideas, I personally do not see any glaring misconfigurations and anything that is toggled/not toggled I have most likely tried already and had no results or no luck in figuring this out.

Somebody in a past post once blamed a similar problem on Microsoft Security Essentials, but that was in 2010 and had plenty of followup posters saying MSE caused no problems for them, so I am truly stumped.

Any help would be greatly appreciated! I need to get this solved for good..

Thank you in advance, folks

Cheers from Toronto
Sponsor
B@R
DD-WRT Guru


Joined: 16 Apr 2011
Posts: 596
Location: Israel

PostPosted: Wed Apr 17, 2013 2:20    Post subject: Reply with quote
My settings 8192. Not only torrent doing connections. If the router say, that it about top border, set more.
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7052
Location: YWG, Canada

PostPosted: Wed Apr 17, 2013 2:27    Post subject: Reply with quote
-see my sig for the latest firmware, it is a must
-change max connections to 8192
-INCREASE, tcp timeout to a BARE MINIMUM of 900 i dont care what anyone else says or what any wiki says, if you want grief then leave it alone
-decrease udp timeout to 90
-change tcp congestion control to westwood, westwood is done at the kernel level, the rest arent. google search what i just said for more info on it
-apply qos if necessary for rates(if you have prenium qos with kbps control)/priority

For the record my sig units handle near infinite amount of torrents only using about 2mb more ram vs idle state, even they are 64mb units the math says 32mb ram will still easily hold that load.. & this is with tcp/udp timeout 7800/300 max connections 16384.

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

[X86-64] Haswell i3-4150/4GB ------> Pending
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r40270M kongat
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41074 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41074 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41074 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r40634 std

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
buddee
DD-WRT Guru


Joined: 06 Feb 2010
Posts: 7401
Location: Little Rock

PostPosted: Wed Apr 17, 2013 3:46    Post subject: Reply with quote
most times i see this type of 'ram eating' behavior is when the port isn't forwarded properly, are you getting a green check box in the bottom status bar when your utorrent is actively being used?
_________________
Wireless N Config | Linking Routers | DD-WRT Wiki | DD-WRT Builds | Peacock - Broadcom FAQ

Having problems with port forwarding? Check out Port Forward Troubleshooting for more info.
duckdown
DD-WRT Novice


Joined: 04 Sep 2012
Posts: 6

PostPosted: Wed Apr 17, 2013 4:53    Post subject: Reply with quote
tatsuya46 wrote:
-see my sig for the latest firmware, it is a must
-change max connections to 8192
-INCREASE, tcp timeout to a BARE MINIMUM of 900 i dont care what anyone else says or what any wiki says, if you want grief then leave it alone
-decrease udp timeout to 90
-change tcp congestion control to westwood, westwood is done at the kernel level, the rest arent. google search what i just said for more info on it
-apply qos if necessary for rates(if you have prenium qos with kbps control)/priority

For the record my sig units handle near infinite amount of torrents only using about 2mb more ram vs idle state, even they are 64mb units the math says 32mb ram will still easily hold that load.. & this is with tcp/udp timeout 7800/300 max connections 16384.


Great post, thank you, I am going to try this now and report back. Also thank you to the fellow above for the 8192 suggestion as well.

I just got home so haven't tried the stuff in your post yet, but I can already say it's completely new stuff I have not tried yet (nor read about in other threads), so thanks again! I've got my fingers crossed maybe this will help it.

I will report back!

Cheers
duckdown
DD-WRT Novice


Joined: 04 Sep 2012
Posts: 6

PostPosted: Wed Apr 17, 2013 4:54    Post subject: Reply with quote
buddee wrote:
most times i see this type of 'ram eating' behavior is when the port isn't forwarded properly, are you getting a green check box in the bottom status bar when your utorrent is actively being used?


Oh yeah, the ports are working perfectly, it's all green, and I upload no problem. Just it kills other devices on my network once the ACTIVE IP CONNECTIONS hit that maximum 4096.
B@R
DD-WRT Guru


Joined: 16 Apr 2011
Posts: 596
Location: Israel

PostPosted: Wed Apr 17, 2013 9:12    Post subject: Reply with quote
Learn about QoS and set upper speed of upload. If up stream is fully used, you will not can use internet because most of your requests (clicks on the links in your browser for example) will be stuck in the out queue. The downstream may be free in that time.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum