Warning! Russian DIR-632 F/W V.1.4.1-Downgrading impossible?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
D2Cap
DD-WRT Novice


Joined: 01 Apr 2013
Posts: 6

PostPosted: Tue Apr 02, 2013 6:25    Post subject: Warning! Russian DIR-632 F/W V.1.4.1-Downgrading impossible? Reply with quote
To cut a long story short I have ended up with the Asia-Pacific (Region 2) version of my DIR-632 running the above FirmWare (Available on the Russian D-Link site ( ftp.dlink.ru/pub/Router/DIR-632/Firmware/ ) as: 20130109_1609_DIR_632_1.4.1_sdk-master.bin .

Although the the router works, has some interesting USB-WiMax features & the interface looks nice & shiny with animated (sliding) set-up screens it's very buggy & all & all a pretty horrible F/W version.
(Can upload screen shots if any one is interested)

The router has previously never had a problem changing between F/W versions, but now I have tried everything I can possibly think of trying to downgrade from this F/W version & then get the wonderful DD-WRT F/W back
on the router again;

1. Trying, from the FirmWare update screen of the router, to downgrade with several different F/W files
found on the net (including earlier versions of the Russian F/W), the V.1.4.1 F/W always reports;
'Incorrect firmware', as soon as I try to upload the file. This happens whether the F/W has been modified or not.

The V.1.4.1. is Region 2 (Asia-Pacific - A101-AR7242-RT-100324-02) FirmWare, & I have therefore hex modified all the F/W files accordingly, & even tried modifying the files to regions 1 (NA) & 3 (WW), but the router never goes on to do the actual update.

It appears there is a another version check in the 1.4.1 version, that prevents a downgrade...?
Looking insde the V.1.4.1 FirmWare file it looks like it might not even be running Linux??

Has anyone had any experince with the V.1.4.1 version on the DIR-632, trying & succeeded in downgrading from the F/W update screen?

2. Having had to admit defeat (so far), trying to downgrade from the router's F/W update screen,
I have tried through the router's 'D-Link Router Recovery Mode' screen, where I have tried uploading a selection of region modified & un-modified FirmWare via several different browsers (IE, FF & Comodo & I'm running Windows 7 by the way)

While Comodo (Chrome based browser) seems to do best & is even indicating that the F/W file is 100% uploaded, The router never installs the older F/W, & the router's orange light never changes to green, just continues blinking orange.

I have tried F/W from North America (Region 1), Taiwan (2), Russia (2) & Australia (2), none of which install...

My Russian leaves a lot to be desired, otherwise I would have posted this in the Russian section as well.

Does anyone know a bit more about the 1.4.1 version?
Is the DIR-632 sold in Russia with that F/W or is it provider specific?

A big warning might be in place that this particular F/W version will not allow you to put DD-WRT on the DIR-632 router, at least at this stage!!?

Don't know where to go from here; jTag??, or might even tFTP work with original D-Link F/W ...??

This forum has so much info, but as I don't speak Russian, I have not been able to find anything on this topic...

Would be VERY grateful for any info on this one!

D2Cap
Sponsor
D2Cap
DD-WRT Novice


Joined: 01 Apr 2013
Posts: 6

PostPosted: Thu Apr 04, 2013 9:24    Post subject: Opera flashed the DIR-632 when other browsers failed! Reply with quote
An update:

I have tried for a few days to flash the DIR-632 back to it's original F/W so I can put dd-wrt back on it.

Tried about 7 different versions of FireFox + IE & the Comodo browser, none of which would flash the router either from the emergency recovery screen or from the F/W update screen.
In a last attempt & after having read about arnfilho's experience with an other router, I tried Opera (Latest V.12.15) & it flashed the router first try from the recovery screen!!

Could warrant an update to a few of the stickies that Opera seems to do the flashing jobs well when other browsers won't!?

D2Cap
progfin
DD-WRT Novice


Joined: 04 Apr 2013
Posts: 5

PostPosted: Fri Apr 05, 2013 2:50    Post subject: Reply with quote
I have the same problem.

Router with 1.4.1 unable to update to DD-WRT.
try a lot of versions of dd-wrt firmware and last one (ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2013/04-01-2013-r21153/dlink-dir632a/)
Updated with different browsers, and try via UART (YMODEM) - have no effects.

The Log of running:

U-Boot 1.1.4-g740d892d-dirty (Oct 7 2011 - 07:40:27)

AP101 (ar7242 - Virian) U-boot
DRAM:
sri
ar7240_ddr_initial_config(133): virian ddr1 init
#### TAP VALUE 1 = 0x2, 2 = 0x2 [0x54040104: 0x2c0004]
64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 234k for U-Boot at: 83fc4000
Reserving 192k for malloc() at: 83f94000
Reserving 44 Bytes for Board Info at: 83f93fd4
Reserving 36 Bytes for Global Data at: 83f93fb0
Reserving 128k for boot params() at: 83f73fb0
Stack Pointer at: 83f73f98
Now running in RAM - U-Boot at: 83fc4000
id read 0x100000ff
sector count = 128
Flash: 8 MB
*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Net: ag7240_enet_initialize...
Fetching MAC Address from 0x83fec6c0
Fetching MAC Address from 0x83fec6c0
: cfg1 0xf cfg2 0x7114
eth0: 83:fd:a8:68:83:fd
eth0 up
: cfg1 0xf cfg2 0x7114
eth1: 83:fd:a8:68:83:fd
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Hit any key to stop autoboot: 1  0
## Booting image at 9f050000 ...
Image Name: MIPS Linux Kernel Image
Created: 2013-04-01 7:08:41 UTC
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 1072503 Bytes = 1 MB
Load Address: 80002000
Entry Point: 802392b0
Verifying Checksum ... OK
Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 802392b0) ...
## Giving linux memsize in bytes, 67108864

Starting kernel ...

[ 0.000000] flash_size passed from bootloader = 8
[ 0.000000] bootconsole [early0] enabled
AR7242
detect mem size
Uart Init
Booting AR7240(Python)...
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x00000000-0x03ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x00000000-0x03ffffff]
[ 0.000000] Primary instruction cache 64kB, 4-way, VIPT, I-cache aliases, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Linux version 3.5.7.9 (root@dd-wrt) (gcc version 4.7.3 20121205 (prerelease) (Linaro GCC 4.7-2012.12) ) #6321 Mon Apr 1 09:05:32 CEST 2013
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: console=ttyS0,115200 root=1f02 rootfstype=squashfs noinitrd init=/sbin/init
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] __ex_table already sorted, skipping sort
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 61576k/65536k available (2303k kernel code, 3960k reserved, 608k data, 168k init, 0k highmem)
[ 0.000000] NR_IRQS:80
[ 0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[ 0.080000] pid_max: default: 32768 minimum: 301
[ 0.080000] Mount-cache hash table entries: 512
[ 0.090000] NET: Registered protocol family 16
[ 0.140000] found calibration data for slot 0 on 0xBF7F1000
[ 0.350000] registering PCI controller with io_map_base unset
[ 0.370000] bio: create slab <bio-0> at 0
[ 0.370000] usbcore: registered new interface driver usbfs
[ 0.380000] usbcore: registered new interface driver hub
[ 0.380000] usbcore: registered new device driver usb
[ 0.390000] PCI host bridge to bus 0000:00
[ 0.390000] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[ 0.400000] pci_bus 0000:00: root bus resource [io 0x0000]
[ 0.400000] pci 0000:00:00.0: fixup device configuration
[ 0.410000] bootstrap returns device 168C:2E
[ 0.410000] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1000ffff 64bit]
[ 0.420000] PCI: mapping irq 72 to pin1@0000:00:00.0
[ 0.420000] Switching to clocksource MIPS
[ 0.430000] NET: Registered protocol family 2
[ 0.430000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.440000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[ 0.450000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.450000] TCP: Hash tables configured (established 2048 bind 2048)
[ 0.460000] TCP: reno registered
[ 0.460000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.470000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.480000] NET: Registered protocol family 1
[ 0.480000] gpio_proc: module loaded and /proc/gpio/ created
[ 0.490000] wl0gpio_proc: module loaded and /proc/wl0gpio/ created
[ 0.500000] squashfs: version 3.0 (2006/03/15) Phillip Lougher
[ 0.500000] msgmni has been set to 120
[ 0.510000] io scheduler noop registered
[ 0.510000] io scheduler deadline registered (default)
[ 0.520000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 0.540000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[ 0.550000] console [ttyS0] enabled, bootconsole disabled
[ 0.550000] console [ttyS0] enabled, bootconsole disabled
[ 0.560000] guessed flashsize = 8M
[ 0.570000] scanning for root partition
[ 0.570000] uboot detected
[ 0.570000] guessed bootloader size = 50000
[ 0.580000]
[ 0.580000] found squashfs at 156000
[ 0.590000] Creating 8 MTD partitions on "ar7240-nor0":
[ 0.590000] 0x000000000000-0x000000050000 : "RedBoot"
[ 0.600000] 0x000000050000-0x0000007e0000 : "linux"
[ 0.600000] 0x000000156000-0x000000720000 : "rootfs"
[ 0.610000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[ 0.620000] mtd: partition "rootfs" set to be root filesystem
[ 0.630000] 0x000000720000-0x0000007e0000 : "ddwrt"
[ 0.640000] 0x0000007e0000-0x0000007f0000 : "nvram"
[ 0.640000] 0x0000007f0000-0x000000800000 : "board_config"
[ 0.650000] 0x000000000000-0x000000800000 : "fullflash"
[ 0.660000] 0x000000000000-0x000000050000 : "fullboot"
[ 0.660000] tun: Universal TUN/TAP device driver, 1.6
[ 0.670000] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[ 0.680000] AG7240: Length per segment 1544
[ 0.680000] AG7240: Max segments per packet 1
[ 0.680000] AG7240: Max tx descriptor count 64
[ 0.690000] AG7240: Max rx descriptor count 128
[ 0.690000] AG7240: fifo cfg 3 01f00140
[ 0.700000] AG7240CHH: Mac address for unit 0
[ 0.700000] AG7240CHH: 00:18:e7:e0:08:1e
[ 0.910000] AG7240CHH: Mac address for unit 1
[ 0.910000] AG7240CHH: ff:ff:ff:ff:ff:ff
[ 1.120000] PPP generic driver version 2.4.2
[ 1.120000] PPP BSD Compression module registered
[ 1.130000] PPP Deflate Compression module registered
[ 1.130000] PPP MPPE Compression module registered
[ 1.140000] NET: Registered protocol family 24
[ 1.160000] u32 classifier
[ 1.160000] Performance counters on
[ 1.160000] input device check on
[ 1.170000] Actions configured
[ 1.170000] Netfilter messages via NETLINK v0.30.
[ 1.180000] nf_conntrack version 0.5.0 (962 buckets, 3848 max)
[ 1.180000] nf_conntrack_rtsp v0.6.21 loading
[ 1.190000] nf_nat_rtsp v0.6.21 loading
[ 1.190000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 1.200000] IPP2P v0.8.2 loading
[ 1.200000] TCP: westwood registered
[ 1.200000] TCP: hybla registered
[ 1.210000] TCP: vegas registered
[ 1.210000] NET: Registered protocol family 17
[ 1.210000] Bridge firewalling registered
[ 1.220000] 8021q: 802.1Q VLAN Support v1.8
[ 1.220000] searching for nvram
[ 1.230000] nvram size = 0
[ 1.260000] Atheros AR71xx hardware watchdog driver version 0.1.0
[ 1.270000] ar71xx-wdt: timeout=15 secs (max=21) ref freq=200000000
[ 1.280000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 1.280000] Freeing unused kernel memory: 168k freed
start service
starting Architecture code for dir615e
starting hotplug
Jan 1 00:00:02 udevtrigger[254]: parse_config_file: can't open '/etc/udev/udev.conf' as config file: No such file or directory

done
load ATH Ethernet Driver
insmod: ag71xx.ko: module not found
insmod: ag7240_mod.ko: module not found
ifconfig: invalid hw-addr öI¸£†\öJ:63:f5:04
ifconfig: invalid hw-addr öI¸£†\öJ:63:f5:05
[ 4.360000] ag7240_ring_alloc Allocated 1024 at 0x83fd9c00
[ 4.370000] ag7240_ring_alloc Allocated 2048 at 0x83cd8000
[ 4.370000] reg init for 0
[ 4.380000] Setting PHY...
[ 6.370000] rtl phy0 id 0:0
[ 6.370000] rtl phy1 id 0:0
[ 6.380000] rtl phy2 id 0:0
[ 6.380000] rtl phy3 id 0:0
[ 6.380000] rtl phy4 id 0:0
[ 6.380000] rtl phy5 id 0:0
[ 6.390000] rtl phy6 id 0:0
[ 6.390000] rtl phy7 id 0:0
[ 6.390000] AG7240: enet unit:0 is up...
[ 6.400000] Mii 100Mbps full duplex
[ 6.400000] AG7240: done cfg2 0x7115 ifctl 0x0 miictrl
[ 6.410000] ag7240_ring_alloc Allocated 1024 at 0x83f82c00
[ 6.420000] ag7240_ring_alloc Allocated 2048 at 0x83f03800
[ 6.420000] reg init for 1
[ 6.430000] ATHRS26: resetting s26
[ 6.530000] ATHRS26: s26 reset done
[ 6.530000] Setting PHY...
Failed to connect to the switch
Failed to connect to the switch
Failed to connect to the switch
Failed to connect to the switch
load ATH 802.11 a/b/g Driver
insmod: ath_hal.ko: module not found
insmod: ath_pci.ko: module not found
insmod: ath_ahb.ko: module not found
load ATH9K 802.11n Driver
[ 7.790000] Compat-drivers backport release: compat-drivers-2013-01-21-1
[ 7.790000] Backport based on wireless-testing.git master-2013-02-22
[ 7.800000] compat.git: wireless-testing.git
insmod: compat_firmware_class.ko: module not found
[ 8.000000] cfg80211: Calling CRDA to update world regulatory domain
[ 8.000000] cfg80211: World regulatory domain updated:
[ 8.010000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 8.020000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 8.020000] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 8.030000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 8.040000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 8.050000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 8.750000] ieee80211 phy0: Atheros AR9287 Rev:2 mem=0xb0000000, irq=72
[ 8.750000] cfg80211: Calling CRDA for country: AM
[ 8.760000] cfg80211: Regulatory domain changed to country: AM
[ 8.770000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 8.770000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 8.780000] cfg80211: (5170000 KHz - 5250000 KHz @ 20000 KHz), (N/A, 1800 mBm)
[ 8.790000] cfg80211: (5250000 KHz - 5330000 KHz @ 20000 KHz), (N/A, 1800 mBm)
[USB] checking...
umount: can't umount /mnt: No such file or directory
rmmod: usblp: No such file or directory
rmmod: printer: No such file or directory
rmmod: usb-storage: No such file or directory
rmmod: sr_mod: No such file or directory
rmmod: cdrom: No such file or directory
rmmod: sd_mod: No such file or directory
rmmod: scsi_wait_scan: No such file or directory
rmmod: scsi_mod: No such file or directory
rmmod: usb-ohci: No such file or directory
rmmod: ohci-hcd: No such file or directory
rmmod: uhci-hcd: No such file or directory
rmmod: usb-uhci: No such file or directory
rmmod: ehci-pci: No such file or directory
rmmod: ehci-platform: No such file or directory
rmmod: ehci-hcd: No such file or directory
rmmod: usbcore: No such file or directory
rmmod: usb-common: No such file or directory
rmmod: xfs: No such file or directory
rmmod: msdos: No such file or directory
rmmod: vfat: No such file or directory
rmmod: fat: No such file or directory
rmmod: nls_utf8: No such file or directory
rmmod: nls_iso8859-2: No such file or directory
rmmod: nls_iso8859-1: No such file or directory
rmmod: nls_cp437: No such file or directory
rmmod: nls_cp932: No such file or directory
rmmod: nls_cp936: No such file or directory
rmmod: nls_cp950: No such file or directory
rmmod: nls_base: No such file or directory
rmmod: ext2: No such file or directory
rmmod: mbcache: No such file or directory
rmmod: fuse: No such file or directory
ath9k deconfigure_single: phy0 ath0
killall: ead: no process killed
[ 11.160000] ag7240_ring_free Freeing at 0x83fd9c00
[ 11.160000] ag7240_ring_free Freeing at 0x83cd8000
[ 11.200000] ag7240_ring_alloc Allocated 1024 at 0x83fd9c00
[ 11.200000] ag7240_ring_alloc Allocated 2048 at 0x83cd8000
[ 11.210000] reg init for 0
[ 11.210000] Setting PHY...
[ 13.210000] rtl phy0 id 0:0
[ 13.210000] rtl phy1 id 0:0
[ 13.210000] rtl phy2 id 0:0
[ 13.210000] rtl phy3 id 0:0
[ 13.220000] rtl phy4 id 0:0
[ 13.220000] rtl phy5 id 0:0
[ 13.220000] rtl phy6 id 0:0
[ 13.230000] rtl phy7 id 0:0
[ 13.240000] ag7240_ring_free Freeing at 0x83fd9c00
[ 13.240000] ag7240_ring_free Freeing at 0x83cd8000
[ 13.260000] ag7240_ring_alloc Allocated 1024 at 0x83fd9c00
[ 13.270000] ag7240_ring_alloc Allocated 2048 at 0x83cd8000
[ 13.270000] reg init for 0
[ 13.270000] Setting PHY...
[ 15.270000] rtl phy0 id 0:0
[ 15.270000] rtl phy1 id 0:0
[ 15.280000] rtl phy2 id 0:0
[ 15.280000] rtl phy3 id 0:0
[ 15.280000] rtl phy4 id 0:0
[ 15.280000] rtl phy5 id 0:0
[ 15.290000] rtl phy6 id 0:0
[ 15.290000] rtl phy7 id 0:0
[ 15.290000] AG7240: enet unit:0 is up...
[ 15.300000] Mii 100Mbps full duplex
[ 15.300000] AG7240: done cfg2 0x7115 ifctl 0x0 miictrl
[ 15.310000] device eth0 entered promiscuous mode
/bin/sh: ead: not found[ 15.330000] br0: port 1(eth0) entered forwarding state

[ 15.330000] br0: port 1(eth0) entered forwarding state
ifconfig: ioctl 0x8914 failed: Cannot assign requested address
ath9k deconfigure_single: phy0 ath0
[ 15.400000] cfg80211: Calling CRDA to update world regulatory domain
[ 15.410000] cfg80211: World regulatory domain updated:
[ 15.420000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 15.420000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.430000] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 15.440000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 15.450000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.460000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.490000] cfg80211: Calling CRDA for country: US
[ 15.490000] cfg80211: Regulatory domain changed to country: US
[ 15.500000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 15.500000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 15.510000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 15.520000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.530000] cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.540000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.540000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 15.550000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
ath9k configure_single: phy0 ath0
549:ath0
call mac80211autochannel for interface: ath0
[ 17.330000] br0: port 1(eth0) entered forwarding state
freq:2412 qual:0 noise:0
freq:2417 qual:29 noise:-91
freq:2422 qual:0 noise:0
freq:2427 qual:48 noise:-91
freq:2432 qual:29 noise:-91
freq:2437 qual:0 noise:0
freq:2442 qual:0 noise:0
freq:2447 qual:0 noise:0
freq:2452 qual:0 noise:0
freq:2457 qual:31 noise:-91
freq:2462 qual:0 noise:0
mac80211autochannel interface: ath0 frequency: 2427
setup ath0 B8:A3:86:5C:F6:49
Configuration file: /tmp/ath0_hostap.conf
Using interface ath0 with hwaddr b8:a3:86:5c:f6:49 and ssid "dd-wrt"
[ 19.000000] device ath0 entered promiscuous mode
[ 19.010000] br0: port 2(ath0) entered forwarding state
[ 19.010000] br0: port 2(ath0) entered forwarding state
killall: roaming_daemon: no process killed
rmmod: bonding: No such file or directory
cp: can't stat '/tmp/mycron.d/*': No such file or directory
cp: can't stat '/jffs/mycron.d/*': No such file or directory
cp: can't stat '/mmc/mycron.d/*': No such file or directory
rmmod: n_hdlc: No such file or directory
[ 20.170000] device eth1 entered promiscuous mode
[ 20.190000] ag7240_ring_free Freeing at 0x83f82c00
[ 20.190000] ag7240_ring_free Freeing at 0x83f03800
[ 20.210000] ag7240_ring_alloc Allocated 1024 at 0x83f82c00
[ 20.220000] ag7240_ring_alloc Allocated 2048 at 0x83f03800
[ 20.230000] reg init for 1
[ 20.230000] Setting PHY...
[ 21.010000] br0: port 2(ath0) entered forwarding state
[ 21.240000] device eth1 left promiscuous mode
SIOCGIFFLAGS: No such device
rmmod: ipt_webstr: No such file or directory
rmmod: ipt_layer7: No such file or directory
rmmod: xt_layer7: No such file or directory
rmmod: ipt_ipp2p: No such file or directory
ath9k radio 1: phy0 ath0
rmmod: xt_physdev: No such file or directory
rmmod: xt_IMQ: No such file or directory
rmmod: ipt_IMQ: No such file or directory
rmmod: imq: No such file or directory
rmmod: sch_codel: No such file or directory
rmmod: sch_fq_codel: No such fil[ 23.360000] etherip: Ethernet over IPv4 tunneling driver
e or directory
The Milkfish Router Services
ERROR: Necessary service setting not found: milkfish_username - aborting.
killall: proxywatchdog.sh: no process killed
umount: can't umount /mnt/smbshare: No such file or directory
rmmod: cifs: No such file or directory
rmmod: fscache: No such file or directory
The Milkfish Router Services
Restoring SIP ddsubscriber database from NVRAM...
Empty.
The Milkfish Router Services
Restoring SIP ddaliases database from NVRAM...
Empty.
killall: schedulerb.sh: no process killed
killall: shatd: no process killed
killall: wdswatchdog.sh: no process killed
D2Cap
DD-WRT Novice


Joined: 01 Apr 2013
Posts: 6

PostPosted: Sat Apr 06, 2013 10:40    Post subject: progfin - Did you try Opera V.12.15? Reply with quote
That's the browser I had success with, while running
Windoze 7. Opera V.12.15 uplodaed D-Link's NA (Region -01) F/W; DIR632_FW_103.bin & installed it 1st try!! from the router's 'Router Recovery Mode' screen.
I think other browsers may (possibly) have caused a CRC error, as I never got any further than the F/W being uploded to the router, without the installation ever starting.
After the successful upload & installation of the NA V.1.03 F/W I then went on to the F/W upgrade screen (of the D-Link F/W) & updated to latest DD-WRT F/W (factory-to-ddwrt_NA(r21061).bin), with no problems, what so ever...
D2Cap
progfin
DD-WRT Novice


Joined: 04 Apr 2013
Posts: 5

PostPosted: Sat Apr 06, 2013 12:11    Post subject: Reply with quote
Any operation with browser - its fake.
I try a lot of browsers and Opera 12.15 at Windows 7 Ultimate - have no results.
Look here, as you can see at my LOGs:
ifconfig: invalid hw-addr öI¸£†\öJ:63:f5:04
ifconfig: invalid hw-addr öI¸£†\öJ:63:f5:05
So DLink firmware 1.4.1 special encoding MAC and another version of firmware would not be working!
So via UART I typed:
# nvram set lan_mac=b8:a3:86:5c:f6:49
# nvram set wan_mac=b8:a3:86:5c:f6:4a
# nvram commit
Turn off the power, press RESET button - wait 20 second.
At WEBpage 192.168.0.1 (PC with settings 192.168.0.2/255.255.255.0 connected via LAN1) upgrade to http://ftp.dlink.ru/pub/Router/DIR-632/Firmware/Old/DIR632A1_FW103RUB11.bin
After upgrading ROUTER will be working with FW1.03
And only after THIS OPERATIONs via ControlPanel do UPGRADE FW to DDWRT.
Now I have DDWRT at DIR632.... Smile)))))
VitalyRus
DD-WRT Novice


Joined: 07 Sep 2014
Posts: 1

PostPosted: Sun Sep 07, 2014 15:09    Post subject: Reply with quote
progfin wrote:

# nvram set lan_mac=b8:a3:86:5c:f6:49
# nvram set wan_mac=b8:a3:86:5c:f6:4a
# nvram commit


Hi,
I can't find nvram command via telnet on my D'link Dir-632 1.4.1. I'm search in U Boot menu, busybox and after firmware loading I'm also can't find nvram command. Where is this command?
Cmp_Cmndo
DD-WRT User


Joined: 14 Dec 2011
Posts: 117
Location: FL-USA

PostPosted: Sun Sep 14, 2014 14:49    Post subject: Reply with quote
These are old firmware versions. The 1st version that seemed to fix most all issues was v22118.

The latest version that has been tried & tested good by others is v23503.

The "master thread" for this router is here (now up to 29 pages):
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=77729&postdays=0&postorder=asc&start=0.
grishindg
DD-WRT Novice


Joined: 03 Oct 2014
Posts: 1

PostPosted: Fri Oct 03, 2014 20:35    Post subject: Reply with quote
Please help with a downgrate of the 1.4.1. I also can not use the NVRAM command via UART.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum