E3000 Time problems

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
plainzwalker
DD-WRT Novice


Joined: 02 Dec 2012
Posts: 5

PostPosted: Sun Dec 02, 2012 4:52    Post subject: E3000 Time problems Reply with quote
I have a E3000 flashed with the following DDWRT version:
DD-WRT v24-sp2 (04/07/12) big
(SVN revision 18946M NEWD-2 K2.6 Eko)

For some reason NTP fails to work and everytime the router is rebooted it loses the time settings causing issues with my openvpn since the cert goes bad.

Is there anyway to fix this issue so I don't have to log in and manually set the time every time it reboots?


Thank you
Sponsor
crashfly
DD-WRT Guru


Joined: 24 Feb 2009
Posts: 2026
Location: Sol System > Earth > USA > Arkansas

PostPosted: Sun Dec 02, 2012 16:49    Post subject: Reply with quote
What are your options set for "Time Settings" on your router? (The option is located at the bottom of the 'Setup' tab and 'Basic Setup' sub-tab.)

If you have something in the "Server IP/Name" option, try clearing it to see if that works then.

_________________
E3000 22200M KongVPN K26
WRT600n v1.1 refirb mega 18767 BS K24 NEWD2 [not used]
WRT54G v2 16214 BS K24 [access point]

Try Dropbox for syncing files - get 2.5gb online for free by signing up.

Read! Peacock thread
*PLEASE* upgrade PAST v24SP1 or no support.
plainzwalker
DD-WRT Novice


Joined: 02 Dec 2012
Posts: 5

PostPosted: Sun Dec 02, 2012 17:44    Post subject: Reply with quote
It only has the NTP option which is turned off, even with it turn on however the time resets to 00:00:00 every time the router is rebooted.

I tested the settings with another router I have running DDWRT and neither the NTP works nor does it save the time. I wonder if it is something that is broke with DDWRT even though they are two different routers they are both linksys and broadcom routers.
LOM
DD-WRT Guru


Joined: 28 Dec 2008
Posts: 7632

PostPosted: Sun Dec 02, 2012 17:53    Post subject: Reply with quote
Routers do not have realtime clocks ticking when the router is powered off.
The ntp client should have got you the correct time within 20-30 seconds after power on.

_________________
Kernel panic: Aiee, killing interrupt handler!
plainzwalker
DD-WRT Novice


Joined: 02 Dec 2012
Posts: 5

PostPosted: Sun Dec 02, 2012 17:56    Post subject: Reply with quote
Okay, well that doesn't work no matter what NTP I use. I've tried state side, and European. IP address and full address, it never sets itself.
plainzwalker
DD-WRT Novice


Joined: 02 Dec 2012
Posts: 5

PostPosted: Sun Dec 02, 2012 18:11    Post subject: Reply with quote
So if I run the following commands:

ntpclient pool.ntp.org
stopservice process_monitor
startservice process_monitor

NTP will work once, however after a reboot it still wont set itself.
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12676

PostPosted: Sun Dec 02, 2012 20:01    Post subject: Reply with quote
Leave NTP blank. It should work then. However, I suspect your VPN problems are build related. See the forum announcements.
_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1552
Location: Zwolle

PostPosted: Sun Dec 02, 2012 20:50    Post subject: Reply with quote
If the DNS server cannot be accessed, then it cannot resolve the NTP server name.

Solution:

Set a static IP in the ntp configuration.

Set some cron jobs like:
Code:
03 * * * * root /usr/sbin/ntpclient 193.67.79.202 > /dev/null 2>&1 &
08 * * * * root /usr/sbin/ntpclient 193.67.79.202 > /dev/null 2>&1 &

And choosing UTC time zone with no daylight savings solves most problems with having a wrong time on the router (i.e. after ntp sync). On a normal Linux system, system time is set to UTC with no dayligh savings, and uclibc does the translation to local time every time an application wants to know it. That's why Hackintosh users who also have Windows on their computer have to have a patch for time settings, otherwise the hardware time is set wrongly.

_________________
2 times APU2 Opnsense 21.1 with Sensei

2 times RT-AC56U running DD-WRT 45493 (one as Gateway, the other as AP, both bridged with LAN cable)

3 times Asus RT-N16 shelved

E4200 V1 running freshtomato 2020.8 (bridged with LAN cable)

3 times Linksys WRT610N V2 converted to E3000 and 1 original E3000 running freshtomato 2020.8 (bridged with LAN cable)

plainzwalker
DD-WRT Novice


Joined: 02 Dec 2012
Posts: 5

PostPosted: Mon Dec 03, 2012 3:53    Post subject: Reply with quote
Thank you, that seems to have fixed it.

I had tried the static ip before but it still wouldn't update, but the cron job did the trick it seems.
bbb3000
DD-WRT Novice


Joined: 06 Mar 2013
Posts: 10

PostPosted: Wed Mar 06, 2013 16:38    Post subject: Reply with quote
I also have the problem where the time never works. Do I just paste these two lines in the cron jobs section?

03 * * * * root /usr/sbin/ntpclient 193.67.79.202 > /dev/null 2>&1 &
08 * * * * root /usr/sbin/ntpclient 193.67.79.202 > /dev/null 2>&1 &

That does not seem to do anything.
slobodan
DD-WRT Guru


Joined: 03 Nov 2011
Posts: 1552
Location: Zwolle

PostPosted: Wed Mar 06, 2013 18:02    Post subject: Reply with quote
bbb3000 wrote:
I also have the problem where the time never works. Do I just paste these two lines in the cron jobs section?

03 * * * * root /usr/sbin/ntpclient 193.67.79.202 > /dev/null 2>&1 &
08 * * * * root /usr/sbin/ntpclient 193.67.79.202 > /dev/null 2>&1 &

That does not seem to do anything.

Use some NTP servers IPs from the part of the world you are living in. Some servers refuse connections outside their continent or country.

The idea is that you paste it in the cron section, activate cron and it should work after you reboot the router.

Also, if everything else fails, set the router to UTC time zone with no daylight savings. This should pass the correct system time to other programs.

_________________
2 times APU2 Opnsense 21.1 with Sensei

2 times RT-AC56U running DD-WRT 45493 (one as Gateway, the other as AP, both bridged with LAN cable)

3 times Asus RT-N16 shelved

E4200 V1 running freshtomato 2020.8 (bridged with LAN cable)

3 times Linksys WRT610N V2 converted to E3000 and 1 original E3000 running freshtomato 2020.8 (bridged with LAN cable)

Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum