problem with getting sonoff lightswitch to connect to router

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
spikey1973
DD-WRT Novice


Joined: 20 Feb 2017
Posts: 29

PostPosted: Thu Nov 07, 2019 19:40    Post subject: problem with getting sonoff lightswitch to connect to router Reply with quote
Hello guys.

I am running a tp link tl-wr1043 nd router with DD-WRT v3.0-r39855 std (05/25/19) installed on it.

i want to re-connect a couple of sonoff-dual wifi light-switch devices to this router so i can control the with the ewelink app.
The setup of this device seemed to work fine but the device doesn't connect to my router afterwards.

the setup steps of the device are the following:

1) re-installed a the newest version of ewelink
2) registered and signed in into the app with my google emailadress
3) went into the menu to add a new sonoff device
4) choose the quick pairing option in the app while connected to my router.
5) entered the SSID and PW of the router.
6) turned the sonoff device into pairing mode.
7) the app searched for the sonoff device, found it and connected to it. (i assume then uploaded the ssid and pw of the router to the device)
Cool setup ended.

afterwards the device does not connect to the router as it should.

On the sonoff device there is no mac-adress noted, but a new unknown mac-adress was found in my routers client list but it does not stay connected more the 4 secs. The TX, RX, SNR all seem fine.. but it just doesn't stay connected (see added image).

i have no mac adress filter active and have enough places in my DHCP namely 10, while i have only 6 pieces of hardware i connect to my router all with stable ip-adress.

does anyone have any idea why this doesn't want to connect? help would be much appreciated.

i don't like sitting in the dark and i can't work the switches now to turn the lights on, i know my own fault but still. help is appreciated.

i have a openvpn running (surfshark) but i just turned disabled this settings and reset-ed the router. with out any effect.

Kind regards

Matthieu
Sponsor
spikey1973
DD-WRT Novice


Joined: 20 Feb 2017
Posts: 29

PostPosted: Thu Nov 14, 2019 0:08    Post subject: Reply with quote
i have not been able to solve this problem in the mean time. i might be overlooking something simple and would really appreciate it if someone would be willing to help me point my attention.

kindest regards

Matt
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1227
Location: Indiana

PostPosted: Thu Nov 14, 2019 0:33    Post subject: Reply with quote
If your Wireless Network Mode is still set to Mixed
try NG-Mixed.

_________________
SUPPORTED DEVICES -- DON'T USE ROUTER DATABASE!
--IMPORTANT UPGRADE INFORMATION--STUBBY install guide
Qualcomm-Atheros:
R7800 x2 kongat & BS WDS AP & Sta- R7500V2 BS std WDS STA- WNDR3700v4 BS std WDS STA- Nanostation M2 AirOS- LocoM2 AirOS
Broadcom:
R6200v2 41491std using R6250.chk WLAN Repeater Archer C9 v1 OEM WAP

DDWRT Policy Based Routing Guide by egc
stephensuley
DD-WRT Guru


Joined: 09 Feb 2008
Posts: 594
Location: Canada

PostPosted: Thu Nov 14, 2019 14:53    Post subject: Reply with quote
I'll admit I know nothing about this light switch....that said with connection issues it's usually one of two things;

1 - it could be the network mode as the previous person posted, To test change the mode to the various options listed for your router and try to connect again.

2 - or it also could be the type of wireless security. To test, if possible in your environment, temporarily disable the wireless security entirely on the SSID you are using and see if the light switch can connect without security.

Come back here and post your results.

Good luck.

_________________
Location 1-rural) -WRT1900AC v1 (AP)- (NG)2.4Ghz/40Mhz) --250ft l.o.s.-->RT-AC87u (N-Only/client bridge) <back2back> RT-AC68u (wl0 & wl1 in AP mode / WAN disabled) - 150MBit/s end to end

Location 2-urban) - 1x Linksys EA8500 (AP)

Location 3-rural) - 1x Asus RT-AC87u (AP)

Latest and greatest builds Wink
stephensuley
DD-WRT Guru


Joined: 09 Feb 2008
Posts: 594
Location: Canada

PostPosted: Thu Nov 14, 2019 14:55    Post subject: Reply with quote
The manufacture also says...

How to solve Sonoff device connect issue?

● Check again that the WiFi access point is at 2.4 GHz

● Verify the WiFi name and password contain only letters a-z (A-Z) and numbers 0-9

● Try to bring the device closer to the WiFi router if it is too far away

● Repeat the pairing procedure on the eWeLink app.

● Perform the pairing procedure with other WiFi access points if available

● Perform the pairing procedure with a WiFi hotspot (such as a smartphone)

If the Sonoff problem does not pair, check on the eWeLink app that the selected pairing mode is consistent with the blinking frequency of the LED on the device:

● If the LED flashes alternately twice fast and once slow, you must use the Quick Pairing mode (default).

● If the LED flashes quickly, you must use the Compatible Pairing mode (AP).

In the case of iOS smartphones for the Compatible Pairing mode, you will need to connect your smartphone to the WiFi network created by the device itself with the name of the type ITEAD-100000xxx and password 12345678:

_________________
Location 1-rural) -WRT1900AC v1 (AP)- (NG)2.4Ghz/40Mhz) --250ft l.o.s.-->RT-AC87u (N-Only/client bridge) <back2back> RT-AC68u (wl0 & wl1 in AP mode / WAN disabled) - 150MBit/s end to end

Location 2-urban) - 1x Linksys EA8500 (AP)

Location 3-rural) - 1x Asus RT-AC87u (AP)

Latest and greatest builds Wink
stephensuley
DD-WRT Guru


Joined: 09 Feb 2008
Posts: 594
Location: Canada

PostPosted: Thu Nov 14, 2019 14:57    Post subject: Reply with quote
spikey1973 wrote:
i have not been able to solve this problem in the mean time. i might be overlooking something simple and would really appreciate it if someone would be willing to help me point my attention.

kindest regards

Matt


"Verify the WiFi name and password contain only letters a-z (A-Z) and numbers 0-9"



so apparently the wireless network name as well as the wifi password cannot have a special character. Numbers and letters only. If I had to guess I would say that's the issue you're having.

_________________
Location 1-rural) -WRT1900AC v1 (AP)- (NG)2.4Ghz/40Mhz) --250ft l.o.s.-->RT-AC87u (N-Only/client bridge) <back2back> RT-AC68u (wl0 & wl1 in AP mode / WAN disabled) - 150MBit/s end to end

Location 2-urban) - 1x Linksys EA8500 (AP)

Location 3-rural) - 1x Asus RT-AC87u (AP)

Latest and greatest builds Wink
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum