NEW Fractal BUILDS 17949 *CLOSED* Moving on to Devel Thread

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3 ... , 10, 11, 12  Next
Author Message
m@rco
DD-WRT Novice


Joined: 03 Dec 2011
Posts: 2

PostPosted: Tue Dec 06, 2011 22:54    Post subject: Reply with quote
@ Fractal and others

i've been lurking dd-wrt for some months now and tried different builds on my e4200; i guess i have some feedbacks to report.

where can i post them? couldn't we make a new thread where we speak about latest and greatest builds and what we shall issue/resolve...?

thanks.


EDIT

i am going to summarize what i found out till now.

i used to test builds in this configuration:
wl0 @ 2.4ghz g-only repeater with a virtual interface
wl1 @ 5ghz n-only ap
usb support on, samba client on.

i tested these builds so far:

dd-wrt.v24-16994_NEWD-2_K2.6_big-nv60k = ugly (lots of tx/rx errors everywhere, bad performance; didn't check well anything else)
dd-wrt.v24-17201_NEWD-2_K2.6_big-nv60k = repeater mode didn't work, clients in 2.4ghz band couldn't join the network created by virtual interface; if i recall correctly, usb support worked (/opt was mounting correctly); tx/rx errors here and there
dd-wrt.v24-17949_NEWD-2_K2.6_mega-nv60k = /opt was being mounted twice, making it unusable; tx/rx errors here and there; bad wl0 performance (didn't enable interface mitigation, yet)
r17940-usb-ftp-samba3-dlna-nv60k-broadcom kong mod = every partition mounts just fine, repeater mode works, small-to-none tx/rx error; moreover, after having turned interference mitigation on, i moved wl0 from a jerky 1/5.5/11mbps to a stable 48/54mbps rate - yeah. edit: got 400+ errors in wl0 and 50+ in wl1..

one sad thing is samba performance: with tomato i was getting some crazy speeds, as opposed to whichever dd-wrt build which gives me (much) worse performance.
i upgraded to samba 3.5.12.1 during my tests with build 17201 with no luck (stuck to the same, exact performance).

well, that's all.

any chance to see better samba performance ?


Last edited by m@rco on Wed Dec 07, 2011 8:30; edited 5 times in total
Sponsor
counterfeit
DD-WRT Novice


Joined: 02 Dec 2011
Posts: 5

PostPosted: Tue Dec 06, 2011 23:08    Post subject: Reply with quote
when i set the interference setting, i do it without a loop in the startup script and as long as i don't change any settings afterwards then it sticks just fine. 24hrs uptime and i can log into ssh server to confirm it is still set.

ErMeglio wrote:
What you speaking about here? The bluetooth coexistence mode setting on the web ui? Or is this simply the common name of the "wl interference 2" command Smile ?


e4200 is has a 2.4ghz radio and a 5ghz radio. if i'm not mistaken, wl -i eth2 sets the 5ghz and thats what he's talking about. saying you can just use wl -i eth1 and set the 2.4ghz


are you guys judging connection purely based on transfer speed or are you looking at SNR status as well? i'm running my e4200 in client bridge mode and with 17201 i was dropping connections on my ps3 intermittently. 17949 with interference setting seems to be much improved but obviously thats a subjective statement. the SNR is still about 31-35 (i'm a fair distance from my main router) and SNR was about the same when i was on 17201.

_________________
Linksys E4200 (17967)
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Wed Dec 07, 2011 0:09    Post subject: Reply with quote
m@rco wrote:
@ Fractal and others

i've been lurking dd-wrt for some months now and tried different builds on my e4200; i guess i have some feedbacks to report.

where can i post them? couldn't we make a new thread where we speak about latest and greatest builds and what we shall issue/resolve...?

thanks.


yeah your welcome to post them here, this thread is getting alot of exposure and informing the community is a good thing, and I am always open to ideas and feedback..

-Fractal
m@rco
DD-WRT Novice


Joined: 03 Dec 2011
Posts: 2

PostPosted: Wed Dec 07, 2011 0:47    Post subject: Reply with quote
Fractal wrote:
m@rco wrote:
@ Fractal and others

i've been lurking dd-wrt for some months now and tried different builds on my e4200; i guess i have some feedbacks to report.

where can i post them? couldn't we make a new thread where we speak about latest and greatest builds and what we shall issue/resolve...?

thanks.


yeah your welcome to post them here, this thread is getting alot of exposure and informing the community is a good thing, and I am always open to ideas and feedback..

-Fractal


thanks for your reply, i've edited my original message.
Taomyn
DD-WRT User


Joined: 23 Oct 2011
Posts: 50

PostPosted: Wed Dec 07, 2011 17:45    Post subject: Reply with quote
ErMeglio wrote:

Intel 5100 AGN. As I was saying (don't remember if in this 3d or not, sorry) it's the same nic an user reported to be able to use @ 300Mbps (its max!) at 5Ghz with wl1. I tried all his settings, both on the client that on the router, with no luck at all. Even the interference didn't make any even slight difference.

I had all manner of issues with a 5100 way back on another laptop, which I upgraded to a 5300. Not saying this is the same for you, just pointing out my experience.


ErMeglio wrote:

I've tried N only 5Ghz, NA mixed, mixed in all the combinations with channels+width auto+auto, upper 161 and down+40mhz, auto+40mhz, and others, always the same results (sometimes worse).
Between all these (many) different tries two times I got the card "locked" at 300Mbps sending packets but receiving absolutely nothing, with counter at 0 and bandwith usage at 0%. I had to disable and re enable it. Oh, btw the card has many Intel settings after the driver upgrade, also something like "lock on a mac", so I could surely decide the wl1 mac, lock on 5ghz, "Cisco radio detection" and so on. I tried many with always the same bad results.


Are you using just the drivers are have you also installed the Intel supporting software? That was nothing but trouble at work and we had to whole-sale remove it from all our laptops.

ErMeglio wrote:

What you speaking about here? The bluetooth coexistence mode setting on the web ui? Or is this simply the common name of the "wl interference 2" command Smile ?


I asked about the BT coexistence setting in the GUI, but it's another setting. On my E4200 on a reboot the 2.4GHz setting is disabled i.e. returns blank, but the 2.4/5Ghz setting is "Non-wireless LAN Interference mitigation is enabled.". Here's the exact output from the two commands:

Code:

root@monty:~# wl -i eth1 interference
root@monty:~# wl -i eth2 interference
Non-wireless LAN Interference mitigation is enabled.
root@monty:~#


Then after my additional startup script lines:

Code:

root@monty:~# wl -i eth1 interference
Wireless LAN Interference mitigation is enabled.
root@monty:~# wl -i eth2 interference
Non-wireless LAN Interference mitigation is enabled.
root@monty:~#


Oddly today the speed is fluctuating wildly between 300 and 450, no idea why. Hopefully the message from Fractal about the kernel and drivers will produce a stabilising fix soon.
Fractal
DD-WRT Guru


Joined: 19 Apr 2010
Posts: 1243

PostPosted: Wed Dec 07, 2011 18:44    Post subject: New official DD-WRT Release is out Reply with quote
a new official dd-wrt release is out:
ftp://dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2011/12-07-11-r17967/

I have emailed brainslayer asking him if there is a new toolchain he is using as I was able to test his std_usb_nas build and confirm that nslookup is working without segfault.. I can also confirm that wiviz is still broken, however if that is the only thing broken and the wireless is more stable I will take that any day... I will follow up when I know more

-Fractal
odie3
DD-WRT Novice


Joined: 03 May 2010
Posts: 15

PostPosted: Wed Dec 07, 2011 18:57    Post subject: Reply with quote
how do you tell which one is for the E4200?

nm, was over looking broadcom_K26

_________________
Odie3
Kyle, Texas

-Did I mention I rolled Odie up in a blanket and stuffed him onto the top shelf of the hall closet?
kt_haddock
DD-WRT Guru


Joined: 25 Dec 2009
Posts: 710

PostPosted: Wed Dec 07, 2011 19:23    Post subject: Reply with quote
Can someone do "wl ver" and se which wifi driver is using ? Laughing build 17967

Oh... Embarassed sorry K2.6

_________________
[I prefer answere in whole sentence]


Last edited by kt_haddock on Wed Dec 07, 2011 19:30; edited 1 time in total
Dark_Shadow
DD-WRT Guru


Joined: 31 Aug 2009
Posts: 2450
Location: Third Rock from the Sun

PostPosted: Wed Dec 07, 2011 19:26    Post subject: Reply with quote
kt_haddock wrote:
Can someone do "wl ver" and se which wifi driver is using ? Laughing build 17967


K2.4 or k2.6?

_________________
Peacock Thread-FAQ -- dd-wrt Wiki

Testing Multiple Routers -- Bootloader Collection Project -- My Wiki
kt_haddock
DD-WRT Guru


Joined: 25 Dec 2009
Posts: 710

PostPosted: Wed Dec 07, 2011 19:32    Post subject: Reply with quote
Dark_Shadow wrote:
kt_haddock wrote:
Can someone do "wl ver" and se which wifi driver is using ? Laughing build 17967


K2.4 or k2.6?


Oh... Embarassed sorry K2.6

_________________
[I prefer answere in whole sentence]
ErMeglio
DD-WRT User


Joined: 11 Jul 2006
Posts: 104

PostPosted: Wed Dec 07, 2011 19:33    Post subject: Reply with quote
@Taomyn
Thanks for all your hints.
I've used the 5100 with no software at all and without updated drivers too, and the results were almost the same.
Now I've upgraded drivers and I thought to have denied the installation of the Intel's connection tool. For sure I asked it not to use Intel to connect to the wireless, but Windows. Instead it installed a pair of applications, the main one is PROset/Wireless that can't make connections but has three sub-apps that are for statistical data of the wireless, diagnostics, a tool to import "profiles" and a sort event registry of wireless statuses. They anyway never appear by themselves, are not even in the tray at the clock.
I see, instead, I could ask, into connection's properties, to use the Intel's subdriver(?) to set some additional settings about the WiFi connection. That's what I was talking about when I spoke about mac address, locked frequency to 2,4 or 5, "Cisco detection" ecc. I tried activating all of these, disactivating the entire subdriver, but no change at all.
The commands you propose with -i eth1 and -i eth2 are exactly the ones I tried without success.

Will check out soon the new BS' build, it would be great if we come to know what's knew, toolchain, uclibc ecc, will look forward for your hot news Fractal Smile




Joined: 01 Jan 1970
Posts:

PostPosted: Wed Dec 07, 2011 22:35    Post subject: Reply with quote
Was reading in the NAT Loopback thread and saw something which made me curious as well; maybe Fractal or other folks in this thread would know?

Mangix wrote:
sorry for bringing this thread from the dead but does svn version 17911 fix nat loopback? many changes were made relating to the nvram variable block_loopback
dc
DD-WRT User


Joined: 08 Jun 2006
Posts: 247
Location: Prince Edward Island - Canada

PostPosted: Wed Dec 07, 2011 23:06    Post subject: Reply with quote
kt_haddock wrote:
Dark_Shadow wrote:
kt_haddock wrote:
Can someone do "wl ver" and se which wifi driver is using ? Laughing build 17967


K2.4 or k2.6?


Oh... Embarassed sorry K2.6


root@dd-wrt-orange:~# wl ver
5.100 RC138.9
wl0: Dec 7 2011 02:36:30 version 5.100.138.9
djroby19
DD-WRT Novice


Joined: 23 Dec 2009
Posts: 34
Location: Italy

PostPosted: Thu Dec 08, 2011 6:52    Post subject: Reply with quote
kt_haddock wrote:
Can someone do "wl ver" and se which wifi driver is using ? Laughing build 17967

Oh... Embarassed sorry K2.6


These are the drivers on my version kong 17940 root @ DD-WRT: ~ # wl ver
5.60 RC127.4
wl0: Jul 18 05:47:50 2011 Version 5,100,127

_________________
Buffalo WZR-HP-AG300H DD-WRT v24-sp2 (03/19/12) std - build 18777 + modem Digicom combo cx + Nas Synology DS-209 da 2 T + LG DP1W+ APC Back-UPS RS-Power Saving Back-UPS Pro 550 + switch Zyxel Gs105B + http://forum.emulesecurity.net/topic.asp?TOPIC_ID=3441
Taomyn
DD-WRT User


Joined: 23 Oct 2011
Posts: 50

PostPosted: Thu Dec 08, 2011 7:52    Post subject: Re: New official DD-WRT Release is out Reply with quote
Fractal wrote:
a new official dd-wrt release is out:
ftp://dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2011/12-07-11-r17967/

I have emailed brainslayer asking him if there is a new toolchain he is using as I was able to test his std_usb_nas build and confirm that nslookup is working without segfault.. I can also confirm that wiviz is still broken, however if that is the only thing broken and the wireless is more stable I will take that any day... I will follow up when I know more

-Fractal


It's a bit annoying that it's been reported that SSH has suddenly broken in this release, is it all builds? Unfortunately the workaround isn't enough for me as the changing certificate I think will mess up some scripts I have on my server Crying or Very sad
Goto page Previous  1, 2, 3 ... , 10, 11, 12  Next Display posts from previous:    Page 11 of 12
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum