HOW TO: TP-Link TL-WR1043ND Wireless Repeater

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3
Author Message
DD-WRT Novice

Joined: 23 Mar 2012
Posts: 2

PostPosted: Fri Mar 23, 2012 3:40    Post subject: Reply with quote
Yep, that's why I specified as a repeater only!!
Don't understand why that's so hard in DD!! Surprised
DD-WRT Novice

Joined: 16 May 2012
Posts: 22

PostPosted: Wed May 16, 2012 16:56    Post subject: Re: HOW TO: TP-Link TL-WR1043ND Wireless Repeater Reply with quote
Ratty wrote:

30. Telnet to, Username = "root", Password = "password" and execute the following command: "echo 1 > /proc/sys/net/ipv4/conf/br0/proxy_arp"

Newbie here. First, my thanks to Ratty for posting instructions that actually worked with my TL-WR1043ND! Very Happy

The only problem I had was with step 30 (above). When I tried to telnet into the router, I was able to input the username (root), but when the password prompt came up it wouldn't let me enter a password. No matter what I typed, the cursor just sat there blinking. And if I just hit <enter> I'd get an error message.

Can anyone give me some guidance on how to telnet into the router to do step 30, or help me figure out why I can't input a password?

DD-WRT Novice

Joined: 30 Jul 2012
Posts: 7

PostPosted: Mon Jul 30, 2012 21:37    Post subject: Reply with quote
vispo60 wrote:
after 4 days unsuccessful testing client bridge (i need repeater bridge but not possible on my device) on wr741nd-ddwrt, i found solution: install Gargoyle firmware v1.13.10, very intuitive and easy configuration (as repeater bridge), it works perfectly! Total time spent: 5 min.!

Very Happy Very Happy Very Happy


I messed around the whole f*****g day trying to set up my TP-LINK TL-WR941ND with dd-wrt as a repeater for my existing AP, could't get it to work at ALL. Tried everything... I was near a mental breakdown Shocked

Then I saw your post, reverted back from dd-wrt to stock firmware, flashed Gargoyle and had what I wanted within 5 minutes. Very Happy

It's ridiculous that with all those options and stuff that dd-wrt brings, you still can't get the most basic sh*t like this to work.
DD-WRT Novice

Joined: 09 Aug 2012
Posts: 1

PostPosted: Thu Aug 09, 2012 10:54    Post subject: Reply with quote
gargoyle for me as well. 2 seconds and it worked. barely any config. i reverted to stock with revert file (dd-wrt to tp-link stock) and then flashed with gargoyle.
DD-WRT Novice

Joined: 15 Aug 2012
Posts: 1

PostPosted: Wed Aug 15, 2012 22:56    Post subject: Reply with quote
If anyone could assist me, I have susccesfully bridged the 1043nd to the orignal router, however when clients try to connect to the bridge they can not obtain an ip and cannot connect to the router, however the bridge does work as a wired bridge and I am able to obtain an ip, it just does not want to work for the wireless.
DD-WRT Novice

Joined: 22 May 2007
Posts: 24

PostPosted: Sat May 25, 2013 19:41    Post subject: Reply with quote
fwiw, this generally worked for me but encryption was disabled on the repeater (so anyone could connect to my network). Enabling it required the following steps:

Wireless -> Wireless Security -> Virtual Interfaces ath0.1 SSID
I entered the same information as the main SSID

Setup -> Networking -> DHCPD
ath0.1 On Start: 100 Max: 50 Leasetime: 3600

Administration -> Commands
iptables -I INPUT -i ath0.1 -p icmp -j ACCEPT
iptables -I INPUT -i ath0.1 -p tcp --dport 23 -j logdrop
iptables -I INPUT -i ath0.1 -p tcp --dport 80 -j logdrop
iptables -I FORWARD -i ath0.1 -o br0 -j logdrop

Save Firewall

The last step might not be necessary because the Firewall was already disabled, but who knows.


Edit: It seems that the bridge drops after a short period of time when clients connect to the repeater. This has been driving me up the wall all day. I'm using BrainSlayer V24 preSP2 r21286 (04-15-2013)

When I made the SSID of the VAP the same as the primary router, there have been less issues. Still testing whether that fixes all of the problems.

Speeds are quoted as 26 Mb/s on the bridge and 144.44 Mb/s on the VAP from the Wireless Status page. However, in practice, the VAP clients are getting 3.75 Mbps / 0.25 Mbps through, way below what a regular wireless client would get. The router is set to Mixed Wireless Network Mode and Dynamic (20/40 MHz) Channel Width and located a few rooms away. Hope that helps some people
DD-WRT Novice

Joined: 24 Mar 2011
Posts: 4

PostPosted: Thu May 30, 2013 22:20    Post subject: Reply with quote
Function wrote:
Edit: It seems that the bridge drops after a short period of time when clients connect to the repeater. This has been driving me up the wall all day. I'm using BrainSlayer V24 preSP2 r21286 (04-15-2013)

Brainsalyer DD-WRT v24-sp2 (05/27/13) std - build 21676 here.

I'm having a similar problem. The bridge itself is working very stable for me, I have been streaming videos from my NAS (wired connection to my router, AVM Fritz!Box 7360SL, not running DD-WRT) to my media streamer (wired connection to the TL-WR1043ND with DD-WRT, set up according to this guide) for two hours without even a hitch.

Devices attached to ath0.1 also work perfectly - for a little less than two minutes Sad - then all Internet connectivity is suddenly lost.

Local connection over the bridge (e.g. to the NAS) continue to function without any kind of problem, though.

DNS resolution still works as well for the attached devices, but all Internet traffic times out after that ...

... disconnect the attached device and reconnect and everything works perfectly again - for another two minutes, then it's the same situation: DNS lookups work, local traffic works, Internet traffic does not.

EDIT: --I think I fixed it.-- nevermind, see EDIT2. Sad

I deviated from the instructions a bit and set Local DNS to my Router's IP instead of leaving it blank and enabled Dynamic Routing for LAN & WLAN.

After rebooting the repeater (and only after that, applying the settings had no effect) everything works like a charm.

I'm not sure which setting had the desired effect, but I'm not going to touch anything while this is working.

The only sour note is that Internet speed is pretty terrible:

Direct connection to the router:

50mbit/s down, 10mbit/s up, 33ms ping according to

Internet through the TP-WR1043ND repeater:

~12mb/s down, ~3mbit/s up, 67ms ping

Which is rather odd, considering that TX and RX for all connection in both directions from the repeater are 130M or higher and signal quality is displayed as 70% or higher - so why on earth is throughput so ludicrously slow and low?

EDIT2: Nope, Internet access still died after a bit over 10 minutes, crap ... Sad
DD-WRT Novice

Joined: 22 May 2007
Posts: 24

PostPosted: Sun Jun 02, 2013 4:55    Post subject: Reply with quote
I'm getting the same, if not very similar issues. Keep trying to find a solution!

Joined: 03 Jan 2010
Posts: 453

PostPosted: Sun Jun 02, 2013 17:31    Post subject: Reply with quote
can you guys check whether you have the save mac addresses for wirelss and lan adapters? my wr1043nd's have them the same and client bridging always crashes for me. all other devices i've used have different mac addresses for lan, wireless, and wan.
thanks - i strongly suspect this is the problem with these otherwise excellent routers.
DD-WRT Novice

Joined: 09 Jan 2011
Posts: 2

PostPosted: Wed Jul 02, 2014 6:19    Post subject: Reply with quote
hi all!

i've set up my 1043nd v1 like described and it works so far. but i've encountered three things:

first setting up repeater mode makes the integrated 4port switch unusable, each port is flooded with multicast packets. is there a way to fix this?
(note: the wireless network is not affected cause i added wan port to switch and left "block wan requests - filter multicast" activated, then i connected wan port as uplink to my network)

second thing is network performance is slowing down upgrading from firmware 24160 to 24461. using previous firmware the wlan interconnection from my avm fritzbox 7390 to the tp-link 1043nd was about 250mbits and now its about 140 mbits. also the connection from clients to 1043 is maximum 54mbit Sad

third is i have about 15% error rate with received packets on the access-point, no errors on the interconnect.

perhaps someone can help me with my issues. any help would be greatly appreciated!

thx in advance
DD-WRT Novice

Joined: 15 Aug 2017
Posts: 1

PostPosted: Tue Aug 15, 2017 22:35    Post subject: 2017 BUMP Reply with quote
This worked for WR841ND v7 running Firmware: DD-WRT v24-sp2 (03/25/13) std

Your step by step works great.
DD-WRT Novice

Joined: 25 Sep 2017
Posts: 2

PostPosted: Mon Sep 25, 2017 16:51    Post subject: Reply with quote
Thanks for sharing these steps!
Goto page Previous  1, 2, 3 Display posts from previous:    Page 3 of 3
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum