TP-Link TL-WR841ND v11 support

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Author Message
KrypteX
DD-WRT Guru


Joined: 18 Jan 2014
Posts: 2411

PostPosted: Tue Nov 10, 2015 16:17    Post subject: TP-Link TL-WR841ND v11 support Reply with quote
I've modified the header of the DD-WRT 28417 factory-to-ddwrt build intended for TL-WR841ND v10, so it will flash on a TL-WR841ND v11 running stock TP-Link firmware.
If the attached build works for you, it can be further updated with any newer-than-28417 webflash build for TL-WR841ND v10.


Disclaimer: I haven't tested the attached build myself, so I'm not responsible in any way if you brick your router.
Please only flash this build if you know how to unbrick it.

Note: You must be logged in to be able to download the attachment.

_________________
THERE ARE NO STRANGERS HERE; ONLY FRIENDS YOU HAVEN'T YET MET.
________________________________________________________________________________________________________
DD-WRT CHANGELOG | DEVICES | DD-WRT BUILDS | KONG BUILDS | UNOFFICIAL BUILDS | DD-WRT in VIRTUALBOX

Testing BrainSlayer's DD-WRT build 31924 on various units:
NETGEAR : WNDR3800 WNDR3800CH WNDRMACv2 WNDRMACv1 WNR2200 WNR2000v3
TP-LINK : ArcherC7v3 WR1043NDv3 WR740Nv4 WR740Nv6 WR710Nv1 WR810Nv1 WA850REv1 WA901NDv3 WA901NDv4
D-LINK : DIR-862L DIR-615D2
ASUS : RT-N10 C1
VirtualBox : x86_64


Last edited by KrypteX on Wed Oct 26, 2016 12:45; edited 3 times in total
Sponsor
maurer
DD-WRT User


Joined: 22 Jun 2009
Posts: 100
Location: Buchrest, Romania

PostPosted: Thu Dec 03, 2015 20:25    Post subject: Reply with quote
i confirm it's working with upgrade to v10 webflash later.
Can you please tell us how you modified the header?
thanks
Florian838
DD-WRT Novice


Joined: 20 Dec 2015
Posts: 1
Location: Germany

PostPosted: Sun Dec 20, 2015 22:29    Post subject: Reply with quote
maurer wrote:
i confirm it's working with upgrade to v10 webflash later.
Can you please tell us how you modified the header?
thanks

@maurer Did "repeater bridge" work for you?
I'm thinking about buying a TP Link wr841n but I don't know any shop (amazon, ...) which specifys the revision so the probability is high I get a 'v11', the newest version.


Link to build 28417 by KrypteX from 3rd December 2015 for not registered users:
https://www.dropbox.com/s/hnsdrlif1i9okc9/factory-to-ddwrt_28417_WR841NDv11.bin?dl=1
laue
DD-WRT Novice


Joined: 23 Dec 2015
Posts: 1

PostPosted: Wed Dec 23, 2015 12:21    Post subject: Reply with quote
@KrypteX Thanks dude, it worked for me.

Florian838 wrote:
@maurer Did "repeater bridge" work for you?


I tested it and it works. Though there's no 'repeater bridge' wireless mode. You can emulate that feature by setting wireless mode to Client Bridge (routed). You can follow this guide starting from Qualcomm Atheros header.

http://www.dd-wrt.com/wiki/index.php/Repeater_Bridge#Qualcomm_Atheros
kennethxu
DD-WRT Novice


Joined: 28 Dec 2015
Posts: 1

PostPosted: Mon Dec 28, 2015 2:12    Post subject: Reply with quote
@Kryptex thank you!
@laue according to the spec (http://www.tp-link.com/en/products/details/cat-9_TL-WR841N.html#specifications), V11 seems to support higher tx power (CE:<20dBm FCC: <30dBm). Were you able to get higher than 19dbm (the best I can get with V9 under DD-WRT) tx power?

Interesting, openwrt seems to able to push tx power for even V9 with a hack, anyone have any luck with it? I really need a bit more power to get across a street.

Lastly, does anyone know if Amazon is shipping V11 routers now?

Thank you!
cutaliviu
DD-WRT Novice


Joined: 13 Sep 2011
Posts: 2

PostPosted: Sat Jan 02, 2016 19:10    Post subject: Reply with quote
Thanks KrypteX. I've tested on a WR841N(RO) v11.0 version and worked very smoothly with your mod.
I've just noticed that the power led is not working anymore after factory-to-ddwrt flash.

So,I've upgraded to ftp://ftp.dd-wrt.com/betas/2015/12-24-2015-r28598/tplink_tl-wr841ndv10/tl-wr841nd-webflash.bin

It's running well, although the power led is still not functional.
beand1p
DD-WRT Novice


Joined: 14 Jan 2016
Posts: 2

PostPosted: Thu Jan 14, 2016 14:28    Post subject: Reply with quote
kennethxu wrote:

Lastly, does anyone know if Amazon is shipping V11 routers now?


I will be receiving a TL-WR841N today from Amazon so I'll report back.

Also, if I'm understanding correctly, for v11 I will need to flash KrypteX's "factory-to-ddwrt_28417_WR841NDv11.bin" and then I can flash the newest v10 webflash.bin beta: 01-02-2016-r28647/tplink_tl-wr841ndv10/ over that correct?

EDIT: I received version 9 from Amazon today. Boo.
DavidDhg
DD-WRT Novice


Joined: 27 Jan 2016
Posts: 3

PostPosted: Wed Feb 03, 2016 3:27    Post subject: Reply with quote
beand1p wrote:
kennethxu wrote:

Lastly, does anyone know if Amazon is shipping V11 routers now?


I will be receiving a TL-WR841N today from Amazon so I'll report back.

Also, if I'm understanding correctly, for v11 I will need to flash KrypteX's "factory-to-ddwrt_28417_WR841NDv11.bin" and then I can flash the newest v10 webflash.bin beta: 01-02-2016-r28647/tplink_tl-wr841ndv10/ over that correct?

EDIT: I received version 9 from Amazon today. Boo.
DavidDhg
DD-WRT Novice


Joined: 27 Jan 2016
Posts: 3

PostPosted: Wed Feb 03, 2016 3:29    Post subject: Unofficial v11 build causes blocking of YouTube Reply with quote
Hi Guys, I have a v11 TL-WR841N router that I upgraded to DD WRT unofficial v11 firmware as instructed here. All went well including adding firewall commands for using Unlocator DNS service to allow use of Chromecast for the BBC iPlayer. That worked well.
However, when I tried to access YouTube with this build and command set installed it timed out. Ping also timed out. (Other websites I tried loaded just fine). Tried various other firewall commands provided by the Unlocator CS guys, but no luck. I also tried various tl-wr841nd-webflash.bin releases, but no improvement.
So I luckily found and purchased a v10 router and used the official v10 flash. Set the new v10 device up as for the v11 device before it, got both Chromecast and YouTube to work flawlessly.
That means apart from the power LED not working in v11 after flashing with v10, there is an additional bug that prevents the router from accessing YouTube when the firewall redirect commands are in place.
These commands are:
iptables -t nat -A PREROUTING -d 8.8.8.8 -j DNAT --to-destination 1xx.xx.xx.xx
iptables -t nat -A PREROUTING -d 8.8.4.4 -j DNAT --to-destination 1xx.xx.xx.xx

Anyone got any idea when an official build for v11 routers may become available, or how to get around the apparent bug? Smile
abramelin
DD-WRT Novice


Joined: 04 Feb 2016
Posts: 1

PostPosted: Thu Feb 04, 2016 20:48    Post subject: Reply with quote
I have a v11 TL-WR841N. Do you recomment me to use KrypteX's mod?

Also cant we downgrade the official firmware that comes with router? FOr example can i downgrade from official v11 to v9?
DavidDhg
DD-WRT Novice


Joined: 27 Jan 2016
Posts: 3

PostPosted: Fri Feb 05, 2016 5:29    Post subject: v11 flash Reply with quote
Hi, you can flash the v11 with the KrypteX modded v10 factory flash, then choose one of the other available tl-wr841nd-webflash.bin releases for the v10 to finish the job. However, you will note that the power LED doesn't work and if you are going to do a Chromecast "fix" as I describe with the Firewall rules, you will not be able to use YouTube.
The v11 refers to the routers build which seems to have changed over the v10 build. There are different antenna for example and a guest network function is available. So "downgrading" as you put it may not be feasible. I haven't tried it apart from the v10 and that clearly isn't working 100% correctly.
kkottikas
DD-WRT Novice


Joined: 15 Feb 2016
Posts: 1

PostPosted: Tue Feb 16, 2016 10:34    Post subject: DHCP not working on Client bridge Reply with quote
Hi all

I have flashed my TL-WR841N v11.1 with the recommended firmware and then with the v10 r29059 webflash.
Then I have configured it as client bridge but dhcp is not working.With static IP everything works well but I need the dhcp. Does anyone have a possible fix for this?

Thanks


edit: solved. the problem was on the primary router/modem where the dhcp server is running
termits
DD-WRT Novice


Joined: 06 Dec 2011
Posts: 5

PostPosted: Fri Feb 19, 2016 9:56    Post subject: Reply with quote
It is possible used for version 12 ? This router have new web gui. This web configuration is only in China language.
QR770
DD-WRT Novice


Joined: 13 Aug 2007
Posts: 6

PostPosted: Thu Mar 31, 2016 22:23    Post subject: http://dd-wrt.com/site/support/other-downloads?path=betas%2F Reply with quote
Has anyone had any luck flashing the TP-Link TL-WR841N v11 with the latest beta firmware for the v11 (3/31 version at http://dd-wrt.com/site/support/other-downloads?path=betas%2F2016%2F03-31-2016-r29387%2Ftplink_tl-wr841ndv11%2F)?

I tried the factory-to-ddwrt-US.bin file there and it totally bricked my router -- no lights when powered on, no TFTP available, no web page or telnet available at 192.168.0.1 or 192.168.1.1. I can ping the router but that is all it will do.
danymarc
DD-WRT Guru


Joined: 04 Nov 2012
Posts: 523
Location: Acapulco, Mexico

PostPosted: Thu Mar 31, 2016 23:01    Post subject: Re: http://dd-wrt.com/site/support/other-downloads?path=beta Reply with quote
QR770 wrote:
Has anyone had any luck flashing the TP-Link TL-WR841N v11 with the latest beta firmware for the v11 (3/31 version at http://dd-wrt.com/site/support/other-downloads?path=betas%2F2016%2F03-31-2016-r29387%2Ftplink_tl-wr841ndv11%2F

Ir you don't have serial cable, and know how to debrick you should wait and read posts about a new build,r2938 is buggy
read here http://www.dd-wrt.com/phpBB2/viewtopic.php?t=300472 and ask him about able to recover v10 with TFTP trick

_________________
TP-Link: TL-WR741ND V4
TP-Link: TL-WR842ND V2
Goto page 1, 2, 3, 4, 5, 6, 7  Next Display posts from previous:    Page 1 of 7
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum