Linksys E3000 on stock fw 1.0.06 refusing to flash anything.

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2
Author Message
bugfinder
DD-WRT Novice


Joined: 23 Feb 2015
Posts: 4

PostPosted: Tue Feb 24, 2015 7:18    Post subject: Reply with quote
JohnnySL wrote:
So that leaves the flashing host as the likely culprit. Something changing the code during upload maybe.


the file could also be corrupted when downloaded. Or after, if some over-zealous malware were trying to infect it. Trying from a completely different computer wouldn't hurt. Static IP on the host computer doesn't hurt either Smile

one more thing, I've sometimes found that a while-powered-on-20-second-hold-then-release of the reset button can work when the 30-30-30 for some reason doesn't.
Sponsor
marcusmpe
DD-WRT Novice


Joined: 23 Mar 2015
Posts: 1

PostPosted: Mon Mar 23, 2015 3:21    Post subject: Same problem, no solution in sight... Reply with quote
I'm running into this same problem, and can't figure out any path to go forward.

I haven't tried to flash this router at all until today, but I've done 2-3 others without any issues.

I'm out of options at this point. Any other thoughts on this? Even some ideas to gather some additional information would be appreciated.

Thanks
bugfinder
DD-WRT Novice


Joined: 23 Feb 2015
Posts: 4

PostPosted: Mon Mar 23, 2015 3:46    Post subject: Reply with quote
It might be interesting to know what happens if you try to flash it with the firmware from here:

http://support.linksys.com/en-us/support/routers/E3000
trafsta
DD-WRT Novice


Joined: 13 Dec 2006
Posts: 44

PostPosted: Thu May 14, 2015 15:23    Post subject: Reply with quote
I have the same problem with 1 of the ~20 E3000's that we have here. All of ours are working great on DD-WRT, except for one that used to be on DD-WRT that I installed the stock 1.0.06 (Build 2) firmware on to test some stability issues we were having with DD-WRT almost a year ago. Since going to this latest stock firmware I cannot get back to DD-WRT. No amount of 30/30/30 resetting has worked. I can flash any of the 50 or so WRT54G/GL/GS, WRT600N, E3000's, and other brand (netgear etc) from my workstation or laptop (Windows 7 32/64bit) without any issues, but this one stubborn E3000 with stock 1.0.06 Build 2 will not flash (stalls at same % complete every time with error, same as others have reported). I was following the thread @ http://www.dd-wrt.com/phpBB2/viewtopic.php?p=900362 for the past 10+ months to see if it would lead to a fix for me but it never did. It can't be a computer or cable issue, as I can flash to/from stock on any of my 50+ routers where I work (we have 20 E3000's that replaced a ton of older WRT54xx's which I still have lying around). I just can't flash to this latest stock linksys firmware, only can flash to older ones.

I cannot downgrade to older stock firmware either, the same issue occurs on this one particular E3000. I haven't messed with it in 6+ months but I have a need for another E3000 so I'm going to try yet again but was hoping someone would have a fix by now. All that I have seen is that there are now others with the same issue, so at least I know it's not just 1 or 2 of us anymore... looking for more ideas to fix this guy, they've been rock solid for us...

P.S. other flash methods have not worked (tftp from command line, old Linksys tftp client, etc) - although those methods work fine on other routers we have here. No AV or firewall software exists, the laptop I use for this sort of stuff is stock windows 7 32bit even. Using a static IP, have tried IE, Firefox portable, Chrome, etc...
Malachi
DD-WRT Guru


Joined: 17 Jul 2012
Posts: 6981
Location: Columbus, Ohio

PostPosted: Thu May 14, 2015 16:00    Post subject: Reply with quote
Use serial to flash it.
_________________
I am far from a guru, I'm barely a novice.
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11436
Location: Wherever the wind blows- North America

PostPosted: Thu May 14, 2015 16:57    Post subject: Reply with quote
Directly from my notes regarding the E3000. (below)...if you are trying to flash from the tftp utility then it shouldn't care what firmware is on the unit. Unless...the newer firmware altered the CFE of that unit and that isn't very likely.

If you want K2.6..then stop after the first mega_nv60k load....and you should be able to run any mega.bin build of K2.6 without the need for trailed builds any longer.


redhawk

Code:
Getting K3.x loaded.

Started with
K2.6_21676_mini_e3000 ....next load
K2.6_21676_mega_nv60K ....then load
K3.x_21676_mega_nv60K

....after that went to newer K3.x_mega builds directly...no need for nv60K builds any longer.

hard reset....192.168.1.1


LOM:
The easiest way of flashing an E3000 when you have serial terminal attached is:

nvram set safe_mode_upgrade=on
nvram commit
reboot

now connect with your browser to 192.168.1.1 which will bring up the CFE recovery gui page where you can upload the firmware.

_________________
Donations have dwindled so testing is limited to C/CB and R/RB modes on just a few newer models. No old router testing performed any longer.

Looking for more test units (newer models only) for the project...got a brick?...PM me to make a hardware donation. (USA) A donation is not a debricking service....it is a way to "Give back" to the dd-wrt project.

I do NOT provide personal assistance through chat or phone....so please don't ask.
trafsta
DD-WRT Novice


Joined: 13 Dec 2006
Posts: 44

PostPosted: Fri May 15, 2015 13:47    Post subject: Reply with quote
Well I hate to say this, but I started reading up on the serial flashing methods, read a few pages about it, watched a video, and I then decided to give the linksys firmware utility one final try (I haven't tried it in at least 6 months) and this time around it worked just fine downgrading to an older stock firmware file. The only thing that I think MAY have been different, was that I did not have the standard password on the unit (I had changed it yesterday)... and I entered that new password into the linksys tftp program while flasing... and voila it went down to the older stock firmware (1.0.04.006), and from there I was able to go to a DD-WRT E3000 trailed build without an issue.

All I can say is WOW... the only other thing I can see different today is that the unit was nice and cool since I just powered it on... but yesterday while trying tftp.exe and web-browser based flashing I had noticed it was quite hot... not sure if it's any hotter than the rest of the E3000's we have around here (have to get up on a ladder to check sometime..) but regardless it is now back on DD-WRT and I'm quite happy, although still a bit confused as to what the problem was...

Sorry for wasting your time! In the end this must have somehow been an ID-10T error, or PEBCAK issue of some kind Sad

P.S. I've been using "dd-wrt.v24-15962_NEWD-2_K2.6_std_usb_nas-e3000.bin" for years now, as it is very stable and from what I read in the past one of the most reliable and stable builds for the E3000. Would you guys recommend using a newer build that offers the same stability or should I just stick with what seems to work well (15962)?
Goto page Previous  1, 2 Display posts from previous:    Page 2 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum