WDR4300 zerflasht ....

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> ARM oder PPC basierte Hardware
Author Message
tuxman1971
DD-WRT Novice


Joined: 19 Apr 2012
Posts: 3

PostPosted: Sat Apr 26, 2014 17:18    Post subject: WDR4300 zerflasht .... Reply with quote
Hallo liebe Leute !

wie ich schon geschrieben habe, habe ich meinen TP-WDR4300 bem flashen zerschossen.
so bin ich vorgegangen:

1. factory-to-ddwrt.bin geflasht.
2. User und pw gesetzt in der Pseudo-ddwrt.
3. dann das finale Image geflasht, ohne dem 30-30-30 Reset dazwischen.

das Resultat ist, das der Router immer wieder neu bootet und alle LEDs zugleich blinken.
also habe ich mich ein bischen schlau gemacht, eine RS232 eingebaut und geguckt.
mit TFTP habe ich dann versucht das file zu flashen.
der Router baut die Verbindung auf, holt sich das File ab, und flasht es scheinbar.
Aber... danach ist wieder das selbe.
Diese Meldung habe ich auf der seriellen Konsole:
=>
U-Boot 1.1.4 (Jun 17 2013 - 12:31:57)

U-boot DB120


DRAM: 128 MB
id read 0x100000ff
flash size 8MB, sector count = 128
Flash: 8 MB
Using default environment

PCIe Reset OK!!!!!!
In: serial
Out: serial
Err: serial
Net: ag934x_enet_initialize...
No valid address in Flash. Using fixed address
wasp reset mask:c03300
WASP ----> S17 PHY *
: cfg1 0x7 cfg2 0x7114
eth0: ba:be:fa:ce:08:41
athrs17_reg_init: complete
eth0 up
eth0
Autobooting in 1 seconds
## Booting image at 9f020000 ...
Uncompressing Kernel Image ... Too big uncompressed streamLZMA ERROR 1 - must RESET board to recover
<=

das wiederholt er jetzt endlos ...

Hat jemand eine Idee wie ich den Router löschen kann?
ein 30-30-30 Reset birngt da nichts leider.

Vielleicht kann mir ja jemand einen Tipp geben, wäre dankbar dafür.

Herzliche Grüße aus Österreich!

Update:
Ich konnte ihn jetzt nach gefühlten 1000 Versuchen mit "tpl" + "Enter" aus der Boot-Schleife bringen.
Wie kann ich jetzt den Speicher löschen, bzw. welchen Bereich sollte ich nach "erase" angeben ?
Ich wäre für Infos sehr dankbar !!!
MfG

Update2:

db12x> printenv
bootargs=console=ttyS0,115200 root=31:02 rootfstype=squashfs init=/sbin/init mtdparts=ath-nor0:256k(u-boot),64k(u-boot-env),63 36k(rootfs),1408k(uImage),64k(mib0),64k(ART)
bootcmd=bootm 0x9f020000
bootdelay=1
baudrate=115200
ethaddr=0xba:0xbe:0xfa:0xce:0x08:0x41
ipaddr=192.168.1.111
serverip=192.168.1.100
dir=
lu=tftp 0x80060000 ${dir}u-boot.bin&&erase 0x9f000000 +$filesize;cp.b $fileaddr 0x9f000000 $filesize
lf=tftp 0x80060000 ${dir}db12x${bc}-jffs2&&erase 0x9f050000 +0x630000;cp.b $fileaddr 0x9f050000 $filesize
lk=tftp 0x80060000 ${dir}vmlinux${bc}.lzma.uImage&&erase 0x9f680000 +$filesize;cp.b $fileaddr 0x9f680000 $filesize
stdin=serial
stdout=serial
stderr=serial
ethact=eth0

Environment size: 686/65532 bytes
db12x> erase FLASH 0x9f680000
Bad address format
db12x>

was kann oder soll ich da jetzt mit erase NVRAM xxx löschen ???
hat wer eine Idee ?
Sponsor
tuxman1971
DD-WRT Novice


Joined: 19 Apr 2012
Posts: 3

PostPosted: Sun Apr 27, 2014 12:44    Post subject: Reply with quote
gibts hier wirklich keinen der irgend welche Infos dazu hätte ?

kann mir jemand helfen bez. was hier flasch gelaufen ist, bzw. welches Image ich für das wiederherstellen per TFTP benutzen kann/soll?

wäre dankbar für jede "Zeile"

MfG
tuxman1971
DD-WRT Novice


Joined: 19 Apr 2012
Posts: 3

PostPosted: Sun Apr 27, 2014 18:23    Post subject: traurig ... aber scheinbar in Mode ... Reply with quote
so liebe Leute ...
Nachdem es hier wirklich absolut niemand schafft oder für Wert befindet, jemandem zu helfen werde ich meine Erfahrung auch nicht weiter teilen!

Es sei nur soviel gesagt:
Dank eines freundlichem Helfers aus einer anderem Comunity läuft der Router wieder einwandfrei.

sollte noch Jemand ein ähnliches Problem haben, hier ist der Verweis:
http://wiki.openwrt.org/toh/tp-link/tl-wdr4300

ab dem Punkt:
de-brick or OEM installation using the TFTP and RS232 (serial) method!!

Hier wird ausfühlich erklärt wie es zu handhaben ist.
Allerdings funktioniert dieser Weg auch nur genau mit dem Image von open-WRT!

Wie es mit einem Image von DD-WRT funktioniert werden einige hier sicherlich wissen, aber da sie keine Infos weitergeben wollen, werde ich es auch nicht machen, da, ab heute, meine zukünftigen Router aller Kunden unter open-WRT laufen werden!

trotzdem Grüße aus Ö
derNils
DD-WRT Novice


Joined: 03 Apr 2014
Posts: 7

PostPosted: Tue Jun 03, 2014 21:29    Post subject: Reply with quote
Hallo,

mein Router läuft leider auch nicht mehr als solcher, nur noch als Bridge oder Hub.

Mal schauen, ob ich mit dem anderen Forum weiterkomme.

Echt schade, das keine brauchbare Hilfe kommt, aber vielleicht liegt es halt daran, dass es zu selten diese Probleme gibt.

Gruß
Nils
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 6840
Location: Dresden, Germany

PostPosted: Thu Oct 23, 2014 15:58    Post subject: Re: traurig ... aber scheinbar in Mode ... Reply with quote
tuxman1971 wrote:
so liebe Leute ...
Nachdem es hier wirklich absolut niemand schafft oder für Wert befindet, jemandem zu helfen werde ich meine Erfahrung auch nicht weiter teilen!

Es sei nur soviel gesagt:
Dank eines freundlichem Helfers aus einer anderem Comunity läuft der Router wieder einwandfrei.

sollte noch Jemand ein ähnliches Problem haben, hier ist der Verweis:
http://wiki.openwrt.org/toh/tp-link/tl-wdr4300

ab dem Punkt:
de-brick or OEM installation using the TFTP and RS232 (serial) method!!

Hier wird ausfühlich erklärt wie es zu handhaben ist.
Allerdings funktioniert dieser Weg auch nur genau mit dem Image von open-WRT!

Wie es mit einem Image von DD-WRT funktioniert werden einige hier sicherlich wissen, aber da sie keine Infos weitergeben wollen, werde ich es auch nicht machen, da, ab heute, meine zukünftigen Router aller Kunden unter open-WRT laufen werden!

trotzdem Grüße aus Ö


es geht mit dem factory-to-ddwrt.bin image exakt auf die selbe weise wie mit openwrt

_________________
one cigarette costs 2 minutes of your life.
one bottle of beer costs 4 minutes of your life.
one working day costs 8 hours of your life.

Yummee:
Linux DD-WRT 4.14.8 #42 SMP PREEMPT Thu Dec 21 18:11:16 CET 2017 armv7l DD-WRT
root@DD-WRT:/sys# nvram get DD_BOARD
Netgear R7800
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> ARM oder PPC basierte Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum