Access restrictions not working

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
canadiangsx
DD-WRT Novice


Joined: 21 Dec 2010
Posts: 4

PostPosted: Tue Dec 06, 2011 3:31    Post subject: Access restrictions not working Reply with quote
I've searched and none of the access restriction threads have solutions or insight on the problem.

I'm running v24-sp2 on a wrt150n.

Trying to get access restrictions to work and nothing I do works.

MAC address, IP address, MAC & IP...you get my drift.

Actually, I'm posting this while a deny 24hours restriction is in effect.

Makes no sense at all.

Anyone ever figure it out? Or is it something not supported?

Any help is appreciated as I need to block access 00:00 to 07:00 and filter sites the rest of the time.

Thanks!

- Lou
Sponsor
Murrkf
DD-WRT Guru


Joined: 22 Sep 2008
Posts: 12680

PostPosted: Tue Dec 06, 2011 3:55    Post subject: Reply with quote
Peacock announcement note 7.

Properly configured with a proper build, access restrictions will shut down users.

Try 12:01 - 7:00

Try selecting each day, rather than "everyday".

_________________
SIG:
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
canadiangsx
DD-WRT Novice


Joined: 21 Dec 2010
Posts: 4

PostPosted: Tue Dec 06, 2011 4:33    Post subject: Reply with quote
Appreciate the hints.

No go on selecting individual days.

I set Mon/Tue and 23:30 - 23:59 (I am in EST)

Client ip of host machine to be blocked is in the list

(I've also tried mac alone and mac/ip combo)

Deny rule enabled


Still posting Smile

- Lou
Johnny Rotten
DD-WRT Novice


Joined: 02 Oct 2009
Posts: 7

PostPosted: Thu Dec 08, 2011 4:49    Post subject: Access Restrictions not working Reply with quote
I'm having the same issue

I have 2 routers in AP mode, WRT54GS V4 as the gateway and WRT54GL V1.1 as the router.
Both are using Firmware Version DD-WRT v24-sp2 (08/12/10) std - build 14929 and neither access restriction policies work when setup as the main router.

The funny thing is I had wrt.v24_vpn_generic.bin build 13064 installed in both routers for 2 years without any issues, until I had a couple of crashes due to I think, too many port forwards, so I went for the standard version for a little more ram space and decided to go for the recommended brainslayer 14929 build, which doesn't seem to be working for me.

Any help would be greatly appreciated.

TIA Johnny
LarrySDonald
DD-WRT Novice


Joined: 17 Feb 2012
Posts: 2

PostPosted: Fri Feb 17, 2012 19:42    Post subject: Reply with quote
Same thing here, v24 sp2 on a WRT54G v2. I've denied the IP and MAC I'm posting from, tested all days instead of everyday, etc. Nothing. Packets go through just fine. I'm hoping to use it to block everything but L2TP for when using a VPN so as to not leak if the connection drops, yet otherwise leave all other devices untouched and running directly.
xanadu
DD-WRT Novice


Joined: 18 Jun 2012
Posts: 3

PostPosted: Fri Jun 22, 2012 16:25    Post subject: Reply with quote
Sorry to reply to an old post, but did anyone find a solution? I just moved to DD-WRT from Tomato and found myself faced with the same problem.

I'm using V24 pre_sp2 on a Asus RT-N13U B1.

Thanks!
bmerc
DD-WRT Novice


Joined: 09 Aug 2012
Posts: 1
Location: Laval, QC, Canada

PostPosted: Thu Aug 09, 2012 22:11    Post subject: Reply with quote
I have exactly the same problem here.

However, in my case, I found out that the issue is caused by having an Openvpn client enabled on the router. Disabling the openvpn client solves the problem.

I have tried to work around the problem by leaving the VPN on during the day, and setting cron jobs to disable the vpn at midnight, and restart it in the morning. My access restrictions are just to deny internet access after midnight after all.

The weird thing is that if the vpn is enabled but not running, the access restrictions still does not work! For example, the vpn client is enabled. I do a "killall openvpn", which shut downs the vpn. Access restrictions does not work. The client needs to be Disabled for access restrictions to work.

Any idea??

Thanks,

Benoit.
srb2975
DD-WRT Novice


Joined: 06 Mar 2013
Posts: 1

PostPosted: Wed Mar 06, 2013 6:43    Post subject: Post subject: Access Restrictions not working Reply with quote
Has anyone come up with a solution to this other than buying another router? Have flashed firmware multiple times and tried all other suggestions with no success.
Egghead
DD-WRT Novice


Joined: 14 Nov 2013
Posts: 1

PostPosted: Thu Nov 14, 2013 18:00    Post subject: Access restrictions Reply with quote
Hi, I know this thread is a bit old but came across it while having problems with access restrictions.
I found the default time server wasnt working and so the time (top right) was wrong. Typed in another and then it worked ok.
Also I had started with filtering mac addresses and went onto fixed IP addresses and filtering them instead (easier to identify) I forgot to delete the mac addresses from the filtering list, which caused some problems.
Also try not starting more than one rule at the same time.
v24 sp2 TL-WR1043ND
dagwud
DD-WRT Novice


Joined: 11 Jan 2014
Posts: 2

PostPosted: Sat Jan 11, 2014 0:50    Post subject: Either MAC or IP Reply with quote
Ok, so I'm not the only one flummoxed by this.

On my router, it seems that MAC addresses only work for access restrictions if the IP address of the computer is dynamically assigned.

Once I assigned static IP numbers to our computers, the access restrictions stopped working. I deleted the MAC address entries and assigned clients based on IP address, and the restrictions worked again.

Can't guarantee this'll be the issue for everyone, but it was for me.
MidnightJava
DD-WRT Novice


Joined: 07 Mar 2013
Posts: 10
Location: Springfield, VA

PostPosted: Sat Jan 11, 2014 4:37    Post subject: Reply with quote
I switched to a Kong build, and access restrictions have worked ever since. It sounds like no one is ever going to fix them in the other builds.
_________________
Router: Linksys E2500
Firmware: DD-WRT v24-sp2 (06/08/12) big - build 19342
dagwud
DD-WRT Novice


Joined: 11 Jan 2014
Posts: 2

PostPosted: Sat Jan 11, 2014 13:39    Post subject: Reply with quote
I'm currently using the most recent Brainslayer build, not the one that comes up from the database.

From what I can tell, my router isn't yet included in the list of models that Kong's build supports.
Roger W
DD-WRT Novice


Joined: 23 Apr 2014
Posts: 7

PostPosted: Wed Apr 23, 2014 5:55    Post subject: Reply with quote
dagwud wrote:
I'm currently using the most recent Brainslayer build, not the one that comes up from the database.

From what I can tell, my router isn't yet included in the list of models that Kong's build supports.


I might have a fix for you -

I have a Linksys E2000 and have been on 14929 for years, but just upgraded to the latest Brainslayer (23919 vpn) to get 4 years of random security and other fixes.

After the update, Access Restrictions (one total Deny, based on MAC) didn't work, and it did on the old build.

I read through tickets that might be related and found this one:

http://svn.dd-wrt.com/ticket/2954

deciphering the tangle of ideas and mutual frustration in that thread, I got the impression that a couple years ago, a firewall module changed to a different one, and the new one sits differently in the stack of filters, so when it's on, the Access Restrictions get skipped entirely.

With this in mind, I looked around the web gui and tinkered with some settings. I found that in Security - Firewall, if I Disable the top line of Stateful SPI Firewall, then suddenly Access Restrictions takes effect again.

On the surface this seems like a bad tradeoff, but I think I'm ok with it - this isn't the setting for the overall firewall, just the Stateful Packet Inspection system that I don't expect to do much in a home router anyway.

I hope this helps others!

ETA - Also confusing things is an apparent bug in time zone offsets, if you tell the web gui that you're not in UTC. To make my time-based Deny work, I set my timezone to UTC, set the access rules in terms of UTC time, and unfortunately then had to split it into two rules spanning midnight, one for M-F and the second Tu-Sa. But at least it works now.
Vorpike
DD-WRT Novice


Joined: 07 Jun 2014
Posts: 17

PostPosted: Wed Jul 16, 2014 0:50    Post subject: Reply with quote
I don't get dadwug's method, and the above method doesn't work either.
Roger W
DD-WRT Novice


Joined: 23 Apr 2014
Posts: 7

PostPosted: Wed Jul 16, 2014 6:01    Post subject: Reply with quote
Vorpike wrote:
I don't get dadwug's method, and the above method doesn't work either.


Yeah, my method above turns out to only sporadically work, unfortunately. I ended up giving up on it but also no longer need the feature active so I stopped looking for other workarounds.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum