IGMP Snooping/Proxy - YouView IPTV - Netgear Config

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
Wriggerz
DD-WRT Novice


Joined: 14 Aug 2013
Posts: 5

PostPosted: Wed Aug 14, 2013 8:38    Post subject: IGMP Snooping/Proxy - YouView IPTV - Netgear Config Reply with quote
Hi all,

I'm new poster to the forums, however have been here many times to find help for other issues i've had.

I have done a fair bit of reading around this one but thought someone might able to help. Unfortunately the info that is currently out there is all over the show and I can't seem to find a config that works.

I have a WNDR3800, running 22118, connected by the GIG port to an unmanaged Netgear GS608 which is then connected to a Humax T1000 IPTV Receiver amongst other devices.

I have disabled the multicast filter on the firewall and have loaded the script below to stop Multicast packets flooding the WLAN.

Quote:

insmod ebtables
insmod ebtable_filter
insmod ebt_pkttype
ebtables -A FORWARD -o "ath0" --pkttype-type multicast -j DROP
ebtables -A OUTPUT -o "ath0" --pkttype-type multicast -j DROP


When I run the command "ebtables -L" the console confirms that these rules are in place.

WLAN still works which is a good sign, but the IPTV box still isn't picking up any IP channels.

Is there something i'm missing? Does DD-WRT work with IPTV?

I've been trying to find out whether IGMP support is built in to the latest builds or not but i can't find detailed info on this either way. I have read somewhere something about it being built in to certain kernels but that goes a bit beyond my current level of knowledge, but always happy to learn!!

Been using DD-WRT as the platform for my router for a few years now and this is the only issue i've really struggled with. I don't want to move to another platform, not even sure another platform would support this function but i don't want to waste time if DD-WRT is capable, which i'm sure it is....

Apologies for the super long first post but hopefully the community can help me learn and understand as it has done for the last few years.

I look forward to discussing this problem further and finding a solution.
Sponsor
Wriggerz
DD-WRT Novice


Joined: 14 Aug 2013
Posts: 5

PostPosted: Wed Aug 14, 2013 8:42    Post subject: Reply with quote
Just another point i forgot to make....

I have tried both of the solutions described here:
http://www.dd-wrt.com/wiki/index.php/Setting_up_IPTV_without_impact_to_LAN_and_Wireless_traffic

But the first, which involves creating VLANs doesn't work for me as the GUI is different. It goes in to VLAN tagging and bridging which is a bit foreign to me and i don;t want to break anything.

I am happy to learn but can't find any detailed info on this either.

Thanks
Wriggerz
DD-WRT Novice


Joined: 14 Aug 2013
Posts: 5

PostPosted: Wed Aug 14, 2013 16:05    Post subject: igmpproxy not running Reply with quote
OK, thought i'd try some commands to see what output i get.

imgprt -h brings up "Usage: imgpproxy [-h] [-d] [-v [-v]]" and some details around each of the commands.

imgpproxy -h comes back with:
/bin/sh: eval: line 1: igmpproxy: not found

So i tried insmod imgpproxy to see if that would install it?? Some will probably laugh.

It came back with something about imgpproxy.ko not being found..... Can't remember exactly, just logged off the router.

It was a long shot! But it doesn;t look like IMGPProxy is running on my router.

Can someone help?? Pleeeaaaasssseeee!

I want to watch BT Sport.
greenair
DD-WRT Novice


Joined: 10 Sep 2013
Posts: 1

PostPosted: Tue Sep 10, 2013 16:34    Post subject: Reply with quote
I need similar help too.
just replaced my talktalk HG533 Router with a netgear router running dd-wrt. the broadband works perfectly but the iptv is gone. cant find IGMP settings anywhere.
can anyone post some simple solutions for the missing settings please?
Pakirava.Datsuma
DD-WRT Novice


Joined: 22 May 2013
Posts: 2

PostPosted: Thu Sep 26, 2013 13:36    Post subject: igmpproxy renamed to igmprt Reply with quote
I found that igmpproxy in DD-WRT v24-sp2 (which I have) is renamed to igmprt.
So to launch it just type:
igmprt <config.conf>

This also listed in
igmprt -h

Also I found that config file creates at every boot-time and is /tmp/igmpproxy.conf
And enabling/disabling option "Filter Multicast" just starts igmprt with/without that config file.
So solution that I found is to save startup commands with modifying that config file.
Pakirava.Datsuma
DD-WRT Novice


Joined: 22 May 2013
Posts: 2

PostPosted: Thu Sep 26, 2013 13:38    Post subject: Reply with quote
found it here (carefully! In russian!)
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum