How to disable SSID on Repearter Bridge

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Tue Apr 17, 2012 22:21    Post subject: How to disable SSID on Repearter Bridge Reply with quote
I have a Linksys wrt54g v2 router with DD-WRT V24 Sp2, build 12548 installed. It is configured as a repeater bridge. Everything is working fine. However I would like to disable the wireless SSID broadcasting. I changed the settings from enable to disable. It is still broadcasting the SSID. I checked the tutorial again. It said to make it enable as if disable was a incorrect setting. So is there a way to disable SSID broadcasting?
Thanks for any replies. Hope I didn't leave out any Info!
Sponsor
UrbanVoyeur
DD-WRT User


Joined: 19 Jun 2010
Posts: 118
Location: Brooklyn, NY

PostPosted: Tue Apr 17, 2012 23:14    Post subject: Reply with quote
Is SSID disabled on both the primary and secondary routers?
_________________
Linksys E900 dd-wrt v24-sp2 18946 mini
Linksys E3000 dd-wrt v24-sp2 15692 std-usb-nas
D-Link DIR-601 Gargoyle 1.5.3 ar71xx dir 600 a1 squashfs
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Tue Apr 17, 2012 23:24    Post subject: Reply with quote
No it is not.
Wait there is no option for that.
UrbanVoyeur
DD-WRT User


Joined: 19 Jun 2010
Posts: 118
Location: Brooklyn, NY

PostPosted: Wed Apr 18, 2012 0:51    Post subject: Reply with quote
Let me see if I understand:
- You have two routers, a primary and a secondary.
- The secondary, a wrt54g v2, is set up as a client or bridge repeater
- Both the primary and secondary have SSID's

To disable broadcast you have to set the SSID to disable in the management interfaces of both the primary and secondary.

On the secondary, if you are connecting on one wireless interface and repeating on another, make sure to turn off the broadcast on the repeater interface.

Basic Settings ---> Wireless SSID Broadcast ---> Disable

_________________
Linksys E900 dd-wrt v24-sp2 18946 mini
Linksys E3000 dd-wrt v24-sp2 15692 std-usb-nas
D-Link DIR-601 Gargoyle 1.5.3 ar71xx dir 600 a1 squashfs
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Wed Apr 18, 2012 1:48    Post subject: Reply with quote
I don't think you understand. I am using the "repeater bridge" to connect to a router(using dd-wrt firmware) that is transmitting wireless (WiFi) from a antenna about 300' away. That router is transmitting a SSID. I connect to the "repeater bridge" with a Ethernet cable to my desktop PC. I also connect wireless to the repeater bridge with my laptop. The router (WIFI) has a password. The password is given to those who pay a fee. In order for the "repeater bridge" and the WIFI router to connect both must have the same password. Someone looking for "available networks" could see mine. If they had paid for the use of the WIFI and tried that password on mine they could connect. That would take bandwith away for me. So I don't want to broadcast my SSID. If you had ever configured a Repeater Bridge or read the tutorial you would understand what I am saying. I may not be explaining it very well. The tutorial says to enable the transmitting of the SSID. I clicked on disable transmitting and it did nothing. So my question "is there a way to make it not transmit a SSID".
CmdrSunshine
DD-WRT Novice


Joined: 16 Apr 2012
Posts: 14

PostPosted: Wed Apr 18, 2012 2:44    Post subject: Reply with quote
I don't think it's really possible to do what you're thinking of. The second router is a repeater, and any time it receives a frame from the access point, it WILL retransmit it. So if your first router is transmitting an SSID, your second router will send it out too.

I basically see four options, only one of which is any good:
1) Disable SSID broadcasts on the first router. (Bad idea.)
2) Add a MAC address filter to your second router. (Bad idea; other people's devices will still see the router, and try to connect to it, but then fail. This will happen even to users who are allowed to connect to the first router. Users will think your network is broken.)
3) Put a second VLAN on your wireless interface to create a custom secondary network (with its own SSID and password). This won't stop other people from connecting to your second access point unless you combine it with a MAC filter like in option 2. This is possibly the worst idea of all.
4) Buy another router or WAP. Convert your second router into a client bridge, and connect the new router to your client bridge with an ethernet cable. Use the new router to create a secondary wifi network with a different password and SSID. You can use pretty much any router for this, even ones that don't run DD-WRT. This is the best option by far.
Hidden option 5) Set the second router to AP mode and use crazy VLAN magic.

I recommend option 4. It will improve your network performance AND prevent other users from connecting to your wifi without borking your network.
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Wed Apr 18, 2012 3:12    Post subject: Reply with quote
Hmm I need to read this over a couple times. A lot to digest. Thank you for all your help. BTW this set up works great. In fact we are thinking of setting up a few repeaters in places where we have poor reception. SSID broadcasting will not be a problem with them. Thanks again for all your help
CmdrSunshine
DD-WRT Novice


Joined: 16 Apr 2012
Posts: 14

PostPosted: Wed Apr 18, 2012 3:15    Post subject: Reply with quote
If you're confused about what I said just do the fourth thing and buy a new wireless router. You can get them REALLY cheaply either by finding refurbished units on websites like Newegg, clearance items (also from Newegg), or by checking secondhand stores. If you buy from a secondhand store remember to test the router before buying - caveat emptor.
UrbanVoyeur
DD-WRT User


Joined: 19 Jun 2010
Posts: 118
Location: Brooklyn, NY

PostPosted: Wed Apr 18, 2012 3:17    Post subject: Reply with quote
Until you create a virtual wireless interface, the repeater bridge does not transmit anything.

The first, (physical) wireless interface on the repeater is used to connect to the primary router. It does bridge this connection to the internal Ethernet ports.

The SSID you are seeing is from the primary.

If you want to connect wireless clients to the secondary router, you will need to create a virtual interface using the "add" button basic settings page.

You can choose to display or hide that interface.

Please see:
http://www.dd-wrt.com/wiki/index.php/Repeater_Bridge

_________________
Linksys E900 dd-wrt v24-sp2 18946 mini
Linksys E3000 dd-wrt v24-sp2 15692 std-usb-nas
D-Link DIR-601 Gargoyle 1.5.3 ar71xx dir 600 a1 squashfs
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Wed Apr 18, 2012 4:21    Post subject: Reply with quote
UrbanVoyeur I did make a virtual interface. I also gave it a different SSID. That is the SSID I see being broadcast. The reference you gave is what I followed. Like I said before it is working perfect. I just would like to stop broadcasting the SSID from the virtual interface. But that seems to not be possible.
UrbanVoyeur
DD-WRT User


Joined: 19 Jun 2010
Posts: 118
Location: Brooklyn, NY

PostPosted: Wed Apr 18, 2012 11:25    Post subject: Reply with quote
grandpa wrote:
UrbanVoyeur I did make a virtual interface. I also gave it a different SSID. That is the SSID I see being broadcast. The reference you gave is what I followed. Like I said before it is working perfect. I just would like to stop broadcasting the SSID from the virtual interface. But that seems to not be possible.


If you hit "apply" and rebooted and it still broadcasts then it must be a bug. Have you tried the recommended version - 14929? or one of the other stable builds, like 15962? 12548 is old.

_________________
Linksys E900 dd-wrt v24-sp2 18946 mini
Linksys E3000 dd-wrt v24-sp2 15692 std-usb-nas
D-Link DIR-601 Gargoyle 1.5.3 ar71xx dir 600 a1 squashfs
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Wed Apr 18, 2012 13:53    Post subject: Reply with quote
12548 was recommended by Murrkf I believe. So no I have not tried any others. But in your last post you said to also reboot. Now that is something I have not done. It is on 24/7. So I will try that and get back.
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Wed Apr 18, 2012 14:47    Post subject: Reply with quote
I rebooted and it did not make a difference. I have another wrt54g v 2 linksys router. Which build would you recommend to try?
UrbanVoyeur
DD-WRT User


Joined: 19 Jun 2010
Posts: 118
Location: Brooklyn, NY

PostPosted: Wed Apr 18, 2012 15:19    Post subject: Reply with quote
grandpa wrote:
I rebooted and it did not make a difference. I have another wrt54g v 2 linksys router. Which build would you recommend to try?

Try them both: 14929 and 15962. Do a 30-30-30 before and after each flash.

_________________
Linksys E900 dd-wrt v24-sp2 18946 mini
Linksys E3000 dd-wrt v24-sp2 15692 std-usb-nas
D-Link DIR-601 Gargoyle 1.5.3 ar71xx dir 600 a1 squashfs
grandpa
DD-WRT Novice


Joined: 14 May 2010
Posts: 29

PostPosted: Wed Apr 18, 2012 16:44    Post subject: Reply with quote
OK will do in a few days. Yes 30-30-30 is very important! Thanks again!
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum