DWL-2100AP

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... , 17, 18, 19  Next
Author Message
vpritiskovic
DD-WRT User


Joined: 28 Aug 2009
Posts: 248
Location: Dalmatia, Croatia

PostPosted: Wed Sep 14, 2011 9:59    Post subject: Reply with quote
@Sash

Where is the problem?

_________________
DD-WRT v24-sp2 (01/21/12) std - build 18613 @SX763
DD-WRT v24-sp2 (10/12/12) std - build 20119 @WZR-HP-G300NH (b0 b0)
Sponsor
vpritiskovic
DD-WRT User


Joined: 28 Aug 2009
Posts: 248
Location: Dalmatia, Croatia

PostPosted: Thu Sep 15, 2011 16:59    Post subject: Reply with quote
@Sash
Please make the long awaited test build...

_________________
DD-WRT v24-sp2 (01/21/12) std - build 18613 @SX763
DD-WRT v24-sp2 (10/12/12) std - build 20119 @WZR-HP-G300NH (b0 b0)
n-di
DD-WRT Novice


Joined: 16 Sep 2011
Posts: 4
Location: Russia, Sibir

PostPosted: Fri Sep 16, 2011 4:31    Post subject: Reply with quote
thanx to vpritiskovic connecticus & Reiter (from openwrt forum)
after reading yours posts i'm successfully upgrade firmware on my DWL-2100AP A4 to OpenWRT Smile
but some trouble i have and wiki needs to be updated to correct procedure of flashing DWL2100.

_________________
OpenWRT backfire 10.03.1-rc5 @ D-link DWL-2100AP A4
n-di
DD-WRT Novice


Joined: 16 Sep 2011
Posts: 4
Location: Russia, Sibir

PostPosted: Sat Sep 17, 2011 20:41    Post subject: Reply with quote
I wrote a detailed step-by-step guide on installing OpenWRT on d-link dwl2100-ap rev a4 router using serial, you may download it at http://rghost.net/22014711


MOD: deleted the stupid instruction which bricks routers!

_________________
OpenWRT backfire 10.03.1-rc5 @ D-link DWL-2100AP A4
vpritiskovic
DD-WRT User


Joined: 28 Aug 2009
Posts: 248
Location: Dalmatia, Croatia

PostPosted: Tue Oct 18, 2011 10:16    Post subject: Reply with quote
BUMP, SASH?
_________________
DD-WRT v24-sp2 (01/21/12) std - build 18613 @SX763
DD-WRT v24-sp2 (10/12/12) std - build 20119 @WZR-HP-G300NH (b0 b0)
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17619
Location: Hesse/Germany

PostPosted: Mon Oct 24, 2011 13:47    Post subject: Reply with quote
i still have problems getting my kristech kt-link running with urjtag. i checked out the current urjtag tree (i think) and it builds sucessfull but i doesnt have kt-link support. following the porter of the kt-link the patch should be already in the current tree. if someone has some hints....
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
vpritiskovic
DD-WRT User


Joined: 28 Aug 2009
Posts: 248
Location: Dalmatia, Croatia

PostPosted: Sat Oct 29, 2011 19:17    Post subject: Reply with quote
@Sash

Ok, redboot can be done later...
Can you please provide a generic atheros build, either (kernel + rootfs) or combined one that fit into (4MB-custom redboot) for test?

HW:http://wiki.openwrt.org/toh/d-link/dwl-2100ap#hardware

_________________
DD-WRT v24-sp2 (01/21/12) std - build 18613 @SX763
DD-WRT v24-sp2 (10/12/12) std - build 20119 @WZR-HP-G300NH (b0 b0)
afm
DD-WRT Novice


Joined: 21 Apr 2007
Posts: 11

PostPosted: Wed Nov 23, 2011 19:55    Post subject: Reply with quote
After putting the redboot and give the command "reset" my 2100 is in this state.

WAP-G02A Boot Procedure V1.0
---------------------------------------------------------
Start ..Boot.B14..

Atheros AR5001AP default version 3.0.0.43A


0
auto-booting...

Attaching to TFFS... tffsDevCreate failed.
usrTffsConfig failed.

Error loading RUNTIME file: errno = 0x0.
Attaching to TFFS... tffsDevCreate failed.
usrTffsConfig failed.

Error loading BACKUP file: errno = 0x0.
Can't load boot file!!

ar531x rev 0x00005850 firmware startup...
SDRAM TEST...PASSED


how to fix it?

Thanks
vpritiskovic
DD-WRT User


Joined: 28 Aug 2009
Posts: 248
Location: Dalmatia, Croatia

PostPosted: Wed Nov 23, 2011 20:27    Post subject: Reply with quote
You have still factory loader...
What did you wanted to do with redboot loader and where did you get it?

_________________
DD-WRT v24-sp2 (01/21/12) std - build 18613 @SX763
DD-WRT v24-sp2 (10/12/12) std - build 20119 @WZR-HP-G300NH (b0 b0)
afm
DD-WRT Novice


Joined: 21 Apr 2007
Posts: 11

PostPosted: Thu Nov 24, 2011 1:06    Post subject: Reply with quote
I'm trying to change the original soft of 2100,with the manual of n-di "Installing_OpenWRT_on_D-link_dwl-2100ap_a4.pdf" in the manual say:

5) Load RedBoot to RAM:
type in boot prompt:

[Boot]: $ae(1,0)hai:redboot220.img h=192.168.1.175 e=192.168.1.1:0xffffff00 f=0x80
Attached TCP/IP interface to ae1.
Attaching network interface lo0... done.
Loading... 279808
Starting at 0x80010000...

+
RedBoot startup
FLASH configuration checksum error or invalid key
Can't get BOOTP info, using default IP address
Ethernet eth1: MAC address 00:1c:f0:89:79:82
IP: 192.168.1.1, Default server: 0.0.0.0

RedBoot(tm) bootstrap and debug environment [RAM]
Non-certified release, version v2_0 - built 17:10:53, Nov 22 2009
With changes made by Artur Korobov <elgenius@yandex.ru>

Copyright (C) 2000, 2001, 2002, Red Hat, Inc.

RAM: 0x80010000-0x80800000, 0x80054500-0x807e1000 available
FLASH: 0xbe000000 - 0xbe3e0000, 62 blocks of 0x00010000 bytes each.
RedBoot>

6) Write RedBoot to ROM:
Warning! The next command will format your router's flash so you will not be able to boot the original firmware anymore.
RedBoot> fis init -f
About to initialize [format] FLASH image system - continue (y/n)? y
*** Initialize FLASH Image System
RedBoot> fis list
Name FLASH addr Mem addr Length Entry point
RedBoot 0xBE000000 0xBE000000 0x00050000 0x00000000
RedBoot config 0xBE3C0000 0xBE3C0000 0x00001000 0x00000000
FIS directory 0xBE3D0000 0xBE3D0000 0x00010000 0x00000000
RedBoot> ip_address -l 192.168.1.1 -h 192.168.1.175
RedBoot> load -r -b 0x80041000 redboot220.bin
Specified address (0x80041000) is not believed to be in RAM - continue (y/n)? y
Raw file loaded 0x80041000-0x800413ff, assumed entry at 0x80041000
RedBoot> reset


I do everything well, the Puty answers is equal to the manual, when I get to send the command "reset", it gives the error, in the my last post.
Thanks for your answers
n-di
DD-WRT Novice


Joined: 16 Sep 2011
Posts: 4
Location: Russia, Sibir

PostPosted: Thu Nov 24, 2011 9:11    Post subject: Reply with quote
May you try to do "5)" and "6)" again and copy&paste output from console to see what happened?
While doing my device i have same error but doing something trouble is go on )

_________________
OpenWRT backfire 10.03.1-rc5 @ D-link DWL-2100AP A4
vpritiskovic
DD-WRT User


Joined: 28 Aug 2009
Posts: 248
Location: Dalmatia, Croatia

PostPosted: Thu Nov 24, 2011 9:52    Post subject: Reply with quote
This was wrong:
afm wrote:

RedBoot> load -r -b 0x80041000 redboot220.bin
Specified address (0x80041000) is not believed to be in RAM - continue (y/n)? y
Raw file loaded 0x80041000-0x800413ff, assumed entry at 0x80041000
RedBoot> reset



type this:
Code:

load -r -b %{FREEMEMLO} redboot220.bin
fis create RedBoot
reset



Later if you want to install OpenWRT then continue with this: http://wiki.openwrt.org/toh/d-link/dwl-2100ap#install.openwrt

_________________
DD-WRT v24-sp2 (01/21/12) std - build 18613 @SX763
DD-WRT v24-sp2 (10/12/12) std - build 20119 @WZR-HP-G300NH (b0 b0)
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17619
Location: Hesse/Germany

PostPosted: Thu Nov 24, 2011 18:01    Post subject: Reply with quote
today i bricked my dwl2100 cause of the stupid PDF instruction from above
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
afm
DD-WRT Novice


Joined: 21 Apr 2007
Posts: 11

PostPosted: Thu Nov 24, 2011 19:34    Post subject: Reply with quote
Thank you guys, for your answers

The sooner I will try the commands:

load -r -b %{FREEMEMLO} redboot220.bin
fis create RedBoot
reset


I'll see if it works

Sash, What is wrong in the manual?
vpritiskovic
DD-WRT User


Joined: 28 Aug 2009
Posts: 248
Location: Dalmatia, Croatia

PostPosted: Thu Nov 24, 2011 21:57    Post subject: Reply with quote
Sash wrote:
today i bricked my dwl2100 cause of the stupid PDF instruction from above


Is that the only one?! If so then I guess then will be no dd-wrt port Sad
I don't know what kind of flash chip was your bricked DWL but if you have a jtag you could fix that too, we ar still waiting for dd-wrt test build...

_________________
DD-WRT v24-sp2 (01/21/12) std - build 18613 @SX763
DD-WRT v24-sp2 (10/12/12) std - build 20119 @WZR-HP-G300NH (b0 b0)
Goto page Previous  1, 2, 3 ... , 17, 18, 19  Next Display posts from previous:    Page 18 of 19
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum