[Howto] Install Optware on Atheros units (such as WNDR3700)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 29, 30, 31  Next
Author Message
gulp
DD-WRT Novice


Joined: 24 Sep 2006
Posts: 24

PostPosted: Tue Mar 08, 2011 13:51    Post subject: Reply with quote
Pada wrote:
Have anyone here managed to get ntfs-3g working, because I get the following errors when I try to install ntfs-3g with my Buffalo WZR-HP-G300NH router


No need to install.
NTFS-3G is already present on ddwrt firmware for Buffalo WZR-HP-G300NH.

i'm using it without problems, try that:

Code:
insmod /lib/modules/2.6.34.8-svn16124/kernel/fs/fuse/fuse.ko
ntfs-3g /dev/sdaxxxxxx /mnt/xxxxxx
Sponsor
Pada
DD-WRT Novice


Joined: 10 May 2009
Posts: 21

PostPosted: Tue Mar 08, 2011 14:16    Post subject: Reply with quote
That is awesome news @ gulp.

I've tried 'mount -t ntfs-3g /dev/discs/disc0/partx /mnt/' which didn't work of course. I didn't realize that there was an 'ntfs-3g' command.

I'm definitely going to try it when I get home in about 2 hours.
Pada
DD-WRT Novice


Joined: 10 May 2009
Posts: 21

PostPosted: Tue Mar 08, 2011 20:33    Post subject: Reply with quote
gulp: where did you get that version for the Buffalo router?

I currently have:
DD-WRT firmware version: DD-WRT v24SP2-EU-US (08/19/10) std - build 14998
uname -a: Linux buffalo 2.6.24.111 #3666 Thu Aug 19 15:24:42 CEST 2010 mips GNU/Linux

There is an ntfs.ko in my /lib/modules/2.6.24.11/fs/ntfs/ folder, but it doesn't provide write support and perhaps not even read support.

I've tried to download the fuse.ko from ftp://ftp.dd-wrt.com/others/eko/Public/modules/2.6.24.111/fuse.ko
but it doesn't want to load with insmod either.

I reckon that I'll just try OTRW when I have the time.
mattandbrandy
DD-WRT Novice


Joined: 06 Mar 2011
Posts: 1

PostPosted: Wed Mar 09, 2011 2:56    Post subject: Reply with quote
Thank you so much for this. I didn't understand half of the steps, but I followed them exactly and it all worked! Smile
gulp
DD-WRT Novice


Joined: 24 Sep 2006
Posts: 24

PostPosted: Wed Mar 09, 2011 9:03    Post subject: Reply with quote
Pada wrote:
gulp: where did you get that version for the Buffalo router?


http://www.dd-wrt.com/site/support/other-downloads?path=others%2Feko%2FBrainSlayer-V24-preSP2%2F2011%2F02-17-11-r16214%2Fbuffalo_wzr-hp-g300nh%2F

rev.16214
Pada
DD-WRT Novice


Joined: 10 May 2009
Posts: 21

PostPosted: Wed Mar 09, 2011 9:13    Post subject: Reply with quote
Thank you very much gulp!
Pada
DD-WRT Novice


Joined: 10 May 2009
Posts: 21

PostPosted: Sat Mar 12, 2011 20:06    Post subject: Reply with quote
I've now installed that wzr-hp-g300nh-dd-wrt-webupgrade-MULTI.bin firmware and the NTFS is working both for reading & writing, but it is incredibly slow (~4MB/s). Edit/Update: At least the read speed is between 8-10MB/s.
I'm just grateful that it is working, because now I can keep my files on an NTFS partition.

Unfortunately the ext2 & ext3 file systems aren't working with that build.

Thanks again for giving the link to that new build.
joegreat
DD-WRT Novice


Joined: 27 May 2010
Posts: 10

PostPosted: Sun Mar 13, 2011 21:34    Post subject: opkg: can't resolve symbol 'glob64' in lib 'opkg'. Reply with quote
Hi,

I got the same error as 'Diehardshorty' below, after installing Transmission and reboot.
Was there a fix of for the posting? Question I did not find a solution by searching the forum.

With kind regards
Joe Cool

Diehardshorty wrote:

And then opkg update
Code:
root@DD-WRT:~# opkg update
opkg: can't resolve symbol 'glob64' in lib 'opkg'.


I did restart like you said but still got the globe64 thing

_________________
Netgear WNDR3700 v2 with Firmware: BrainSlayer-V24-preSP2 (02/19/11) std r16230
sas.69
DD-WRT Novice


Joined: 31 Mar 2010
Posts: 22

PostPosted: Sun Mar 13, 2011 22:09    Post subject: Reply with quote
Hi, joegreat
Copy the following commands to ssh and try again with opkg update. If it`s working copy them to your startup script :)

Code:
export LD_LIBRARY_PATH='/opt/lib:/opt/usr/lib:/lib:/usr/lib'
export PATH='/opt/bin:/opt/usr/bin:/opt/sbin:/opt/usr/sbin:/bin:/sbin:/usr/sbin:/usr/bin'
Sabrewulf
DD-WRT Novice


Joined: 15 Mar 2011
Posts: 1

PostPosted: Thu Mar 17, 2011 15:48    Post subject: Re: opkg: can't resolve symbol 'glob64' in lib 'opkg'. Reply with quote
joegreat wrote:
Hi,

I got the same error as 'Diehardshorty' below, after installing Transmission and reboot.
Was there a fix of for the posting? Question I did not find a solution by searching the forum.

With kind regards
Joe Cool

Diehardshorty wrote:

And then opkg update
Code:
root@DD-WRT:~# opkg update
opkg: can't resolve symbol 'glob64' in lib 'opkg'.


I did restart like you said but still got the globe64 thing


Hi;

What I did was change the sleep from 5 to 10. This seem to have resolved mine.

Hope this help you out
joegreat
DD-WRT Novice


Joined: 27 May 2010
Posts: 10

PostPosted: Thu Mar 17, 2011 21:03    Post subject: Re: opkg: can't resolve symbol 'glob64' in lib 'opkg'. Reply with quote
Sabrewulf wrote:

What I did was change the sleep from 5 to 10. This seem to have resolved mine.

Hope this help you out


Thx Sabrewulf!
That was/is the solution: Just wait a little bit and re-login into the telnet session, and everything works fine!

With kind regards
Josip Cool

_________________
Netgear WNDR3700 v2 with Firmware: BrainSlayer-V24-preSP2 (02/19/11) std r16230
ammaree
DD-WRT Novice


Joined: 13 Mar 2011
Posts: 6

PostPosted: Thu Mar 17, 2011 21:17    Post subject: Reply with quote
to dynek,

followed your instructions as per post on 28 Jan 2011 to the letter, all worked as expected until I got to step 8.

a) After reboot the USB memory was not mounted, but after removing the USB and reinserting it automounted correctly, so that solved.

b) when trying to do the opkg update it returned an error "opkg: not found". I located the opkg in /mnt/opt/bin and also located the opkg.conf in /mnt/etc but could not successfully run opkg no matter where from.

Any suggestions??

Andre

WZR-HP-G300NH
necreo
DD-WRT Novice


Joined: 18 Mar 2011
Posts: 20

PostPosted: Fri Mar 18, 2011 1:08    Post subject: Reply with quote
Doesn't work for me.

Router: WDNR3700
DD-WRT v24-sp2 (02/17/11) std
(SVN revision 16214)

http://192.168.1.1/USB.asp wrote:
--- /dev/sda
Block device, size 7.469 GiB (8019509248 bytes)
DOS/MBR partition map
Partition 1: 6.971 GiB (7484972544 bytes, 14619087 sectors from 63, bootable)
Type 0x0B (Win95 FAT32)
FAT32 file system (hints score 5 of 5)
Volume size 6.957 GiB (7470362624 bytes, 1823819 clusters of 4 KiB)
Volume name ""
Partition 2: 502.0 MiB (526417920 bytes, 1028160 sectors from 14619150)
Type 0x83 (Linux)
Ext3 file system
UUID 7457514B-AD5C-49B0-93F6-BD43EEDAB505 (DCE, v4)
Volume size 502.0 MiB (526417920 bytes, 514080 blocks of 1 KiB)
Status: Mounted on /mnt


Mount:
Quote:

root@WDNR3700:~# mount
...
/dev/sda1 on /mnt type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)


Attempting to mount /dev/sda2:
Quote:
root@WDNR3700:~# umount /dev/sda1
root@WDNR3700:~# mount /dev/sda2 /mnt/
mount: mounting /dev/sda2 on /mnt/ failed: Invalid argument
root@WDNR3700:~# mount -t ext3 -o noatime /dev/sda2 /mnt/
mount: mounting /dev/sda2 on /mnt/ failed: No such device


Also: I don't have
Quote:
Under Services->USB:
* Enable Core USB Support
* Disable USB 1.1 Support (UHCI)
* Disable USB 1.1 Support (OHCI)
* Enable USB 2.0 Support
* Disable USB Printer Support (you can enable it if you want)
* Enable USB Storage Support
* Enable Automatic Drive Mount
* Set Disk Mount Point to /mnt
* Click Apply Settings


Only got:
Quote:
Under Services->USB:
* Enable Core USB Support
* Disable USB Printer Support (you can enable it if you want)
* Enable USB Storage Support
* Enable Automatic Drive Mount
* Set Disk Mount Point to /mnt


Because this FAT32 partition is mounted and I can't get the ext3 to mount I can't continue.

Can someone help me please?
If I need another firmware: please give me a downloadlink.

I would LOVE to run software on it, been trying for a week now :(

EDIT:
Reformatted the entire memory stick to ext2 and that worked.
Any way I can still use a partition instead of dedicating all of it?
dynek
DD-WRT User


Joined: 19 Oct 2006
Posts: 131

PostPosted: Fri Mar 18, 2011 10:24    Post subject: Reply with quote
ammaree wrote:
After reboot the USB memory was not mounted, but after removing the USB and reinserting it automounted correctly, so that solved.

If the USB stick was not mounted then it is the root cause of your problems.
Did you configured correctly the USB settings at step 2 ?

necreo wrote:
Any way I can still use a partition instead of dedicating all of it?

Sure !
blade0383
DD-WRT Novice


Joined: 17 Mar 2011
Posts: 1

PostPosted: Sun Mar 20, 2011 14:17    Post subject: Reply with quote
hi,

install of optware was sucessfull and everthing is working. at the moment i try to install pyload.

but to install completely some packages are needed. i coulndt find python-django, pyqt4 and nothing to tesseract.

maybe no packages available, btw i use a wzr-hp-g300-nh

has someone allready managed to install and get pyload working?

thx for replies Smile
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 29, 30, 31  Next Display posts from previous:    Page 7 of 31
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum