help needed - 3 xbox 360's needing open nat

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8
Author Message
barryware
DD-WRT Guru


Joined: 26 Jan 2008
Posts: 13049
Location: Behind The Reset Button

PostPosted: Sun Jan 30, 2011 15:03    Post subject: Reply with quote
@stslimited84... Check your PM's
_________________
[Moderator Deleted] Shocked
Sponsor
stslimited84
DD-WRT User


Joined: 05 Jan 2011
Posts: 73

PostPosted: Sun Jan 30, 2011 21:25    Post subject: Reply with quote
Any recommendations on hardware at this point? I could get the e2000 refurbed for $38, or maybe something a bit more pricey like the RT-N16 or e3000 with usb support.

The main thing is getting open nats for all 3 xbox's.
doogie
DD-WRT Novice


Joined: 30 Jan 2011
Posts: 13

PostPosted: Sun Jan 30, 2011 21:46    Post subject: Reply with quote
A couple of findings from getting my setup working:

-If you have more than one router in the house, make sure that the device you have plugged in and bound to WAN (call it "core" or "edge" or "firewall", whatever), has UPnP enabled.

-Use DHCP on the Xbox. This will save you a lot of headache. If you so desire, use DHCP reservations on the router. (what scenarios/what reasons do people have to do static IPs on the Xbox, I'm curious)

-My particular setup uses a WRT610Nv2, DD-WRT v24-sp2 (12/19/10) mega - build 15943M NEWD-2 K2.6 Eko. However I've had plenty of success with the recommended build, 14929, and with OpenWrt as well on a Buffalo WZR-HP-600NH. I have a Linksys E4200 that only does WAP duty, and so it has UPnP disabled.

-Enable UPnP and leave "clear port forwards at startup" disabled. If you choose to clear forwards on startup, you will need to run the Test Connection procedure on your Xboxes again to make them register with the router.

-At this point, double check that you do not have any other routers on the network with UPnP enabled.

-Now, on each Xbox, go to System Settings -> Network -> (Select your connection) -> Test Xbox LIVE Connection. This will clear cached data on the console, acquire DHCP lease, verify MTU and NAT, among other things. If UPnP capability is detected the console should now register and should appear on your router.

-The first console will attempt to register 3074/udp. Subsequent consoles will grab a random high port, 20008, 20672 or some such. This is equally fine and will result in Open NAT.

-If the console reports, at the end of the Test Connection, that "You can connect to Xbox LIVE, but your settings might restrict online play", we've detected that you are behind a NAT but you won't accept unsolicited UDP (which is the reason for the port forward). This is needed to matchmake with the largest part of the service.

-If you do not care about matchmaking/online gaming on this console, you can freely ignore "Moderate NAT". The rest of the service functionality will work.

If you have further questions I am happy to answer. :D

edit=Super interested to know of other multiple Xbox setups, working 100% or not, this is one area that can be difficult. UPnP should make it easier but are most folks willing to turn that on (insecure?)?
stslimited84
DD-WRT User


Joined: 05 Jan 2011
Posts: 73

PostPosted: Sun Jan 30, 2011 22:39    Post subject: Reply with quote
doogie wrote:
A couple of findings from getting my setup working:

-If you have more than one router in the house, make sure that the device you have plugged in and bound to WAN (call it "core" or "edge" or "firewall", whatever), has UPnP enabled.

-Use DHCP on the Xbox. This will save you a lot of headache. If you so desire, use DHCP reservations on the router. (what scenarios/what reasons do people have to do static IPs on the Xbox, I'm curious)

-My particular setup uses a WRT610Nv2, DD-WRT v24-sp2 (12/19/10) mega - build 15943M NEWD-2 K2.6 Eko. However I've had plenty of success with the recommended build, 14929, and with OpenWrt as well on a Buffalo WZR-HP-600NH. I have a Linksys E4200 that only does WAP duty, and so it has UPnP disabled.

-Enable UPnP and leave "clear port forwards at startup" disabled. If you choose to clear forwards on startup, you will need to run the Test Connection procedure on your Xboxes again to make them register with the router.

-At this point, double check that you do not have any other routers on the network with UPnP enabled.

-Now, on each Xbox, go to System Settings -> Network -> (Select your connection) -> Test Xbox LIVE Connection. This will clear cached data on the console, acquire DHCP lease, verify MTU and NAT, among other things. If UPnP capability is detected the console should now register and should appear on your router.

-The first console will attempt to register 3074/udp. Subsequent consoles will grab a random high port, 20008, 20672 or some such. This is equally fine and will result in Open NAT.

-If the console reports, at the end of the Test Connection, that "You can connect to Xbox LIVE, but your settings might restrict online play", we've detected that you are behind a NAT but you won't accept unsolicited UDP (which is the reason for the port forward). This is needed to matchmake with the largest part of the service.

-If you do not care about matchmaking/online gaming on this console, you can freely ignore "Moderate NAT". The rest of the service functionality will work.

If you have further questions I am happy to answer. :D

edit=Super interested to know of other multiple Xbox setups, working 100% or not, this is one area that can be difficult. UPnP should make it easier but are most folks willing to turn that on (insecure?)?



SUCCESS SUCCESS SUCCESS SUCCESS SUCCESS SUCCESS SUCCESS


The problem has been resolved. It seems running the Xbox Live connection test was the key. All 3 Xbox's now have confirmed open nat!

I took the following steps after reading Doogie's post:

1) Doubled checked settings on the second router on the network which is acting as a switch. It was the primary router previously, so I ensured any/all old rules were deleted and that UPnP was off.

2) I made sure all three Xbox's were off, then rebooted the WRT54Gl, and ensured UPnP was turned on.

3) Turned on each Xbox one at a time, and ran the Xbox Live Connection Test. One by one, they all reported Open Nat.

4) Loaded Call of Duty Black Ops and had all three log onto multiplayer to verify simultaneous open nat on all three consoles.

Success! Cool
doogie
DD-WRT Novice


Joined: 30 Jan 2011
Posts: 13

PostPosted: Sun Jan 30, 2011 23:03    Post subject: Reply with quote
right on brother! Let me know if you guys have any other 360 troubles...
barryware
DD-WRT Guru


Joined: 26 Jan 2008
Posts: 13049
Location: Behind The Reset Button

PostPosted: Sun Jan 30, 2011 23:37    Post subject: Reply with quote
stslimited84 wrote:

SUCCESS SUCCESS SUCCESS SUCCESS SUCCESS SUCCESS SUCCESS


The problem has been resolved. It seems running the Xbox Live connection test was the key. All 3 Xbox's now have confirmed open nat!

I took the following steps after reading Doogie's post:

1) Doubled checked settings on the second router on the network which is acting as a switch. It was the primary router previously, so I ensured any/all old rules were deleted and that UPnP was off.



Good for you.. However, where in the 108 posts in this thread did you mention you had two routers going? Twisted Evil

Maybe I missed it..

Enjoy your open nat!

WTF! Evil or Very Mad

_________________
[Moderator Deleted] Shocked
stslimited84
DD-WRT User


Joined: 05 Jan 2011
Posts: 73

PostPosted: Sun Jan 30, 2011 23:55    Post subject: Reply with quote
barryware wrote:

Good for you.. However, where in the 108 posts in this thread did you mention you had two routers going? Twisted Evil

Maybe I missed it..

Enjoy your open nat!

WTF! Evil or Very Mad


Barry, back on page five we were discussing the setup I have, here's a quote from the discussion...the second router is the actiontec from the discussion:

stslimited84 wrote:
barryware wrote:


Well... that explains it. You have your router connected via lan port to your ISP's device. Nothing means anything now.. Upnp, port forwarding, etc, etc. only works when the router is actually routing traffic. Your GL is just a switch and AP.. It is not routing anything.

So the Fios is actually the router, dhcp server. All tweeking needs to be done in the Fios.

I believe there is a way to get your Fios to had your router a wan ip via the wan port. I believe it takes a phone call to your provider so they can configure the fios to allow that.

I'm not sure as I have only read about it. There is a wiki for the fios in the dd-wrt wiki. Don't know how much help that will be.


My router receives direct internet connection from the ONT (think cable modem) which is outside the residence. The internet connection goes straight into the WRT54GL, and the actiontec (ISP supplied router) is connected to the WRT54GL via a lan port, NOT the other way around.

The WRT54GL is handling the routing duties. I posted that last link to explain how the setup is in further detail if needed. The actiontec isnt handling DHCP. From the link "The Actiontec at this point is now on the LAN side of your primary router acting as a bridge from your router's ethernet to the coax."

So the actiontec is only in the equation b/c it is needed to maintain TV service. The WRT54GL handles the routing. That was the whole reason I went with the DD-WRT after we switched to Verizon.

Hopefully that clears that up.



stslimited84 wrote:
fggs wrote:
If WRT54GL doesn't have a public wan ip, then it's not handling routing. I'm almost sure it has a private wan ip from Actiontec. Typical double nat.



stslimited84 wrote:
Per the guide, there is no double NAT situation. The WRT54GL IS handling routing, and the actiontec is just a bridge so the TV's can get the data they need through the internet.

The actiontec is behind the WRT54GL as a bridge for the TV's, so it is not handling routing duties.
toadslayer72
DD-WRT Novice


Joined: 27 Jan 2011
Posts: 6

PostPosted: Wed Feb 16, 2011 12:59    Post subject: Up and running Reply with quote
Sorry to revive this old thread but I'm doing so mainly for anyone who may end up here looking for answers, like me. I finally flashed my e2000 last night and now all 3 boxes show open NAT. I did my initial test with two of the boxes playing Halo Reach and the third playing Black Ops, all simultaneous multi-player matchmaking games, all open NAT, no problems playing. Later I had two boxes going for about an hour or so and there were no problems at all. I don't know if I can expect any problems in the future but as of now, my problem is solved. I didn't do anything with the settings other than enable UPnP and clear port forwards at startup under the NAT/QoS tab.

I am so grateful for this service and site. I spent hours trying to find a solution on the net before I ended up here. Thank you DD-WRT community!
gene
DD-WRT Guru


Joined: 28 Dec 2007
Posts: 619

PostPosted: Wed Feb 16, 2011 15:21    Post subject: Reply with quote
OK, here is an explanation of why:

Many assume that adding a static reservation for the xbox(s) will insert that IP address in the DHCP server list of managed clients.....it does NOT. All adding a static reservation does is remove THAT IP address from the pool of DHCP addresses that can be 'offered' to a client when a request is made for an IP. 'Offered' IP addresses are managed, reserved IP's addresses are not.

If the client(xbox) has been configured with a static address, then it IS NOT making a DHCP request to the DHCP server for an IP address, and therefore the DHCP server IS NOT managing that IP address. Now if the DHCP server is not managing an IP address, then port forwarding cannot be completed due to the lack of management of the IP address. Now, before anyone says, wait, I use static on all my devices....humm, and do you have more than ONE device requesting the VERY SAME services ? probably not. UPnP may work right for a single network client that is statically configured, but usually not reliably if another network client suddenly starts using the very same service and is also statically configured.

This is easily tested and proved: turn on UPnP(in your gateway(and ONLY your gateway)), add a static reservation on the services page, now configure your xbox with that same static IP address, now reboot both. Now check to see if UPnP has an entry listed ? Now go back to the xbox and configure the xbox to automatic DHCP, then reboot or test xbox live connection again(now your DHCP server/gateway has offered your statically reserved address to THAT client by matching MAC addresses(for more than one xbox)), now you will see an entry for the xbox on the UPnP page BECAUSE an IP address request was actually made...... Or you can just point a sniffer to your xbox and capture the traffic when you boot it up and then look at the captured traffic, no DHCP request made, no DHCP offer replied, therefore no management of the IP used.

There have been many complaints made that UPnP did not work right in the past, I have never experienced that myself(6 years now with xboxlive and not one single problem EVER with open NAT problems), and while I understand that some advocate not using DHCP for security reasons, the trade-off is that management of the IP addresses in the network is not being handled. In order for UPnP and port forwarding (and port range forwarding ) to work reliably, the pool of addresses your network uses must be managed. I have NEVER had a NAT problem with dd-wrt(that I was aware of).

I did not bother to look to see if there were any references to the other two ports that should be forwarded on the port triggering page : port 53 both tcp and udp, as well as port 88 udp only. UPnP does not forward these two ports(only 3074), nor can you get OPEN NAT with out them being triggered(forwarded)(well, sometimes it will complain if 53 is not forwarded during the test, but I point my xbox to my gateway for a static DNS server on the xbox's. Why MSFT needs DNS forwarded I don't know, but port 88, Protocol / Name: kerberos is definitely needed)

_________________
1 WRT160N v3 - remote AP WPA2 Personal Aes dd-wrt-mini-trailed CPU OC400,
2 wrt54G v3(BCM4712 chip rev 1, corerev=7)- AP WPA2 Personal Aes dd-wrt-mini-generic CPU OC228,
1 wrt54gs v6 - remote AP WPA2 Personal Aes dd-wrt-micro CPU OC228 ,
3 WAP54g v3 - repeater, client Bridge, repeater bridge dd-wrt-micro CPU OC225,
1 NetGear WNR2000 v3 AP Atheros AR7241 ver 1 rev 1.1 (0x0101) Trailed build CPU OC360
DD-WRT usually the most current BS builds and less frequently lately EKO builds(because of new BS rules that eliminated EKO builds I used).
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8 Display posts from previous:    Page 8 of 8
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum