Asterisk Installation

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3 ... 13, 14, 15 ... 27, 28, 29  Next
Author Message
KevinRea
DD-WRT Novice


Joined: 28 Nov 2010
Posts: 10

PostPosted: Tue Nov 30, 2010 3:57    Post subject: Reply with quote
Kate6 wrote:
The SIP extension you want ringing... It's actually defined as "1" in sip.conf?

Yes. As I said the incoming gtalk call does in fact cause my IP phone at extension 1 to ring, but asterisk crashes immediately after that and the call is not connected. In addition, calls between my two IP phones work fine. Here's the relevant configuration in sip.conf:

Code:
[1]
; office
type=peer
secret=MySecret
host=dynamic
context=local

[2]
; kitchen
type=peer
secret=MySecret
host=dynamic
context=local


The behavior is the same whether the IP phone type is specified as peer or friend.
Sponsor
Kate6
DD-WRT Novice


Joined: 12 Aug 2009
Posts: 44
Location: Vancouver, WA

PostPosted: Tue Nov 30, 2010 4:03    Post subject: Reply with quote
KevinRea wrote:
As I said the incoming gtalk call does in fact cause my IP phone at extension 1 to ring, but asterisk crashes immediately after that and the call is not connected. In addition, calls between my two IP phones work fine.


Still sounds like a probable codec issue to me. Maybe the negotiation of what codec will be used goes a bit differently if it starts out on Google Talk's side. I'd mess with the preferred and allowed codec options on your ATA, or in your soft phone.

That's my best guess. Sad
KevinRea
DD-WRT Novice


Joined: 28 Nov 2010
Posts: 10

PostPosted: Tue Nov 30, 2010 4:21    Post subject: Reply with quote
Kate6 wrote:
My gut feeling based on the little experience I have getting this to work says it might be a codec issue. But you said outgoing calls work fine for you, right?

I hate how one problem always seems to lead to another. Your comment about codecs got me thinking that I probably should have the asterisk core ulaw sounds installed which I don't. But when I tried to install them the installation failed:


And no, running update does not fix things.
Kate6
DD-WRT Novice


Joined: 12 Aug 2009
Posts: 44
Location: Vancouver, WA

PostPosted: Tue Nov 30, 2010 4:31    Post subject: Reply with quote
KevinRea wrote:
Your comment about codecs got me thinking that I probably should have the asterisk core ulaw sounds installed which I don't. But when I tried to install them the installation failed:


And no, running update does not fix things.


Any chance your /opt is out of disk space? That looks like it's just failing to download the package from the repository... And I just copy-and-pasted the URL from your wget command line, the package is there.
KevinRea
DD-WRT Novice


Joined: 28 Nov 2010
Posts: 10

PostPosted: Tue Nov 30, 2010 5:13    Post subject: Re: Asterisk 1.8 and Google Voice Reply with quote
Kate6 wrote:
Any chance your /opt is out of disk space? That looks like it's just failing to download the package from the repository... And I just copy-and-pasted the URL from your wget command line, the package is there.

Yup. That was the problem indeed. However installing the ulaw core sounds didn't change anything on the asterisk side of the equation. I'm wondering what asterisk-related packages you have installed in addition to asterisk18.
Kate6
DD-WRT Novice


Joined: 12 Aug 2009
Posts: 44
Location: Vancouver, WA

PostPosted: Tue Nov 30, 2010 5:17    Post subject: Re: Asterisk 1.8 and Google Voice Reply with quote
KevinRea wrote:
Yup. That was the problem indeed. However installing the ulaw core sounds didn't change anything on the asterisk side of the equation. I'm wondering what asterisk-related packages you have installed in addition to asterisk18.


I have no other "asterisk*" packages installed. I did briefly install the ulaw freeplay music on hold package, but as it turns out, Asterisk correctly detects when I put the soft phone on my laptop on hold but does not correctly detect when I hit the hold button on the cordless phone attached to my ATA... So I gave up and uninstalled.
davidnewton
DD-WRT User


Joined: 02 Apr 2010
Posts: 93

PostPosted: Thu Dec 02, 2010 2:27    Post subject: GV problem with asterisk18 today Reply with quote
I was able to make gv calls using Asterisk1.8 behind my tomato router using 2 different gv accounts without problem for a week. But today, there is a strange problem: one of the GV account can not make outgoing calls while the other can without problem. For the not-working one, it keeps giving the following error message:

[Dec 2 00:07:28] NOTICE[386]: chan_gtalk.c:1942 gtalk_parser: Remote peer reported an error, trying to establish the call anyway
[Dec 2 00:07:28] NOTICE[386]: chan_gtalk.c:1942 gtalk_parser: Remote peer reported an error, trying to establish the call anyway

Initially I suspect that one batch of gv account may not work, the others may work, but I went back to use sipsorcery to make the calls with the same account, it works fine. This means that the gv account not-working on the asterisk is ok. I don't know what is the reason now since the incoming calls work ok for both accounts, and the outgoing calls work too for another gv account. Anybody have this kind of problem before? Thanks in advance.


UPDATE: 1 hour later, neither of the gv accounts from the asterisk server work now. Both give the same error messages now. I guess GV has blocked calls from my asterisk server. I can still make calls through sipsorcery. If anybody experienced the same problem, please share.
KevinRea
DD-WRT Novice


Joined: 28 Nov 2010
Posts: 10

PostPosted: Thu Dec 02, 2010 18:45    Post subject: Re: GV problem with asterisk18 today Reply with quote
When I initially was setting up asterisk with gv I ran into this problem after a day or so. I just created a new Google Voice account and out going calls have been working for around 3 weeks. Working, that is until today, now I'm getting the same problem with this gv account.

I tried creating another new google voice account but I get the same behavior. Seems like Google is somehow disabling calls initiated by Asterisk.
frater
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 2777

PostPosted: Thu Dec 02, 2010 20:35    Post subject: Reply with quote
Did you notice that the internal asterisk is now being upgraded to 1.8?
_________________
Asus RT16N + OTRW
Kingston 4GB USB-disk 128 MB swap + 1.4GB ext3 on /opt + 2 GB ext3 on /mnt
Copperjet 1616 modem in ZipB-config
Asterisk, pixelserv & Pound running on router
Another Asus RT16N as WDS-bridge

DD-WRT v24-sp2 vpn (c) 2010 NewMedia-NET GmbH
Release: 12/16/10 (SVN revision: 15758M)
davidnewton
DD-WRT User


Joined: 02 Apr 2010
Posts: 93

PostPosted: Thu Dec 02, 2010 21:29    Post subject: Re: GV problem with asterisk18 today Reply with quote
KevinRea wrote:
When I initially was setting up asterisk with gv I ran into this problem after a day or so. I just created a new Google Voice account and out going calls have been working for around 3 weeks. Working, that is until today, now I'm getting the same problem with this gv account.

I tried creating another new google voice account but I get the same behavior. Seems like Google is somehow disabling calls initiated by Asterisk.


Looks like that gv blocks all calls from Asterisk. If that is the case, then all the efforts on this matter by Asterisk team will be wasted. Hope it is only temporary.
bazzoola
DD-WRT Novice


Joined: 06 Oct 2007
Posts: 27

PostPosted: Mon Dec 06, 2010 17:40    Post subject: Re: GV problem with asterisk18 today Reply with quote
[quote="davidnewton"]
UPDATE: 1 hour later, neither of the gv accounts from the asterisk server work now. Both give the same error messages now. I guess GV has blocked calls from my asterisk server. I can still make calls through sipsorcery. If anybody experienced the same problem, please share.[/quote]

I am having exactly the same issue. I am not using DD-WRT. I built my box from scratch on a dedicated box.

My outgoing was working fine til last week. It get lots of messages in debug here are the most interesting:


WARNING[52339]: acl.c:698 ast_ouraddrfor: Cannot connect
-- Called asteriskgv/..........@voice.google.com
-- Gtalk/............@voice.google.com-XXX is ringing
NOTICE[52339]: chan_gtalk.c:1942 gtalk_parser: Remote peer reported an error, trying to establish the call anyway

NOTICE[52339]: chan_gtalk.c:1942 gtalk_parser: Remote peer reported an error, trying to establish the call anyway
NOTICE[52339]: chan_gtalk.c:768 gtalk_hangup_farend: Whoa, didn't find call during hangup!


UPDATE

For those interested
https://issues.asterisk.org/view.php?id=18412

Possible work around
http://supermario-world.blogspot.com/2010/12/nov-30th-break-of-asterisk-18-w-gv.html
frater
DD-WRT Guru


Joined: 07 Jun 2006
Posts: 2777

PostPosted: Tue Dec 07, 2010 21:26    Post subject: Reply with quote
For those that are using OTRW to start asterisk on DD-WRT.
I enhanced the script to create the necessary firewall rules and initiates a 2-minute cronjob that will check the asterisk /opt/var/log/asterisk/messages file to check for failed logins. If it detects more than 6 failed IP's in that timeframe, it will put that IP in a special chain and that will ban that IP from accessing asterisk.

It's a bit strange such a feature is not inside asterisk already. I actually did test it with sipvicious and it works.

_________________
Asus RT16N + OTRW
Kingston 4GB USB-disk 128 MB swap + 1.4GB ext3 on /opt + 2 GB ext3 on /mnt
Copperjet 1616 modem in ZipB-config
Asterisk, pixelserv & Pound running on router
Another Asus RT16N as WDS-bridge

DD-WRT v24-sp2 vpn (c) 2010 NewMedia-NET GmbH
Release: 12/16/10 (SVN revision: 15758M)
vindicator
DD-WRT Novice


Joined: 01 Nov 2010
Posts: 15

PostPosted: Wed Dec 08, 2010 7:17    Post subject: Asterisk Disconnected Reply with quote
KevinRea wrote:

Here's the output at the asterisk cli when I get an incoming gtalk call:

    == Starting Gtalk/+16503278911-e8af at from-google,kreaworld.gv@gmail.com,1 failed so falling back to exten 's'
    -- Executing [s@from-google:1] Dial("Gtalk/+16503278911-e8af", "SIP/1") in new stack
    == Using SIP RTP CoS mark 5
    -- Called 1
    ReaHomeWireless*CLI>
    Disconnected from Asterisk server


It would seem that I'm also having Asterisk disconnected due to an incoming GTalk call.
I'm aware of the outbound call issues, but I'm trying to start with receiving, but with no success.

Based on a link to "Mario's Adventures In Geekery", I followed his link to his conf files http://www.arctangent.net/~superm1/gv_configs/, and the disconnect still occurs after basically mirroring his configuration files.

*Edit: Still using Mario's scripts, I attempted an outbound and immediately got the "Disconnected from Asterisk server"
== Using SIP RTP CoS mark 5
-- Executing [18004444444@outbound:1] Dial("SIP/101-00000001", "Gtalk/username/18004444444@voice.google.com") in new stack
okki
DD-WRT User


Joined: 20 Jul 2010
Posts: 115

PostPosted: Sat Dec 11, 2010 11:02    Post subject: Reply with quote
I finally installed Asterisk 1.8 too. It works better than 1.6, but, like 1.6, I get crashes when doing certain things like:

  • When doing built-in transfer by pressing # during a call;
  • exten => 123,1,ChanSpy(SIP,B) - Starting the ChanSpy application;
  • exten => 456,1,Playback(tt-monkeys) - Playing back audio files.


For all of these I get
Disconnected from Asterisk server
in the CLI and Asterisk is killed.

Can anyone reproduce this?

Maybe I need to install some other dependent programs? At installation it said:
    asterisk18: unsatisfied recommendation for
    package asterisk18 suggests installing net-snmp
    package asterisk18 suggests installing radiusclient-ng
    package asterisk18 suggests installing sqlite2
    package asterisk18 suggests installing unixodbc
    package asterisk18 suggests installing iksemel
    package asterisk18 suggests installing x11
    Configuring asterisk18
    Successfully terminated.

But do I really have to install all of these???


Last edited by okki on Thu Dec 16, 2010 18:10; edited 6 times in total
okki
DD-WRT User


Joined: 20 Jul 2010
Posts: 115

PostPosted: Sun Dec 12, 2010 11:16    Post subject: Reply with quote
Can anyone reproduce the crash with either ChanSpy or transfer or audio playback?
Goto page Previous  1, 2, 3 ... 13, 14, 15 ... 27, 28, 29  Next Display posts from previous:    Page 14 of 29
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum