15778 Brainslayer Build

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 10, 11, 12  Next
Author Message
blaser
DD-WRT User


Joined: 16 Jul 2006
Posts: 474

PostPosted: Sun Nov 28, 2010 14:38    Post subject: Reply with quote
Linksys 160nv3 Upgraded from 15396 openvpn small and all look good for now, I will still need to test the vpn tomorrow from the office and report of any issues.

Port forwarding looks good.

I noticed a change in the openvpn screen "Switch Server config" parameter, anyone knows what it is?

_________________
Asus RT-AC68U
Sponsor
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11451
Location: Wherever the wind blows- North America

PostPosted: Sun Nov 28, 2010 20:35    Post subject: Reply with quote
Sorry all...this problem has propagated into the 15825 build of K26 mega as well.

Just tested it on my RT-N16 - same issue...fall back to 15704 K26 Mega and all is well again with my port forwards to the ftp server.

redhawk

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.
crashfly
DD-WRT Guru


Joined: 24 Feb 2009
Posts: 2026
Location: Sol System > Earth > USA > Arkansas

PostPosted: Sun Nov 28, 2010 20:45    Post subject: Reply with quote
redhawk0 wrote:
Sorry all...this problem has propagated into the 15825 build of K26 mega as well.

Just tested it on my RT-N16 - same issue...fall back to 15704 K26 Mega and all is well again with my port forwards to the ftp server.

redhawk

The question is: what got changed between 15704 and this build to be causing issues in only *some* routers?

_________________
E3000 22200M KongVPN K26
WRT600n v1.1 refirb mega 18767 BS K24 NEWD2 [not used]
WRT54G v2 16214 BS K24 [access point]

Try Dropbox for syncing files - get 2.5gb online for free by signing up.

Read! Peacock thread
*PLEASE* upgrade PAST v24SP1 or no support.
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11451
Location: Wherever the wind blows- North America

PostPosted: Sun Nov 28, 2010 20:48    Post subject: Reply with quote
crashfly wrote:
redhawk0 wrote:
Sorry all...this problem has propagated into the 15825 build of K26 mega as well.

Just tested it on my RT-N16 - same issue...fall back to 15704 K26 Mega and all is well again with my port forwards to the ftp server.

redhawk

The question is: what got changed between 15704 and this build to be causing issues in only *some* routers?


Yeah...unfortunately, I don't have time to test nightly builds right now to figure out which one. I believe someone said they did NOT see the problem with 15747...but did with 15778...so I when time permits...I'll get the nightly builds and try to figure out which one (by process of elimination) breaks the port forwarding....that might be later in the week though.

[EDIT]
Hmmm...I see there were only 2 Broadcom K26 builds available between the 15747 and the 15778 builds...I'll try the 15753 and 15776 to see if either work today...that will narrow it down as far as I can go with the nightly builds.


redhawk

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.


Last edited by redhawk0 on Sun Nov 28, 2010 20:55; edited 1 time in total
mastacontrola
DD-WRT Novice


Joined: 23 Nov 2010
Posts: 28
Location: Crown Point, NY

PostPosted: Sun Nov 28, 2010 20:52    Post subject: Reply with quote
redhawk0,

I wish I knew more to be able to help. Not being one who knows how to create my own firmware, I know I'm not much assistance to anyone. What are the changes being made? Or what was the change that was made, especially between 15704 AND 15747, to the current builds?

I understand not everybody is having this issue, and I don't know why. I have a Linksys E3000, though that particular router doesn't seem to be having issues, and it does seem to be having issues.

Through my testing using nmap to scan for open ports, the port forwards are working, (at least recognized) but they are becoming filtered and unusable to the requests. On others, if anyone would be willing to test, what are their results? nmap -sS domain.tld (or public IP) is the easy way to test for some of the open ports within the first 1000. Since most of my open ports fall into this range, it gives me open in builds 15704 and 15747, but filters them in 15778.

What can we do?
redhawk0 wrote:
Sorry all...this problem has propagated into the 15825 build of K26 mega as well.

Just tested it on my RT-N16 - same issue...fall back to 15704 K26 Mega and all is well again with my port forwards to the ftp server.

redhawk
[/b]
crashfly
DD-WRT Guru


Joined: 24 Feb 2009
Posts: 2026
Location: Sol System > Earth > USA > Arkansas

PostPosted: Sun Nov 28, 2010 20:56    Post subject: Reply with quote
mastacontrola wrote:
I wish I knew more to be able to help. Not being one who knows how to create my own firmware, I know I'm not much assistance to anyone. What are the changes being made? Or what was the change that was made, especially between 15704 AND 15747, to the current builds?

The best I can suggest is this: http://svn.dd-wrt.com:8000/dd-wrt/timeline

That might be a way to figure it out, but that is not always the case.

_________________
E3000 22200M KongVPN K26
WRT600n v1.1 refirb mega 18767 BS K24 NEWD2 [not used]
WRT54G v2 16214 BS K24 [access point]

Try Dropbox for syncing files - get 2.5gb online for free by signing up.

Read! Peacock thread
*PLEASE* upgrade PAST v24SP1 or no support.
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11451
Location: Wherever the wind blows- North America

PostPosted: Sun Nov 28, 2010 21:04    Post subject: Reply with quote
OK...the problem is between the 15753 and the 15776 builds....sorry I can't narrow it down more than that.

15753 gives me an instant connection to my ftp server.
15776 gives me a connection timeout.

redhawk

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.
voldemar
DD-WRT Novice


Joined: 26 Jul 2009
Posts: 28

PostPosted: Sun Nov 28, 2010 22:17    Post subject: Reply with quote
Changeset 15760 - fixes to firewall.c
Could it be the problem?
blaser
DD-WRT User


Joined: 16 Jul 2006
Posts: 474

PostPosted: Sun Nov 28, 2010 23:26    Post subject: Reply with quote
Just tested my port forwarding and openvpn all work good.
using openvpn small

_________________
Asus RT-AC68U
phuzi0n
DD-WRT Guru


Joined: 10 Oct 2006
Posts: 10143

PostPosted: Sun Nov 28, 2010 23:27    Post subject: Reply with quote
Aha! 15760 breaks loopback though port forwards should still be functional from the outside. I guess I still had a connection open on the WAN side when I was testing loopback... Anyways, this very simple/broad rule should fix loopback, put it in your firewall script on the admin->commands page.

iptables -t nat -A POSTROUTING -j MASQUERADE

_________________
Read the forum announcements thoroughly! Be cautious if you're inexperienced.
Available for paid consulting. (Don't PM about complicated setups otherwise)
Looking for bricks and spare routers to expand my collection. (not interested in G spec models)
mastacontrola
DD-WRT Novice


Joined: 23 Nov 2010
Posts: 28
Location: Crown Point, NY

PostPosted: Mon Nov 29, 2010 3:13    Post subject: Reply with quote
phuzi0n, That fixed my port forwarding issues. I thank you very much and at least you figured out where it issue is/was. Only question that I have then, how can I ensure this stays open (working) when the router restarts?

phuzi0n wrote:
Aha! 15760 breaks loopback though port forwards should still be functional from the outside. I guess I still had a connection open on the WAN side when I was testing loopback... Anyways, this very simple/broad rule should fix loopback, put it in your firewall script on the admin->commands page.

iptables -t nat -A POSTROUTING -j MASQUERADE
phuzi0n
DD-WRT Guru


Joined: 10 Oct 2006
Posts: 10143

PostPosted: Mon Nov 29, 2010 3:35    Post subject: Reply with quote
mastacontrola wrote:
phuzi0n, That fixed my port forwarding issues. I thank you very much and at least you figured out where it issue is/was. Only question that I have then, how can I ensure this stays open (working) when the router restarts?

phuzi0n wrote:
Aha! 15760 breaks loopback though port forwards should still be functional from the outside. I guess I still had a connection open on the WAN side when I was testing loopback... Anyways, this very simple/broad rule should fix loopback, put it in your firewall script on the admin->commands page.

iptables -t nat -A POSTROUTING -j MASQUERADE

_________________
Read the forum announcements thoroughly! Be cautious if you're inexperienced.
Available for paid consulting. (Don't PM about complicated setups otherwise)
Looking for bricks and spare routers to expand my collection. (not interested in G spec models)
mastacontrola
DD-WRT Novice


Joined: 23 Nov 2010
Posts: 28
Location: Crown Point, NY

PostPosted: Mon Nov 29, 2010 5:01    Post subject: Reply with quote
Had already done that, I didn't know it would work upon restarts, but thank you much for the quick reply.

phuzi0n wrote:
mastacontrola wrote:
phuzi0n, That fixed my port forwarding issues. I thank you very much and at least you figured out where it issue is/was. Only question that I have then, how can I ensure this stays open (working) when the router restarts?

phuzi0n wrote:
Aha! 15760 breaks loopback though port forwards should still be functional from the outside. I guess I still had a connection open on the WAN side when I was testing loopback... Anyways, this very simple/broad rule should fix loopback, put it in your firewall script on the admin->commands page.

iptables -t nat -A POSTROUTING -j MASQUERADE

_________________
Running Build(s) on
WNDR4500v1 BrainSlayer 21995
E4200 BrainSlayer 21605
WNDR3700v2 BrainSlayer 21286

"Insanity: Trying the same thing over and over again, expecting a
different result"
crashfly
DD-WRT Guru


Joined: 24 Feb 2009
Posts: 2026
Location: Sol System > Earth > USA > Arkansas

PostPosted: Mon Nov 29, 2010 6:03    Post subject: Reply with quote
phuzi0n wrote:
Aha! 15760 breaks loopback though port forwards should still be functional from the outside.

So what you are telling us is that this change was really only effecting people who were testing forwarding from inside their own LAN?

_________________
E3000 22200M KongVPN K26
WRT600n v1.1 refirb mega 18767 BS K24 NEWD2 [not used]
WRT54G v2 16214 BS K24 [access point]

Try Dropbox for syncing files - get 2.5gb online for free by signing up.

Read! Peacock thread
*PLEASE* upgrade PAST v24SP1 or no support.
phuzi0n
DD-WRT Guru


Joined: 10 Oct 2006
Posts: 10143

PostPosted: Mon Nov 29, 2010 6:16    Post subject: Reply with quote
crashfly wrote:
phuzi0n wrote:
Aha! 15760 breaks loopback though port forwards should still be functional from the outside.

So what you are telling us is that this change was really only effecting people who were testing forwarding from inside their own LAN?

Yes, it should have only affected loopback. People need to respond with both external and internal testing results before and after using the fix though.

_________________
Read the forum announcements thoroughly! Be cautious if you're inexperienced.
Available for paid consulting. (Don't PM about complicated setups otherwise)
Looking for bricks and spare routers to expand my collection. (not interested in G spec models)
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 10, 11, 12  Next Display posts from previous:    Page 7 of 12
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum