Linksys E3000 bricked

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
versiona
DD-WRT Novice


Joined: 05 Oct 2010
Posts: 4

PostPosted: Fri Oct 08, 2010 21:04    Post subject: Linksys E3000 bricked Reply with quote
Hello,

I need some help to retrieve my Linksys E3000 in good shape. I bricked the router when I tried to flash with a firmware that have OpenVPN. This is what I was doing:

1- Flash from Linksys default firmware to DD-WRT with firmware -> dd-wrt.v24-14853_NEWD-2_K2.6_std_usb_ftp-e3000.bin

*Flash succeed! At this point all works great.

2- After to put OpenVPN facility in the router, I try to flash with this firmware -> dd-wrt.v24-15355_NEWD-2_K2.6_openvpn.bin

*Flash don't succeed! E3000 Bricked

I think I miss something because I flash the router based on information from Markus. This is the answer from Markus about my question:

My Question
Quote:

Am 07.10.2010 um 17:48 schrieb Alan Pinard:
Hello Markus,

Thank you for your information. I have an other question? Could you send me the link for DD-WRT OpenVPN version compatible with Linksys E3000.

Alan Pinard


Markus answer
Quote:

http://dd-wrt.com/dd-wrtv2/downloads/others/eko/BrainSlayer-V24-preSP2/10-05-10-r15362/broadcom_K26/dd-wrt.v24-15355_NEWD-2_K2.6_openvpn.bin

You can only flash this image if another build of dd-wrt is already running on your router. The initial flashing process (changing preinstalled stock firmware with dd-wrt) needs the special file!

Markus


Now I have a zombie Linksys E3000. I tried to find a solution in the forum but I juste see things about Debug Cable. I want more information about it because I red a lot of post but I don't understand what I need to do with this cable and how to create the cable.

I need your help to solve my problem!

Thanks in advance,

*I tried TFTP method but the router doesn't respond. Ethernet ports seems to be not working!

Alan
Sponsor
barryware
DD-WRT Guru


Joined: 26 Jan 2008
Posts: 13049
Location: Behind The Reset Button

PostPosted: Fri Oct 08, 2010 21:41    Post subject: Reply with quote
your router bricked cuz you did not flash a trailed build.. The E2000, E3000 must always be flashed with hardware specific builds cuz of the increased nvram partition.

You can fix your router using serial console. You will need a 3.3v ttl adapter. That router has no operational jtag.

Do not short pins. Fix it via serial console or send it to someone to fix for you.

_________________
[Moderator Deleted] Shocked
Phonism
DD-WRT User


Joined: 27 Sep 2008
Posts: 449
Location: Norway

PostPosted: Fri Oct 08, 2010 21:46    Post subject: Reply with quote
Have you checked out this thread Routers with serial port inside WAN port? It has pictures of how to create a cable for using to get serial access. If not you can also get serial access by opening the router and soldering directly to the mainboard.

The important thing you need to remember with the E3000, is that you can ONLY flash with either -e3000.bins or e2k-e3k.bins - as you've found out, any other builds will brick it.

edit: barryware was just a little faster than me Razz

_________________

Asus RT-AC66U DD-WRT v24-sp2 giga - build 25015 [Main]
Linksys E3000 DD-WRT v24-sp2 mega - build 15962 [Backup]
Linksys WRT600N v1.1 DD-WRT v24-sp2 (08/12/10) mega - build 14929 [Retired]
Linksys WRT54GS v4 DD-WRT v24-sp2 mini - build 15747 [Retired]
E3000 Info | WRT600N Info | Know-it-all thread
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum