2GB SD Mod - Help Needed!

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Hardware DIY / Hardware Mods
Author Message
DD-WRT Novice

Joined: 27 Dec 2009
Posts: 5
Location: Birmingham, UK

PostPosted: Sun Dec 27, 2009 20:53    Post subject: 2GB SD Mod - Help Needed! Reply with quote
Hi all,
About 4 months ago I (Badly) attempted an SD mod on my WRT54GS V4, Which sounded so simple when i first read how to go about doing it. I purchased the card for a fortune in a local Jessops store as i was so exited to get started.
I took the card home, opened it, got some cable, ripped apart my router, grabbed the soldering iron and solder, and opened the guide up on my IPod Touch. I read the guide several times in the earlier days and ran over it once before fitting.
I soldered all of the wires onto the board and directly onto the SD card (ensuring everything stayed cool so that i didnt fry anything).
Upon re-assembling my router and plugging it back in, i was feeling somewhat reasured that i had done it ok, as the router booted as usual.
I got that far, and now i am stuck.

I have no idea how you actualy format, mount, or use the card.

I thought it would just be immediately recognised, my bad! Embarassed

Upon googling some things, i realised that it may be a problem to mount anyway with it being a 2Gb card and the functionality of the MMC.O file with DD-WRT Firmware.
I have tried what "That Guy" refers to as "mmc fix" in his post here.

rmmod mmc
insmod mmc
mke2fs /dev/mmc/disc0/part1
mount -t ext2 /dev/mmc/disc0/part1 /mmc

upon running dmesg after this, like he does, i get loads of garble about IP Addresses Etc. (I have attached the dmesg output in a text file)

I am no expert at all at running commands or telnet.
If anyone can point me in the right direction or help me fix this, please post!

Router Make: Linksys
Router Model: WRT54GS
Router Version: V4
Firmware Make: DD-WRT
Firmware Version: v24 SP2
SD Card Make: Jessops
SD Card Size: 2GB
Heatsinks: 2
Fans: 1 (12V 0.25A)
CPU Speed: 237MHz

(If anone needs no know anything else, please ask! Very Happy )

Thanks in Advance,
Dan (The.Pain) Very Happy
DD-WRT Novice

Joined: 28 Dec 2009
Posts: 17

PostPosted: Mon Dec 28, 2009 14:05    Post subject: Reply with quote
In your dmesg can't see the mmc module.

You must enable it in web gui and manual set the GPIO pins. And i advice you to format card in ext2 on PC before soldering!

WRT54GL 1.1 with MMC mod

DD-WRT v24-sp2 (10/10/09) std - build 13064
DD-WRT Novice

Joined: 27 Dec 2009
Posts: 5
Location: Birmingham, UK

PostPosted: Wed Dec 30, 2009 10:49    Post subject: Reply with quote
thanks roco, Very Happy
As soon as i get chance i will check the MMC module setings in the GUI, and attempt to format the card
(If i can get it out of my router and of the cable in once piece )

Anyone Else Have Any Other Suggestions? Question

Hey There! Very Happy

Joined: 26 Jan 2008
Posts: 13049
Location: Behind The Reset Button

PostPosted: Thu Dec 31, 2009 15:40    Post subject: Reply with quote
I did an sd mod to a tm a few weeks ago.. Finally got it going so maybe what I learned will help:

not all 2gb cards are created equal. A sandisk card worked, an pny card did not.

I started with a 256 mb card to get it working.

I pre-formatted the card using G-Parted live cd (ext2). I could not get the card to format properly in the router. I set up the folders using winscp once I got the router to see and mount the card.

I selected to enter the gpio manually, auto did not work. The TM's gpio may be different than yours but I used:

DI - 2, D0 - 4, CLK - 3, CS - 7

My mount command.. Mounting the opt folder of the sd card to opt: mount /mmc/opt /opt

Here is a link to my thread where I got help:


Good luck..

[Moderator Deleted] Shocked
DD-WRT Novice

Joined: 27 Dec 2009
Posts: 5
Location: Birmingham, UK

PostPosted: Mon Feb 01, 2010 21:00    Post subject: Reply with quote
Hey all, i know its been a while, ive got time too look at it again now! And still... nothing Evil or Very Mad .

Ok, I Have ensured that the MMC Driver is turned on, which it is, and have manually set the GPIO. (Screen Snippings Attached)
For Some reason, rather than showing "Not Mounted" under "Space Usage" in the GUI it shows:
MMC 2,816.00 KB / 0
Random Figure? Confused
After cracking my unit open again and looking inside, everything looks fine, but after this, upon plugging it in the white light will flash for about a min, then reboot, and repeat, then reboot and it comes on, but still shows the above figure in "Space Usage"

Running the "df" command through SSH (via PuTTY) i get:
root@Dan's Computer Services:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2816      2816         0 100% /

Any Ideas? Or have i got to rip this SD card out and format it externaly to see if that works?

Im feeling like such an idiot right now.
Crying or Very sad

Hey There! Very Happy
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Hardware DIY / Hardware Mods All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum