OSBRiDGE 2Si

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Senao Devices
Author Message
fm
DD-WRT Novice


Joined: 06 Nov 2009
Posts: 5

PostPosted: Sat Nov 07, 2009 23:10    Post subject: OSBRiDGE 2Si Reply with quote
Hi,

I have a OSBRiDGE 2Si which is the same hardware as the EOC 2610. They even share the same FCC ID.

Out of the box I can telnet into it on 192.168.1.7:9000 and get the following.

Code:

OsWave> version

RedBoot(tm) bootstrap and debug environment.
OSWAVE 2315/16 bootloader: [ROMRAM]
Version 1.02 - built 15:10:45, Jan  9 2009
Copyright (C) 2007.

RAM: 0x80000000-0x82000000, [0x8002c410-0x80ff0000] available
FLASH: 0xa8000000 - 0xa87f0000, 128 blocks of 0x00010000 bytes each.
OsWave> fis init
*** Initialize FLASH Image System
... Erase from 0xa8030000-0xa8040000: .
... Program from 0x80ff0000-0x81000000 at 0xa8030000: .
OsWave> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA8030000  0xA8030000  0x00010000  0x00000000
zImage            0xA8050000  0xA8050000  0x002D0000  0x80800000


As I need several features that OsWave does not offer. I tried to upgrade the device to dd-wrt.

Code:

OsWave> load -r -b 0x80041000 linux.bin
Using default protocol (TFTP)
Raw file loaded 0x80041000-0x80760fff, assumed entry at 0x80041000
OsWave> fis create linux
Can't locate 720000(7471104) bytes free in FLASH


This is because of not enough space. Therefore I deleted the zImage partition:
Code:

OsWave> fis delete zImage
Delete image 'zImage' - continue (y/n)? y
... Erase from 0xa8050000-0xa8320000: .............................................
... Erase from 0xa8030000-0xa8040000: .
... Program from 0x80ff0000-0x81000000 at 0xa8030000: .
OsWave> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA8030000  0xA8030000  0x00010000  0x00000000
OsWave> fis create linux
... Erase from 0xa8040000-0xa8760000: ..................................................................................................................
... Program from 0x80041000-0x80761000 at 0xa8040000: ..................................................................................................................
... Erase from 0xa8030000-0xa8040000: .
... Program from 0x80ff0000-0x81000000 at 0xa8030000: .
OsWave> fconfig
** Error: Illegal command: "fconfig"
OsWave> reset


After the reboot I have the following:
Code:
OsWave> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA8030000  0xA8030000  0x00010000  0x00000000
linux             0xA8040000  0x80041000  0x00720000  0x80041000
OsWave> fis load linux


but the fis load does never finish. :-(

Any idea how to continue? Where do I get an upstream RedBoot for this device? Why does fis load not work?

thanks for your answers.

Felix[/code]
Sponsor
fm
DD-WRT Novice


Joined: 06 Nov 2009
Posts: 5

PostPosted: Sat Nov 07, 2009 23:35    Post subject: Reply with quote
I have used the most uptodate dd-wrt version for this device afaik.

http://www.dd-wrt.com/routerdb/de/download/Senao%20/%20EnGenius/EOC-2610/-/linux.bin/2032

Code:

EOC-2610 Firmware: Console image     linux.bin     2009-10-10     7,13 MB
MichelG
DD-WRT Guru


Joined: 12 Feb 2007
Posts: 903
Location: Galati - RO / Kishinev - MD / Geneva - CH / Tarragona - E

PostPosted: Sun Nov 08, 2009 0:59    Post subject: Reply with quote
Hi, loading the FW into memory will take 10-15 minutes. Be patient. Also, try a previous version, a I had some issues loading the latest one.

When having the previous version loaded, perform an reset to defaults in the firmware, then reboot and reload the latest Linux.bin.

Should be fine.
Michel

_________________
2x EOC-2160 - AP 2x14dB Yagy to 450m link
2x EOC-2160 - RP 2x17dB Panels - 2x 7Mbps
1x WRT54G v2.2 - V24-SP2 13577VPN Eko
All Senao EOC-2610 V1.10 Std 15362 BS
1x UBNT Bullet 2 - RP 18dB Panel - 11Mbps - 13Km link
fm
DD-WRT Novice


Joined: 06 Nov 2009
Posts: 5

PostPosted: Sun Nov 08, 2009 1:27    Post subject: Reply with quote
MichelG wrote:
Hi, loading the FW into memory will take 10-15 minutes. Be patient. Also, try a previous version, a I had some issues loading the latest one.

I realized that a fis create takes a long time, this is mentioned in several howtos too. But does a fis load really take that long?

I just downloaded ddwrt r12533 for the device and will try that now.

The OsWave bootloader on the device does not support exec. I just have go is that going to be a problem?

MichelG wrote:
When having the previous version loaded, perform an reset to defaults in the firmware, then reboot and reload the latest Linux.bin.

I'd be happy as soon as anything runs on this thing. ;)

thanks for your reply
fm

P.S: Will post the result of the downgrade soon it is still flashing...
fm
DD-WRT Novice


Joined: 06 Nov 2009
Posts: 5

PostPosted: Sun Nov 08, 2009 1:44    Post subject: Reply with quote
Ok I reflashed with an older dd-wrt version. But still the device does not come up after boot. I assume the error was because the length was too small.

You can see my session in the following snippet.
Code:

Connected to 192.168.1.7.
Escape character is '^]'.
OsWave> ip_addr -h 192.168.1.11
IP: 192.168.1.7/255.255.255.0, Gateway: 192.168.1.1
Default server: 192.168.1.11
OsWave> fis init
*** Initialize FLASH Image System
... Erase from 0xa8030000-0xa8040000: .
... Program from 0x80ff0000-0x81000000 at 0xa8030000: .
OsWave> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA8030000  0xA8030000  0x00010000  0x00000000
zImage            0xA8050000  0xA8050000  0x002D0000  0x80800000
OsWave> load -r -b 0x80041000 ddwrt12533
Using default protocol (TFTP)
Raw file loaded 0x80041000-0x806affff, assumed entry at 0x80041000
OsWave> fis create zImage
 ... Erase from 0xa8050000-0xa8320000: .............................................
... Program from 0x80041000-0x806b0000 at 0xa8050000: .............................................V
Can't program region at 0xa8320000: Unknown error
OsWave> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA8030000  0xA8030000  0x00010000  0x00000000
zImage            0xA8050000  0xA8050000  0x002D0000  0x80800000
OsWave> fis delete zImage
Delete image 'zImage' - continue (y/n)? y
... Erase from 0xa8050000-0xa8320000: .............................................
... Erase from 0xa8030000-0xa8040000: .
... Program from 0x80ff0000-0x81000000 at 0xa8030000: .
OsWave> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA8030000  0xA8030000  0x00010000  0x00000000
OsWave> fis create zImage
... Erase from 0xa8040000-0xa86af000: .......................................................................................................
... Program from 0x80041000-0x806b0000 at 0xa8040000: .......................................................................................................
... Erase from 0xa8030000-0xa8040000: .
... Program from 0x80ff0000-0x81000000 at 0xa8030000: .
OsWave> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xA8000000  0xA8000000  0x00030000  0x00000000
FIS directory     0xA8030000  0xA8030000  0x00010000  0x00000000
zImage            0xA8040000  0x80041000  0x0066F000  0x80041000
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17619
Location: Hesse/Germany

PostPosted: Sun Nov 08, 2009 18:49    Post subject: Reply with quote
seems thats oswave put a custom redboot on this thing...
so u will have to flash the ddwrt micro redboot first so u can use fconfig and other stuff.

there is a special for senao products

senao->redboot_ap51_32M_8M_kendin.rom

_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!


Last edited by Sash on Mon Nov 09, 2009 9:54; edited 1 time in total
fm
DD-WRT Novice


Joined: 06 Nov 2009
Posts: 5

PostPosted: Sun Nov 08, 2009 20:32    Post subject: Reply with quote
Hi Sash,

thanks for your reply.

Are you talking about http://www.dd-wrt.com/dd-wrtv2/downloads/others/redboot_collection/images_senao/redboot_ap51_32M_8M_kendin.rom

http://www.dd-wrt.com/wiki/index.php/Micro_Redboot does not help too much.

How do I update it?

Code:

fis init -f
load -r reboot.bin
fis create Redboot

Do I replace the originial RedBoot partition? How can I set the default boot entry? As I currently have not fconfig I cannot set the boot script. Is there a special memory adress to write it to?

Can I just load it and start with go? (i.e. chainloading several redboots?)
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17619
Location: Hesse/Germany

PostPosted: Mon Nov 09, 2009 9:58    Post subject: Reply with quote
ep

redboot_ap51_32M_8M_kendin.rom

is right.

there a serveral ways to flash. one is:

Code:
fis init -f
load -r -b %{FREEMEMLO} redboot.bin
fis create -l 0x30000 -e 0xA8000000 RedBoot
reset

fis init -f

_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!


Last edited by Sash on Fri Feb 19, 2010 10:31; edited 2 times in total
gypsy
DD-WRT Novice


Joined: 19 Feb 2010
Posts: 4

PostPosted: Fri Feb 19, 2010 5:12    Post subject: Reply with quote
I'm experiencing a similar issue with the EOC-2610 I have here. It was flashed with OSWave and the OSBridge 2Si firmware, then given to me. It also has a modified RedBoot that identifies itself as OsWave; doing a fis init/fis init -f locks the device up (no further output for at least 30min) most of the time. Other times it works; I then load the 2610 recovery image into RAM, but attempting to write it into flash.. I don't even get the "caution" prompt, just a blank line. It then sits there. Same thing happens when I try to reflash RedBoot from the aforementioned file.

What I'm guessing would be the next solution is a RedBoot RAM image that I can then use to wipe the flash and redo it all without being limited by the quirky OsWave RedBoot. I could then recover my device. The file linked here is a ROM image and won't run from RAM (from what I gather, I need an ELF image). If someone could help me out with this, it'd be eternally appreciated.

(apologies for reviving an old thread, but I figured it's better to keep all the information in one place than make a new thread)
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17619
Location: Hesse/Germany

PostPosted: Fri Feb 19, 2010 10:30    Post subject: Reply with quote
read wiki: micro redboot



what must work is:

get redboot_ap51_32M_8M_kendin.ram rename to redboot.ram

set the tftp server address in redboot
Code:

load redboot.ram
go


ram redboot gets a dhcp address or falls back to 192.168.1.1

and then:

Sash wrote:


redboot_ap51_32M_8M_kendin.rom

set the tftp server address in redboot
Code:
fis init -f
load -r -b %{FREEMEMLO} redboot.bin
fis create -l 0x30000 -e 0xA8000000 RedBoot
reset


after this microredboot is at 192.168.1.1 9000

_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
gmoncada
DD-WRT Novice


Joined: 05 Mar 2010
Posts: 1

PostPosted: Fri Mar 05, 2010 18:40    Post subject: Reply with quote
Hello Sash...
this redboot can work on Ubiquiti devices?

i have lite station5 bricked?

do you know any redbot for this?? or redboot compatible?


Thanks
Sash
DD-WRT Guru


Joined: 20 Sep 2006
Posts: 17619
Location: Hesse/Germany

PostPosted: Sat Mar 06, 2010 0:55    Post subject: Reply with quote
as i see u dont read this topic....
_________________
Forum Guidelines...How to get help
&
Forum Rules
&
RTFM/STFW
&
Throw some buzzwords into the WIKI search Exclamation
_________________
I'm NOT rude, just offer pure facts!
_________________
Atheros (TP-Link & Clones, etc ) debrick service in EU
_________________
Guide on HowTo be Safe, Secure and Protect Your Online Anonymity!
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Senao Devices All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum