HowTo: unbrick a WL500g Deluxe and a WL500g Premium

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Author Message
DD-WRT Novice

Joined: 25 Feb 2009
Posts: 3

PostPosted: Wed Mar 04, 2009 7:48    Post subject: expensive switch ---> 500gP :) Reply with quote
I will describe below shortly what happened to us.

We have 2 pcs. of asus 500 G Premium. (now both of them is Brick - or
switch - whatever)

My friend wanted to put back the original firmware from asus, he has
DD-WRT - 24 sp1 before, but it was too difficult for him to get the
printer workink.

We use:
1. the original firmware restoration tool from asus,
2. Enter in failsafe mode, restore button and power cord in
3. Upload the file: WL500gp_1.9.7.7_TW.trx
4. Wait until the software finishes about 5 min.
5. after we cut the power and we put it back, the router goes back
automatically in failsafe mode (power led slowly blinking)
6. We use the restoration software again to put the same file again.

7. after this the router it's like a switch. if we connect anything to
the ethernet port the led's are ok, but power led is off, and air is

We have tried already to get in failsafe mode:

1. restore button + powercord in ---> nothing
2. Pin 9 to ground + powercord in (wait) --> nothing
3. tryed also 10, 9/10, 16, 17, 16/17 but nothing
4. we made a connection with max232 -> tx0 rx0 gnd hyperterminal
115000, 8, n, 1, n ---> at boot time we cannot see nothing

We have the same problem with another router 500 gp, but with this one
we proceed different (before it was ddwrt 2.4.sp1):

1.after the first flash WL500gp_1.9.7.7_TW.trx ---> failsafe
2. put clear-nvram.trx
put recover.trx

after this THE SAME simptoms like you have read before. :(

If you have any suggestion or solution please let us know.
DD-WRT Novice

Joined: 03 Mar 2009
Posts: 1

PostPosted: Fri Mar 06, 2009 1:35    Post subject: pin 9 trick not working as expected for asus wl500w. Ideas? Reply with quote
I bricked my Asus wl900w after I changed the SSID in WRT (dd-wrt.v24-11218_NEWD_mega build). The pin 9 trick just puts the router into what appears to be recover mode... the power light doesn't go out as others have reported; it flashes. The router is not responsive to pings, and was not before I did pin 9. The 30/30/30 trick did not work for me. (wired connected is set per specifications identified earlier in this thread.) Anyone have any ideas? Thanks much.
DD-WRT Novice

Joined: 08 Mar 2009
Posts: 1

PostPosted: Sun Mar 08, 2009 6:50    Post subject: dim wireless light bricked Reply with quote
I have the same problem as markus,godfather and bkiss
none of the pin methods work cant ping reset or get any response,the lan leds light up but no power light and very dim wireless light
DD-WRT Novice

Joined: 25 Feb 2009
Posts: 3

PostPosted: Sun Mar 08, 2009 7:41    Post subject: expensive switch Reply with quote

i think we have a few very expensive switches...

Maybe it's better to use the linksys instead of asus.


Joined: 01 Aug 2006
Posts: 296
Location: Waldo Florida(trailer trash)

PostPosted: Sun Mar 08, 2009 7:55    Post subject: Re: expensive switch Reply with quote
bkiss wrote:

i think we have a few very expensive switches...

Maybe it's better to use the linksys instead of asus.

Buffalo WHR-HP-G54 are available now. I just bought one from Provantage for $62.
DSL from Windstream
I feed a friend 400 meters through trees to Wi Fi station taped to his window from my bullet hp feeding 15db pringles type antenna
DD-WRT Novice

Joined: 17 May 2009
Posts: 2

PostPosted: Sun May 17, 2009 7:14    Post subject: Successful recovery procedure for Asus WL-520GC Reply with quote
Hello everybody and thanks a lot for your help,

Trying to upload an OpenWRT image I have succeeded in crashing my router. Symptoms were somehow familiar with other models, box was responding to ping a couple of times when in firmware recovery mode and after than went dead; same thing happening with TFTP transfer, accept two packets and after that going dead. I have tried every recovery procedure I could find on the web, with no success; someone was even saying to keep trying as it will eventually work. WRONG, it is not working; I have tried more that a hundred times the “firmware restoration” process with the same result, ping reply a couple of times and box went dead. What seams really wrong to me is that the router does not reset its nvram values, whatever I have tried, so in “firmware recovery” mode it was using a bad configuration which made it crash.

Now comes the magic trick (pin 10 and 12 trick for WL-500G models, for 520GC is actually pin 9 and 12 trick); WL-500G deluxe and WL-520GC use the same flash model MX 29LV, with the difference that 520 uses a smaller one 16Mbiti instead of 32Mbiti. Recovery procedure for MX with 32Mbiti is described at the beginning of this forum, but it does not actually say why is doing that. Regarding MX29LV16, the difference than MX29LV32 is that it has one less line of data, MX29LV32 has A1-A20 lines for data, and MX29LV16 has A1-A19. In case of MX29LV32 pin 12 is reset and pin 10 is A20 (data line), for MX29LV16 reset pin is the same pin 12, and for data line A19 should be used (pin 9). MX29LV160 manual says that reseting (put reset pin to ground while router is on) the flash will force it to load “boot-firmware”. Correct, but I would expect some default configuration to be used as current one might be wrong. However the box does not do that, and loads saved configuration making it unusable even in recovery mode. So, reseting pin 9 (A19 data line for 520GC model) during boot, will cause the router not to load its bad configuration and start with a fresh, default configuration and working recovery firmware.

Procedure that I have done for 520GC is reset pin 12, which forces the router to reboot, and immediately reset pin 9 caused the router to enter the firmware recovery mode. Obviously, reseting pin 9 after boot is useless. In this state, router has its default configuration ( and FTFP upload worked the first time and router started working again.

Please note that even the flash has the same number of pins as 500G model, in 520GC it is glued to the board in a different position, so be careful, DO NOT just follow the pictures for 500G models, but check the actual chip position and writings (flash datasheet can be found on the web).

Thank you everybody for clues about how to recovery my router,
DD-WRT Novice

Joined: 20 Sep 2008
Posts: 5

PostPosted: Fri Jun 12, 2009 17:13    Post subject: Reply with quote
I solve my problem with 520GC; I put this version (works fine for me) :

If someone have same problem (rescue mode doesn't work by holding rescue button 5 seconds, even when the power button is flashing and showing that the router is in rescue mode), try putting the router in rescue mode by reseting pin 9 from MX29LV32 when you power on the router (I put a small cable from pin 9 to the ground from the power supply and power on the router);

THANK YOU : ice_ice

Joined: 22 Jun 2009
Posts: 100
Location: Buchrest, Romania

PostPosted: Mon Jun 22, 2009 9:05    Post subject: thanks Reply with quote
i managed to revive my wl-500gx (deluxe) with the pins 10-12 trick.
Thank you all!
DD-WRT Novice

Joined: 11 Nov 2007
Posts: 21

PostPosted: Thu Jul 23, 2009 21:11    Post subject: Reply with quote
The 9-pin save my router!

Used a safety needle, a coppercable, silvertape =)
DD-WRT Novice

Joined: 29 Oct 2008
Posts: 48

PostPosted: Thu Jul 23, 2009 23:54    Post subject: Reply with quote
I would not recommend it until it is your last resort but the 9 pin short has worked for me twice on two different bricked Asus WL-500Ws. Just realize exactly what you're doing to the hardware. As far as Linksys vs. Asus, I love the WL-500W and don't see a Linksys router in the same class that I would rather have.
DD-WRT Novice

Joined: 21 Aug 2009
Posts: 1

PostPosted: Fri Aug 21, 2009 16:40    Post subject: WL500GP weirdo Reply with quote
So, Tomato is my flavour of choice.

Changed because i wanted pptp client and it ended horribly with dd-wrt as it always tends to do with this model of router. Anyhooo.

I could not put in recovery mode while any Ethernet ports where occupied. If i removed them, the unit went into recovery *blink* *blink* fine, as soon as i introduced a network cable the light would go i decided to short some pins. I mean pin 9 to ground in the first post.

The only thing i could find was a mangled staple Very Happy
good news is it worked a treat and not only that it restored to the version of Tomato i wanted installed
WTF i know

here is what i used, i was very careful of course

 Filesize:  133.63 KB
 Viewed:  31277 Time(s)


DD-WRT Novice

Joined: 15 Aug 2009
Posts: 19

PostPosted: Sat Aug 22, 2009 15:27    Post subject: Reply with quote
I newly bought a WL-500gP V2 (with mod 64mb RAM), I upgrade with Asus restoration utility from oleg to Tomato_RAF_1.25.8515 ND USB .8_snmp_vpn_v3.trx. The router's 'air' and 'power' leds goes out immediately after the flash and wait for a long time without change. The LAN led (the one attached with a cable to the PC) still lights. Tried 30-30-30s recovery but the Power LED never lights up again even after power down/up (appears cannot enter recovery mode anymore). The only LED that lights up after router power on is the one attached a LAN cable but no ip can be acquired.

How can I recover? If Jtag needed, pls let me have more detailed steps
DD-WRT Novice

Joined: 05 Sep 2006
Posts: 29

PostPosted: Thu Aug 27, 2009 9:44    Post subject: air led flashing Reply with quote

tried the pin9 trick but the only thing I got is that the router now shows me power led on and air led flashing.

seems that nobody before had the air led flashing while using this method.

somebody can help me?

Joined: 22 Sep 2008
Posts: 12676

PostPosted: Thu Aug 27, 2009 12:38    Post subject: Reply with quote
Pin shorting is a last resort. A serial clear of nvram will also work and will not do damage. If you pin shorted and it did not work, pin shorting should be a LAST resort. should have tried everything else first, including a serial flash.

Once you pin short and fail, you "f" your router. Time to toss it out. If you haven't tried everything else, you were foolish, and now have to go back and try proper steps with no idea if you damaged your router or not.

I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."

Joined: 22 Jun 2008
Posts: 489

PostPosted: Thu Aug 27, 2009 13:12    Post subject: Reply with quote
Kinda makes you wonder why manufacturers don't simply include traces to solder points / pin holes so you can do this more safely. Like the CMOS CLR points they USED to include on some peecee motherboards.
2x Asus RT-AC68U
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next Display posts from previous:    Page 7 of 10
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum